]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
Add link to downloads
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
ee4f2132 2# - /etc/sysconfig/nginx file
1c438d78 3# - missing perl build/install requires
644ecce3 4# - add njs: https://nginx.org/en/docs/njs/
ee4f2132 5#
362f5ab2 6# Conditional build for nginx:
d2732616
ER
7# Features
8%bcond_with debug # enable debug logging: http://nginx.org/en/docs/debugging_log.html
d54a9642 9%bcond_without threads # thread pool support
d2732616
ER
10# Modules
11%bcond_without addition # http addition module
12%bcond_without auth_request # auth_request module
13%bcond_without dav # WebDAV
14%bcond_without flv # http FLV module
278483d6 15%bcond_without gd # without http image filter module
82f38dc6 16%bcond_without geoip # without http geoip module and stream geoip module
d2732616 17%bcond_without http2 # HTTP/2 module
056acc18 18%bcond_without mail # don't build imap/mail proxy
19%bcond_without perl # don't build with perl module
d2732616 20%bcond_without poll # poll module
d0c0492d 21%bcond_without realip # real ip (behind proxy)
d2732616
ER
22%bcond_without select # select module
23%bcond_without ssl # ssl support and http ssl module
24%bcond_without stream # TCP/UDP proxy module
25%bcond_without stub_status # http stub status module
26%bcond_without sub # ngx_http_sub_module
278483d6 27%bcond_without xslt # without http xslt module
d2732616 28%bcond_with http_browser # http browser module (header "User-agent" parser)
ba5570e8 29%bcond_with modsecurity # modsecurity module
d2732616 30%bcond_with rtmp # rtmp support
a7bd1a0f 31%bcond_without vts # virtual host traffic status module
fb649fe5 32
8cf64677
WF
33%ifarch x32
34%undefine with_rtsig
35%endif
36
27ce902f 37%define ssl_version 1.0.2
a71fb2d9 38%define rtmp_version 1.2.1
a7bd1a0f 39%define vts_version 0.1.18
ba5edeb7 40%define modsecurity_version 2.9.3
8e1389c7 41Summary: High perfomance HTTP and reverse proxy server
185313bb 42Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
3dfa1ca2
AM
43# nginx lines:
44# - stable: production quality with stable API
45# - mainline: production quality but API can change
436be8d4 46# http://nginx.org/en/download.html
f9e65082 47Name: nginx
e344670b 48Version: 1.16.1
cfc47b1f 49Release: 3
51ef519b 50License: BSD-like
cbf76340 51Group: Networking/Daemons/HTTP
06e274b9 52Source0: http://nginx.org/download/%{name}-%{version}.tar.gz
e344670b 53# Source0-md5: 45a80f75336c980d240987badc3dcf60
06e274b9 54Source1: http://nginx.net/favicon.ico
87404bf2 55# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
06e274b9 56Source2: proxy.conf
226bcc40 57Source3: %{name}.logrotate
58Source4: %{name}.mime
7f97359c 59Source6: %{name}.monitrc
2cb3d9b2 60Source7: %{name}.init
5d9f0850 61Source14: %{name}.conf
7d80c773 62Source17: %{name}-mime.types.sh
8d0ed4b0 63Source18: %{name}.service
ba5570e8 64Source22: http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
ba5edeb7 65# Source22-md5: 215a96d679a5b0fadcf13b5d09b35422
278483d6 66Source101: https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
a71fb2d9 67# Source101-md5: 639ac2b78103adaccbcfe484a92acf44
a7bd1a0f
AM
68Source102: https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
69# Source102-md5: 409a10dbd85e0b807cc77eecec29a3b5
5ca9795d 70Patch0: %{name}-no-Werror.patch
7ce2935c 71Patch1: %{name}-modsecurity-xheaders.patch
b7a97f81 72URL: http://nginx.org/
dfef7372 73BuildRequires: mailcap
f1fc9780 74BuildRequires: pcre-devel
d323480a 75BuildRequires: rpmbuild(macros) >= 1.644
f9e65082 76BuildRequires: zlib-devel
278483d6
ER
77%if %{with geoip}
78BuildRequires: GeoIP-devel
79%endif
80%if %{with gd}
81BuildRequires: gd-devel
82%endif
83%if %{with modsecurity}
84BuildRequires: lua-devel
85%endif
86%if %{with perl}
87BuildRequires: perl-CGI
88BuildRequires: perl-devel
89BuildRequires: python
90BuildRequires: rpm-perlprov
91%endif
92%if %{with ssl}
93BuildRequires: openssl-devel >= %{ssl_version}
94Requires: openssl >= %{ssl_version}
95%endif
96%if %{with xslt}
97BuildRequires: libxslt-devel
98%endif
1a973791
JK
99Provides: group(http)
100Provides: group(nginx)
101Provides: user(nginx)
4ac1d45f 102Provides: webserver
9b47506f
AM
103Provides: webserver(access)
104Provides: webserver(alias)
81d5057a
JK
105Provides: webserver(auth)
106Provides: webserver(expires)
107Provides: webserver(headers)
1e42c256 108Provides: webserver(indexfile)
81d5057a
JK
109Provides: webserver(log)
110Provides: webserver(mime)
111Provides: webserver(reqtimeout)
112Provides: webserver(rewrite)
113Provides: webserver(setenv)
1a973791 114Conflicts: logrotate < 3.8.0
85600569 115Requires(post,preun): /sbin/chkconfig
1a973791 116Requires(post,preun,postun): systemd-units >= 38
4ac1d45f
ER
117Requires(postun): /usr/sbin/groupdel
118Requires(postun): /usr/sbin/userdel
119Requires(pre): /bin/id
120Requires(pre): /usr/bin/getgid
121Requires(pre): /usr/sbin/groupadd
122Requires(pre): /usr/sbin/useradd
123Requires: rc-scripts >= 0.2.0
124Requires: systemd-units >= 38
125Suggests: vim-syntax-nginx
7cd50bff
AM
126Obsoletes: nginx-common < 1.13.3
127Obsoletes: nginx-light < 1.13.3
128Obsoletes: nginx-standard < 1.13.3
6d00ffc3 129Conflicts: rpm < 4.4.2-0.2
4ac1d45f 130BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1a973791 131
4ac1d45f
ER
132%define _sysconfdir /etc/%{name}
133%define _nginxdir /home/services/%{name}
1a973791 134
6d00ffc3
ER
135# minimizing restarts logics. we restart webserver:
136#
137# 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
138# 2. first install of module (post: $1 = 1)
139# 2. uninstall of module (postun: $1 == 0)
140#
141# the strict internal deps between modules and
142# main package are very important for all this to work.
85600569 143
6d00ffc3
ER
144# restart webserver at the end of transaction
145
146%define restart_webserver \
147 %systemd_post %{name}.service \
148 %service %{name} force-reload \
149 %{nil}
150
151# macro called at module post scriptlet
152%define module_post \
153if [ "$1" = "1" ]; then \
154 %restart_webserver \
155fi
156
157# macro called at module postun scriptlet
158%define module_postun \
159if [ "$1" = "0" ]; then \
160 %restart_webserver \
161fi
162
163# it's sooo annoying to write them
164%define module_scripts() \
165%post %1 \
166%module_post \
167\
168%postun %1 \
169%module_postun
2ee780b1 170
4ac1d45f 171%description
1a973791
JK
172nginx ("engine x") is a high-performance HTTP server and reverse
173proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
174Sysoev for Rambler.ru, Russia's second-most visited website, where it
175has been running in production for over two and a half years. Igor has
176released the source code under a BSD-like license. Although still in
177beta, nginx is known for its stability, rich feature set, simple
178configuration, and low resource consumption.
179
4ac1d45f 180%description -l pl.UTF-8
1a973791 181nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
182a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
183potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 184odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
185opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
186fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
187prostej konfiguracji oraz małej "zasobożerności".
188
278483d6
ER
189%package mod_http_geoip
190Summary: Nginx HTTP geoip module
191Group: Daemons
192Requires: %{name} = %{version}-%{release}
193Requires: GeoIP
2ee780b1 194
278483d6
ER
195%description mod_http_geoip
196Nginx HTTP geoip module.
2ee780b1 197
82f38dc6
ER
198%package mod_stream_geoip
199Summary: Nginx stream geoip module
200Group: Daemons
201Requires: %{name} = %{version}-%{release}
57aa9c0a 202Requires: %{name}-mod_stream = %{version}-%{release}
82f38dc6 203Requires: GeoIP
1a973791 204
82f38dc6
ER
205%description mod_stream_geoip
206Nginx stream geoip module.
2ee780b1 207
278483d6
ER
208%package mod_http_image_filter
209Summary: Nginx HTTP image filter module
210Group: Daemons
211Requires: %{name} = %{version}-%{release}
1a973791 212
278483d6
ER
213%description mod_http_image_filter
214Nginx HTTP image filter module.
2ee780b1 215
f5d76ba0
ER
216%package mod_http_perl
217Summary: Nginx HTTP Perl module
cbf76340 218Group: Networking/Daemons/HTTP
4ac1d45f 219Requires: %{name} = %{version}-%{release}
2ee780b1 220
f5d76ba0
ER
221%description mod_http_perl
222Nginx HTTP Perl module.
1a973791 223
278483d6
ER
224%package mod_http_xslt_filter
225Summary: Nginx XSLT module
226Group: Daemons
227Requires: %{name} = %{version}-%{release}
2ee780b1 228
278483d6
ER
229%description mod_http_xslt_filter
230Nginx XSLT module.
2ee780b1 231
f5d76ba0
ER
232%package mod_mail
233Summary: Nginx mail module
cbf76340 234Group: Networking/Daemons/HTTP
4ac1d45f 235Requires: %{name} = %{version}-%{release}
28a25161 236
f5d76ba0
ER
237%description mod_mail
238Nginx mail module.
1a973791 239
9b4add35
AM
240%package mod_vts
241Summary: Nginx virtual host traffic status module
242Group: Networking/Daemons/HTTP
243Requires: %{name} = %{version}-%{release}
244
245%description mod_vts
246Nginx virtual host traffic status module.
247
278483d6
ER
248%package mod_stream
249Summary: Nginx stream modules
250Group: Daemons
251Requires: %{name} = %{version}-%{release}
fccff804 252
278483d6
ER
253%description mod_stream
254Nginx stream modules.
85600569 255
dd7459ac 256%package -n monit-rc-nginx
57f21172 257Summary: nginx support for monit
258Summary(pl.UTF-8): Wsparcie nginx dla monit
60b8f836 259Group: Applications/System
4ac1d45f 260Requires: %{name} = %{version}-%{release}
1cf92547 261Requires: monit
dd7459ac 262
263%description -n monit-rc-nginx
57f21172 264monitrc file for monitoring nginx webserver.
dd7459ac 265
266%description -n monit-rc-nginx -l pl.UTF-8
57f21172 267Plik monitrc do monitorowania serwera WWW nginx.
dd7459ac 268
f9e65082 269%prep
a7bd1a0f 270%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102}
717159c4 271%patch0 -p0
7ce2935c 272%{?with_modsecurity:%patch1 -p0}
f9e65082 273
fb649fe5
ER
274%if %{with rtmp}
275mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
276%endif
277
a7bd1a0f
AM
278%if %{with vts}
279mv nginx-module-vts-%{vts_version} nginx-vts-module
280%endif
281
a8eaad11 282# build mime.types.conf
7d80c773 283#sh %{SOURCE17} /etc/mime.types
a8eaad11 284
f9e65082
ER
285%build
286# NB: not autoconf generated configure
056acc18 287cp -f configure auto/
5d0d957d 288
056acc18 289./configure \
290 --prefix=%{_prefix} \
483adace 291 --modules-path=%{_libdir}/%{name}/modules \
efc6207e
ER
292 --sbin-path=%{_sbindir}/%{name} \
293 --conf-path=%{_sysconfdir}/%{name}.conf \
294 --error-log-path=%{_localstatedir}/log/%{name}/error.log \
295 --http-log-path=%{_localstatedir}/log/%{name}/access.log \
296 --pid-path=%{_localstatedir}/run/%{name}.pid \
297 --lock-path=%{_localstatedir}/lock/subsys/%{name} \
298 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
299 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
300 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
0bd5043b 301 --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
bfad744d 302 --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
2fb62cf2
ER
303 --user=nginx \
304 --group=nginx \
021e3ce8
ER
305 %{?with_select:--with-select_module} \
306 %{?with_poll:--with-poll_module} \
307 %{?with_rtsig:--with-rtsig_module} \
278483d6 308 %{?with_perl:--with-http_perl_module=dynamic} \
278483d6
ER
309 %{?with_gd:--with-http_image_filter_module=dynamic} \
310 %{?with_xslt:--with-http_xslt_module=dynamic} \
82f38dc6
ER
311 %{?with_geoip:--with-http_geoip_module=dynamic} \
312 %{?with_geoip:--with-stream_geoip_module=dynamic} \
008e09c3
ER
313%if %{with mail}
314 --with-mail=dynamic \
315 --with-mail_ssl_module \
278483d6
ER
316%endif
317%if %{with stream}
318 --with-stream=dynamic \
319 --with-stream_ssl_module \
008e09c3 320%endif
2fb62cf2
ER
321 --with-cc="%{__cc}" \
322 --with-cc-opt="%{rpmcflags}" \
323 --with-ld-opt="%{rpmldflags}" \
0aa7dc69 324 %{?with_debug:--with-debug} \
056acc18 325 %{?with_addition:--with-http_addition_module} \
326 %{?with_dav:--with-http_dav_module} \
327 %{?with_flv:--with-http_flv_module} \
d6fc4b09 328 %{?with_sub:--with-http_sub_module} \
056acc18 329 %{?with_realip:--with-http_realip_module} \
d2732616 330 %{?with_stub_status:--with-http_stub_status_module} \
056acc18 331 %{?with_ssl:--with-http_ssl_module} \
332 %{!?with_http_browser:--without-http_browser_module} \
fb649fe5 333 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
9b4add35 334 %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
e9a11359 335 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 336 %{?with_threads:--with-threads} \
6f05a009 337 %{?with_http2:--with-http_v2_module} \
ba5570e8 338 %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
ca3f3f03 339 --with-http_secure_link_module \
2fb62cf2
ER
340 %{nil}
341
53215d5e 342%{__make}
f9e65082 343
53215d5e
ER
344%if %{with modsecurity}
345cd modsecurity-%{modsecurity_version}
346./autogen.sh
347%configure \
348 --enable-standalone-module \
349 --disable-mlogc \
350 --enable-alp2 \
351 --with-lua=/usr
352%{__make}
353cd ..
354%endif
056acc18 355
f9e65082
ER
356%install
357rm -rf $RPM_BUILD_ROOT
362f5ab2 358install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
359 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
4e61eac8 360 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
c63e9e18
ER
361 $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
362 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
97ac281a 363 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
924400ca 364 $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
d323480a 365 $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
599f35f0 366 $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
f9e65082 367
483adace
ER
368%{__make} install \
369 INSTALLDIRS=vendor \
370 DESTDIR=$RPM_BUILD_ROOT
371
372%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
373
7f97359c
ER
374cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
375cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
376cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
c63e9e18
ER
377install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
378
483adace
ER
379cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
380cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
3c75ce8a 381cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
483adace 382rm -r $RPM_BUILD_ROOT%{_prefix}/html
5ca9795d
ER
383cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
384cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
385cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
c9aa991c 386
a88a446d
ER
387load_module() {
388 local module=ngx_${1}_module.so conffile=mod_$1.conf
9453c586 389 printf 'load_module "%{_libdir}/%{name}/modules/%s";' "$module" \
97ac281a 390 > $RPM_BUILD_ROOT%{_sysconfdir}/modules.d/$conffile
c9aa991c
ER
391}
392
85600569 393%if %{with perl}
483adace
ER
394%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
395%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
a88a446d 396load_module http_perl
85600569 397%endif
f9e65082 398
a88a446d
ER
399%if %{with geoip}
400load_module http_geoip
763de572 401load_module stream_geoip
a88a446d
ER
402%endif
403%if %{with gd}
404load_module http_image_filter
405%endif
406%if %{with xslt}
407load_module http_xslt_filter
408%endif
c9aa991c 409%if %{with mail}
a88a446d
ER
410load_module mail
411%endif
d925a29b 412%{?with_vts:load_module http_vhost_traffic_status}
a88a446d
ER
413%if %{with stream}
414load_module stream
c9aa991c 415%endif
32c47bd6 416
f9e65082
ER
417%clean
418rm -rf $RPM_BUILD_ROOT
419
c63e9e18 420%pre
a37373c3 421%groupadd -r -g 213 %{name}
362f5ab2 422%groupadd -g 51 http
a37373c3 423%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
362f5ab2 424%addusertogroup %{name} http
f1fc9780 425
c63e9e18 426%post
738166d2 427for a in access.log error.log; do
c63e9e18 428 if [ ! -f /var/log/%{name}/$a ]; then
98376457 429 umask 022
c63e9e18
ER
430 touch /var/log/%{name}/$a
431 chown nginx:nginx /var/log/%{name}/$a
432 chmod 644 /var/log/%{name}/$a
738166d2 433 fi
434done
c63e9e18 435/sbin/chkconfig --add %{name}
738166d2 436
6d00ffc3
ER
437%posttrans
438%restart_webserver
738166d2 439
c63e9e18 440%preun
7d80c773 441if [ "$1" = "0" ];then
c63e9e18
ER
442 %service %{name} stop
443 /sbin/chkconfig --del %{name}
f9e65082 444fi
c63e9e18 445%systemd_preun %{name}.service
f9e65082 446
c63e9e18 447%postun
f1fc9780 448if [ "$1" = "0" ]; then
7d9b86c7
ER
449 %userremove %{name}
450 %groupremove %{name}
f1fc9780 451fi
d323480a
JK
452%systemd_reload
453
6d00ffc3
ER
454%module_scripts mod_http_geoip
455%module_scripts mod_http_image_filter
456%module_scripts mod_http_perl
457%module_scripts mod_http_xslt_filter
458%module_scripts mod_mail
9b4add35 459%module_scripts mod_vts
6d00ffc3
ER
460%module_scripts mod_stream
461%module_scripts mod_stream_geoip
d323480a 462
c63e9e18 463%files
f9e65082 464%defattr(644,root,root,755)
6f8318ed 465%doc CHANGES LICENSE README html/index.html conf/nginx.conf
f9e65082 466%doc %lang(ru) CHANGES.ru
28a25161 467%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
7f6266e4
ER
468%attr(754,root,root) /etc/rc.d/init.d/%{name}
469%dir %attr(750,root,nginx) %{_sysconfdir}
943e8c63 470%dir %{_sysconfdir}/conf.d
97ac281a 471%dir %{_sysconfdir}/modules.d
924400ca 472%dir %{_sysconfdir}/snippets
7f6266e4
ER
473%dir %{_sysconfdir}/vhosts.d
474%dir %{_sysconfdir}/webapps.d
f1fc9780 475%attr(640,root,root) %{_sysconfdir}/mime.types
57f21172 476%attr(640,root,root) %{_sysconfdir}/koi-utf
477%attr(640,root,root) %{_sysconfdir}/koi-win
478%attr(640,root,root) %{_sysconfdir}/win-utf
ba3249a3 479%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.conf
7f6266e4
ER
480%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
481%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
482%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
483%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
484%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
483adace 485%attr(755,root,root) %{_sbindir}/%{name}
278483d6
ER
486%dir %{_libdir}/%{name}
487%dir %{_libdir}/%{name}/modules
c63e9e18 488%{systemdunitdir}/%{name}.service
b0fa7cc6 489
debe6eba
JR
490%attr(750,nginx,logs) %dir /var/log/archive/%{name}
491%attr(750,nginx,logs) /var/log/%{name}
7f6266e4
ER
492%attr(770,root,nginx) /var/cache/%{name}
493
494%dir %{_nginxdir}
495%dir %{_nginxdir}/cgi-bin
496%dir %{_nginxdir}/html
497%dir %{_nginxdir}/errors
475fecd1 498%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
cd728db7 499%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
28a25161 500
278483d6
ER
501%if %{with geoip}
502%files mod_http_geoip
b0fa7cc6 503%defattr(644,root,root,755)
97ac281a 504%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_geoip.conf
278483d6 505%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
b0fa7cc6 506
82f38dc6 507%files mod_stream_geoip
85600569 508%defattr(644,root,root,755)
97ac281a 509%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream_geoip.conf
82f38dc6 510%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
85600569 511%endif
512
278483d6
ER
513%if %{with gd}
514%files mod_http_image_filter
85600569 515%defattr(644,root,root,755)
97ac281a 516%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_image_filter.conf
278483d6 517%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
85600569 518%endif
519
520%if %{with perl}
f5d76ba0 521%files mod_http_perl
85600569 522%defattr(644,root,root,755)
97ac281a 523%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_perl.conf
008e09c3 524%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
85600569 525%dir %{perl_vendorarch}/auto/%{name}
526%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
98376457 527%{perl_vendorarch}/%{name}.pm
483adace 528%{_mandir}/man3/nginx.3pm*
dd7459ac 529%endif
530
278483d6
ER
531%if %{with xslt}
532%files mod_http_xslt_filter
dd7459ac 533%defattr(644,root,root,755)
97ac281a 534%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_xslt_filter.conf
278483d6 535%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
dd7459ac 536%endif
278483d6 537
dd7459ac 538%if %{with mail}
278483d6
ER
539%files mod_mail
540%defattr(644,root,root,755)
97ac281a 541%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_mail.conf
278483d6 542%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
dd7459ac 543%endif
278483d6 544
9b4add35
AM
545%if %{with vts}
546%files mod_vts
547%defattr(644,root,root,755)
d925a29b 548%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_vhost_traffic_status.conf
9b4add35
AM
549%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_vhost_traffic_status_module.so
550%endif
551
278483d6
ER
552%if %{with stream}
553%files mod_stream
554%defattr(644,root,root,755)
97ac281a 555%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream.conf
278483d6
ER
556%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
557%endif
558
dd7459ac 559%files -n monit-rc-nginx
560%defattr(644,root,root,755)
c63e9e18 561%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.226465 seconds and 4 git commands to generate.