]> git.pld-linux.org Git - packages/neovim.git/blame - neovim.spec
new, version 0.1.5
[packages/neovim.git] / neovim.spec
CommitLineData
0a9d0af1
ER
1# TODO
2# - -rt subpackage? -lang subpackage?
3Summary: Vim-fork focused on extensibility and agility
4Name: neovim
5Version: 0.1.5
6Release: 0.1
7License: Apache v2.0
8Group: Applications/Editors/Vim
9Source0: https://github.com/neovim/neovim/archive/v%{version}/%{name}-%{version}.tar.gz
10URL: https://neovim.io/
11Source1: %{name}.desktop
12Source2: %{name}.svg
13BuildRequires: cmake
14BuildRequires: fdupes
15BuildRequires: hicolor-icon-theme
16BuildRequires: jemalloc-devel
17BuildRequires: libmsgpack-devel >= 1.2.0
18BuildRequires: libmsgpackc-devel >= 1.2.0
19BuildRequires: libstdc++-devel
20BuildRequires: libuv-devel
21BuildRequires: lua51-BitOp
22BuildRequires: lua51-LPeg
23BuildRequires: lua51-mpack
24BuildRequires: luajit-devel
25BuildRequires: pkgconfig
26BuildRequires: pkgconfig(termkey)
27BuildRequires: pkgconfig(unibilium)
28BuildRequires: pkgconfig(vterm)
29BuildRequires: update-desktop-files
30Suggests: python-neovim
31Suggests: python3-neovim
32Suggests: xsel
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36Neovim is a refactor - and sometimes redactor - in the tradition of
37Vim, which itself derives from Stevie. It is not a rewrite, but a
38continuation and extension of Vim. Many rewrites, clones, emulators
39and imitators exist; some are very clever, but none are Vim. Neovim
40strives to be a superset of Vim, notwithstanding some intentionally
41removed misfeatures; excepting those few and carefully-considered
42excisions, Neovim is Vim. It is built for users who want the good
43parts of Vim, without compromise, and more.
44
45%prep
46%setup -q
47
48# Remove __DATE__ and __TIME__.
49BUILD_TIME=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{H}:%{M}')
50BUILD_DATE=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{b} %{d} %{Y}')
51sed -i "s/__TIME__/\"$BUILD_TIME\"/" $(grep -rl '__TIME__')
52sed -i "s/__DATE__/\"$BUILD_DATE\"/" $(grep -rl '__DATE__')
53
54%build
55%cmake \
56 -DLUA_PRG=%{_bindir}/lua \
57 -DUSE_BUNDLED=OFF \
58 -DLUAJIT_USE_BUNDLED=OFF \
59 -DENABLE_JEMALLOC=ON
60
61%{__make}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65%{__make} install \
66 DESTDIR=$RPM_BUILD_ROOT
67
68cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/neovim.desktop
69cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/neovim.svg
70
71%find_lang nvim
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77%update_desktop_database
78%icon_theme_cache_post
79
80%postun
81%update_desktop_database
82%icon_theme_cache_postun
83
84%files -f nvim.lang
85%defattr(644,root,root,755)
86%doc BACKERS.md CONTRIBUTING.md LICENSE README.md
87%attr(755,root,root) %{_bindir}/nvim
88%{_datadir}/nvim
89%{_desktopdir}/%{name}.desktop
90%{_iconsdir}/hicolor/*/apps/%{name}.svg
91%{_mandir}/man1/nvim.1*
This page took 0.08043 seconds and 4 git commands to generate.