]> git.pld-linux.org Git - packages/neon.git/blame - neon.spec
- rel 2
[packages/neon.git] / neon.spec
CommitLineData
d69a9291 1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
9065805f 4%bcond_without kerberos5 # don't build Kerberos V support
e0c5c301 5%bcond_without libproxy # don't build libproxy support
d69a9291 6#
94a59c75 7Summary: An HTTP and WebDAV client library
b690de02 8Summary(pl.UTF-8): Biblioteka kliencka HTTP i WebDAV
94a59c75 9Name: neon
ee06f030 10Version: 0.29.4
ed164367 11Release: 2
b8ab1935 12License: LGPL v2+
94a59c75 13Group: Libraries
94a59c75 14Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
ee06f030 15# Source0-md5: 29438dbdaee84db2d7fbc73248a92d93
769e704f 16URL: http://www.webdav.org/neon/
b8ab1935 17BuildRequires: autoconf >= 2.58
60170b09 18BuildRequires: automake
bb8183bd 19%{?with_kerberos5:BuildRequires: heimdal-devel}
e0c5c301 20%{?with_libproxy:BuildRequires: libproxy-devel}
f9ae6476 21BuildRequires: libtool >= 2:2.2
9dc601f3 22BuildRequires: libxml2-devel
fbe113ef 23BuildRequires: openssl-devel >= 0.9.7d
0eb136aa 24BuildRequires: pkgconfig
a8ebb846 25BuildRequires: zlib-devel
e914cc74 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94a59c75 27
28%description
29neon is an HTTP and WebDAV client library, with a C interface.
30Featuring:
b9b2c7f8 31 - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD etc).
94a59c75 32 - Low-level interface to HTTP request handling, to allow implementing
33 new methods easily.
b9b2c7f8 34 - HTTP/1.1 and HTTP/1.0 persistent connections.
94a59c75 35 - RFC2617 basic and digest authentication (including auth-int,
b9b2c7f8 36 md5-sess).
37 - Proxy support (including basic/digest authentication).
38 - Generic WebDAV 207 XML response handling mechanism.
39 - XML parsing using the expat or libxml parsers.
40 - Easy generation of error messages from 207 error responses.
94a59c75 41 - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
42 - WebDAV metadata support: set and remove properties, query any set of
43 properties (PROPPATCH/PROPFIND).
44
daa7576e 45%description -l pl.UTF-8
769e704f 46neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
daa7576e 47Możliwości:
b9b2c7f8 48 - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET, HEAD...),
4b31dd0e 49 - niskopoziomowy interfejs do obsługi żądań HTTP pozwalający łatwo
daa7576e
JR
50 implementować nowe metody,
51 - stałe połączenia HTTP/1.1 i HTTP/1.0,
4b31dd0e
JB
52 - uwierzytelnianie podstawowe (basic) i skrótem RFC-2617 (auth-int,
53 md5-sess...),
54 - obsługa proxy (w tym uwierzytelnianie podstawowe i skrótem),
daa7576e
JR
55 - mechanizm obsługi odpowiedzi WebDAV 207 XML,
56 - analiza składniowa XML przy pomocy expat lub libxml,
57 - proste generowanie komunikatów błędów dla odpowiedzi 207,
b9b2c7f8 58 - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
daa7576e
JR
59 - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
60 sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
769e704f
JB
61
62%package devel
63Summary: Header files for neon
b690de02 64Summary(pl.UTF-8): Pliki nagłówkowe neon
769e704f 65Group: Development/Libraries
72e4cede 66Requires: %{name} = %{version}-%{release}
bb8183bd 67%{?with_kerberos5:Requires: heimdal-devel}
b45d8f35 68Requires: libxml2-devel
b00d07c4 69Requires: openssl-devel >= 0.9.7c
769e704f
JB
70
71%description devel
72C header files for the neon library.
73
daa7576e
JR
74%description devel -l pl.UTF-8
75Pliki nagłówkowe dla biblioteki neon.
769e704f
JB
76
77%package static
78Summary: Static libraries for neon
b690de02 79Summary(pl.UTF-8): Biblioteki statyczne neon
94a59c75 80Group: Development/Libraries
72e4cede 81Requires: %{name}-devel = %{version}-%{release}
94a59c75 82
769e704f
JB
83%description static
84Static neon libraries.
85
daa7576e 86%description static -l pl.UTF-8
769e704f 87Statyczne biblioteki neon.
94a59c75 88
89%prep
90%setup -q
91
92%build
318af41d 93%{__libtoolize} --install
387c948a 94%{__aclocal} -I macros
45b289d5 95%{__autoconf}
9dc601f3 96%configure \
9dc601f3 97 --with-ssl \
3aeb853f 98 --enable-threadsafe-ssl=posix \
9dc601f3 99 --enable-shared \
d69a9291 100 %{!?with_static_libs:--enable-static=no} \
9065805f 101 %{!?with_kerberos5:--without-gssapi} \
e0c5c301 102 %{!?with_libproxy:--without-libproxy} \
9dc601f3
PG
103 --with-libxml2
104
94a59c75 105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
f97eaad9 109install -d $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man1,%{_mandir}/man3}
769e704f 110
c8dbfeab
JB
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
94a59c75 113
d5a2bb25
MM
114mv -f doc/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
115mv -f doc/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
94a59c75 116
e80eb8df 117%find_lang %{name}
118
94a59c75 119%clean
120rm -rf $RPM_BUILD_ROOT
121
769e704f
JB
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
94a59c75 124
e80eb8df 125%files -f %{name}.lang
94a59c75 126%defattr(644,root,root,755)
d5a2bb25 127%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*.txt doc/html/*
b8ab1935
JB
128%attr(755,root,root) %{_libdir}/libneon.so.*.*.*
129%attr(755,root,root) %ghost %{_libdir}/libneon.so.27
94a59c75 130
131%files devel
132%defattr(644,root,root,755)
2c6a6cf1 133%attr(755,root,root) %{_bindir}/neon-config
b8ab1935
JB
134%attr(755,root,root) %{_libdir}/libneon.so
135%{_libdir}/libneon.la
2f50aeeb 136%{_includedir}/neon
afebb879 137%{_pkgconfigdir}/neon.pc
b8ab1935
JB
138%{_mandir}/man1/neon-config.1*
139%{_mandir}/man3/ne_*.3*
140%{_mandir}/man3/neon.3*
769e704f 141
d69a9291 142%if %{with static_libs}
769e704f
JB
143%files static
144%defattr(644,root,root,755)
b8ab1935 145%{_libdir}/libneon.a
d69a9291 146%endif
This page took 0.107945 seconds and 4 git commands to generate.