]> git.pld-linux.org Git - packages/neon.git/blame - neon.spec
- release 3
[packages/neon.git] / neon.spec
CommitLineData
d69a9291 1#
2# Conditional build:
38878d3d 3%bcond_without apidocs # do not build and package API docs
d69a9291 4%bcond_without static_libs # don't build static libraries
9065805f 5%bcond_without kerberos5 # don't build Kerberos V support
e0c5c301 6%bcond_without libproxy # don't build libproxy support
38878d3d 7
94a59c75 8Summary: An HTTP and WebDAV client library
b690de02 9Summary(pl.UTF-8): Biblioteka kliencka HTTP i WebDAV
94a59c75 10Name: neon
882d452f 11Version: 0.29.5
8beb675e 12Release: 3
b8ab1935 13License: LGPL v2+
94a59c75 14Group: Libraries
94a59c75 15Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
882d452f 16# Source0-md5: ff369e69ef0f0143beb5626164e87ae2
769e704f 17URL: http://www.webdav.org/neon/
b8ab1935 18BuildRequires: autoconf >= 2.58
60170b09 19BuildRequires: automake
bb8183bd 20%{?with_kerberos5:BuildRequires: heimdal-devel}
e0c5c301 21%{?with_libproxy:BuildRequires: libproxy-devel}
f9ae6476 22BuildRequires: libtool >= 2:2.2
9dc601f3 23BuildRequires: libxml2-devel
fbe113ef 24BuildRequires: openssl-devel >= 0.9.7d
0eb136aa 25BuildRequires: pkgconfig
a8ebb846 26BuildRequires: zlib-devel
e914cc74 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94a59c75 28
29%description
30neon is an HTTP and WebDAV client library, with a C interface.
31Featuring:
882d452f 32 - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD
33 etc).
94a59c75 34 - Low-level interface to HTTP request handling, to allow implementing
35 new methods easily.
b9b2c7f8 36 - HTTP/1.1 and HTTP/1.0 persistent connections.
94a59c75 37 - RFC2617 basic and digest authentication (including auth-int,
b9b2c7f8 38 md5-sess).
39 - Proxy support (including basic/digest authentication).
40 - Generic WebDAV 207 XML response handling mechanism.
41 - XML parsing using the expat or libxml parsers.
42 - Easy generation of error messages from 207 error responses.
94a59c75 43 - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
44 - WebDAV metadata support: set and remove properties, query any set of
45 properties (PROPPATCH/PROPFIND).
46
daa7576e 47%description -l pl.UTF-8
769e704f 48neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
daa7576e 49Możliwości:
882d452f 50 - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET,
51 HEAD...),
4b31dd0e 52 - niskopoziomowy interfejs do obsługi żądań HTTP pozwalający łatwo
daa7576e
JR
53 implementować nowe metody,
54 - stałe połączenia HTTP/1.1 i HTTP/1.0,
4b31dd0e
JB
55 - uwierzytelnianie podstawowe (basic) i skrótem RFC-2617 (auth-int,
56 md5-sess...),
57 - obsługa proxy (w tym uwierzytelnianie podstawowe i skrótem),
daa7576e
JR
58 - mechanizm obsługi odpowiedzi WebDAV 207 XML,
59 - analiza składniowa XML przy pomocy expat lub libxml,
60 - proste generowanie komunikatów błędów dla odpowiedzi 207,
b9b2c7f8 61 - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
daa7576e
JR
62 - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
63 sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
769e704f
JB
64
65%package devel
66Summary: Header files for neon
b690de02 67Summary(pl.UTF-8): Pliki nagłówkowe neon
769e704f 68Group: Development/Libraries
72e4cede 69Requires: %{name} = %{version}-%{release}
bb8183bd 70%{?with_kerberos5:Requires: heimdal-devel}
b45d8f35 71Requires: libxml2-devel
b00d07c4 72Requires: openssl-devel >= 0.9.7c
769e704f
JB
73
74%description devel
75C header files for the neon library.
76
daa7576e
JR
77%description devel -l pl.UTF-8
78Pliki nagłówkowe dla biblioteki neon.
769e704f
JB
79
80%package static
81Summary: Static libraries for neon
b690de02 82Summary(pl.UTF-8): Biblioteki statyczne neon
94a59c75 83Group: Development/Libraries
72e4cede 84Requires: %{name}-devel = %{version}-%{release}
94a59c75 85
769e704f
JB
86%description static
87Static neon libraries.
88
daa7576e 89%description static -l pl.UTF-8
769e704f 90Statyczne biblioteki neon.
94a59c75 91
38878d3d
ER
92%package apidocs
93Summary: neon API documentation
94Summary(pl.UTF-8): Dokumentacja API biblioteki neon
95Group: Documentation
96
97%description apidocs
98API and internal documentation for neon library.
99
100%description apidocs -l pl.UTF-8
101Dokumentacja API biblioteki neon.
102
94a59c75 103%prep
104%setup -q
105
106%build
318af41d 107%{__libtoolize} --install
387c948a 108%{__aclocal} -I macros
45b289d5 109%{__autoconf}
9dc601f3 110%configure \
9dc601f3 111 --with-ssl \
3aeb853f 112 --enable-threadsafe-ssl=posix \
9dc601f3 113 --enable-shared \
df50a546 114 %{!?with_static_libs:--disable-static} \
9065805f 115 %{!?with_kerberos5:--without-gssapi} \
e0c5c301 116 %{!?with_libproxy:--without-libproxy} \
9dc601f3
PG
117 --with-libxml2
118
94a59c75 119%{__make}
120
121%install
122rm -rf $RPM_BUILD_ROOT
769e704f 123
c8dbfeab
JB
124%{__make} install \
125 DESTDIR=$RPM_BUILD_ROOT
94a59c75 126
e80eb8df 127%find_lang %{name}
128
94a59c75 129%clean
130rm -rf $RPM_BUILD_ROOT
131
769e704f
JB
132%post -p /sbin/ldconfig
133%postun -p /sbin/ldconfig
94a59c75 134
e80eb8df 135%files -f %{name}.lang
94a59c75 136%defattr(644,root,root,755)
38878d3d 137%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
b8ab1935
JB
138%attr(755,root,root) %{_libdir}/libneon.so.*.*.*
139%attr(755,root,root) %ghost %{_libdir}/libneon.so.27
94a59c75 140
141%files devel
142%defattr(644,root,root,755)
38878d3d 143%doc doc/*.txt
2c6a6cf1 144%attr(755,root,root) %{_bindir}/neon-config
b8ab1935
JB
145%attr(755,root,root) %{_libdir}/libneon.so
146%{_libdir}/libneon.la
2f50aeeb 147%{_includedir}/neon
afebb879 148%{_pkgconfigdir}/neon.pc
b8ab1935
JB
149%{_mandir}/man1/neon-config.1*
150%{_mandir}/man3/ne_*.3*
151%{_mandir}/man3/neon.3*
769e704f 152
d69a9291 153%if %{with static_libs}
769e704f
JB
154%files static
155%defattr(644,root,root,755)
b8ab1935 156%{_libdir}/libneon.a
d69a9291 157%endif
38878d3d
ER
158
159%if %{with apidocs}
160%files apidocs
161%defattr(644,root,root,755)
162%doc doc/html/*
163%endif
This page took 0.058947 seconds and 4 git commands to generate.