]> git.pld-linux.org Git - packages/neon.git/blame - neon.spec
- s/libproxy/libproxy-devel/
[packages/neon.git] / neon.spec
CommitLineData
d69a9291 1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
9065805f 4%bcond_without kerberos5 # don't build Kerberos V support
d69a9291 5#
94a59c75 6Summary: An HTTP and WebDAV client library
b690de02 7Summary(pl.UTF-8): Biblioteka kliencka HTTP i WebDAV
94a59c75 8Name: neon
626804e0 9Version: 0.29.0
5b977782 10Release: 1
b8ab1935 11License: LGPL v2+
94a59c75 12Group: Libraries
94a59c75 13Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
626804e0 14# Source0-md5: 18a3764b70f9317f8b61509fd90d9e7a
769e704f 15URL: http://www.webdav.org/neon/
b8ab1935 16BuildRequires: autoconf >= 2.58
60170b09 17BuildRequires: automake
bb8183bd 18%{?with_kerberos5:BuildRequires: heimdal-devel}
79071a73 19BuildRequires: libproxy-devel
f9ae6476 20BuildRequires: libtool >= 2:2.2
9dc601f3 21BuildRequires: libxml2-devel
fbe113ef 22BuildRequires: openssl-devel >= 0.9.7d
a8ebb846 23BuildRequires: zlib-devel
e914cc74 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94a59c75 25
26%description
27neon is an HTTP and WebDAV client library, with a C interface.
28Featuring:
b9b2c7f8 29 - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD etc).
94a59c75 30 - Low-level interface to HTTP request handling, to allow implementing
31 new methods easily.
b9b2c7f8 32 - HTTP/1.1 and HTTP/1.0 persistent connections.
94a59c75 33 - RFC2617 basic and digest authentication (including auth-int,
b9b2c7f8 34 md5-sess).
35 - Proxy support (including basic/digest authentication).
36 - Generic WebDAV 207 XML response handling mechanism.
37 - XML parsing using the expat or libxml parsers.
38 - Easy generation of error messages from 207 error responses.
94a59c75 39 - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
40 - WebDAV metadata support: set and remove properties, query any set of
41 properties (PROPPATCH/PROPFIND).
42
daa7576e 43%description -l pl.UTF-8
769e704f 44neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
daa7576e 45Możliwości:
b9b2c7f8 46 - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET, HEAD...),
4b31dd0e 47 - niskopoziomowy interfejs do obsługi żądań HTTP pozwalający łatwo
daa7576e
JR
48 implementować nowe metody,
49 - stałe połączenia HTTP/1.1 i HTTP/1.0,
4b31dd0e
JB
50 - uwierzytelnianie podstawowe (basic) i skrótem RFC-2617 (auth-int,
51 md5-sess...),
52 - obsługa proxy (w tym uwierzytelnianie podstawowe i skrótem),
daa7576e
JR
53 - mechanizm obsługi odpowiedzi WebDAV 207 XML,
54 - analiza składniowa XML przy pomocy expat lub libxml,
55 - proste generowanie komunikatów błędów dla odpowiedzi 207,
b9b2c7f8 56 - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
daa7576e
JR
57 - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
58 sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
769e704f
JB
59
60%package devel
61Summary: Header files for neon
b690de02 62Summary(pl.UTF-8): Pliki nagłówkowe neon
769e704f 63Group: Development/Libraries
72e4cede 64Requires: %{name} = %{version}-%{release}
bb8183bd 65%{?with_kerberos5:Requires: heimdal-devel}
b45d8f35 66Requires: libxml2-devel
b00d07c4 67Requires: openssl-devel >= 0.9.7c
769e704f
JB
68
69%description devel
70C header files for the neon library.
71
daa7576e
JR
72%description devel -l pl.UTF-8
73Pliki nagłówkowe dla biblioteki neon.
769e704f
JB
74
75%package static
76Summary: Static libraries for neon
b690de02 77Summary(pl.UTF-8): Biblioteki statyczne neon
94a59c75 78Group: Development/Libraries
72e4cede 79Requires: %{name}-devel = %{version}-%{release}
94a59c75 80
769e704f
JB
81%description static
82Static neon libraries.
83
daa7576e 84%description static -l pl.UTF-8
769e704f 85Statyczne biblioteki neon.
94a59c75 86
87%prep
88%setup -q
89
90%build
318af41d 91%{__libtoolize} --install
387c948a 92%{__aclocal} -I macros
45b289d5 93%{__autoconf}
9dc601f3 94%configure \
9dc601f3 95 --with-ssl \
3aeb853f 96 --enable-threadsafe-ssl=posix \
9dc601f3 97 --enable-shared \
d69a9291 98 %{!?with_static_libs:--enable-static=no} \
9065805f 99 %{!?with_kerberos5:--without-gssapi} \
9dc601f3
PG
100 --with-libxml2
101
94a59c75 102%{__make}
103
104%install
105rm -rf $RPM_BUILD_ROOT
f97eaad9 106install -d $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man1,%{_mandir}/man3}
769e704f 107
c8dbfeab
JB
108%{__make} install \
109 DESTDIR=$RPM_BUILD_ROOT
94a59c75 110
d5a2bb25
MM
111mv -f doc/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
112mv -f doc/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
94a59c75 113
e80eb8df 114%find_lang %{name}
115
94a59c75 116%clean
117rm -rf $RPM_BUILD_ROOT
118
769e704f
JB
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
94a59c75 121
e80eb8df 122%files -f %{name}.lang
94a59c75 123%defattr(644,root,root,755)
d5a2bb25 124%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*.txt doc/html/*
b8ab1935
JB
125%attr(755,root,root) %{_libdir}/libneon.so.*.*.*
126%attr(755,root,root) %ghost %{_libdir}/libneon.so.27
94a59c75 127
128%files devel
129%defattr(644,root,root,755)
2c6a6cf1 130%attr(755,root,root) %{_bindir}/neon-config
b8ab1935
JB
131%attr(755,root,root) %{_libdir}/libneon.so
132%{_libdir}/libneon.la
2f50aeeb 133%{_includedir}/neon
afebb879 134%{_pkgconfigdir}/neon.pc
b8ab1935
JB
135%{_mandir}/man1/neon-config.1*
136%{_mandir}/man3/ne_*.3*
137%{_mandir}/man3/neon.3*
769e704f 138
d69a9291 139%if %{with static_libs}
769e704f
JB
140%files static
141%defattr(644,root,root,755)
b8ab1935 142%{_libdir}/libneon.a
d69a9291 143%endif
This page took 0.070427 seconds and 4 git commands to generate.