]> git.pld-linux.org Git - packages/neon.git/blame - neon.spec
- up to 0.28.0
[packages/neon.git] / neon.spec
CommitLineData
d69a9291 1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
9065805f 4%bcond_without kerberos5 # don't build Kerberos V support
d69a9291 5#
94a59c75 6Summary: An HTTP and WebDAV client library
b690de02 7Summary(pl.UTF-8): Biblioteka kliencka HTTP i WebDAV
94a59c75 8Name: neon
753e76da 9Version: 0.28.0
ec1886f3 10Release: 1
94a59c75 11License: GPL
12Group: Libraries
94a59c75 13Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
753e76da 14# Source0-md5: 9d938e1e46003cae11d9e6f596da8c95
769e704f 15URL: http://www.webdav.org/neon/
60170b09
JB
16BuildRequires: autoconf >= 2.53
17BuildRequires: automake
9065805f 18%{?with_kerberos5:BuildRequires: krb5-devel}
0b3420ad 19BuildRequires: libtool
9dc601f3 20BuildRequires: libxml2-devel
fbe113ef 21BuildRequires: openssl-devel >= 0.9.7d
a8ebb846 22BuildRequires: zlib-devel
e914cc74 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94a59c75 24
25%description
26neon is an HTTP and WebDAV client library, with a C interface.
27Featuring:
b9b2c7f8 28 - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD etc).
94a59c75 29 - Low-level interface to HTTP request handling, to allow implementing
30 new methods easily.
b9b2c7f8 31 - HTTP/1.1 and HTTP/1.0 persistent connections.
94a59c75 32 - RFC2617 basic and digest authentication (including auth-int,
b9b2c7f8 33 md5-sess).
34 - Proxy support (including basic/digest authentication).
35 - Generic WebDAV 207 XML response handling mechanism.
36 - XML parsing using the expat or libxml parsers.
37 - Easy generation of error messages from 207 error responses.
94a59c75 38 - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
39 - WebDAV metadata support: set and remove properties, query any set of
40 properties (PROPPATCH/PROPFIND).
41
daa7576e 42%description -l pl.UTF-8
769e704f 43neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
daa7576e 44Możliwości:
b9b2c7f8 45 - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET, HEAD...),
daa7576e
JR
46 - niskopziomowy interfejs to obsługi żądań HTTP pozwalający łatwo
47 implementować nowe metody,
48 - stałe połączenia HTTP/1.1 i HTTP/1.0,
49 - autentykacja podstawowa i skrótem RFC-2617 (auth-int, md5-sess...),
50 - obsługa proxy (w tym autentykacja podstawowa i skrótem),
51 - mechanizm obsługi odpowiedzi WebDAV 207 XML,
52 - analiza składniowa XML przy pomocy expat lub libxml,
53 - proste generowanie komunikatów błędów dla odpowiedzi 207,
b9b2c7f8 54 - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
daa7576e
JR
55 - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
56 sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
769e704f
JB
57
58%package devel
59Summary: Header files for neon
b690de02 60Summary(pl.UTF-8): Pliki nagłówkowe neon
769e704f 61Group: Development/Libraries
72e4cede 62Requires: %{name} = %{version}-%{release}
9065805f 63%{?with_kerberos5:Requires: krb5-devel}
b45d8f35 64Requires: libxml2-devel
b00d07c4 65Requires: openssl-devel >= 0.9.7c
769e704f
JB
66
67%description devel
68C header files for the neon library.
69
daa7576e
JR
70%description devel -l pl.UTF-8
71Pliki nagłówkowe dla biblioteki neon.
769e704f
JB
72
73%package static
74Summary: Static libraries for neon
b690de02 75Summary(pl.UTF-8): Biblioteki statyczne neon
94a59c75 76Group: Development/Libraries
72e4cede 77Requires: %{name}-devel = %{version}-%{release}
94a59c75 78
769e704f
JB
79%description static
80Static neon libraries.
81
daa7576e 82%description static -l pl.UTF-8
769e704f 83Statyczne biblioteki neon.
94a59c75 84
85%prep
86%setup -q
87
88%build
0b3420ad 89%{__libtoolize}
387c948a 90%{__aclocal} -I macros
45b289d5 91%{__autoconf}
9dc601f3 92%configure \
9dc601f3 93 --with-ssl \
3aeb853f 94 --enable-threadsafe-ssl=posix \
9dc601f3 95 --enable-shared \
d69a9291 96 %{!?with_static_libs:--enable-static=no} \
9065805f 97 %{!?with_kerberos5:--without-gssapi} \
9dc601f3
PG
98 --with-libxml2
99
94a59c75 100%{__make}
101
102%install
103rm -rf $RPM_BUILD_ROOT
f97eaad9 104install -d $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man1,%{_mandir}/man3}
769e704f 105
c8dbfeab
JB
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
94a59c75 108
d5a2bb25
MM
109mv -f doc/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
110mv -f doc/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
94a59c75 111
4cebf91b 112mv $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
e80eb8df 113%find_lang %{name}
114
94a59c75 115%clean
116rm -rf $RPM_BUILD_ROOT
117
769e704f
JB
118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
94a59c75 120
e80eb8df 121%files -f %{name}.lang
94a59c75 122%defattr(644,root,root,755)
d5a2bb25 123%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*.txt doc/html/*
60170b09 124%attr(755,root,root) %{_libdir}/*.so.*.*
94a59c75 125
126%files devel
127%defattr(644,root,root,755)
2c6a6cf1 128%attr(755,root,root) %{_bindir}/neon-config
c8dbfeab
JB
129%attr(755,root,root) %{_libdir}/*.so
130%{_libdir}/*.la
2f50aeeb 131%{_includedir}/neon
2c6a6cf1 132%{_mandir}/man*/*
afebb879 133%{_pkgconfigdir}/neon.pc
769e704f 134
d69a9291 135%if %{with static_libs}
769e704f
JB
136%files static
137%defattr(644,root,root,755)
94a59c75 138%{_libdir}/*.a
d69a9291 139%endif
This page took 0.046299 seconds and 4 git commands to generate.