]> git.pld-linux.org Git - packages/neon.git/blame - neon.spec
- release 2
[packages/neon.git] / neon.spec
CommitLineData
d69a9291 1#
2# Conditional build:
38878d3d 3%bcond_without apidocs # do not build and package API docs
d69a9291 4%bcond_without static_libs # don't build static libraries
9065805f 5%bcond_without kerberos5 # don't build Kerberos V support
e0c5c301 6%bcond_without libproxy # don't build libproxy support
38878d3d 7
94a59c75 8Summary: An HTTP and WebDAV client library
b690de02 9Summary(pl.UTF-8): Biblioteka kliencka HTTP i WebDAV
94a59c75 10Name: neon
ad370de7 11Version: 0.29.6
5c5efe41 12Release: 2
b8ab1935 13License: LGPL v2+
94a59c75 14Group: Libraries
94a59c75 15Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
ad370de7 16# Source0-md5: 591e0c82e6979e7e615211b386b8f6bc
769e704f 17URL: http://www.webdav.org/neon/
b8ab1935 18BuildRequires: autoconf >= 2.58
60170b09 19BuildRequires: automake
bb8183bd 20%{?with_kerberos5:BuildRequires: heimdal-devel}
e0c5c301 21%{?with_libproxy:BuildRequires: libproxy-devel}
f9ae6476 22BuildRequires: libtool >= 2:2.2
9dc601f3 23BuildRequires: libxml2-devel
fbe113ef 24BuildRequires: openssl-devel >= 0.9.7d
0eb136aa 25BuildRequires: pkgconfig
a8ebb846 26BuildRequires: zlib-devel
e914cc74 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94a59c75 28
29%description
30neon is an HTTP and WebDAV client library, with a C interface.
31Featuring:
882d452f 32 - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD
33 etc).
94a59c75 34 - Low-level interface to HTTP request handling, to allow implementing
35 new methods easily.
b9b2c7f8 36 - HTTP/1.1 and HTTP/1.0 persistent connections.
94a59c75 37 - RFC2617 basic and digest authentication (including auth-int,
b9b2c7f8 38 md5-sess).
39 - Proxy support (including basic/digest authentication).
40 - Generic WebDAV 207 XML response handling mechanism.
41 - XML parsing using the expat or libxml parsers.
42 - Easy generation of error messages from 207 error responses.
94a59c75 43 - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
44 - WebDAV metadata support: set and remove properties, query any set of
45 properties (PROPPATCH/PROPFIND).
46
daa7576e 47%description -l pl.UTF-8
769e704f 48neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
daa7576e 49Możliwości:
882d452f 50 - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET,
51 HEAD...),
4b31dd0e 52 - niskopoziomowy interfejs do obsługi żądań HTTP pozwalający łatwo
daa7576e
JR
53 implementować nowe metody,
54 - stałe połączenia HTTP/1.1 i HTTP/1.0,
4b31dd0e
JB
55 - uwierzytelnianie podstawowe (basic) i skrótem RFC-2617 (auth-int,
56 md5-sess...),
57 - obsługa proxy (w tym uwierzytelnianie podstawowe i skrótem),
daa7576e
JR
58 - mechanizm obsługi odpowiedzi WebDAV 207 XML,
59 - analiza składniowa XML przy pomocy expat lub libxml,
60 - proste generowanie komunikatów błędów dla odpowiedzi 207,
b9b2c7f8 61 - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
daa7576e
JR
62 - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
63 sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
769e704f
JB
64
65%package devel
66Summary: Header files for neon
b690de02 67Summary(pl.UTF-8): Pliki nagłówkowe neon
769e704f 68Group: Development/Libraries
72e4cede 69Requires: %{name} = %{version}-%{release}
bb8183bd 70%{?with_kerberos5:Requires: heimdal-devel}
a3226741 71%{?with_libproxy:Requires: libproxy-devel}
b45d8f35 72Requires: libxml2-devel
b00d07c4 73Requires: openssl-devel >= 0.9.7c
769e704f
JB
74
75%description devel
76C header files for the neon library.
77
daa7576e
JR
78%description devel -l pl.UTF-8
79Pliki nagłówkowe dla biblioteki neon.
769e704f
JB
80
81%package static
82Summary: Static libraries for neon
b690de02 83Summary(pl.UTF-8): Biblioteki statyczne neon
94a59c75 84Group: Development/Libraries
72e4cede 85Requires: %{name}-devel = %{version}-%{release}
94a59c75 86
769e704f
JB
87%description static
88Static neon libraries.
89
daa7576e 90%description static -l pl.UTF-8
769e704f 91Statyczne biblioteki neon.
94a59c75 92
38878d3d
ER
93%package apidocs
94Summary: neon API documentation
95Summary(pl.UTF-8): Dokumentacja API biblioteki neon
96Group: Documentation
97
98%description apidocs
99API and internal documentation for neon library.
100
101%description apidocs -l pl.UTF-8
102Dokumentacja API biblioteki neon.
103
94a59c75 104%prep
105%setup -q
106
107%build
318af41d 108%{__libtoolize} --install
387c948a 109%{__aclocal} -I macros
45b289d5 110%{__autoconf}
9dc601f3 111%configure \
9dc601f3 112 --with-ssl \
3aeb853f 113 --enable-threadsafe-ssl=posix \
9dc601f3 114 --enable-shared \
df50a546 115 %{!?with_static_libs:--disable-static} \
9065805f 116 %{!?with_kerberos5:--without-gssapi} \
e0c5c301 117 %{!?with_libproxy:--without-libproxy} \
9dc601f3
PG
118 --with-libxml2
119
94a59c75 120%{__make}
121
122%install
123rm -rf $RPM_BUILD_ROOT
769e704f 124
c8dbfeab
JB
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT
94a59c75 127
e80eb8df 128%find_lang %{name}
129
94a59c75 130%clean
131rm -rf $RPM_BUILD_ROOT
132
769e704f
JB
133%post -p /sbin/ldconfig
134%postun -p /sbin/ldconfig
94a59c75 135
e80eb8df 136%files -f %{name}.lang
94a59c75 137%defattr(644,root,root,755)
38878d3d 138%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
b8ab1935
JB
139%attr(755,root,root) %{_libdir}/libneon.so.*.*.*
140%attr(755,root,root) %ghost %{_libdir}/libneon.so.27
94a59c75 141
142%files devel
143%defattr(644,root,root,755)
38878d3d 144%doc doc/*.txt
2c6a6cf1 145%attr(755,root,root) %{_bindir}/neon-config
b8ab1935
JB
146%attr(755,root,root) %{_libdir}/libneon.so
147%{_libdir}/libneon.la
2f50aeeb 148%{_includedir}/neon
afebb879 149%{_pkgconfigdir}/neon.pc
b8ab1935
JB
150%{_mandir}/man1/neon-config.1*
151%{_mandir}/man3/ne_*.3*
152%{_mandir}/man3/neon.3*
769e704f 153
d69a9291 154%if %{with static_libs}
769e704f
JB
155%files static
156%defattr(644,root,root,755)
b8ab1935 157%{_libdir}/libneon.a
d69a9291 158%endif
38878d3d
ER
159
160%if %{with apidocs}
161%files apidocs
162%defattr(644,root,root,755)
163%doc doc/html/*
164%endif
This page took 0.065761 seconds and 4 git commands to generate.