]> git.pld-linux.org Git - packages/neon.git/blame - neon.spec
- release 2 (by relup.sh)
[packages/neon.git] / neon.spec
CommitLineData
d69a9291 1#
2# Conditional build:
38878d3d 3%bcond_without apidocs # do not build and package API docs
d69a9291 4%bcond_without static_libs # don't build static libraries
9065805f 5%bcond_without kerberos5 # don't build Kerberos V support
e0c5c301 6%bcond_without libproxy # don't build libproxy support
caa88408 7%bcond_without pakchois # don't build pakchois-based PKCS#11 support
38878d3d 8
94a59c75 9Summary: An HTTP and WebDAV client library
b690de02 10Summary(pl.UTF-8): Biblioteka kliencka HTTP i WebDAV
94a59c75 11Name: neon
eb908ec5 12Version: 0.30.0
4f1895b0 13Release: 2
b8ab1935 14License: LGPL v2+
94a59c75 15Group: Libraries
94a59c75 16Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
eb908ec5 17# Source0-md5: fb60b3a124eeec441937a812c456fd94
769e704f 18URL: http://www.webdav.org/neon/
b8ab1935 19BuildRequires: autoconf >= 2.58
60170b09 20BuildRequires: automake
bb8183bd 21%{?with_kerberos5:BuildRequires: heimdal-devel}
e0c5c301 22%{?with_libproxy:BuildRequires: libproxy-devel}
f9ae6476 23BuildRequires: libtool >= 2:2.2
9dc601f3 24BuildRequires: libxml2-devel
fbe113ef 25BuildRequires: openssl-devel >= 0.9.7d
caa88408 26%{?with_pakchois:BuildRequires: pakchois-devel}
0eb136aa 27BuildRequires: pkgconfig
a8ebb846 28BuildRequires: zlib-devel
8c7138b5 29%requires_eq_to openssl openssl-devel
e914cc74 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94a59c75 31
32%description
33neon is an HTTP and WebDAV client library, with a C interface.
34Featuring:
882d452f 35 - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD
36 etc).
94a59c75 37 - Low-level interface to HTTP request handling, to allow implementing
38 new methods easily.
b9b2c7f8 39 - HTTP/1.1 and HTTP/1.0 persistent connections.
94a59c75 40 - RFC2617 basic and digest authentication (including auth-int,
b9b2c7f8 41 md5-sess).
42 - Proxy support (including basic/digest authentication).
43 - Generic WebDAV 207 XML response handling mechanism.
44 - XML parsing using the expat or libxml parsers.
45 - Easy generation of error messages from 207 error responses.
94a59c75 46 - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
47 - WebDAV metadata support: set and remove properties, query any set of
48 properties (PROPPATCH/PROPFIND).
49
daa7576e 50%description -l pl.UTF-8
769e704f 51neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
daa7576e 52Możliwości:
882d452f 53 - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET,
54 HEAD...),
4b31dd0e 55 - niskopoziomowy interfejs do obsługi żądań HTTP pozwalający łatwo
daa7576e
JR
56 implementować nowe metody,
57 - stałe połączenia HTTP/1.1 i HTTP/1.0,
4b31dd0e
JB
58 - uwierzytelnianie podstawowe (basic) i skrótem RFC-2617 (auth-int,
59 md5-sess...),
60 - obsługa proxy (w tym uwierzytelnianie podstawowe i skrótem),
daa7576e
JR
61 - mechanizm obsługi odpowiedzi WebDAV 207 XML,
62 - analiza składniowa XML przy pomocy expat lub libxml,
63 - proste generowanie komunikatów błędów dla odpowiedzi 207,
b9b2c7f8 64 - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
daa7576e
JR
65 - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
66 sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
769e704f
JB
67
68%package devel
69Summary: Header files for neon
b690de02 70Summary(pl.UTF-8): Pliki nagłówkowe neon
769e704f 71Group: Development/Libraries
72e4cede 72Requires: %{name} = %{version}-%{release}
bb8183bd 73%{?with_kerberos5:Requires: heimdal-devel}
a3226741 74%{?with_libproxy:Requires: libproxy-devel}
caa88408 75%{?with_pakchois:Requires: pakchois-devel}
b45d8f35 76Requires: libxml2-devel
b00d07c4 77Requires: openssl-devel >= 0.9.7c
769e704f
JB
78
79%description devel
80C header files for the neon library.
81
daa7576e
JR
82%description devel -l pl.UTF-8
83Pliki nagłówkowe dla biblioteki neon.
769e704f
JB
84
85%package static
86Summary: Static libraries for neon
b690de02 87Summary(pl.UTF-8): Biblioteki statyczne neon
94a59c75 88Group: Development/Libraries
72e4cede 89Requires: %{name}-devel = %{version}-%{release}
94a59c75 90
769e704f
JB
91%description static
92Static neon libraries.
93
daa7576e 94%description static -l pl.UTF-8
769e704f 95Statyczne biblioteki neon.
94a59c75 96
38878d3d
ER
97%package apidocs
98Summary: neon API documentation
99Summary(pl.UTF-8): Dokumentacja API biblioteki neon
100Group: Documentation
101
102%description apidocs
103API and internal documentation for neon library.
104
105%description apidocs -l pl.UTF-8
106Dokumentacja API biblioteki neon.
107
94a59c75 108%prep
109%setup -q
110
111%build
318af41d 112%{__libtoolize} --install
387c948a 113%{__aclocal} -I macros
45b289d5 114%{__autoconf}
9dc601f3 115%configure \
bbe4098c 116 --with-ssl=openssl \
3aeb853f 117 --enable-threadsafe-ssl=posix \
9dc601f3 118 --enable-shared \
bbe4098c 119 --with-ca-bundle=/etc/certs/ca-certificates.crt \
caa88408 120 --with%{!?with_pakchois:out}-pakchois \
df50a546 121 %{!?with_static_libs:--disable-static} \
9065805f 122 %{!?with_kerberos5:--without-gssapi} \
e0c5c301 123 %{!?with_libproxy:--without-libproxy} \
9dc601f3
PG
124 --with-libxml2
125
94a59c75 126%{__make}
127
128%install
129rm -rf $RPM_BUILD_ROOT
769e704f 130
c8dbfeab
JB
131%{__make} install \
132 DESTDIR=$RPM_BUILD_ROOT
94a59c75 133
9dc179f0
JP
134%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html
135%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
caa88408 136
e80eb8df 137%find_lang %{name}
138
94a59c75 139%clean
140rm -rf $RPM_BUILD_ROOT
141
769e704f
JB
142%post -p /sbin/ldconfig
143%postun -p /sbin/ldconfig
94a59c75 144
e80eb8df 145%files -f %{name}.lang
94a59c75 146%defattr(644,root,root,755)
38878d3d 147%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
b8ab1935
JB
148%attr(755,root,root) %{_libdir}/libneon.so.*.*.*
149%attr(755,root,root) %ghost %{_libdir}/libneon.so.27
94a59c75 150
151%files devel
152%defattr(644,root,root,755)
38878d3d 153%doc doc/*.txt
2c6a6cf1 154%attr(755,root,root) %{_bindir}/neon-config
b8ab1935 155%attr(755,root,root) %{_libdir}/libneon.so
2f50aeeb 156%{_includedir}/neon
afebb879 157%{_pkgconfigdir}/neon.pc
b8ab1935
JB
158%{_mandir}/man1/neon-config.1*
159%{_mandir}/man3/ne_*.3*
160%{_mandir}/man3/neon.3*
769e704f 161
d69a9291 162%if %{with static_libs}
769e704f
JB
163%files static
164%defattr(644,root,root,755)
b8ab1935 165%{_libdir}/libneon.a
d69a9291 166%endif
38878d3d
ER
167
168%if %{with apidocs}
169%files apidocs
170%defattr(644,root,root,755)
171%doc doc/html/*
172%endif
This page took 0.207757 seconds and 4 git commands to generate.