]> git.pld-linux.org Git - packages/neon.git/blame - neon.spec
- 0.29.3
[packages/neon.git] / neon.spec
CommitLineData
d69a9291 1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
9065805f 4%bcond_without kerberos5 # don't build Kerberos V support
e0c5c301 5%bcond_without libproxy # don't build libproxy support
d69a9291 6#
94a59c75 7Summary: An HTTP and WebDAV client library
b690de02 8Summary(pl.UTF-8): Biblioteka kliencka HTTP i WebDAV
94a59c75 9Name: neon
16b2e527 10Version: 0.29.3
5b977782 11Release: 1
b8ab1935 12License: LGPL v2+
94a59c75 13Group: Libraries
94a59c75 14Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
16b2e527 15# Source0-md5: ba1015b59c112d44d7797b62fe7bee51
769e704f 16URL: http://www.webdav.org/neon/
b8ab1935 17BuildRequires: autoconf >= 2.58
60170b09 18BuildRequires: automake
bb8183bd 19%{?with_kerberos5:BuildRequires: heimdal-devel}
e0c5c301 20%{?with_libproxy:BuildRequires: libproxy-devel}
f9ae6476 21BuildRequires: libtool >= 2:2.2
9dc601f3 22BuildRequires: libxml2-devel
fbe113ef 23BuildRequires: openssl-devel >= 0.9.7d
a8ebb846 24BuildRequires: zlib-devel
e914cc74 25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94a59c75 26
27%description
28neon is an HTTP and WebDAV client library, with a C interface.
29Featuring:
b9b2c7f8 30 - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD etc).
94a59c75 31 - Low-level interface to HTTP request handling, to allow implementing
32 new methods easily.
b9b2c7f8 33 - HTTP/1.1 and HTTP/1.0 persistent connections.
94a59c75 34 - RFC2617 basic and digest authentication (including auth-int,
b9b2c7f8 35 md5-sess).
36 - Proxy support (including basic/digest authentication).
37 - Generic WebDAV 207 XML response handling mechanism.
38 - XML parsing using the expat or libxml parsers.
39 - Easy generation of error messages from 207 error responses.
94a59c75 40 - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
41 - WebDAV metadata support: set and remove properties, query any set of
42 properties (PROPPATCH/PROPFIND).
43
daa7576e 44%description -l pl.UTF-8
769e704f 45neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
daa7576e 46Możliwości:
b9b2c7f8 47 - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET, HEAD...),
4b31dd0e 48 - niskopoziomowy interfejs do obsługi żądań HTTP pozwalający łatwo
daa7576e
JR
49 implementować nowe metody,
50 - stałe połączenia HTTP/1.1 i HTTP/1.0,
4b31dd0e
JB
51 - uwierzytelnianie podstawowe (basic) i skrótem RFC-2617 (auth-int,
52 md5-sess...),
53 - obsługa proxy (w tym uwierzytelnianie podstawowe i skrótem),
daa7576e
JR
54 - mechanizm obsługi odpowiedzi WebDAV 207 XML,
55 - analiza składniowa XML przy pomocy expat lub libxml,
56 - proste generowanie komunikatów błędów dla odpowiedzi 207,
b9b2c7f8 57 - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
daa7576e
JR
58 - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
59 sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
769e704f
JB
60
61%package devel
62Summary: Header files for neon
b690de02 63Summary(pl.UTF-8): Pliki nagłówkowe neon
769e704f 64Group: Development/Libraries
72e4cede 65Requires: %{name} = %{version}-%{release}
bb8183bd 66%{?with_kerberos5:Requires: heimdal-devel}
b45d8f35 67Requires: libxml2-devel
b00d07c4 68Requires: openssl-devel >= 0.9.7c
769e704f
JB
69
70%description devel
71C header files for the neon library.
72
daa7576e
JR
73%description devel -l pl.UTF-8
74Pliki nagłówkowe dla biblioteki neon.
769e704f
JB
75
76%package static
77Summary: Static libraries for neon
b690de02 78Summary(pl.UTF-8): Biblioteki statyczne neon
94a59c75 79Group: Development/Libraries
72e4cede 80Requires: %{name}-devel = %{version}-%{release}
94a59c75 81
769e704f
JB
82%description static
83Static neon libraries.
84
daa7576e 85%description static -l pl.UTF-8
769e704f 86Statyczne biblioteki neon.
94a59c75 87
88%prep
89%setup -q
90
91%build
318af41d 92%{__libtoolize} --install
387c948a 93%{__aclocal} -I macros
45b289d5 94%{__autoconf}
9dc601f3 95%configure \
9dc601f3 96 --with-ssl \
3aeb853f 97 --enable-threadsafe-ssl=posix \
9dc601f3 98 --enable-shared \
d69a9291 99 %{!?with_static_libs:--enable-static=no} \
9065805f 100 %{!?with_kerberos5:--without-gssapi} \
e0c5c301 101 %{!?with_libproxy:--without-libproxy} \
9dc601f3
PG
102 --with-libxml2
103
94a59c75 104%{__make}
105
106%install
107rm -rf $RPM_BUILD_ROOT
f97eaad9 108install -d $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man1,%{_mandir}/man3}
769e704f 109
c8dbfeab
JB
110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
94a59c75 112
d5a2bb25
MM
113mv -f doc/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
114mv -f doc/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
94a59c75 115
e80eb8df 116%find_lang %{name}
117
94a59c75 118%clean
119rm -rf $RPM_BUILD_ROOT
120
769e704f
JB
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
94a59c75 123
e80eb8df 124%files -f %{name}.lang
94a59c75 125%defattr(644,root,root,755)
d5a2bb25 126%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*.txt doc/html/*
b8ab1935
JB
127%attr(755,root,root) %{_libdir}/libneon.so.*.*.*
128%attr(755,root,root) %ghost %{_libdir}/libneon.so.27
94a59c75 129
130%files devel
131%defattr(644,root,root,755)
2c6a6cf1 132%attr(755,root,root) %{_bindir}/neon-config
b8ab1935
JB
133%attr(755,root,root) %{_libdir}/libneon.so
134%{_libdir}/libneon.la
2f50aeeb 135%{_includedir}/neon
afebb879 136%{_pkgconfigdir}/neon.pc
b8ab1935
JB
137%{_mandir}/man1/neon-config.1*
138%{_mandir}/man3/ne_*.3*
139%{_mandir}/man3/neon.3*
769e704f 140
d69a9291 141%if %{with static_libs}
769e704f
JB
142%files static
143%defattr(644,root,root,755)
b8ab1935 144%{_libdir}/libneon.a
d69a9291 145%endif
This page took 0.097693 seconds and 4 git commands to generate.