]> git.pld-linux.org Git - packages/neon.git/blame - neon.spec
- added CVE reference to rev 1.59 changelog
[packages/neon.git] / neon.spec
CommitLineData
d69a9291 1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
9065805f 4%bcond_without kerberos5 # don't build Kerberos V support
d69a9291 5#
94a59c75 6Summary: An HTTP and WebDAV client library
b690de02 7Summary(pl.UTF-8): Biblioteka kliencka HTTP i WebDAV
94a59c75 8Name: neon
fb8c15cc 9Version: 0.26.3
9065805f 10Release: 2
94a59c75 11License: GPL
12Group: Libraries
94a59c75 13Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
fb8c15cc 14# Source0-md5: 6e52cd9c03e372026d6eccbfb80f09ef
769e704f 15URL: http://www.webdav.org/neon/
60170b09
JB
16BuildRequires: autoconf >= 2.53
17BuildRequires: automake
9065805f 18%{?with_kerberos5:BuildRequires: krb5-devel}
0b3420ad 19BuildRequires: libtool
9dc601f3 20BuildRequires: libxml2-devel
fbe113ef 21BuildRequires: openssl-devel >= 0.9.7d
a8ebb846 22BuildRequires: zlib-devel
e914cc74 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94a59c75 24
25%description
26neon is an HTTP and WebDAV client library, with a C interface.
27Featuring:
b9b2c7f8 28 - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD etc).
94a59c75 29 - Low-level interface to HTTP request handling, to allow implementing
30 new methods easily.
b9b2c7f8 31 - HTTP/1.1 and HTTP/1.0 persistent connections.
94a59c75 32 - RFC2617 basic and digest authentication (including auth-int,
b9b2c7f8 33 md5-sess).
34 - Proxy support (including basic/digest authentication).
35 - Generic WebDAV 207 XML response handling mechanism.
36 - XML parsing using the expat or libxml parsers.
37 - Easy generation of error messages from 207 error responses.
94a59c75 38 - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
39 - WebDAV metadata support: set and remove properties, query any set of
40 properties (PROPPATCH/PROPFIND).
41
daa7576e 42%description -l pl.UTF-8
769e704f 43neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
daa7576e 44Możliwości:
b9b2c7f8 45 - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET, HEAD...),
daa7576e
JR
46 - niskopziomowy interfejs to obsługi żądań HTTP pozwalający łatwo
47 implementować nowe metody,
48 - stałe połączenia HTTP/1.1 i HTTP/1.0,
49 - autentykacja podstawowa i skrótem RFC-2617 (auth-int, md5-sess...),
50 - obsługa proxy (w tym autentykacja podstawowa i skrótem),
51 - mechanizm obsługi odpowiedzi WebDAV 207 XML,
52 - analiza składniowa XML przy pomocy expat lub libxml,
53 - proste generowanie komunikatów błędów dla odpowiedzi 207,
b9b2c7f8 54 - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
daa7576e
JR
55 - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
56 sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
769e704f
JB
57
58%package devel
59Summary: Header files for neon
b690de02 60Summary(pl.UTF-8): Pliki nagłówkowe neon
769e704f 61Group: Development/Libraries
72e4cede 62Requires: %{name} = %{version}-%{release}
9065805f 63%{?with_kerberos5:Requires: krb5-devel}
b45d8f35 64Requires: libxml2-devel
b00d07c4 65Requires: openssl-devel >= 0.9.7c
769e704f
JB
66
67%description devel
68C header files for the neon library.
69
daa7576e
JR
70%description devel -l pl.UTF-8
71Pliki nagłówkowe dla biblioteki neon.
769e704f
JB
72
73%package static
74Summary: Static libraries for neon
b690de02 75Summary(pl.UTF-8): Biblioteki statyczne neon
94a59c75 76Group: Development/Libraries
72e4cede 77Requires: %{name}-devel = %{version}-%{release}
94a59c75 78
769e704f
JB
79%description static
80Static neon libraries.
81
daa7576e 82%description static -l pl.UTF-8
769e704f 83Statyczne biblioteki neon.
94a59c75 84
85%prep
86%setup -q
87
88%build
0b3420ad 89%{__libtoolize}
387c948a 90%{__aclocal} -I macros
45b289d5 91%{__autoconf}
9dc601f3 92%configure \
9dc601f3
PG
93 --with-ssl \
94 --enable-shared \
d69a9291 95 %{!?with_static_libs:--enable-static=no} \
9065805f 96 %{!?with_kerberos5:--without-gssapi} \
9dc601f3
PG
97 --with-libxml2
98
94a59c75 99%{__make}
100
101%install
102rm -rf $RPM_BUILD_ROOT
f97eaad9 103install -d $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man1,%{_mandir}/man3}
769e704f 104
c8dbfeab
JB
105%{__make} install \
106 DESTDIR=$RPM_BUILD_ROOT
94a59c75 107
d5a2bb25
MM
108mv -f doc/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
109mv -f doc/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
94a59c75 110
4cebf91b 111mv $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
e80eb8df 112%find_lang %{name}
113
94a59c75 114%clean
115rm -rf $RPM_BUILD_ROOT
116
769e704f
JB
117%post -p /sbin/ldconfig
118%postun -p /sbin/ldconfig
94a59c75 119
e80eb8df 120%files -f %{name}.lang
94a59c75 121%defattr(644,root,root,755)
d5a2bb25 122%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*.txt doc/html/*
60170b09 123%attr(755,root,root) %{_libdir}/*.so.*.*
94a59c75 124
125%files devel
126%defattr(644,root,root,755)
2c6a6cf1 127%attr(755,root,root) %{_bindir}/neon-config
c8dbfeab
JB
128%attr(755,root,root) %{_libdir}/*.so
129%{_libdir}/*.la
2f50aeeb 130%{_includedir}/neon
2c6a6cf1 131%{_mandir}/man*/*
afebb879 132%{_pkgconfigdir}/neon.pc
769e704f 133
d69a9291 134%if %{with static_libs}
769e704f
JB
135%files static
136%defattr(644,root,root,755)
94a59c75 137%{_libdir}/*.a
d69a9291 138%endif
This page took 0.103855 seconds and 4 git commands to generate.