]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- relup
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
24%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 25%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
26%bcond_without osd # osd menu support
27%bcond_without rtmp # RTMPDump Streaming Media support
28%bcond_with shared # experimental libmplayer.so support
29%bcond_without smb # Samba (SMB) input support
10a6d1a6 30%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
31# - codecs:
32%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 33%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
34%bcond_without crystalhd # CrystalHD support
35%bcond_without faad # FAAD2 (AAC) support
36%bcond_without gif # GIF support
63bba7db
JB
37%bcond_without ladspa # LADSPA plugin support
38%bcond_without libdts # libdts support
39%bcond_without libdv # libdv en/decoding support
63bba7db
JB
40%bcond_without lzo # LZO support (requires lzo 2.x)
41%bcond_without mad # mad (audio MPEG) support
42%bcond_without mpg123 # libmpg123 MP3 decoding support
44d571a0 43%bcond_with musepack # libmpcdec support (deprecated in favour of libavcodec)
63bba7db 44%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
45%bcond_without quicktime # binary quicktime dll support
46%bcond_without real # Real* 8/9 codecs support
63bba7db 47%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
44d571a0 48%bcond_with tremor # use tremor instead of libvorbis
62ba71a7
JB
49%bcond_without theora # Ogg Theora video support
50%bcond_without win32 # Win32 codecs support
51%bcond_without x264 # x264 support
52%bcond_with xmms # XMMS inputplugin support
63bba7db 53%bcond_without xvid # XviD codec
62ba71a7 54%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 55%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
56# - video output:
57%bcond_without aalib # aalib video output
58%bcond_without caca # libcaca video output
59%bcond_with directfb # DirectFB video output
10a6d1a6
JB
60%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
61%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
62%bcond_with ggi # GGI video output
63%bcond_without sdl # SDL video output
64%bcond_with svga # svgalib video output
65%bcond_without vdpau # VDPAU acceleration
66%bcond_without vidix # VIDIX video drivers
63bba7db 67%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
68%bcond_with gnomess # controling gnome screensaver [patch not updated]
69# - audio output:
70%bcond_without alsa # ALSA audio output
71%bcond_with arts # aRts audio output
72%bcond_with esd # EsounD sound support
73%bcond_without jack # JACKD support
74%bcond_with nas # NAS audio output
75%bcond_without pulseaudio # pulseaudio output
76%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 77
9accd5e5 78%if %{with alsa}
79%undefine with_select
80%endif
d1f72115 81%if %{without vorbis}
44d571a0 82%undefine with_tremor
d1f72115 83%endif
84
94cb018b
JB
85%ifnarch %{ix86}
86%undefine with_win32
7a82c266 87%undefine with_quicktime
1087e996 88%undefine with_vidix
94cb018b 89%endif
38c74592 90%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
91%undefine with_runtime
92%endif
ca278bdf
ER
93%ifnarch %{ix86} %{x8664}
94%undefine with_vdpau
95%endif
3d17ae18
ER
96%ifnarch ppc
97%undefine with_altivec
98%endif
810f3f3d
ER
99%ifnarch i686 pentium4 athlon %{x8664}
100%undefine with_crystalhd
101%endif
3d17ae18 102
b4c9d1de 103%if "%{_lib}" != "lib"
40ce9ce9 104%define binsuf %(lib=%{_lib} ; echo ${lib#lib})
1a8df7bd 105%else
40ce9ce9 106%ifarch %{ix86} ppc sparc sparcv9 s390
e2b12b5a 107%define binsuf 32
40ce9ce9
JB
108%else
109%define binsuf %{nil}
110%endif
1a8df7bd 111%endif
112
b1e29978 113%if 0
0cd1ec52 114# date from directory inside of tarball (like mplayer-export-2014-04-29)
b13d3bd9 115%define snap 2018-05-22
0cd1ec52 116%define ssnap %(echo %{snap} | tr -d -)
b1e29978 117%endif
906bf13b 118Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
119Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
120Summary(es.UTF-8): Otro reproductor de películas
121Summary(ko.UTF-8): 리눅스용 미디어플레이어
122Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
123Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 124Name: mplayer
24bfe2fa 125Version: 1.5
6e2d8021 126Release: 4
1f85fd72
ER
127# DO NOT increase epoch unless it's really neccessary!
128# especially such changes like pre7->pre7try2, increase Release instead!
129# PS: $ rpmvercmp pre7try2 pre7
130# pre7try2 > pre7
59476b48 131Epoch: 3
bc426a7f 132License: GPL
906bf13b 133Group: Applications/Multimedia
b1e29978
JB
134# Source0: http://mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
135Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
24bfe2fa 136# Source0-md5: 0419b64db24b6db0943dbc6afece7c44
b1e29978 137%if 0
0cd1ec52 138Source1: http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
dea0f5a7 139# Source1-md5: b1b71cc56b15da49cee1ede9a7b8134e
b1e29978
JB
140%endif
141Source2: http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
142# Source2-md5: 1ecd31d17b51f16332b1fcc7da36b312
143Source3: http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 144# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
b1e29978
JB
145Source4: http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-7.tar.bz2
146# Source4-md5: 956a9d9ea51970e057f0deb7b2e25889
e601cd91 147Source5: g%{name}.desktop
11b89ef7 148Source7: %{name}.png
24481cd2 149Source8: %{name}.desktop
79907b07 150
151# build (configure / Makefile) related:
152Patch10: %{name}-ldflags.patch
153Patch11: %{name}-altivec.patch
154Patch12: %{name}-check-byteswap.patch
c2bf8f19 155Patch13: %{name}-visibility-hidden-fix.patch
2bb2f3d6 156Patch14: cflags.patch
1ee1ef52 157Patch15: %{name}-live555-async.patch
24bfe2fa 158Patch16: %{name}-live555-config.patch
63bba7db 159Patch17: %{name}-gsm.patch
7eb1aa3e 160
63bba7db 161Patch19: %{name}-shared.patch
990687b2 162Patch20: %{name}-vstream.patch
79907b07 163
164# codecs, outputs, demuxers:
990687b2
JB
165Patch21: %{name}-auto-expand.patch
166Patch22: %{name}-release_directfb.patch
79907b07 167
168# goodies:
169Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 170Patch31: %{name}-350.patch
d1f72115 171# update, hard to fix right now because of gnome bug 579430:
172# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 173#Patch32: %{name}-gnome-screensaver.patch
d03dba0e 174Patch33: binutils2.41.patch
0859151b 175Patch34: po-charset.patch
79907b07 176
b252aa8a 177Patch101: %{name}-link.patch
79907b07 178
c5b97685 179URL: http://www.mplayerhq.hu/
44d571a0
JB
180%{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.22}
181BuildRequires: EGL-devel
aeb67db6 182BuildRequires: OpenAL-devel
44d571a0 183BuildRequires: OpenGL-GLX-devel
11421384 184%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
44d571a0
JB
185# checked, but seems actually not used
186#%{?with_sdl:BuildRequires: SDL_image-devel}
63bba7db 187BuildRequires: a52dec-libs-devel
dd6c659c
JB
188%{?with_aalib:BuildRequires: aalib-devel}
189%{?with_alsa:BuildRequires: alsa-lib-devel}
24bfe2fa 190BuildRequires: aom-devel
dd6c659c 191%{?with_arts:BuildRequires: artsc-devel}
92e0d154 192BuildRequires: binutils >= 1:2.10.1
841cb995 193%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 194BuildRequires: bzip2-devel
364125e7 195#%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
24bfe2fa 196BuildRequires: dav1d-devel
df52db46 197%{?with_gnomess:BuildRequires: dbus-glib-devel}
d6da6cb0 198%{?with_doc:BuildRequires: docbook-dtd45-xml}
5dcdda0f 199%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 200%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 201%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
202%{?with_enca:BuildRequires: enca-devel}
203%{?with_esd:BuildRequires: esound-devel}
30e3739f 204BuildRequires: faac-devel
3c3fdfcc 205%{?with_faad:BuildRequires: faad2-devel >= 2.0}
24bfe2fa 206%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 5.1}
63bba7db 207BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 208BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 209BuildRequires: fribidi-devel
3d17ae18 210%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 211%{?with_gif:BuildRequires: giflib-devel}
44d571a0
JB
212%{?with_gui:BuildRequires: glib2-devel >= 1:2.6.0}
213BuildRequires: gnutls-devel
214%{?with_gui:BuildRequires: gtk+2-devel >= 2:2.4.0}
d336e259 215%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 216%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 217BuildRequires: lame-libs-devel
6bd88460 218BuildRequires: libass-devel >= 0.9.10
c3a1256a 219%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 220%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 221%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
222%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
223%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 224%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 225%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
364125e7 226#%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 227%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 228%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 229%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
230%{?with_ggi:BuildRequires: libggiwmh-devel}
231BuildRequires: libgsm-devel
af480c75 232BuildRequires: libjpeg-devel
dd6c659c 233%{?with_mad:BuildRequires: libmad-devel}
c521a17c 234BuildRequires: libmng-devel
63bba7db
JB
235%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
236%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
237%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 238%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 239BuildRequires: libnut-devel
af480c75 240BuildRequires: libpng-devel
63bba7db 241%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 242%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 243%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 244%{?with_vdpau:BuildRequires: libvdpau-devel}
44d571a0
JB
245%if %{with vorbis} && %{without tremor}
246BuildRequires: libvorbis-devel
247%endif
0431b837 248BuildRequires: libvpx-devel
44d571a0 249# build >= 118
bbab8eb7 250%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
24bfe2fa 251BuildRequires: libxml2-devel >= 2.0
ceb01d0e 252BuildRequires: libxslt-progs
44d571a0
JB
253# with v4l2 headers
254BuildRequires: linux-libc-headers >= 7:2.6.22
dd6c659c 255%{?with_lirc:BuildRequires: lirc-devel}
1ee1ef52 256%{?with_live:BuildRequires: live-devel >= 2:2011.01.10}
841cb995 257%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 258%{?with_nas:BuildRequires: nas-devel}
b458005d 259BuildRequires: ncurses-devel
b69a6f83 260%{?with_amr:BuildRequires: opencore-amr-devel}
4362ee26 261%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
44d571a0 262BuildRequires: opus-devel
e9d22b19 263BuildRequires: pkgconfig
86bc294f 264%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 265BuildRequires: rpm >= 4.4.9-56
9accd5e5 266BuildRequires: rpmbuild(macros) >= 1.527
aeb67db6 267BuildRequires: speex-devel >= 1.1
dd6c659c 268%{?with_svga:BuildRequires: svgalib-devel}
3af20979 269BuildRequires: tar >= 1:1.22
44d571a0 270%{?with_tremor:BuildRequires: tremor-devel}
c521a17c 271BuildRequires: twolame-devel
3af20979 272%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 273%{?with_vstream:BuildRequires: vstream-client-devel}
44d571a0 274BuildRequires: webrtc-libilbc-devel
c521a17c 275%{?with_xmms:BuildRequires: xmms-devel}
627a7a97 276BuildRequires: xorg-lib-libX11-devel
c521a17c 277BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
278BuildRequires: xorg-lib-libXext-devel
279BuildRequires: xorg-lib-libXinerama-devel
280BuildRequires: xorg-lib-libXv-devel
281BuildRequires: xorg-lib-libXvMC-devel
282BuildRequires: xorg-lib-libXxf86dga-devel
283BuildRequires: xorg-lib-libXxf86vm-devel
b57c3c6c
ER
284%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
285BuildRequires: xz
286%ifarch %{ix86} %{x8664}
287BuildRequires: yasm
288%endif
289BuildRequires: zlib-devel
4d75c49f 290Requires: %{name}-common = %{epoch}:%{version}-%{release}
4362ee26 291%{?with_openjpeg:Requires: openjpeg2 >= 2.1.0}
0f2a502d 292BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 293
bb27cfbd 294%define specflags_ia32 -fomit-frame-pointer
198487b4 295%if %{with altivec}
adfd0023 296%define specflags_ppc -maltivec
20a66bdb 297%endif
2adea73e
AM
298
299%description
c902f7c6 300Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
301AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 302MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
303MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 304devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
305optionally with SHM extension, X11 using overlays with the Xvideo
306extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
307Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 308
8b146837 309If you want to use win32 codecs install w32codec package.
4228a246 310
e011d408 311%description -l de.UTF-8
deba608c 312MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
313Kennzeichnend ist die herausragende Format- und
e011d408 314Plattform-Kompatibilität.
deba608c 315
e011d408
JR
316Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
317plattformexklusive, wodurch etwa Windows Media auch außerhalb von
318Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
319Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 320ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
321Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
322installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 323
e011d408 324%description -l es.UTF-8
c902f7c6 325Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
326MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
327(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
328de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
329Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
330G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
331overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 332G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
333v1.1.7 etc.
33c4efab 334
8b146837 335Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 336
e011d408
JR
337%description -l ko.UTF-8
338MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
339파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
340MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
341Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
342(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
343수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
344크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
345있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
346부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 347
e011d408
JR
348%description -l pl.UTF-8
349Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 350RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
351(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
352Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 353Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 354rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 355G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 356
e011d408 357Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 358
e011d408
JR
359%description -l pt_BR.UTF-8
360MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
361áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 362escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
363
11421384
ER
364%package -n gmplayer
365Summary: MPlayer with GTK+ GUI interface
eeb91a66 366Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 367Group: X11/Applications/Multimedia
11421384 368Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 369Requires: %{name}-skin
11421384
ER
370
371%description -n gmplayer
372MPlayer with GUI GTK+ interface.
373
e011d408 374%description -n gmplayer -l pl.UTF-8
906bf13b
JB
375MPlayer z graficznym interfejsem GTK+.
376
11421384 377%package common
906bf13b 378Summary: Configuration files and documentation for MPlayer
eeb91a66 379Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 380Group: Applications/Multimedia
c521a17c 381Suggests: unrar
c7132fcf 382Obsoletes: mplayer-vidix < 1.0-3.rc1.2
11421384
ER
383
384%description common
906bf13b
JB
385Configuration files, man page and HTML documentation for MPlayer.
386
e011d408 387%description common -l pl.UTF-8
906bf13b 388Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 389
dc3c7d77 390%package doc
63bba7db
JB
391Summary: HTML documentation for MPlayer
392Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
393Group: Documentation
394
395%description doc
63bba7db
JB
396HTML Documentation for MPlayer.
397
398%description doc -l pl.UTF-8
399Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 400
11421384 401%package -n mencoder
906bf13b 402Summary: MEncoder - a movie encoder for Linux
eeb91a66 403Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
404Group: Applications/Multimedia
405Requires: %{name}-common = %{epoch}:%{version}-%{release}
406
407%description -n mencoder
906bf13b
JB
408MEncoder is a movie encoder for Linux and is a part of the MPlayer
409package.
410
e011d408
JR
411%description -n mencoder -l pl.UTF-8
412MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 413
2adea73e 414%prep
b1e29978
JB
415%if 0%{?snap:1}
416%setup -q -n %{name}-export-%{snap} -a1 -a2 -a3 -a4
417%else
418%setup -q -n MPlayer-%{version} -a2 -a3 -a4
419%endif
833dbe20 420cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 421
422# build (configure / Makefile) related:
423%patch10 -p1
424%patch11 -p1
425%patch12 -p1
c2bf8f19 426%patch13 -p1
2bb2f3d6 427%patch14 -p1
e2b12b5a 428%patch15 -p1
24bfe2fa 429%patch16 -p1
63bba7db 430%patch17 -p1
7eb1aa3e 431
63bba7db 432%{?with_shared:%patch19 -p1}
990687b2 433%patch20 -p1
79907b07 434
435# codecs, outputs, demuxers:
79907b07 436%patch21 -p1
990687b2 437%patch22 -p1
79907b07 438
439# goodies:
440%patch30 -p0
2833f81f 441%patch31 -p1
442#%{with_gnomess:%patch32 -p1}
d03dba0e 443%patch33 -p1 -d ffmpeg
0859151b 444%patch34 -p1
59ba0205 445
b252aa8a
PS
446%patch101 -p1
447
53f97285 448cat etc/example.conf > etc/mplayer.conf
c521a17c 449cat <<'CONFIGADD' >> etc/mplayer.conf
450
d1f72115 451######################
8b2ed1fb 452# PLD Linux Defaults #
d1f72115 453######################
2833f81f 454[default]
455
456# alternate solution for CP1250-encoded subtitles
457fontconfig = yes
458subcp = cp1250
459
460# ...or if you prefer native bitmap fonts shipped with mplayer
461#fontconfig = no
462#subcp = iso-8859-1
463
464# Standard location
465unrarexec = "%{_bindir}/unrar"
466
993f72f1
ER
467# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
468joystick=no
469
c521a17c 470CONFIGADD
d1732085 471
1f8d8779
ER
472%if %{with system_ffmpeg}
473# using external ffmpeg, but mplayer adds these to includepath
0cd1ec52 474%{__rm} -rf ffmpeg
1f8d8779
ER
475%endif
476
2adea73e 477%build
5dcdda0f 478CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
24bfe2fa 479CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb: -I%{_includedir}/directfb} -DHAVE_GSM_H=1"
53f97285 480
63bba7db
JB
481# NOTE:
482# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
483# - toolame is obsolete predecessor of twolame
44d571a0 484# - libcdio-paranoia is preferred over cdparanoia-III libs
11421384 485build() {
c521a17c 486 set -x
53f97285 487
11421384
ER
488 ./configure \
489 %{?debug:--enable-debug=3} \
dd6c659c 490 --prefix=%{_prefix} \
63bba7db 491 --codecsdir=%{_libdir}/codecs \
dd6c659c 492 --confdir=%{_sysconfdir}/mplayer \
53f97285 493 --cc="%{__cc}" \
494 --extra-cflags="$CFLAGS" \
79907b07 495 --real-ldflags="%{rpmldflags}" \
496 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 497 --language=all \
1f8d8779 498%if %{with system_ffmpeg}
0cd1ec52 499 --disable-ffmpeg_a \
1f8d8779 500%endif
57f87bc2 501%ifnarch %{ix86} %{x8664}
dd6c659c 502 --disable-3dnow \
a14f4270 503 --disable-3dnowext \
63bba7db
JB
504 --disable-fastmemcpy \
505 --disable-mmx \
506 --disable-mmxext \
dd6c659c
JB
507 --disable-sse \
508 --disable-sse2 \
dfeec30a 509%endif
9accd5e5 510 %{__disable ssse3} \
1837afdf 511%ifarch ppc
9accd5e5 512 %{__disable altivec} \
1837afdf 513%endif
9accd5e5 514 %{__disable aalib aa} \
9accd5e5 515 %{__enable_disable alsa} \
516 %{__disable arts} \
63bba7db 517 %{__disable bluray} \
9accd5e5 518 %{__disable caca} \
519 %{__disable cdparanoia} \
63bba7db
JB
520 --enable-dga1 \
521 --enable-dga2 \
522 %{__enable_disable directfb} \
523 %{__enable_disable dvdnav} \
524 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 525 %{__disable dxr2} \
63bba7db
JB
526 %{__disable dxr3} \
527 --enable-dynamic-plugins \
9accd5e5 528 %{__disable enca} \
529 %{__disable esd} \
9accd5e5 530 %{__disable faad} \
63bba7db 531 --enable-fbdev \
9accd5e5 532 %{__disable gif} \
63bba7db
JB
533 --enable-gl \
534 %{__disable ggi} \
535 %{__disable jack} \
9accd5e5 536 %{__enable joystick} \
63bba7db
JB
537 %{__disable cdio libcdio} \
538 %{__disable ladspa} \
10a6d1a6 539 %{__disable bs2b libbs2b} \
9accd5e5 540 %{__disable libdts libdca} \
63bba7db 541 %{__disable libdv} \
24bfe2fa 542 %{__enable_disable live} \
63bba7db
JB
543 %{__disable system_dvdcss libdvdcss-internal} \
544 %{__disable lzo liblzo} \
545 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 546 %{__disable nemesi} \
63bba7db
JB
547 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
548 %{__disable openjpeg} \
549 %{__disable rtmp librtmp} \
550 %{__disable vorbis libvorbis} \
9accd5e5 551 %{__enable_disable lirc} \
63bba7db
JB
552 --disable-lircc \
553 %{__disable live} \
9accd5e5 554 %{__disable mad} \
63bba7db
JB
555 %{__disable mencoder} \
556 %{__enable osd menu} \
557 --enable-mga \
558 %{__disable mpg123} \
559 %{__enable musepack} \
560 %{__disable nas} \
9accd5e5 561 %{__disable pulseaudio pulse} \
562 %{__disable quicktime qtx} \
63bba7db
JB
563 --enable-radio \
564 --enable-radio-capture \
9accd5e5 565 %{__disable real} \
566 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 567 %{__enable_disable sdl} \
9accd5e5 568 %{__disable select} \
10a6d1a6 569 --enable-s3fb \
9accd5e5 570 %{__disable smb} \
63bba7db
JB
571 %{__disable svga} \
572 --enable-tdfxfb \
10a6d1a6 573 --enable-tdfxvid \
9accd5e5 574 %{__disable theora} \
63bba7db 575 --disable-toolame \
44d571a0 576 %{!?with_tremor:--disable-tremor} \
63bba7db 577 --enable-unrarexec \
9accd5e5 578 %{__disable vdpau} \
63bba7db 579 %{__disable vidix} \
10a6d1a6 580 %{__disable vstream} \
dd6c659c 581 --enable-vm \
10a6d1a6
JB
582%ifarch ppc
583 --enable-wii \
584%endif
63bba7db 585 %{__disable win32 win32dll} \
dd6c659c 586 --enable-x11 \
63bba7db 587 %{__disable x264} \
dd6c659c 588 --enable-xmga \
63bba7db 589 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 590 --enable-xv \
63bba7db
JB
591 %{__disable xvid} \
592 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 593 %{__enable_disable zr} \
11421384 594 "$@"
eb52750a 595
d53c9a42 596 %{__make} %{?with_verbose:V=1}
11421384 597}
2adea73e 598
11421384
ER
599%if %{with gui}
600# build GUI version
841cb995 601build --enable-gui --disable-mencoder
d6da6cb0 602%{__mv} mplayer gmplayer
aeb67db6 603%{__make} distclean
11421384
ER
604%endif
605
606# now build regular version
607build --disable-gui
608
aab7d90d 609%if %{with doc}
ef1e3931 610%{__make} -j1 doc
11421384 611%endif
ceb01d0e 612
2adea73e
AM
613%install
614rm -rf $RPM_BUILD_ROOT
e0e4b963 615install -d \
d23c171d 616 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
40ce9ce9 617 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
9accd5e5 618 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 619 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 620
e0e4b963 621# default config files
c455a752 622install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 623
624# executables
40ce9ce9
JB
625for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
626install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
627%if "%{binsuf}" != ""
628ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
11421384 629%endif
40ce9ce9 630done
e0e4b963 631
c2bf8f19 632%if %{with shared}
633install -d $RPM_BUILD_ROOT%{_libdir}
634install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
635%endif
636
e0e4b963 637# fonts
9d62f689 638cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 639ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 640
11421384 641%if %{with gui}
f0d8c47e 642install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 643%endif
9accd5e5 644touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 645install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 646install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 647
648# man pages
59ba0205 649install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 650install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
651install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
652install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
653install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
654install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 655install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 656install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
40ce9ce9 657install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
841cb995 658#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
40ce9ce9 659install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 660
2adea73e
AM
661%clean
662rm -rf $RPM_BUILD_ROOT
663
a69eaaef 664%post -n gmplayer
cd748ae6 665umask 022
cd748ae6 666[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
667
a69eaaef 668%postun -n gmplayer
cd748ae6 669umask 022
75b3147a 670[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 671
2adea73e
AM
672%files
673%defattr(644,root,root,755)
1a8df7bd 674%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
675
676%if %{with gui}
677%files -n gmplayer
678%defattr(644,root,root,755)
1a8df7bd 679%attr(755,root,root) %{_bindir}/gmplayer*
11421384 680%{_desktopdir}/gmplayer.desktop
11421384
ER
681%endif
682
0fb5a7ee 683%if %{with mencoder}
11421384
ER
684%files -n mencoder
685%defattr(644,root,root,755)
aeb67db6 686%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
687%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
688%doc DOCS/tech/colorspaces.txt
1a8df7bd 689%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 690%endif
11421384 691
841cb995 692%if %{with doc}
dc3c7d77 693%files doc
df52db46 694%defattr(644,root,root,755)
dc3c7d77 695%doc DOCS/tech
841cb995
ER
696# HTML and XML-generated docs
697%doc DOCS/HTML/en
0ffd4cd0 698%lang(cs) %doc DOCS/HTML/cs
aeb67db6 699%lang(de) %doc DOCS/HTML/de
aee40e50 700%lang(es) %doc DOCS/HTML/es
701%lang(fr) %doc DOCS/HTML/fr
8cda16b8 702%lang(hu) %doc DOCS/HTML/hu
d6da6cb0 703%lang(it) %doc DOCS/HTML/it
aee40e50 704%lang(pl) %doc DOCS/HTML/pl
705%lang(ru) %doc DOCS/HTML/ru
d6da6cb0 706%lang(zh_CN) %doc DOCS/HTML/zh_CN
841cb995 707%endif
dc3c7d77
ER
708
709%files common
710%defattr(644,root,root,755)
841cb995 711%doc AUTHORS README
dc3c7d77
ER
712%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
713%if %{with win32}
714%doc etc/codecs.win32.conf
715%endif
11421384 716
906bf13b
JB
717%dir %{_sysconfdir}/%{name}
718%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
40ce9ce9
JB
719%{_mandir}/man1/mplayer.1*
720%lang(cs) %{_mandir}/cs/man1/mplayer.1*
721%lang(de) %{_mandir}/de/man1/mplayer.1*
722%lang(es) %{_mandir}/es/man1/mplayer.1*
723%lang(fr) %{_mandir}/fr/man1/mplayer.1*
724%lang(hu) %{_mandir}/hu/man1/mplayer.1*
725%lang(it) %{_mandir}/it/man1/mplayer.1*
726%lang(pl) %{_mandir}/pl/man1/mplayer.1*
727%lang(ru) %{_mandir}/ru/man1/mplayer.1*
728#%lang(sv) %{_mandir}/sv/man1/mplayer.1*
729%lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
24481cd2 730%{_desktopdir}/mplayer.desktop
1087e996 731%{_pixmapsdir}/mplayer.png
11421384
ER
732%dir %{_datadir}/%{name}
733%{_datadir}/%{name}/font*
59ce39fb
ER
734%dir %{_datadir}/%{name}/skins
735%ghost %{_datadir}/%{name}/skins/default
This page took 0.39687 seconds and 4 git commands to generate.