]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- up to 20170130
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
24%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 25%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
26%bcond_with on2 # patches from On2 Flix Engine for Linux
27%bcond_without osd # osd menu support
28%bcond_without rtmp # RTMPDump Streaming Media support
29%bcond_with shared # experimental libmplayer.so support
30%bcond_without smb # Samba (SMB) input support
10a6d1a6 31%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
32# - codecs:
33%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 34%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
35%bcond_without crystalhd # CrystalHD support
36%bcond_without faad # FAAD2 (AAC) support
37%bcond_without gif # GIF support
63bba7db
JB
38%bcond_without ladspa # LADSPA plugin support
39%bcond_without libdts # libdts support
40%bcond_without libdv # libdv en/decoding support
63bba7db
JB
41%bcond_without lzo # LZO support (requires lzo 2.x)
42%bcond_without mad # mad (audio MPEG) support
43%bcond_without mpg123 # libmpg123 MP3 decoding support
44d571a0 44%bcond_with musepack # libmpcdec support (deprecated in favour of libavcodec)
63bba7db 45%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
46%bcond_without quicktime # binary quicktime dll support
47%bcond_without real # Real* 8/9 codecs support
63bba7db 48%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
44d571a0 49%bcond_with tremor # use tremor instead of libvorbis
62ba71a7
JB
50%bcond_without theora # Ogg Theora video support
51%bcond_without win32 # Win32 codecs support
52%bcond_without x264 # x264 support
53%bcond_with xmms # XMMS inputplugin support
63bba7db 54%bcond_without xvid # XviD codec
62ba71a7 55%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 56%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
57# - video output:
58%bcond_without aalib # aalib video output
59%bcond_without caca # libcaca video output
60%bcond_with directfb # DirectFB video output
10a6d1a6
JB
61%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
62%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
63%bcond_with ggi # GGI video output
64%bcond_without sdl # SDL video output
65%bcond_with svga # svgalib video output
66%bcond_without vdpau # VDPAU acceleration
67%bcond_without vidix # VIDIX video drivers
63bba7db 68%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
69%bcond_with gnomess # controling gnome screensaver [patch not updated]
70# - audio output:
71%bcond_without alsa # ALSA audio output
72%bcond_with arts # aRts audio output
73%bcond_with esd # EsounD sound support
74%bcond_without jack # JACKD support
75%bcond_with nas # NAS audio output
76%bcond_without pulseaudio # pulseaudio output
77%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 78
9accd5e5 79%if %{with alsa}
80%undefine with_select
81%endif
d1f72115 82%if %{without vorbis}
44d571a0 83%undefine with_tremor
d1f72115 84%endif
85
94cb018b
JB
86%ifnarch %{ix86}
87%undefine with_win32
7a82c266 88%undefine with_quicktime
1087e996 89%undefine with_vidix
94cb018b 90%endif
38c74592 91%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
92%undefine with_runtime
93%endif
ca278bdf
ER
94%ifnarch %{ix86} %{x8664}
95%undefine with_vdpau
96%endif
3d17ae18
ER
97%ifnarch ppc
98%undefine with_altivec
99%endif
810f3f3d
ER
100%ifnarch i686 pentium4 athlon %{x8664}
101%undefine with_crystalhd
102%endif
3d17ae18 103
40ce9ce9
JB
104%if %{_lib} != "lib"
105%define binsuf %(lib=%{_lib} ; echo ${lib#lib})
1a8df7bd 106%else
40ce9ce9 107%ifarch %{ix86} ppc sparc sparcv9 s390
e2b12b5a 108%define binsuf 32
40ce9ce9
JB
109%else
110%define binsuf %{nil}
111%endif
1a8df7bd 112%endif
113
0cd1ec52 114# date from directory inside of tarball (like mplayer-export-2014-04-29)
64f0513f 115%define snap 2017-01-30
0cd1ec52 116%define ssnap %(echo %{snap} | tr -d -)
ca90c34e 117%define rel 1
906bf13b 118Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
119Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
120Summary(es.UTF-8): Otro reproductor de películas
121Summary(ko.UTF-8): 리눅스용 미디어플레이어
122Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
123Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 124Name: mplayer
03487a7d 125Version: 1.3
c748315c 126Release: 1.%{ssnap}.%{rel}
1f85fd72
ER
127# DO NOT increase epoch unless it's really neccessary!
128# especially such changes like pre7->pre7try2, increase Release instead!
129# PS: $ rpmvercmp pre7try2 pre7
130# pre7try2 > pre7
59476b48 131Epoch: 3
bc426a7f 132License: GPL
906bf13b 133Group: Applications/Multimedia
0cd1ec52
AM
134# Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
135Source0: ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
64f0513f 136# Source0-md5: d37b1d63a139fdf021f78add1ffc1d35
0cd1ec52 137Source1: http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
64f0513f 138# Source1-md5: 5703ec6fc03b8d2509b0a58b132ec67f
031c3c7c 139Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 140# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
e601cd91 141Source5: g%{name}.desktop
623ea2d1 142Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
0a38bda8 143# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
11b89ef7 144Source7: %{name}.png
24481cd2 145Source8: %{name}.desktop
dfd680ce 146# http://www.on2.com/gpl/mplayer/
53f97285 147Source9: http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
148# Source9-md5: 07774a2663a8fda07c308df0c6569b56
79907b07 149
150# build (configure / Makefile) related:
151Patch10: %{name}-ldflags.patch
152Patch11: %{name}-altivec.patch
153Patch12: %{name}-check-byteswap.patch
c2bf8f19 154Patch13: %{name}-visibility-hidden-fix.patch
0cd1ec52 155
1ee1ef52 156Patch15: %{name}-live555-async.patch
e156db0d 157
63bba7db
JB
158Patch17: %{name}-gsm.patch
159Patch18: %{name}-openjpeg.patch
160Patch19: %{name}-shared.patch
990687b2 161Patch20: %{name}-vstream.patch
79907b07 162
163# codecs, outputs, demuxers:
990687b2
JB
164Patch21: %{name}-auto-expand.patch
165Patch22: %{name}-release_directfb.patch
79907b07 166
167# goodies:
168Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 169Patch31: %{name}-350.patch
d1f72115 170# update, hard to fix right now because of gnome bug 579430:
171# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 172#Patch32: %{name}-gnome-screensaver.patch
79907b07 173
174Patch100: %{name}-on2flix.patch
b252aa8a 175Patch101: %{name}-link.patch
79907b07 176
c5b97685 177URL: http://www.mplayerhq.hu/
44d571a0
JB
178%{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.22}
179BuildRequires: EGL-devel
aeb67db6 180BuildRequires: OpenAL-devel
44d571a0 181BuildRequires: OpenGL-GLX-devel
11421384 182%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
44d571a0
JB
183# checked, but seems actually not used
184#%{?with_sdl:BuildRequires: SDL_image-devel}
63bba7db 185BuildRequires: a52dec-libs-devel
dd6c659c
JB
186%{?with_aalib:BuildRequires: aalib-devel}
187%{?with_alsa:BuildRequires: alsa-lib-devel}
188%{?with_arts:BuildRequires: artsc-devel}
44d571a0 189BuildRequires: binutils >= 2.10.1
841cb995 190%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 191BuildRequires: bzip2-devel
364125e7 192#%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
df52db46 193%{?with_gnomess:BuildRequires: dbus-glib-devel}
c521a17c 194BuildRequires: dirac-devel
5dcdda0f
ER
195%{?with_doc:BuildRequires: docbook-dtd412-xml}
196%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 197%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 198%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
199%{?with_enca:BuildRequires: enca-devel}
200%{?with_esd:BuildRequires: esound-devel}
30e3739f 201BuildRequires: faac-devel
3c3fdfcc 202%{?with_faad:BuildRequires: faad2-devel >= 2.0}
759ef2d3 203%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-4.20081024.3}
63bba7db 204BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 205BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 206BuildRequires: fribidi-devel
3d17ae18 207%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 208%{?with_gif:BuildRequires: giflib-devel}
44d571a0
JB
209%{?with_gui:BuildRequires: glib2-devel >= 1:2.6.0}
210BuildRequires: gnutls-devel
211%{?with_gui:BuildRequires: gtk+2-devel >= 2:2.4.0}
d336e259 212%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 213%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 214BuildRequires: lame-libs-devel
6bd88460 215BuildRequires: libass-devel >= 0.9.10
c3a1256a 216%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 217%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 218%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
219%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
220%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 221%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 222%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
364125e7 223#%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 224%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 225%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 226%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
227%{?with_ggi:BuildRequires: libggiwmh-devel}
228BuildRequires: libgsm-devel
af480c75 229BuildRequires: libjpeg-devel
dd6c659c 230%{?with_mad:BuildRequires: libmad-devel}
c521a17c 231BuildRequires: libmng-devel
63bba7db
JB
232%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
233%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
234%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 235%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 236BuildRequires: libnut-devel
af480c75 237BuildRequires: libpng-devel
63bba7db 238%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 239%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 240%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 241%{?with_vdpau:BuildRequires: libvdpau-devel}
44d571a0
JB
242%if %{with vorbis} && %{without tremor}
243BuildRequires: libvorbis-devel
244%endif
0431b837 245BuildRequires: libvpx-devel
44d571a0 246# build >= 118
bbab8eb7 247%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
ceb01d0e 248BuildRequires: libxslt-progs
44d571a0
JB
249# with v4l2 headers
250BuildRequires: linux-libc-headers >= 7:2.6.22
dd6c659c 251%{?with_lirc:BuildRequires: lirc-devel}
1ee1ef52 252%{?with_live:BuildRequires: live-devel >= 2:2011.01.10}
841cb995 253%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 254%{?with_nas:BuildRequires: nas-devel}
b458005d 255BuildRequires: ncurses-devel
b69a6f83 256%{?with_amr:BuildRequires: opencore-amr-devel}
63bba7db 257%{?with_openjpeg:BuildRequires: openjpeg-devel}
44d571a0 258BuildRequires: opus-devel
e9d22b19 259BuildRequires: pkgconfig
86bc294f 260%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 261BuildRequires: rpm >= 4.4.9-56
9accd5e5 262BuildRequires: rpmbuild(macros) >= 1.527
c521a17c 263BuildRequires: schroedinger-devel
aeb67db6 264BuildRequires: speex-devel >= 1.1
dd6c659c 265%{?with_svga:BuildRequires: svgalib-devel}
3af20979 266BuildRequires: tar >= 1:1.22
44d571a0 267%{?with_tremor:BuildRequires: tremor-devel}
c521a17c 268BuildRequires: twolame-devel
3af20979 269%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 270%{?with_vstream:BuildRequires: vstream-client-devel}
44d571a0 271BuildRequires: webrtc-libilbc-devel
c521a17c 272%{?with_xmms:BuildRequires: xmms-devel}
627a7a97 273BuildRequires: xorg-lib-libX11-devel
c521a17c 274BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
275BuildRequires: xorg-lib-libXext-devel
276BuildRequires: xorg-lib-libXinerama-devel
277BuildRequires: xorg-lib-libXv-devel
278BuildRequires: xorg-lib-libXvMC-devel
279BuildRequires: xorg-lib-libXxf86dga-devel
280BuildRequires: xorg-lib-libXxf86vm-devel
b57c3c6c
ER
281%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
282BuildRequires: xz
283%ifarch %{ix86} %{x8664}
284BuildRequires: yasm
285%endif
286BuildRequires: zlib-devel
4d75c49f 287Requires: %{name}-common = %{epoch}:%{version}-%{release}
b458005d 288Requires: OpenGL
0f2a502d 289BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 290
a8e3a9a7 291%define _noautoreqdep libGL.so.1 libGLU.so.1
bb27cfbd 292%define specflags_ia32 -fomit-frame-pointer
198487b4 293%if %{with altivec}
adfd0023 294%define specflags_ppc -maltivec
20a66bdb 295%endif
2adea73e
AM
296
297%description
c902f7c6 298Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
299AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 300MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
301MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 302devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
303optionally with SHM extension, X11 using overlays with the Xvideo
304extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
305Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 306
8b146837 307If you want to use win32 codecs install w32codec package.
4228a246 308
e011d408 309%description -l de.UTF-8
deba608c 310MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
311Kennzeichnend ist die herausragende Format- und
e011d408 312Plattform-Kompatibilität.
deba608c 313
e011d408
JR
314Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
315plattformexklusive, wodurch etwa Windows Media auch außerhalb von
316Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
317Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 318ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
319Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
320installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 321
e011d408 322%description -l es.UTF-8
c902f7c6 323Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
324MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
325(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
326de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
327Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
328G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
329overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 330G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
331v1.1.7 etc.
33c4efab 332
8b146837 333Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 334
e011d408
JR
335%description -l ko.UTF-8
336MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
337파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
338MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
339Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
340(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
341수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
342크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
343있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
344부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 345
e011d408
JR
346%description -l pl.UTF-8
347Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 348RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
349(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
350Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 351Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 352rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 353G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 354
e011d408 355Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 356
e011d408
JR
357%description -l pt_BR.UTF-8
358MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
359áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 360escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
361
11421384
ER
362%package -n gmplayer
363Summary: MPlayer with GTK+ GUI interface
eeb91a66 364Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 365Group: X11/Applications/Multimedia
11421384 366Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 367Requires: %{name}-skin
11421384
ER
368
369%description -n gmplayer
370MPlayer with GUI GTK+ interface.
371
e011d408 372%description -n gmplayer -l pl.UTF-8
906bf13b
JB
373MPlayer z graficznym interfejsem GTK+.
374
11421384 375%package common
906bf13b 376Summary: Configuration files and documentation for MPlayer
eeb91a66 377Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 378Group: Applications/Multimedia
c521a17c 379Suggests: unrar
1087e996 380Obsoletes: mplayer-vidix
11421384
ER
381
382%description common
906bf13b
JB
383Configuration files, man page and HTML documentation for MPlayer.
384
e011d408 385%description common -l pl.UTF-8
906bf13b 386Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 387
dc3c7d77 388%package doc
63bba7db
JB
389Summary: HTML documentation for MPlayer
390Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
391Group: Documentation
392
393%description doc
63bba7db
JB
394HTML Documentation for MPlayer.
395
396%description doc -l pl.UTF-8
397Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 398
11421384 399%package -n mencoder
906bf13b 400Summary: MEncoder - a movie encoder for Linux
eeb91a66 401Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
402Group: Applications/Multimedia
403Requires: %{name}-common = %{epoch}:%{version}-%{release}
404
405%description -n mencoder
906bf13b
JB
406MEncoder is a movie encoder for Linux and is a part of the MPlayer
407package.
408
e011d408
JR
409%description -n mencoder -l pl.UTF-8
410MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 411
2adea73e 412%prep
0cd1ec52 413%setup -q -n %{name}-export-%{snap} -a1 -a3 -a6 -a9
833dbe20 414cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 415
416# build (configure / Makefile) related:
417%patch10 -p1
418%patch11 -p1
419%patch12 -p1
c2bf8f19 420%patch13 -p1
0cd1ec52 421
e2b12b5a 422%patch15 -p1
e156db0d 423
63bba7db
JB
424%patch17 -p1
425%patch18 -p1
426%{?with_shared:%patch19 -p1}
990687b2 427%patch20 -p1
79907b07 428
429# codecs, outputs, demuxers:
79907b07 430%patch21 -p1
990687b2 431%patch22 -p1
79907b07 432
433# goodies:
434%patch30 -p0
2833f81f 435%patch31 -p1
436#%{with_gnomess:%patch32 -p1}
59ba0205 437
dfd680ce 438# on2flix
759ef2d3 439mv mencoder-on2flixenglinux{-*-*-*,}
d1f72115 440%if %{with on2}
79907b07 441#%%patch100 -p1
d1f72115 442cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
443# remove broken patches:
444# - first set does not apply
445# - second set beakes build
446for PATCH in asf-correct_movielength avi_check_idxflags \
447 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
448 mencoder_07_demux_update_pts mencoder_10_correct_pts \
449 mpegvideo-revert_r18381 \
450 \
451 reduce_spurious_logging
452do
453 rm mencoder-on2flixenglinux/patch/$PATCH.diff
454done
455for a in mencoder-on2flixenglinux/patch/*.diff; do
456 patch -p0 < $a
457done
458%endif
dfd680ce 459
b252aa8a
PS
460%patch101 -p1
461
53f97285 462cat etc/example.conf > etc/mplayer.conf
c521a17c 463cat <<'CONFIGADD' >> etc/mplayer.conf
464
d1f72115 465######################
8b2ed1fb 466# PLD Linux Defaults #
d1f72115 467######################
2833f81f 468[default]
469
470# alternate solution for CP1250-encoded subtitles
471fontconfig = yes
472subcp = cp1250
473
474# ...or if you prefer native bitmap fonts shipped with mplayer
475#fontconfig = no
476#subcp = iso-8859-1
477
478# Standard location
479unrarexec = "%{_bindir}/unrar"
480
993f72f1
ER
481# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
482joystick=no
483
c521a17c 484CONFIGADD
d1732085 485
1f8d8779
ER
486%if %{with system_ffmpeg}
487# using external ffmpeg, but mplayer adds these to includepath
0cd1ec52 488%{__rm} -rf ffmpeg
1f8d8779
ER
489%endif
490
2adea73e 491%build
5dcdda0f 492CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
3c96218e 493CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
53f97285 494
63bba7db
JB
495# NOTE:
496# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
497# - toolame is obsolete predecessor of twolame
44d571a0 498# - libcdio-paranoia is preferred over cdparanoia-III libs
11421384 499build() {
c521a17c 500 set -x
53f97285 501
11421384
ER
502 ./configure \
503 %{?debug:--enable-debug=3} \
dd6c659c 504 --prefix=%{_prefix} \
63bba7db 505 --codecsdir=%{_libdir}/codecs \
dd6c659c 506 --confdir=%{_sysconfdir}/mplayer \
53f97285 507 --cc="%{__cc}" \
508 --extra-cflags="$CFLAGS" \
79907b07 509 --real-ldflags="%{rpmldflags}" \
510 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 511 --language=all \
1f8d8779 512%if %{with system_ffmpeg}
0cd1ec52 513 --disable-ffmpeg_a \
1f8d8779 514%endif
57f87bc2 515%ifnarch %{ix86} %{x8664}
dd6c659c 516 --disable-3dnow \
a14f4270 517 --disable-3dnowext \
63bba7db
JB
518 --disable-fastmemcpy \
519 --disable-mmx \
520 --disable-mmxext \
dd6c659c
JB
521 --disable-sse \
522 --disable-sse2 \
dfeec30a 523%endif
9accd5e5 524 %{__disable ssse3} \
1837afdf 525%ifarch ppc
9accd5e5 526 %{__disable altivec} \
1837afdf 527%endif
9accd5e5 528 %{__disable aalib aa} \
9accd5e5 529 %{__enable_disable alsa} \
530 %{__disable arts} \
63bba7db 531 %{__disable bluray} \
9accd5e5 532 %{__disable caca} \
533 %{__disable cdparanoia} \
63bba7db
JB
534 --enable-dga1 \
535 --enable-dga2 \
536 %{__enable_disable directfb} \
537 %{__enable_disable dvdnav} \
538 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 539 %{__disable dxr2} \
63bba7db
JB
540 %{__disable dxr3} \
541 --enable-dynamic-plugins \
9accd5e5 542 %{__disable enca} \
543 %{__disable esd} \
9accd5e5 544 %{__disable faad} \
63bba7db 545 --enable-fbdev \
9accd5e5 546 %{__disable gif} \
63bba7db
JB
547 --enable-gl \
548 %{__disable ggi} \
549 %{__disable jack} \
9accd5e5 550 %{__enable joystick} \
63bba7db
JB
551 %{__disable cdio libcdio} \
552 %{__disable ladspa} \
10a6d1a6 553 %{__disable bs2b libbs2b} \
9accd5e5 554 %{__disable libdts libdca} \
63bba7db
JB
555 %{__disable libdv} \
556 %{__disable system_dvdcss libdvdcss-internal} \
557 %{__disable lzo liblzo} \
558 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 559 %{__disable nemesi} \
63bba7db
JB
560 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
561 %{__disable openjpeg} \
562 %{__disable rtmp librtmp} \
563 %{__disable vorbis libvorbis} \
9accd5e5 564 %{__enable_disable lirc} \
63bba7db
JB
565 --disable-lircc \
566 %{__disable live} \
9accd5e5 567 %{__disable mad} \
63bba7db
JB
568 %{__disable mencoder} \
569 %{__enable osd menu} \
570 --enable-mga \
571 %{__disable mpg123} \
572 %{__enable musepack} \
573 %{__disable nas} \
9accd5e5 574 %{__disable pulseaudio pulse} \
575 %{__disable quicktime qtx} \
63bba7db
JB
576 --enable-radio \
577 --enable-radio-capture \
9accd5e5 578 %{__disable real} \
579 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 580 %{__enable_disable sdl} \
9accd5e5 581 %{__disable select} \
10a6d1a6 582 --enable-s3fb \
9accd5e5 583 %{__disable smb} \
63bba7db
JB
584 %{__disable svga} \
585 --enable-tdfxfb \
10a6d1a6 586 --enable-tdfxvid \
9accd5e5 587 %{__disable theora} \
63bba7db 588 --disable-toolame \
44d571a0 589 %{!?with_tremor:--disable-tremor} \
63bba7db 590 --enable-unrarexec \
9accd5e5 591 %{__disable vdpau} \
63bba7db 592 %{__disable vidix} \
10a6d1a6 593 %{__disable vstream} \
dd6c659c 594 --enable-vm \
10a6d1a6
JB
595%ifarch ppc
596 --enable-wii \
597%endif
63bba7db 598 %{__disable win32 win32dll} \
dd6c659c 599 --enable-x11 \
63bba7db 600 %{__disable x264} \
dd6c659c 601 --enable-xmga \
63bba7db 602 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 603 --enable-xv \
63bba7db
JB
604 %{__disable xvid} \
605 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 606 %{__enable_disable zr} \
11421384 607 "$@"
eb52750a 608
d53c9a42 609 %{__make} %{?with_verbose:V=1}
11421384 610}
2adea73e 611
11421384
ER
612%if %{with gui}
613# build GUI version
841cb995 614build --enable-gui --disable-mencoder
11421384 615mv -f mplayer gmplayer
aeb67db6 616%{__make} distclean
11421384
ER
617%endif
618
619# now build regular version
620build --disable-gui
621
aab7d90d 622%if %{with doc}
ef1e3931 623%{__make} -j1 doc
11421384 624%endif
ceb01d0e 625
2adea73e
AM
626%install
627rm -rf $RPM_BUILD_ROOT
e0e4b963 628install -d \
d23c171d 629 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
40ce9ce9 630 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
9accd5e5 631 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 632 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 633
e0e4b963 634# default config files
c455a752 635install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 636
637# executables
40ce9ce9
JB
638for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
639install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
640%if "%{binsuf}" != ""
641ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
11421384 642%endif
40ce9ce9 643done
e0e4b963 644
c2bf8f19 645%if %{with shared}
646install -d $RPM_BUILD_ROOT%{_libdir}
647install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
648%endif
649
e0e4b963 650# fonts
9d62f689 651cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 652ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 653
11421384 654%if %{with gui}
f0d8c47e 655install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 656%endif
9accd5e5 657touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 658install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 659install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 660
661# man pages
59ba0205 662install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 663install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
664install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
665install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
666install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
667install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 668install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 669install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
40ce9ce9 670install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
841cb995 671#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
40ce9ce9 672install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 673
2adea73e
AM
674%clean
675rm -rf $RPM_BUILD_ROOT
676
a69eaaef 677%post -n gmplayer
cd748ae6 678umask 022
cd748ae6 679[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
680
a69eaaef 681%postun -n gmplayer
cd748ae6 682umask 022
75b3147a 683[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 684
2adea73e
AM
685%files
686%defattr(644,root,root,755)
1a8df7bd 687%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
688
689%if %{with gui}
690%files -n gmplayer
691%defattr(644,root,root,755)
1a8df7bd 692%attr(755,root,root) %{_bindir}/gmplayer*
11421384 693%{_desktopdir}/gmplayer.desktop
11421384
ER
694%endif
695
0fb5a7ee 696%if %{with mencoder}
11421384
ER
697%files -n mencoder
698%defattr(644,root,root,755)
aeb67db6 699%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
700%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
701%doc DOCS/tech/colorspaces.txt
1a8df7bd 702%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 703%endif
11421384 704
841cb995 705%if %{with doc}
dc3c7d77 706%files doc
df52db46 707%defattr(644,root,root,755)
dc3c7d77 708%doc DOCS/tech
841cb995
ER
709# HTML and XML-generated docs
710%doc DOCS/HTML/en
0ffd4cd0 711%lang(cs) %doc DOCS/HTML/cs
aeb67db6 712%lang(de) %doc DOCS/HTML/de
aee40e50 713%lang(es) %doc DOCS/HTML/es
714%lang(fr) %doc DOCS/HTML/fr
8cda16b8 715%lang(hu) %doc DOCS/HTML/hu
aee40e50 716%lang(pl) %doc DOCS/HTML/pl
717%lang(ru) %doc DOCS/HTML/ru
841cb995
ER
718#%lang(zh_CN) %doc DOCS/zh
719%endif
dc3c7d77
ER
720
721%files common
722%defattr(644,root,root,755)
841cb995 723%doc AUTHORS README
dc3c7d77
ER
724%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
725%if %{with win32}
726%doc etc/codecs.win32.conf
727%endif
11421384 728
906bf13b
JB
729%dir %{_sysconfdir}/%{name}
730%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
40ce9ce9
JB
731%{_mandir}/man1/mplayer.1*
732%lang(cs) %{_mandir}/cs/man1/mplayer.1*
733%lang(de) %{_mandir}/de/man1/mplayer.1*
734%lang(es) %{_mandir}/es/man1/mplayer.1*
735%lang(fr) %{_mandir}/fr/man1/mplayer.1*
736%lang(hu) %{_mandir}/hu/man1/mplayer.1*
737%lang(it) %{_mandir}/it/man1/mplayer.1*
738%lang(pl) %{_mandir}/pl/man1/mplayer.1*
739%lang(ru) %{_mandir}/ru/man1/mplayer.1*
740#%lang(sv) %{_mandir}/sv/man1/mplayer.1*
741%lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
24481cd2 742%{_desktopdir}/mplayer.desktop
1087e996 743%{_pixmapsdir}/mplayer.png
11421384
ER
744%dir %{_datadir}/%{name}
745%{_datadir}/%{name}/font*
59ce39fb
ER
746%dir %{_datadir}/%{name}/skins
747%ghost %{_datadir}/%{name}/skins/default
This page took 0.280229 seconds and 4 git commands to generate.