]> git.pld-linux.org Git - packages/mosh.git/blame - mosh.spec
build with --disable-silent-rules
[packages/mosh.git] / mosh.spec
CommitLineData
0e141888 1
c5194fa9 2# force gcc4 for ac
b0706f31
ER
3%if "%{pld_release}" == "ac"
4# add suffix, but allow ccache, etc in ~/.rpmmacros
5%{expand:%%define __cc %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
6%{expand:%%define __cxx %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
7%{expand:%%define __cpp %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
8%endif
9
37060d63 10%include /usr/lib/rpm/macros.perl
dc576455
CM
11Summary: Mosh mobile shell
12Name: mosh
7bc19f9c 13Version: 1.2.4
a6dfe832 14Release: 3
dc576455
CM
15License: GPL v3+
16Group: X11/Applications
7bc19f9c
ER
17Source0: http://mosh.mit.edu/%{name}-%{version}.tar.gz
18# Source0-md5: c2d918f4d91fdc32546e2e089f9281b2
dc576455 19URL: http://mosh.mit.edu/
b0706f31 20BuildRequires: binutils >= 2.20.51.0.2
246f59c7 21BuildRequires: libstdc++-devel >= 5:4.0
dc576455
CM
22BuildRequires: libutempter-devel
23BuildRequires: ncurses-devel
a81725ba 24BuildRequires: openssl-devel
23ab9f92 25BuildRequires: pkgconfig
ab99cc95 26BuildRequires: protobuf
dc576455 27BuildRequires: protobuf-devel
37060d63
ER
28BuildRequires: rpm-perlprov >= 4.1-13
29BuildRequires: sed >= 4.0
dc576455 30BuildRequires: zlib-devel
b0706f31
ER
31# gcc4 might be installed, but not current __cc
32%if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
33BuildRequires: __cc >= 4.0
34%endif
dc576455
CM
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
9eaea372
ER
37# PLD stack protector flags are weaker than upstream, filter them out
38# https://github.com/keithw/mosh/issues/203
7bc19f9c 39%define _ssp_cflags %{nil}
9eaea372 40
dc576455
CM
41%description
42Remote terminal application that allows roaming, supports intermittent
43connectivity, and provides intelligent local echo and line editing of
44user keystrokes.
45
46Mosh is a replacement for SSH. It's more robust and responsive,
47especially over Wi-Fi, cellular, and long-distance links.
48
49%prep
50%setup -q
37060d63 51%{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh
dc576455
CM
52
53%build
c5194fa9 54CPPFLAGS="-I/usr/include/ncurses"
dc576455 55%configure \
c5194fa9
ER
56 --disable-silent-rules \
57 --enable-compile-warnings=error
58%{__make}
dc576455
CM
59
60%install
61rm -rf $RPM_BUILD_ROOT
dc576455
CM
62%{__make} install \
63 DESTDIR=$RPM_BUILD_ROOT
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc AUTHORS ChangeLog NEWS THANKS
dc576455
CM
71%attr(755,root,root) %{_bindir}/%{name}
72%attr(755,root,root) %{_bindir}/%{name}-client
73%attr(755,root,root) %{_bindir}/%{name}-server
74%{_mandir}/man1/%{name}.1*
75%{_mandir}/man1/%{name}-client.1*
76%{_mandir}/man1/%{name}-server.1*
This page took 0.106853 seconds and 4 git commands to generate.