]> git.pld-linux.org Git - packages/monodevelop.git/blame - monodevelop.spec
- release 3 (by relup.sh)
[packages/monodevelop.git] / monodevelop.spec
CommitLineData
d1fde2e0 1# TODO: use system libgit2, libgit2sharp, nunit, mono-addins
62b68ce6 2#
3# Conditional build:
1fe81bf9 4%bcond_without subversion # disable subversion backend
62b68ce6 5#
8e4dce97 6%include /usr/lib/rpm/macros.mono
0c7dc1fc 7#
6b471955 8Summary: Mono IDE
50630820 9Summary(pl.UTF-8): IDE dla Mono
6b471955 10Name: monodevelop
d1fde2e0 11Version: 5.10.0.871
ce22c8db 12Release: 3
64d2d161
JB
13# most of code is MIT-licensed, some parts LGPL v2
14License: LGPL v2, MIT
6b471955 15Group: Development/Tools
d1fde2e0
JB
16Source0: http://download.mono-project.com/sources/monodevelop/%{name}-%{version}.tar.bz2
17# Source0-md5: 4722cbbaeb7a518dceea8147e6cb6181
66b10581 18Patch0: %{name}-desktop.patch
d1fde2e0
JB
19Patch1: %{name}-aspnet.patch
20Patch2: %{name}-nunit.patch
21Patch3: %{name}-avoidgiterrors.patch
22Patch4: %{name}-nuget-unbundle.patch
23Patch5: %{name}-no-nuget-packages.patch
c74fc8cc 24Patch6: %{name}-json.patch
64d2d161 25URL: http://monodevelop.com/
0c7dc1fc 26BuildRequires: autoconf >= 2.53
64d2d161
JB
27BuildRequires: automake >= 1:1.10
28# gconf-sharp, gnome-sharp, gnome-vfs-sharp
5226a43e 29BuildRequires: dotnet-gconf-sharp-devel
5b5c21f8 30BuildRequires: dotnet-gnome-sharp-devel >= 2.16.0
0c7dc1fc 31BuildRequires: dotnet-gtk-sharp2-devel >= 2.12.8
d1fde2e0
JB
32BuildRequires: dotnet-newtonsoft-json-devel >= 6.0
33BuildRequires: dotnet-nuget-devel
34BuildRequires: dotnet-nunit2 >= 2.6.4
a2390e5e 35BuildRequires: gettext-tools
cf122d6b 36BuildRequires: mono-csharp >= 3.0.4
4a9e8acc 37BuildRequires: monodoc >= 1.0
ddc1d267 38BuildRequires: pkgconfig
b51a6d0d 39BuildRequires: rpmbuild(macros) >= 1.311
cf122d6b 40BuildRequires: sed >= 4.0
86a4eb83 41Requires(post,postun): desktop-file-utils
62eb64a9
AF
42Requires(post,postun): gtk-update-icon-cache
43Requires(post,postun): hicolor-icon-theme
515a83a9 44Requires(post,postun): shared-mime-info
64d2d161 45Requires: dotnet-gtk-sharp2 >= 2.12.8
0c7dc1fc 46Requires: hicolor-icon-theme
0c7dc1fc 47Requires: pkgconfig
62b68ce6 48%{?with_subversion:Requires: subversion-libs}
0c7dc1fc
MB
49Requires: xulrunner-libs
50Suggests: ctags
cf122d6b
JB
51Suggests: mono-compat-links >= 3.0.4
52Suggests: mono-csharp >= 3.0.4
64d2d161 53Suggests: monodoc >= 1.0
0c7dc1fc 54Suggests: xsp
6b471955 55Obsoletes: MonoDevelop
d54d7115 56ExcludeArch: alpha i386 sparc sparc64
6b471955 57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
c62ae1b5
JR
59%define _noautoreq 'mono\\(System.Data.Entity\\)' 'mono\\(System.Web.WebPages.Deployment\\)'
60
6b471955 61%description
62Mono IDE, in the very early stages of development right now, and
63progressing quickly. MonoDevelop has many features. Some of these
64include:
d54d7115 65- Class Management MonoDevelop has a class viewer which allows you to
66 list the classes in your project, their methods, and properties. Your
67 namespaces are also kept track of to keep the classes separated. When
68 you add something to your project, it will automatically be added to
69 the class viewer, even if they're namespaces, classes, methods, or
70 even variables.
71- Code Completion With the .NET and Gtk# frameworks put together, it
72 can be challenging to remember all the classes, methods, or properties
73 that are at your disposal. MonoDevelop's intelligent code completion
74 attempts to complete what you're typing. If it finds a match, just hit
75 tab and MonoDevelop will do the typing for you.
76- Project Support MonoDevelop comes with built in projects that help
77 get you started with your console, Gnome# or Gtk# application.
6b471955 78
4c24f807
JR
79%description -l pl.UTF-8
80MonoDevelop to IDE (zintegrowane środowisko programisty) dla Mono we
81wczesnym, ale szybko postępującym stadium rozwoju. Ma wiele
82możliwości, a wśród nich:
83- zarządzanie klasami MonoDevelop ma przeglądarkę klas pozwalającą
84 wyświetlać klasy w projekcie, ich metody oraz własności. Przestrzenie
85 nazw są uwzględniane, aby zachować separację klas. Przy dodawaniu
86 czegoś do projektu jest to automatycznie dodawane do przeglądarki
87 klas, nawet jeśli są to przestrzenie nazw, klasy, metody, a nawet
d54d7115 88 zmienne.
4c24f807
JR
89- dopełnianie kodu Przy połączeniu szkieletów .NET i Gtk# pamiętanie
90 samemu wszystkich klas, metod i własności mogłoby być nie lada
91 wyzwaniem. MonoDevelop w sposób inteligentny próbuje dopełniać to, co
92 się pisze. Jeśli znajdzie dopasowanie, wystarczy nacisnąć tabulację,
93 aby dokończył pisać za nas.
94- obsługa projektów MonoDevelop przychodzi z wbudowanymi projektami,
95 pomagającymi zacząć tworzyć aplikacje konsolowe, Gnome# albo Gtk#.
6b471955 96
97%prep
d1fde2e0 98%setup -q -n monodevelop-5.10
6b471955 99%patch0 -p1
d1fde2e0
JB
100%patch1 -p1
101%patch2 -p1
102%patch3 -p1
103%patch4 -p1
104%patch5 -p1
c74fc8cc 105%patch6 -p1
6b471955 106
cf122d6b
JB
107%{__sed} -i -e 's,\.\./version\.config,version.config,' configure.in
108# bash is needed because of exec -a; avoid hiding dependency by env
109%{__sed} -i -e '1s,#!/usr/bin/env bash,#!/bin/bash,' mdtool.in monodevelop.in
110
d1fde2e0
JB
111# fake target
112touch restore-packages
113
6b471955 114%build
6b471955 115%{__aclocal}
6b471955 116%{__autoconf}
0c7dc1fc 117%{__automake}
d54d7115 118%configure \
119 --disable-update-mimedb \
62b68ce6 120 --disable-update-desktopdb \
62b68ce6 121 %{?with_subversion:--enable-subversion}
122
d1fde2e0
JB
123cd external/libgit2sharp/Lib/CustomBuildTasks
124xbuild CustomBuildTasks.csproj /property:Configuration=Release
125ln -snf bin/Release/CustomBuildTasks.dll .
126cd ../../../..
127
083c8a3a 128%{__make} -j1
6b471955 129
130%install
131rm -rf $RPM_BUILD_ROOT
0c7dc1fc 132install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
6b471955 133
134%{__make} install \
135 DESTDIR=$RPM_BUILD_ROOT
136
665d58e9 137%if "%{_lib}" != "lib"
0c7dc1fc 138%{__mv} -f $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_pkgconfigdir}
665d58e9 139%endif
0c7dc1fc 140
515a83a9
MM
141%find_lang %{name}
142
6b471955 143%clean
144rm -rf $RPM_BUILD_ROOT
145
515a83a9 146%post
86a4eb83 147%update_desktop_database_post
148%update_mime_database
1b366289 149%update_icon_cache hicolor
515a83a9
MM
150
151%postun
86a4eb83 152%update_desktop_database_postun
153%update_mime_database
1b366289 154%update_icon_cache hicolor
515a83a9
MM
155
156%files -f %{name}.lang
6b471955 157%defattr(644,root,root,755)
0c7dc1fc
MB
158%doc AUTHORS ChangeLog README
159%attr(755,root,root) %{_bindir}/mdtool
160%attr(755,root,root) %{_bindir}/monodevelop
161%{_prefix}/lib/monodevelop
162%{_datadir}/mime/packages/monodevelop.xml
163%{_desktopdir}/monodevelop.desktop
164%{_pkgconfigdir}/monodevelop-core-addins.pc
165%{_pkgconfigdir}/monodevelop.pc
d1fde2e0
JB
166%{_iconsdir}/hicolor/*x*/apps/monodevelop.png
167%{_iconsdir}/hicolor/scalable/apps/monodevelop.svg
e33fffc0 168%{_mandir}/man1/mdtool.1*
1b366289 169%{_mandir}/man1/monodevelop.1*
This page took 0.105372 seconds and 4 git commands to generate.