]> git.pld-linux.org Git - packages/mono.git/blame - mono.spec
- up to 1.2.3.1
[packages/mono.git] / mono.spec
CommitLineData
fef1a4c5 1# NOTE: Makefiles are broken, build could stop long time after first fatal error
245657c9
MM
2#
3# Conditional build:
fef1a4c5 4%bcond_without tls # don't use TLS (which requires recent 2.4.x or 2.6 kernel)
4d9455d0 5%bcond_without static_libs # don't build static libraries
8cabdc4d 6%bcond_with bootstrap # don't require mono-devel to find req/prov
75873ca6 7%bcond_with mint # build mint instead of mono VM (JIT) [broken]
245657c9 8#
75873ca6
JB
9%ifnarch %{ix86} %{x8664} alpha arm ia64 ppc s390 s390x sparc sparcv9 sparc64
10# JIT not supported on hppa
a465d985 11%define with_mint 1
f1c5438d 12%endif
75873ca6 13%define _glibver 1:2.4
8cabdc4d 14#
728c2265 15Summary: Common Language Infrastructure implementation
d1081961 16Summary(pl.UTF-8): Implementacja Common Language Infrastructure
728c2265 17Name: mono
e9682c1e 18Version: 1.2.3.1
c895038f 19Release: 1
245657c9 20License: GPL/LGPL/MIT
728c2265 21Group: Development/Languages
1e5be752 22#Source0Download: http://go-mono.com/sources-stable/
da85c5a5 23Source0: http://www.go-mono.com/sources/mono/%{name}-%{version}.tar.gz
e9682c1e 24# Source0-md5: 4e4cdb6f98f1ea62bb1900f214c55e58
ddb02eae
JB
25Patch0: %{name}-alpha-float.patch
26Patch1: %{name}-mint.patch
27Patch2: %{name}-sonames.patch
f50ca0e9 28Patch3: %{name}-script_fixes.patch
4a893061 29Patch4: %{name}-awk.patch
68174c6e 30URL: http://www.mono-project.com/
96185d3a
JB
31%if %(test -r /dev/random ; echo $?)
32BuildRequires: ACCESSIBLE_/dev/random
33%endif
8aa3dace 34BuildRequires: autoconf
35BuildRequires: automake
3c4b0944 36BuildRequires: bison
2c1ff86a 37BuildRequires: glib2-devel >= %{_glibver}
f7c57864 38BuildRequires: libtool
609d5e15 39%{!?with_bootstrap:BuildRequires: mono-devel >= 1.1.8.3-2}
f7c57864 40BuildRequires: pkgconfig
71415791 41BuildRequires: rpmbuild(macros) >= 1.213
2ca5ca77 42BuildRequires: rpmbuild(monoautodeps)
446b74e3 43Requires: binfmt-detector
4a893061 44Requires: libgdiplus >= 1.2.3
5ba8acd1 45ExclusiveArch: %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9 sparc64
1de8200d
JB
46# plain i386 is not supported; mono uses cmpxchg/xadd which require i486
47ExcludeArch: i386
728c2265
AM
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
ad29385a 50%define _rpmlibdir /usr/lib/rpm
51
baf6636c 52# debugger doesn't work with stripped mono
53%define _noautostrip .*/mono
54
d0023a38 55%if ! %{with bootstrap}
56%define __mono_provides %{_rpmlibdir}/mono-find-provides
57%define __mono_requires %{_rpmlibdir}/mono-find-requires
58%endif
59
728c2265
AM
60%description
61The Common Language Infrastructure platform. Microsoft has created a
62new development platform. The highlights of this new development
63platform are:
86d7bbf3 64- A runtime environment that provides garbage collection, threading
728c2265 65 and a virtual machine specification (The Virtual Execution System,
8aa3dace 66 VES),
67- A comprehensive class library,
728c2265 68- A new language, C#. Very similar to Java, C# allows programmers to
8aa3dace 69 use all the features available on the .NET runtime,
728c2265
AM
70- A language specification that compilers can follow if they want to
71 generate classes and code that can interoperate with other programming
8aa3dace 72 languages (The Common Language Specification: CLS).
728c2265 73
fef1a4c5 74%{?with_tls:This version was build with TLS __thread.}
245657c9 75
a86cd9c8
JR
76%description -l pl.UTF-8
77Platforma CLI (Common Language Infrastructure). Microsoft stworzył
78nową platformę developerską. Zalety tej platformy to:
79- środowisko, które dostarcza garbage collector, wątki oraz
80 specyfikację maszyny wirtualnej (The Virtual Execution System, VES),
81- bibliotekę klas,
82- nowy język, C#. Bardzo podobny do Javy, C# pozwala programistom na
83 używanie wszystkich możliwości dostarczanych przez platformę .NET,
84- specyfikacja dla kompilatorów, które chcą generować kod
85 współpracujący z innymi językami programowania (The Common Language
8aa3dace 86 Specification: CLS).
87
a86cd9c8 88%{?with_tls:Ta wersja została zbudowana z TLS __thread.}
245657c9 89
8aa3dace 90%package devel
91Summary: Development resources for mono
d1081961 92Summary(pl.UTF-8): Zasoby programisty do mono
8aa3dace 93Group: Development/Libraries
76e7cb31 94Requires: %{name} = %{version}-%{release}
2c1ff86a 95Requires: glib2-devel >= %{_glibver}
8aa3dace 96
97%description devel
98Development resources for mono.
99
a86cd9c8 100%description devel -l pl.UTF-8
18ff84b2
MM
101Zasoby programisty dla mono.
102
5dab3216 103%package debug
104Summary: Mono libraries debugging resources
d1081961 105Summary(pl.UTF-8): Pliki umożliwiające debugowanie bibliotek mono
5dab3216 106Group: Development/Libraries
107Requires: %{name} = %{version}-%{release}
108
109%description debug
110Mono libraries debugging resources.
111
a86cd9c8
JR
112%description debug -l pl.UTF-8
113Pliki umożliwiające debugowanie bibliotek mono.
5dab3216 114
18ff84b2
MM
115%package csharp
116Summary: C# compiler for mono
d1081961 117Summary(pl.UTF-8): Kompilator C# dla mono
18ff84b2 118Group: Development/Languages
76e7cb31 119Requires: %{name}-devel = %{version}-%{release}
18ff84b2
MM
120
121%description csharp
122C# compiler for mono.
123
a86cd9c8 124%description csharp -l pl.UTF-8
18ff84b2
MM
125Kompilator C# dla mono.
126
127%package ilasm
128Summary: ILasm compiler for mono
d1081961 129Summary(pl.UTF-8): Kompilator ILasm dla mono
18ff84b2 130Group: Development/Languages
76e7cb31 131Requires: %{name}-devel = %{version}-%{release}
6ec58c77 132Provides: ilasm
133Obsoletes: pnet-compiler-ilasm
18ff84b2
MM
134
135%description ilasm
136ILasm compiler for mono.
137
a86cd9c8 138%description ilasm -l pl.UTF-8
18ff84b2 139Kompilator ILasm dla mono.
71c7a580 140
245657c9
MM
141%package jscript
142Summary: jscript compiler for mono
d1081961 143Summary(pl.UTF-8): Kompilator jscript dla mono
245657c9
MM
144Group: Development/Languages
145Requires: %{name}-devel = %{version}-%{release}
146
147%description jscript
148jscript compiler for mono.
149
a86cd9c8 150%description jscript -l pl.UTF-8
245657c9
MM
151Kompilator jscript dla mono.
152
8aa3dace 153%package static
154Summary: Static mono library
d1081961 155Summary(pl.UTF-8): Statyczna biblioteka mono
8aa3dace 156Group: Development/Libraries
76e7cb31 157Requires: %{name}-devel = %{version}-%{release}
8aa3dace 158
159%description static
160Static mono library.
161
a86cd9c8 162%description static -l pl.UTF-8
71c7a580
JB
163Statyczna biblioteka mono.
164
ea0e88d4
MM
165%package jay
166Summary: Yacc-like parser generator for Java and C#
d1081961 167Summary(pl.UTF-8): Podobny do Yacca generator parserów dla Javy i C#
ea0e88d4
MM
168Group: Development/Tools
169
170%description jay
171Yacc-like parser generator for Java and C#.
172
a86cd9c8
JR
173%description jay -l pl.UTF-8
174Podobny do Yacca generator parserów dla Javy i C#.
ea0e88d4 175
f327d485
MM
176%package compat-links
177Summary: Mono compatibility links
d1081961 178Summary(pl.UTF-8): Dowiązania dla kompatybilności
f327d485
MM
179Group: Development/Languages
180Requires: %{name}-devel = %{version}-%{release}
181
182%description compat-links
183This package contains links to binaries with names used in .NET and
184dotGNU.
185
a86cd9c8
JR
186%description compat-links -l pl.UTF-8
187Pakiet ten zawiera dowiązania do programów o nazwach używanych w .NET
f327d485
MM
188oraz dotGNU.
189
728c2265 190%prep
245657c9 191%setup -q
ddb02eae 192%patch0 -p1
24b388af 193%patch1 -p1
b3bdc9af 194%patch2 -p1
09957200 195%patch3 -p1
4a893061 196%patch4 -p1
394cba3f 197
728c2265 198%build
7f02b7bf
JB
199cp -f /usr/share/automake/config.sub .
200cp -f /usr/share/automake/config.sub libgc
18ff84b2
MM
201%{__libtoolize}
202%{__aclocal}
245657c9 203%{__autoheader}
18ff84b2
MM
204%{__autoconf}
205%{__automake}
245657c9
MM
206cd libgc
207%{__libtoolize}
208%{__aclocal}
209%{__autoconf}
210%{__automake}
211cd ..
212
cff23ab8 213CPPFLAGS="-DUSE_LIBC_PRIVATE_SYMBOLS"
0eeed8fb 214%configure \
f1c5438d 215 %{!?with_static_libs:--disable-static} \
91164168 216 --enable-fast-install \
f1c5438d 217 --with-gc=included \
245657c9 218 --with-icu=no \
f1c5438d
JB
219 --with-interp=%{?with_mint:yes}%{!?with_mint:no} \
220 --with-jit=%{?with_mint:no}%{!?with_mint:yes} \
221 --with-preview=yes \
fef1a4c5 222 --with-tls=%{?with_tls:__thread}%{!?with_tls:pthread}
0eeed8fb 223
a317f685
JB
224# mint uses heap to make trampolines, which need to be executable
225# there is mprotect(...,PROT_EXEC) for ppc/s390, but not used
226# (ifdef NEED_MPROTECT, which is never defined)
227# in fact the flag should be "-Wl,-z,execheap" for libmint, but:
228# -z execheap doesn't seem to do anything currently
229# -z execstack for library makes only stack executable, but not heap
24b469a9 230%{__make} -j1 \
a317f685 231 mint_LDFLAGS="-Wl,-z,execheap -Wl,-z,execstack"
728c2265
AM
232
233%install
234rm -rf $RPM_BUILD_ROOT
ad29385a 235install -d $RPM_BUILD_ROOT%{_rpmlibdir}
728c2265 236
24b469a9 237%{__make} -j1 install \
866e5301 238 DESTDIR=$RPM_BUILD_ROOT
b11f008f 239
65a9c4dc 240strip --strip-debug $RPM_BUILD_ROOT%{_bindir}/mono
241
ea0e88d4 242rm -f $RPM_BUILD_ROOT%{_datadir}/jay/[A-Z]*
728c2265 243
18ff84b2
MM
244# this way we can run rpmbuild -bi several times, and directories
245# have more meaningful name.
246rm -rf pld-doc
247mkdir -p pld-doc/{webpage,notes}
5385129f 248cp -a web/* pld-doc/webpage
03ad8b19 249cp -a docs/* pld-doc/notes
18ff84b2 250rm -f pld-doc/*/Makefile*
728c2265 251
245657c9
MM
252rm -rf $RPM_BUILD_ROOT%{_datadir}/libgc-mono
253
ad29385a 254mv -f $RPM_BUILD_ROOT%{_bindir}/mono-find* $RPM_BUILD_ROOT%{_rpmlibdir}
255
728c2265
AM
256%clean
257rm -rf $RPM_BUILD_ROOT
258
71c7a580
JB
259%post -p /sbin/ldconfig
260%postun -p /sbin/ldconfig
261
728c2265
AM
262%files
263%defattr(644,root,root,755)
4ffe85ea 264%doc AUTHORS ChangeLog NEWS README pld-doc/*
f1c5438d 265%if %{with mint}
245657c9 266%attr(755,root,root) %{_bindir}/mint
f1c5438d
JB
267%else
268%attr(755,root,root) %{_bindir}/mono
48941467 269%endif
840f8203 270%attr(755,root,root) %{_bindir}/caspol
245657c9 271%attr(755,root,root) %{_bindir}/cert*
26f2f2f5 272%attr(755,root,root) %{_bindir}/chktrust*
48cd6fab 273%attr(755,root,root) %{_bindir}/dtd2rng
245657c9 274%attr(755,root,root) %{_bindir}/gacutil*
c895038f 275#%attr(755,root,root) %{_bindir}/httpcfg
5385129f 276%attr(755,root,root) %{_bindir}/makecert*
245657c9 277%attr(755,root,root) %{_bindir}/mkbundle*
840f8203 278%attr(755,root,root) %{_bindir}/mono-service
48cd6fab 279%attr(755,root,root) %{_bindir}/mono-service2
280%attr(755,root,root) %{_bindir}/mono-xmltool
840f8203 281%attr(755,root,root) %{_bindir}/mozroots
245657c9 282%attr(755,root,root) %{_bindir}/secutil*
5385129f 283%attr(755,root,root) %{_bindir}/setreg*
8ef557a4 284%attr(755,root,root) %{_bindir}/sgen
245657c9
MM
285%attr(755,root,root) %{_bindir}/signcode*
286%attr(755,root,root) %{_bindir}/sn*
0eeed8fb 287%attr(755,root,root) %{_libdir}/lib*.so.*.*
2c1ff86a 288%attr(755,root,root) %{_libdir}/libMonoPosixHelper.so
ff3439a4 289%attr(755,root,root) %{_libdir}/libMonoSupportW.so
2c1ff86a 290%attr(755,root,root) %{_libdir}/libikvm-native.so
f1c5438d
JB
291%dir %{_prefix}/lib/mono
292%dir %{_prefix}/lib/mono/1.0
293%dir %{_prefix}/lib/mono/2.0
6d20487b 294%dir %{_prefix}/lib/mono/compat-1.0
295%dir %{_prefix}/lib/mono/compat-2.0
f1c5438d
JB
296%attr(755,root,root) %{_prefix}/lib/mono/*.*/*.dll
297%attr(755,root,root) %{_prefix}/lib/mono/1.0/cert*
298%attr(755,root,root) %{_prefix}/lib/mono/1.0/chktrust*
299%attr(755,root,root) %{_prefix}/lib/mono/1.0/gacutil*
f1c5438d 300%attr(755,root,root) %{_prefix}/lib/mono/1.0/mkbundle*
840f8203 301%attr(755,root,root) %{_prefix}/lib/mono/1.0/mozroots*
f1c5438d
JB
302%attr(755,root,root) %{_prefix}/lib/mono/1.0/secutil*
303%attr(755,root,root) %{_prefix}/lib/mono/1.0/setreg*
304%attr(755,root,root) %{_prefix}/lib/mono/1.0/signcode*
305%attr(755,root,root) %{_prefix}/lib/mono/1.0/sn*
306%attr(755,root,root) %{_prefix}/lib/mono/1.0/caspol*
307%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-service*
7e3aee8d 308%attr(755,root,root) %{_prefix}/lib/mono/2.0/mkbundle*
99f430c1 309%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-service*
8ef557a4 310%attr(755,root,root) %{_prefix}/lib/mono/2.0/sgen*
5dab3216 311%exclude %{_prefix}/lib/mono/1.0/*.mdb
f1c5438d 312%{_prefix}/lib/mono/gac
5dab3216 313%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
5385129f 314%{_mandir}/man1/cert*.1*
245657c9
MM
315%{_mandir}/man1/chktrust.1*
316%{_mandir}/man1/gacutil.1*
4a893061 317%{_mandir}/man1/httpcfg.1*
5385129f 318%{_mandir}/man1/makecert.1*
245657c9
MM
319%{_mandir}/man1/mkbundle.1*
320%{_mandir}/man1/mint.1*
321%{_mandir}/man1/mono.1*
322%{_mandir}/man1/mono-service.1*
840f8203 323%{_mandir}/man1/mozroots.1*
5385129f 324%{_mandir}/man1/secutil.1*
5385129f 325%{_mandir}/man1/setreg.1*
8ef557a4 326%{_mandir}/man1/sgen.1*
245657c9
MM
327%{_mandir}/man1/signcode.1*
328%{_mandir}/man1/sn.1*
329%{_mandir}/man1/permview.1*
330%{_mandir}/man5/mono-config.5*
fdd46781 331%dir %{_sysconfdir}/mono
f1c5438d
JB
332%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/config
333%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/browscap.ini
245657c9 334%dir %{_sysconfdir}/mono/1.0
f1c5438d
JB
335%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/machine.config
336%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
245657c9 337%dir %{_sysconfdir}/mono/2.0
f1c5438d
JB
338%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/machine.config
339%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
48cd6fab 340%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/web.config
8aa3dace 341
9f4cf2f1 342%exclude %{_prefix}/lib/mono/gac/Microsoft.JScript
343%exclude %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
344%exclude %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
345
ea0e88d4
MM
346%files jay
347%defattr(644,root,root,755)
245657c9 348%doc mcs/jay/{ACKNOWLEDGEMENTS,ChangeLog,NEW_FEATURES,NOTES,README,README.jay}
ea0e88d4
MM
349%attr(755,root,root) %{_bindir}/jay
350%dir %{_datadir}/jay
351%{_datadir}/jay/skeleton*
352%{_mandir}/man1/jay.1*
353
245657c9
MM
354%files jscript
355%defattr(644,root,root,755)
356%attr(755,root,root) %{_bindir}/mjs
f1c5438d 357%attr(755,root,root) %{_prefix}/lib/mono/1.0/mjs*
5dab3216 358%exclude %{_prefix}/lib/mono/1.0/*.mdb
9f4cf2f1 359%{_prefix}/lib/mono/gac/Microsoft.JScript
360%{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
361%{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
5dab3216 362%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
245657c9 363
f327d485
MM
364%files compat-links
365%defattr(644,root,root,755)
366%attr(755,root,root) %{_bindir}/resgen
3d1af25b 367%attr(755,root,root) %{_bindir}/resgen2
f327d485 368
8aa3dace 369%files devel
370%defattr(644,root,root,755)
245657c9
MM
371%attr(755,root,root) %{_bindir}/al*
372%attr(755,root,root) %{_bindir}/cilc*
373%attr(755,root,root) %{_bindir}/disco*
994ec6f9 374%attr(755,root,root) %{_bindir}/dtd2xsd
245657c9 375%attr(755,root,root) %{_bindir}/genxs*
994ec6f9 376%attr(755,root,root) %{_bindir}/macpack
377%attr(755,root,root) %{_bindir}/monodiet
245657c9 378%attr(755,root,root) %{_bindir}/monodis
2affc12a 379%attr(755,root,root) %{_bindir}/monograph
245657c9 380%attr(755,root,root) %{_bindir}/monop*
994ec6f9 381%attr(755,root,root) %{_bindir}/mono-shlib-cop*
ff3439a4 382%attr(755,root,root) %{_bindir}/nunit-console
48cd6fab 383%attr(755,root,root) %{_bindir}/nunit-console2
18ff84b2 384%attr(755,root,root) %{_bindir}/pedump
994ec6f9 385%attr(755,root,root) %{_bindir}/permview
386%attr(755,root,root) %{_bindir}/prj2make
ff112d9b 387%attr(755,root,root) %{_bindir}/soapsuds*
245657c9
MM
388%attr(755,root,root) %{_bindir}/sqlsharp*
389%attr(755,root,root) %{_bindir}/wsdl*
4ffe85ea 390%attr(755,root,root) %{_bindir}/xbuild
245657c9 391%attr(755,root,root) %{_bindir}/xsd*
f1c5438d
JB
392%if %{with mint}
393%attr(755,root,root) %{_libdir}/libmint.so
394%else
2c1ff86a
KK
395%attr(755,root,root) %{_libdir}/libmono.so
396%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so
f1c5438d 397%endif
a3e92bcf 398%{_libdir}/lib*.la
f1c5438d
JB
399%attr(755,root,root) %{_prefix}/lib/mono/1.0/al*
400%attr(755,root,root) %{_prefix}/lib/mono/1.0/browsercaps-updater*
401%attr(755,root,root) %{_prefix}/lib/mono/1.0/cilc*
402%attr(755,root,root) %{_prefix}/lib/mono/1.0/CorCompare*
403%attr(755,root,root) %{_prefix}/lib/mono/1.0/disco*
48cd6fab 404%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2rng*
f1c5438d
JB
405%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2xsd*
406%attr(755,root,root) %{_prefix}/lib/mono/1.0/genxs*
407%attr(755,root,root) %{_prefix}/lib/mono/1.0/ictool*
408%attr(755,root,root) %{_prefix}/lib/mono/1.0/macpack*
ff3439a4 409%attr(755,root,root) %{_prefix}/lib/mono/1.0/makecert*
f1c5438d
JB
410%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-api-*
411%attr(755,root,root) %{_prefix}/lib/mono/1.0/monop*
412%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-shlib-cop*
48cd6fab 413%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-xmltool*
ff3439a4 414%attr(755,root,root) %{_prefix}/lib/mono/1.0/nunit-console*
f1c5438d
JB
415%attr(755,root,root) %{_prefix}/lib/mono/1.0/permview*
416%attr(755,root,root) %{_prefix}/lib/mono/1.0/prj2make*
417%attr(755,root,root) %{_prefix}/lib/mono/1.0/resgen*
418%attr(755,root,root) %{_prefix}/lib/mono/1.0/soapsuds*
419%attr(755,root,root) %{_prefix}/lib/mono/1.0/sqlsharp*
420%attr(755,root,root) %{_prefix}/lib/mono/1.0/wsdl*
421%attr(755,root,root) %{_prefix}/lib/mono/1.0/xsd*
4a893061 422%attr(755,root,root) %{_prefix}/lib/mono/2.0/al*
f1c5438d 423%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-api-info*
ff3439a4 424%attr(755,root,root) %{_prefix}/lib/mono/2.0/monop*
425%attr(755,root,root) %{_prefix}/lib/mono/2.0/nunit-console*
3d1af25b 426%attr(755,root,root) %{_prefix}/lib/mono/2.0/resgen*
f1c5438d 427%attr(755,root,root) %{_prefix}/lib/mono/2.0/wsdl*
4ffe85ea 428%attr(755,root,root) %{_prefix}/lib/mono/2.0/xbuild*
4a893061 429%{_prefix}/lib/mono/2.0/MSBuild
430%{_prefix}/lib/mono/2.0/*.xsd
431%{_prefix}/lib/mono/2.0/*.targets
432%{_prefix}/lib/mono/2.0/*.tasks
5dab3216 433%exclude %{_prefix}/lib/mono/1.0/*.mdb
434%exclude %{_prefix}/lib/mono/2.0/*.mdb
f1c5438d 435%attr(755,root,root) %{_rpmlibdir}/mono-find*
4a893061 436%{_datadir}/%{name}-1.0
0eeed8fb 437%{_pkgconfigdir}/*.pc
4a893061 438%{_includedir}/%{name}-1.0
ff3439a4 439%{_mandir}/man1/al.1*
c8f3b110 440%{_mandir}/man1/cilc.1*
994ec6f9 441%{_mandir}/man1/disco.1*
442%{_mandir}/man1/dtd2xsd.1*
e0aee78b 443%{_mandir}/man1/genxs.1*
994ec6f9 444%{_mandir}/man1/macpack.1*
2affc12a
MM
445%{_mandir}/man1/monoburg.1*
446%{_mandir}/man1/monodis.1*
994ec6f9 447%{_mandir}/man1/monop.1*
448%{_mandir}/man1/mono-shlib-cop.1*
48cd6fab 449%{_mandir}/man1/mono-xmltool.1*
2affc12a 450%{_mandir}/man1/monostyle.1*
994ec6f9 451%{_mandir}/man1/oldmono.1*
452%{_mandir}/man1/prj2make.1*
453%{_mandir}/man1/soapsuds.1*
18ff84b2 454%{_mandir}/man1/sqlsharp.1*
ff112d9b 455%{_mandir}/man1/wsdl.1*
a66172db 456%{_mandir}/man1/xsd.1*
18ff84b2
MM
457
458%files csharp
609883c4 459%defattr(644,root,root,755)
a66172db
MM
460%attr(755,root,root) %{_bindir}/mcs
461%attr(755,root,root) %{_bindir}/gmcs
f1c5438d
JB
462%attr(755,root,root) %{_prefix}/lib/mono/1.0/mcs.exe*
463%attr(755,root,root) %{_prefix}/lib/mono/2.0/gmcs.exe*
5dab3216 464%exclude %{_prefix}/lib/mono/1.0/*.mdb
465%exclude %{_prefix}/lib/mono/2.0/*.mdb
18ff84b2
MM
466%{_mandir}/man1/mcs.1*
467
18ff84b2 468%files ilasm
609883c4 469%defattr(644,root,root,755)
18ff84b2 470%attr(755,root,root) %{_bindir}/ilasm*
f1c5438d 471%attr(755,root,root) %{_prefix}/lib/mono/1.0/ilasm*
4ffe85ea 472%attr(755,root,root) %{_prefix}/lib/mono/2.0/ilasm*
5dab3216 473%exclude %{_prefix}/lib/mono/1.0/*.mdb
474%exclude %{_prefix}/lib/mono/2.0/*.mdb
c8f3b110 475%{_mandir}/man1/ilasm.1*
8aa3dace 476
5dab3216 477%files debug
478%defattr(644,root,root,755)
479%{_prefix}/lib/mono/1.0/*.mdb
480%{_prefix}/lib/mono/2.0/*.mdb
481%{_prefix}/lib/mono/gac/*/*/*.mdb
482
4d9455d0 483%if %{with static_libs}
8aa3dace 484%files static
485%defattr(644,root,root,755)
486%{_libdir}/lib*.a
4d9455d0 487%endif
This page took 0.136573 seconds and 4 git commands to generate.