]> git.pld-linux.org Git - packages/mono.git/blame - mono.spec
- start upgrade to 2.4.2
[packages/mono.git] / mono.spec
CommitLineData
39176ea5 1#
fef1a4c5 2# NOTE: Makefiles are broken, build could stop long time after first fatal error
245657c9
MM
3#
4# Conditional build:
fef1a4c5 5%bcond_without tls # don't use TLS (which requires recent 2.4.x or 2.6 kernel)
4d9455d0 6%bcond_without static_libs # don't build static libraries
8cabdc4d 7%bcond_with bootstrap # don't require mono-devel to find req/prov
75873ca6 8%bcond_with mint # build mint instead of mono VM (JIT) [broken]
245657c9 9#
75873ca6
JB
10%ifnarch %{ix86} %{x8664} alpha arm ia64 ppc s390 s390x sparc sparcv9 sparc64
11# JIT not supported on hppa
a465d985 12%define with_mint 1
f1c5438d 13%endif
5114c445 14%define glib_ver 1:2.4
8cabdc4d 15#
728c2265 16Summary: Common Language Infrastructure implementation
d1081961 17Summary(pl.UTF-8): Implementacja Common Language Infrastructure
728c2265 18Name: mono
7bad922f 19Version: 2.4.2
20Release: 0.1
5114c445 21License: LGPL (VM), GPL (C# compilers), MIT X11 with GPL additions (classes, tools)
728c2265 22Group: Development/Languages
0f6bc6e4
JB
23# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
24Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
7bad922f 25# Source0-md5: f086227f3cd4cecb5c1fe0f566760f81
ddb02eae
JB
26Patch0: %{name}-alpha-float.patch
27Patch1: %{name}-mint.patch
28Patch2: %{name}-sonames.patch
3cdc32b9
JB
29Patch3: %{name}-awk.patch
30Patch4: %{name}-console-no-utf8-bom.patch
5114c445 31Patch5: %{name}-pc.patch
0f6bc6e4 32Patch6: %{name}-ARG_MAX.patch
e9945d9e 33Patch7: %{name}-metadata-makefile.patch
68174c6e 34URL: http://www.mono-project.com/
39176ea5 35%if %(test -r /dev/random; echo $?)
96185d3a
JB
36BuildRequires: ACCESSIBLE_/dev/random
37%endif
8aa3dace 38BuildRequires: autoconf
39BuildRequires: automake
3c4b0944 40BuildRequires: bison
5114c445 41BuildRequires: glib2-devel >= %{glib_ver}
f7c57864 42BuildRequires: libtool
609d5e15 43%{!?with_bootstrap:BuildRequires: mono-devel >= 1.1.8.3-2}
f7c57864 44BuildRequires: pkgconfig
71415791 45BuildRequires: rpmbuild(macros) >= 1.213
2ca5ca77 46BuildRequires: rpmbuild(monoautodeps)
8c34c74b 47Suggests: binfmt-detector
5114c445 48# for System.Drawing
7b0dd1f7 49Suggests: libgdiplus >= 2.0
e19321c3 50ExclusiveArch: %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
1de8200d
JB
51# plain i386 is not supported; mono uses cmpxchg/xadd which require i486
52ExcludeArch: i386
728c2265
AM
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
ad29385a 55%define _rpmlibdir /usr/lib/rpm
56
baf6636c 57# debugger doesn't work with stripped mono
58%define _noautostrip .*/mono
59
39176ea5 60%if %{without bootstrap}
d0023a38 61%define __mono_provides %{_rpmlibdir}/mono-find-provides
62%define __mono_requires %{_rpmlibdir}/mono-find-requires
63%endif
64
728c2265
AM
65%description
66The Common Language Infrastructure platform. Microsoft has created a
67new development platform. The highlights of this new development
68platform are:
86d7bbf3 69- A runtime environment that provides garbage collection, threading
728c2265 70 and a virtual machine specification (The Virtual Execution System,
8aa3dace 71 VES),
72- A comprehensive class library,
728c2265 73- A new language, C#. Very similar to Java, C# allows programmers to
8aa3dace 74 use all the features available on the .NET runtime,
728c2265
AM
75- A language specification that compilers can follow if they want to
76 generate classes and code that can interoperate with other programming
8aa3dace 77 languages (The Common Language Specification: CLS).
728c2265 78
39176ea5 79%{?with_tls:This version was built with TLS __thread.}
245657c9 80
a86cd9c8
JR
81%description -l pl.UTF-8
82Platforma CLI (Common Language Infrastructure). Microsoft stworzył
83nową platformę developerską. Zalety tej platformy to:
84- środowisko, które dostarcza garbage collector, wątki oraz
85 specyfikację maszyny wirtualnej (The Virtual Execution System, VES),
86- bibliotekę klas,
87- nowy język, C#. Bardzo podobny do Javy, C# pozwala programistom na
88 używanie wszystkich możliwości dostarczanych przez platformę .NET,
89- specyfikacja dla kompilatorów, które chcą generować kod
90 współpracujący z innymi językami programowania (The Common Language
8aa3dace 91 Specification: CLS).
92
a86cd9c8 93%{?with_tls:Ta wersja została zbudowana z TLS __thread.}
245657c9 94
8aa3dace 95%package devel
96Summary: Development resources for mono
d1081961 97Summary(pl.UTF-8): Zasoby programisty do mono
5114c445 98License: LGPL (VM), MIT X11 with GPL additions (classes, tools)
8aa3dace 99Group: Development/Libraries
76e7cb31 100Requires: %{name} = %{version}-%{release}
5114c445 101Requires: glib2-devel >= %{glib_ver}
8aa3dace 102
103%description devel
104Development resources for mono.
105
a86cd9c8 106%description devel -l pl.UTF-8
18ff84b2
MM
107Zasoby programisty dla mono.
108
5dab3216 109%package debug
110Summary: Mono libraries debugging resources
d1081961 111Summary(pl.UTF-8): Pliki umożliwiające debugowanie bibliotek mono
5dab3216 112Group: Development/Libraries
113Requires: %{name} = %{version}-%{release}
114
115%description debug
116Mono libraries debugging resources.
117
a86cd9c8
JR
118%description debug -l pl.UTF-8
119Pliki umożliwiające debugowanie bibliotek mono.
5dab3216 120
18ff84b2
MM
121%package csharp
122Summary: C# compiler for mono
d1081961 123Summary(pl.UTF-8): Kompilator C# dla mono
5114c445 124License: GPL
18ff84b2 125Group: Development/Languages
76e7cb31 126Requires: %{name}-devel = %{version}-%{release}
18ff84b2
MM
127
128%description csharp
129C# compiler for mono.
130
a86cd9c8 131%description csharp -l pl.UTF-8
18ff84b2
MM
132Kompilator C# dla mono.
133
134%package ilasm
135Summary: ILasm compiler for mono
d1081961 136Summary(pl.UTF-8): Kompilator ILasm dla mono
5114c445
JB
137# implied
138License: MIT X11
18ff84b2 139Group: Development/Languages
76e7cb31 140Requires: %{name}-devel = %{version}-%{release}
6ec58c77 141Provides: ilasm
142Obsoletes: pnet-compiler-ilasm
18ff84b2
MM
143
144%description ilasm
145ILasm compiler for mono.
146
a86cd9c8 147%description ilasm -l pl.UTF-8
18ff84b2 148Kompilator ILasm dla mono.
71c7a580 149
245657c9
MM
150%package jscript
151Summary: jscript compiler for mono
d1081961 152Summary(pl.UTF-8): Kompilator jscript dla mono
5114c445 153License: MIT X11
245657c9
MM
154Group: Development/Languages
155Requires: %{name}-devel = %{version}-%{release}
156
157%description jscript
158jscript compiler for mono.
159
a86cd9c8 160%description jscript -l pl.UTF-8
245657c9
MM
161Kompilator jscript dla mono.
162
e9945d9e 163%package monodoc
164Summary: Documentation for Mono class libraries and tools to produce and edit the documentation
165Summary(pl.UTF-8): Dokumentacja klas Mono wraz z narzędziami do jej generowania i przeglądania
166License: LGPL
167Group: Development/Libraries
168Requires: %{name}-devel = %{version}-%{release}
d9fa5933 169Provides: monodoc
e9945d9e 170Obsoletes: monodoc
171
172%description monodoc
173This package contains the documentation for the Mono class libraries,
174tools to produce and edit the documentation, and a documentation
175browser.
176
177%description monodoc -l pl.UTF-8
178Ten pakiet zawiera dokumentację klas Mono wraz z narzędziami do jej
179generowania i przeglądania.
180
8aa3dace 181%package static
182Summary: Static mono library
d1081961 183Summary(pl.UTF-8): Statyczna biblioteka mono
5114c445 184License: LGPL
8aa3dace 185Group: Development/Libraries
76e7cb31 186Requires: %{name}-devel = %{version}-%{release}
8aa3dace 187
188%description static
189Static mono library.
190
a86cd9c8 191%description static -l pl.UTF-8
71c7a580
JB
192Statyczna biblioteka mono.
193
ea0e88d4
MM
194%package jay
195Summary: Yacc-like parser generator for Java and C#
d1081961 196Summary(pl.UTF-8): Podobny do Yacca generator parserów dla Javy i C#
5114c445 197License: BSD
ea0e88d4
MM
198Group: Development/Tools
199
200%description jay
201Yacc-like parser generator for Java and C#.
202
a86cd9c8
JR
203%description jay -l pl.UTF-8
204Podobny do Yacca generator parserów dla Javy i C#.
ea0e88d4 205
f327d485
MM
206%package compat-links
207Summary: Mono compatibility links
d1081961 208Summary(pl.UTF-8): Dowiązania dla kompatybilności
5114c445
JB
209# resgen license
210License: MIT X11
f327d485
MM
211Group: Development/Languages
212Requires: %{name}-devel = %{version}-%{release}
213
214%description compat-links
215This package contains links to binaries with names used in .NET and
216dotGNU.
217
a86cd9c8
JR
218%description compat-links -l pl.UTF-8
219Pakiet ten zawiera dowiązania do programów o nazwach używanych w .NET
f327d485
MM
220oraz dotGNU.
221
728c2265 222%prep
245657c9 223%setup -q
ddb02eae 224%patch0 -p1
24b388af 225%patch1 -p1
b3bdc9af 226%patch2 -p1
3cdc32b9 227%patch3 -p1
4a893061 228%patch4 -p1
ca59b162 229#%patch5 -p1
0f6bc6e4 230%patch6 -p1
e9945d9e 231%patch7 -p1
394cba3f 232
5114c445
JB
233# for jay
234cat >>mcs/build/config-default.make <<EOF
235CC = %{__cc}
236CFLAGS = %{rpmcflags}
237EOF
238
728c2265 239%build
7f02b7bf
JB
240cp -f /usr/share/automake/config.sub .
241cp -f /usr/share/automake/config.sub libgc
18ff84b2
MM
242%{__libtoolize}
243%{__aclocal}
245657c9 244%{__autoheader}
18ff84b2
MM
245%{__autoconf}
246%{__automake}
245657c9
MM
247cd libgc
248%{__libtoolize}
249%{__aclocal}
250%{__autoconf}
251%{__automake}
252cd ..
253
5114c445
JB
254# -DUSE_COMPILER_TLS is passed to libgc by main configure, but our
255# CPPFLAGS override that CPPFLAGS
256CPPFLAGS="-DUSE_LIBC_PRIVATE_SYMBOLS -DUSE_COMPILER_TLS"
0eeed8fb 257%configure \
f1c5438d 258 %{!?with_static_libs:--disable-static} \
91164168 259 --enable-fast-install \
f1c5438d 260 --with-gc=included \
245657c9 261 --with-icu=no \
f1c5438d
JB
262 --with-interp=%{?with_mint:yes}%{!?with_mint:no} \
263 --with-jit=%{?with_mint:no}%{!?with_mint:yes} \
264 --with-preview=yes \
fef1a4c5 265 --with-tls=%{?with_tls:__thread}%{!?with_tls:pthread}
0eeed8fb 266
a317f685
JB
267# mint uses heap to make trampolines, which need to be executable
268# there is mprotect(...,PROT_EXEC) for ppc/s390, but not used
269# (ifdef NEED_MPROTECT, which is never defined)
270# in fact the flag should be "-Wl,-z,execheap" for libmint, but:
271# -z execheap doesn't seem to do anything currently
272# -z execstack for library makes only stack executable, but not heap
24b469a9 273%{__make} -j1 \
a317f685 274 mint_LDFLAGS="-Wl,-z,execheap -Wl,-z,execstack"
728c2265
AM
275
276%install
277rm -rf $RPM_BUILD_ROOT
ad29385a 278install -d $RPM_BUILD_ROOT%{_rpmlibdir}
728c2265 279
24b469a9 280%{__make} -j1 install \
866e5301 281 DESTDIR=$RPM_BUILD_ROOT
b11f008f 282
65a9c4dc 283strip --strip-debug $RPM_BUILD_ROOT%{_bindir}/mono
284
ea0e88d4 285rm -f $RPM_BUILD_ROOT%{_datadir}/jay/[A-Z]*
728c2265 286
18ff84b2
MM
287# this way we can run rpmbuild -bi several times, and directories
288# have more meaningful name.
289rm -rf pld-doc
e6c59841 290install -d pld-doc/{webpage,notes}
5385129f 291cp -a web/* pld-doc/webpage
03ad8b19 292cp -a docs/* pld-doc/notes
18ff84b2 293rm -f pld-doc/*/Makefile*
728c2265 294
245657c9
MM
295rm -rf $RPM_BUILD_ROOT%{_datadir}/libgc-mono
296
5114c445
JB
297mv -f $RPM_BUILD_ROOT%{_bindir}/mono-find-* $RPM_BUILD_ROOT%{_rpmlibdir}
298
299# loadable modules
300rm $RPM_BUILD_ROOT%{_libdir}/lib{MonoPosixHelper,MonoSupportW,ikvm-native}.{la,a}
ad29385a 301
728c2265
AM
302%clean
303rm -rf $RPM_BUILD_ROOT
304
71c7a580
JB
305%post -p /sbin/ldconfig
306%postun -p /sbin/ldconfig
307
728c2265
AM
308%files
309%defattr(644,root,root,755)
4ffe85ea 310%doc AUTHORS ChangeLog NEWS README pld-doc/*
f1c5438d 311%if %{with mint}
245657c9 312%attr(755,root,root) %{_bindir}/mint
f1c5438d
JB
313%else
314%attr(755,root,root) %{_bindir}/mono
48941467 315%endif
840f8203 316%attr(755,root,root) %{_bindir}/caspol
5114c445
JB
317%attr(755,root,root) %{_bindir}/cert2spc
318%attr(755,root,root) %{_bindir}/certmgr
319%attr(755,root,root) %{_bindir}/chktrust
48cd6fab 320%attr(755,root,root) %{_bindir}/dtd2rng
e6c59841 321%attr(755,root,root) %{_bindir}/gacutil1
5114c445 322%attr(755,root,root) %{_bindir}/gacutil
7b0dd1f7 323%attr(755,root,root) %{_bindir}/gacutil2
4f35821b 324%attr(755,root,root) %{_bindir}/httpcfg
325%attr(755,root,root) %{_bindir}/installvst
5114c445
JB
326%attr(755,root,root) %{_bindir}/makecert
327%attr(755,root,root) %{_bindir}/mconfig
328%attr(755,root,root) %{_bindir}/mkbundle
7b0dd1f7 329%attr(755,root,root) %{_bindir}/mkbundle1
5114c445 330%attr(755,root,root) %{_bindir}/mkbundle2
840f8203 331%attr(755,root,root) %{_bindir}/mono-service
48cd6fab 332%attr(755,root,root) %{_bindir}/mono-service2
f3b0e346 333%attr(755,root,root) %{_bindir}/mono-test-install
48cd6fab 334%attr(755,root,root) %{_bindir}/mono-xmltool
840f8203 335%attr(755,root,root) %{_bindir}/mozroots
5114c445
JB
336%attr(755,root,root) %{_bindir}/secutil
337%attr(755,root,root) %{_bindir}/setreg
8ef557a4 338%attr(755,root,root) %{_bindir}/sgen
5114c445
JB
339%attr(755,root,root) %{_bindir}/signcode
340%attr(755,root,root) %{_bindir}/sn
341%if %{with mint}
342%attr(755,root,root) %{_libdir}/libmint.so.*.*.*
343%attr(755,root,root) %ghost %{_libdir}/libmint.so.0
344%else
345%attr(755,root,root) %{_libdir}/libmono.so.*.*.*
346%attr(755,root,root) %ghost %{_libdir}/libmono.so.0
347%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so.*.*.*
348%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-aot.so.0
349%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so.*.*.*
350%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-cov.so.0
7b0dd1f7 351%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so.*.*.*
352%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-logging.so.0
5114c445 353%endif
2c1ff86a 354%attr(755,root,root) %{_libdir}/libMonoPosixHelper.so
ff3439a4 355%attr(755,root,root) %{_libdir}/libMonoSupportW.so
2c1ff86a 356%attr(755,root,root) %{_libdir}/libikvm-native.so
f1c5438d
JB
357%dir %{_prefix}/lib/mono
358%dir %{_prefix}/lib/mono/1.0
5114c445
JB
359%{_prefix}/lib/mono/1.0/*.dll
360%attr(755,root,root) %{_prefix}/lib/mono/1.0/caspol.exe
361%attr(755,root,root) %{_prefix}/lib/mono/1.0/cert2spc.exe
362%attr(755,root,root) %{_prefix}/lib/mono/1.0/certmgr.exe
363%attr(755,root,root) %{_prefix}/lib/mono/1.0/chktrust.exe
364%attr(755,root,root) %{_prefix}/lib/mono/1.0/culevel.exe
365%attr(755,root,root) %{_prefix}/lib/mono/1.0/gacutil.exe
f3b0e346 366%attr(755,root,root) %{_prefix}/lib/mono/1.0/installutil.exe
5114c445
JB
367%attr(755,root,root) %{_prefix}/lib/mono/1.0/installvst.exe
368%attr(755,root,root) %{_prefix}/lib/mono/1.0/mkbundle.exe
369%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-service.exe
370%attr(755,root,root) %{_prefix}/lib/mono/1.0/mozroots.exe
371%attr(755,root,root) %{_prefix}/lib/mono/1.0/secutil.exe
372%attr(755,root,root) %{_prefix}/lib/mono/1.0/setreg.exe
373%attr(755,root,root) %{_prefix}/lib/mono/1.0/signcode.exe
374%attr(755,root,root) %{_prefix}/lib/mono/1.0/sn.exe
f1c5438d 375%dir %{_prefix}/lib/mono/2.0
5114c445 376%{_prefix}/lib/mono/2.0/*.dll
7b0dd1f7 377%attr(755,root,root) %{_prefix}/lib/mono/2.0/gacutil.exe
5114c445 378%attr(755,root,root) %{_prefix}/lib/mono/2.0/httpcfg.exe
f3b0e346 379%attr(755,root,root) %{_prefix}/lib/mono/2.0/installutil.exe
5114c445
JB
380%attr(755,root,root) %{_prefix}/lib/mono/2.0/mconfig.exe
381%attr(755,root,root) %{_prefix}/lib/mono/2.0/mkbundle.exe
382%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-service.exe
383%attr(755,root,root) %{_prefix}/lib/mono/2.0/sgen.exe
7b0dd1f7 384%attr(755,root,root) %{_prefix}/lib/mono/2.0/xsd.exe
f3b0e346 385%dir %{_prefix}/lib/mono/2.1
386%{_prefix}/lib/mono/2.1/*.dll
387%attr(755,root,root) %{_prefix}/lib/mono/2.1/smcs.exe
388%dir %{_prefix}/lib/mono/3.5
389%{_prefix}/lib/mono/3.5/*.dll
6d20487b 390%dir %{_prefix}/lib/mono/compat-1.0
5114c445 391%{_prefix}/lib/mono/compat-1.0/*.dll
6d20487b 392%dir %{_prefix}/lib/mono/compat-2.0
5114c445 393%{_prefix}/lib/mono/compat-2.0/*.dll
f1c5438d 394%{_prefix}/lib/mono/gac
5dab3216 395%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
5114c445
JB
396%{_mandir}/man1/cert2spc.1*
397%{_mandir}/man1/certmgr.1*
245657c9
MM
398%{_mandir}/man1/chktrust.1*
399%{_mandir}/man1/gacutil.1*
4a893061 400%{_mandir}/man1/httpcfg.1*
5385129f 401%{_mandir}/man1/makecert.1*
5114c445 402%{_mandir}/man1/mconfig.1*
245657c9
MM
403%{_mandir}/man1/mkbundle.1*
404%{_mandir}/man1/mint.1*
405%{_mandir}/man1/mono.1*
406%{_mandir}/man1/mono-service.1*
840f8203 407%{_mandir}/man1/mozroots.1*
5385129f 408%{_mandir}/man1/secutil.1*
5385129f 409%{_mandir}/man1/setreg.1*
8ef557a4 410%{_mandir}/man1/sgen.1*
245657c9
MM
411%{_mandir}/man1/signcode.1*
412%{_mandir}/man1/sn.1*
245657c9 413%{_mandir}/man5/mono-config.5*
fdd46781 414%dir %{_sysconfdir}/mono
f1c5438d 415%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/browscap.ini
f3b0e346 416%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/config
5114c445
JB
417%dir %{_sysconfdir}/mono/mconfig
418%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/mconfig/config.xml
245657c9 419%dir %{_sysconfdir}/mono/1.0
f1c5438d 420%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 421%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/machine.config
245657c9 422%dir %{_sysconfdir}/mono/2.0
f1c5438d 423%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 424%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/machine.config
425%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/settings.map
48cd6fab 426%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/web.config
7b0dd1f7 427%dir %{_sysconfdir}/mono/2.0/Browsers
428%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
8aa3dace 429
9f4cf2f1 430%exclude %{_prefix}/lib/mono/gac/Microsoft.JScript
431%exclude %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
432%exclude %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
504c4464 433%exclude %{_prefix}/lib/mono/gac/monodoc
9f4cf2f1 434
ea0e88d4
MM
435%files jay
436%defattr(644,root,root,755)
245657c9 437%doc mcs/jay/{ACKNOWLEDGEMENTS,ChangeLog,NEW_FEATURES,NOTES,README,README.jay}
ea0e88d4
MM
438%attr(755,root,root) %{_bindir}/jay
439%dir %{_datadir}/jay
440%{_datadir}/jay/skeleton*
441%{_mandir}/man1/jay.1*
442
245657c9
MM
443%files jscript
444%defattr(644,root,root,755)
445%attr(755,root,root) %{_bindir}/mjs
5114c445 446%attr(755,root,root) %{_prefix}/lib/mono/1.0/mjs.exe
9f4cf2f1 447%{_prefix}/lib/mono/gac/Microsoft.JScript
448%{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
449%{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
5dab3216 450%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
245657c9 451
f327d485
MM
452%files compat-links
453%defattr(644,root,root,755)
454%attr(755,root,root) %{_bindir}/resgen
7b0dd1f7 455%attr(755,root,root) %{_bindir}/resgen1
3d1af25b 456%attr(755,root,root) %{_bindir}/resgen2
f327d485 457
8aa3dace 458%files devel
459%defattr(644,root,root,755)
5114c445 460%attr(755,root,root) %{_bindir}/al
7b0dd1f7 461%attr(755,root,root) %{_bindir}/al1
5114c445
JB
462%attr(755,root,root) %{_bindir}/al2
463%attr(755,root,root) %{_bindir}/cilc
464%attr(755,root,root) %{_bindir}/disco
994ec6f9 465%attr(755,root,root) %{_bindir}/dtd2xsd
5114c445 466%attr(755,root,root) %{_bindir}/genxs
7b0dd1f7 467%attr(755,root,root) %{_bindir}/genxs1
994ec6f9 468%attr(755,root,root) %{_bindir}/macpack
39d58cda 469%attr(755,root,root) %{_bindir}/mono-api-info
e6c59841 470%attr(755,root,root) %{_bindir}/mono-cil-strip
245657c9 471%attr(755,root,root) %{_bindir}/monodis
2affc12a 472%attr(755,root,root) %{_bindir}/monograph
613285b2 473%attr(755,root,root) %{_bindir}/monolinker
5114c445 474%attr(755,root,root) %{_bindir}/monop
7b0dd1f7 475%attr(755,root,root) %{_bindir}/monop1
5114c445
JB
476%attr(755,root,root) %{_bindir}/monop2
477%attr(755,root,root) %{_bindir}/mono-shlib-cop
ff3439a4 478%attr(755,root,root) %{_bindir}/nunit-console
48cd6fab 479%attr(755,root,root) %{_bindir}/nunit-console2
18ff84b2 480%attr(755,root,root) %{_bindir}/pedump
994ec6f9 481%attr(755,root,root) %{_bindir}/permview
482%attr(755,root,root) %{_bindir}/prj2make
613285b2 483%attr(755,root,root) %{_bindir}/smcs
5114c445
JB
484%attr(755,root,root) %{_bindir}/soapsuds
485%attr(755,root,root) %{_bindir}/sqlsharp
486%attr(755,root,root) %{_bindir}/wsdl
7b0dd1f7 487%attr(755,root,root) %{_bindir}/wsdl1
5114c445 488%attr(755,root,root) %{_bindir}/wsdl2
4ffe85ea 489%attr(755,root,root) %{_bindir}/xbuild
5114c445 490%attr(755,root,root) %{_bindir}/xsd
7b0dd1f7 491%attr(755,root,root) %{_bindir}/xsd2
f1c5438d
JB
492%if %{with mint}
493%attr(755,root,root) %{_libdir}/libmint.so
5114c445 494%{_libdir}/libmint.la
f1c5438d 495%else
2c1ff86a 496%attr(755,root,root) %{_libdir}/libmono.so
5114c445 497%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so
2c1ff86a 498%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so
7b0dd1f7 499%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so
5114c445
JB
500%{_libdir}/libmono.la
501%{_libdir}/libmono-profiler-aot.la
502%{_libdir}/libmono-profiler-cov.la
7b0dd1f7 503%{_libdir}/libmono-profiler-logging.la
f1c5438d 504%endif
5114c445
JB
505%attr(755,root,root) %{_prefix}/lib/mono/1.0/al.exe
506%attr(755,root,root) %{_prefix}/lib/mono/1.0/browsercaps-updater.exe
507%attr(755,root,root) %{_prefix}/lib/mono/1.0/cilc.exe
508%attr(755,root,root) %{_prefix}/lib/mono/1.0/disco.exe
509%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2rng.exe
510%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2xsd.exe
511%attr(755,root,root) %{_prefix}/lib/mono/1.0/genxs.exe
512%attr(755,root,root) %{_prefix}/lib/mono/1.0/ictool.exe
513%attr(755,root,root) %{_prefix}/lib/mono/1.0/macpack.exe
514%attr(755,root,root) %{_prefix}/lib/mono/1.0/makecert.exe
e6c59841 515%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-cil-strip.exe
5114c445
JB
516%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-xmltool.exe
517%attr(755,root,root) %{_prefix}/lib/mono/1.0/monolinker.exe
518%attr(755,root,root) %{_prefix}/lib/mono/1.0/monop.exe
519%attr(755,root,root) %{_prefix}/lib/mono/1.0/nunit-console.exe
520%{_prefix}/lib/mono/1.0/nunit-console.exe.config
521%attr(755,root,root) %{_prefix}/lib/mono/1.0/permview.exe
522%attr(755,root,root) %{_prefix}/lib/mono/1.0/prj2make.exe
523%attr(755,root,root) %{_prefix}/lib/mono/1.0/resgen.exe
524%attr(755,root,root) %{_prefix}/lib/mono/1.0/soapsuds.exe
5114c445
JB
525%attr(755,root,root) %{_prefix}/lib/mono/1.0/wsdl.exe
526%attr(755,root,root) %{_prefix}/lib/mono/1.0/xsd.exe
527%attr(755,root,root) %{_prefix}/lib/mono/2.0/al.exe
528%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-api-info.exe
e6c59841 529%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-shlib-cop.exe
530%{_prefix}/lib/mono/2.0/mono-shlib-cop.exe.config
5114c445
JB
531%attr(755,root,root) %{_prefix}/lib/mono/2.0/monop.exe
532%attr(755,root,root) %{_prefix}/lib/mono/2.0/nunit-console.exe
533%{_prefix}/lib/mono/2.0/nunit-console.exe.config
534%attr(755,root,root) %{_prefix}/lib/mono/2.0/resgen.exe
e6c59841 535%attr(755,root,root) %{_prefix}/lib/mono/2.0/sqlsharp.exe
5114c445
JB
536%attr(755,root,root) %{_prefix}/lib/mono/2.0/wsdl.exe
537%attr(755,root,root) %{_prefix}/lib/mono/2.0/xbuild.exe
538%{_prefix}/lib/mono/2.0/xbuild.rsp
4a893061 539%{_prefix}/lib/mono/2.0/MSBuild
5114c445
JB
540%{_prefix}/lib/mono/2.0/Microsoft.Build.xsd
541%{_prefix}/lib/mono/2.0/Microsoft.CSharp.targets
542%{_prefix}/lib/mono/2.0/Microsoft.Common.targets
543%{_prefix}/lib/mono/2.0/Microsoft.VisualBasic.targets
544%{_prefix}/lib/mono/2.0/Microsoft.Common.tasks
545%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
546%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
4a893061 547%{_datadir}/%{name}-1.0
5114c445
JB
548%{_pkgconfigdir}/cecil.pc
549%{_pkgconfigdir}/dotnet.pc
7b0dd1f7 550%{_pkgconfigdir}/dotnet35.pc
5114c445
JB
551%{_pkgconfigdir}/mono-cairo.pc
552%{_pkgconfigdir}/mono-nunit.pc
553%if %{with mint}
554%{_pkgconfigdir}/mint.pc
555%else
556%{_pkgconfigdir}/mono.pc
557%endif
7b0dd1f7 558%{_pkgconfigdir}/smcs.pc
4a893061 559%{_includedir}/%{name}-1.0
ff3439a4 560%{_mandir}/man1/al.1*
c8f3b110 561%{_mandir}/man1/cilc.1*
994ec6f9 562%{_mandir}/man1/disco.1*
563%{_mandir}/man1/dtd2xsd.1*
e0aee78b 564%{_mandir}/man1/genxs.1*
994ec6f9 565%{_mandir}/man1/macpack.1*
2affc12a 566%{_mandir}/man1/monodis.1*
613285b2 567%{_mandir}/man1/monolinker.1*
994ec6f9 568%{_mandir}/man1/monop.1*
e9945d9e 569%{_mandir}/man1/mono-cil-strip.1*
994ec6f9 570%{_mandir}/man1/mono-shlib-cop.1*
2affc12a 571%{_mandir}/man1/monostyle.1*
613285b2 572%{_mandir}/man1/mono-xmltool.1*
994ec6f9 573%{_mandir}/man1/oldmono.1*
5114c445 574%{_mandir}/man1/permview.1*
994ec6f9 575%{_mandir}/man1/prj2make.1*
613285b2 576%{_mandir}/man1/resgen.1*
994ec6f9 577%{_mandir}/man1/soapsuds.1*
18ff84b2 578%{_mandir}/man1/sqlsharp.1*
ff112d9b 579%{_mandir}/man1/wsdl.1*
a66172db 580%{_mandir}/man1/xsd.1*
18ff84b2 581
b6aa60a1
JB
582%files debug
583%defattr(644,root,root,755)
584%{_prefix}/lib/mono/1.0/*.mdb
585%{_prefix}/lib/mono/2.0/*.mdb
f3b0e346 586%{_prefix}/lib/mono/2.1/*.mdb
b6aa60a1
JB
587%{_prefix}/lib/mono/gac/*/*/*.mdb
588
18ff84b2 589%files csharp
609883c4 590%defattr(644,root,root,755)
e6c59841 591%attr(755,root,root) %{_bindir}/csharp
a66172db 592%attr(755,root,root) %{_bindir}/mcs
7b0dd1f7 593%attr(755,root,root) %{_bindir}/mcs1
a66172db 594%attr(755,root,root) %{_bindir}/gmcs
5114c445
JB
595%attr(755,root,root) %{_prefix}/lib/mono/1.0/mcs.exe
596%{_prefix}/lib/mono/1.0/mcs.exe.config
597%attr(755,root,root) %{_prefix}/lib/mono/2.0/gmcs.exe
598%{_prefix}/lib/mono/2.0/gmcs.exe.config
e6c59841 599%attr(755,root,root) %{_prefix}/lib/mono/2.0/csharp.exe
18ff84b2 600%{_mandir}/man1/mcs.1*
e6c59841 601%{_mandir}/man1/csharp.1*
18ff84b2 602
18ff84b2 603%files ilasm
609883c4 604%defattr(644,root,root,755)
5114c445 605%attr(755,root,root) %{_bindir}/ilasm
7b0dd1f7 606%attr(755,root,root) %{_bindir}/ilasm1
5114c445
JB
607%attr(755,root,root) %{_bindir}/ilasm2
608%attr(755,root,root) %{_prefix}/lib/mono/1.0/ilasm.exe
609%attr(755,root,root) %{_prefix}/lib/mono/2.0/ilasm.exe
c8f3b110 610%{_mandir}/man1/ilasm.1*
8aa3dace 611
e9945d9e 612%files monodoc
613%defattr(644,root,root,755)
614%attr(755,root,root) %{_bindir}/mdassembler
615%attr(755,root,root) %{_bindir}/mdoc*
616%attr(755,root,root) %{_bindir}/mod
617%attr(755,root,root) %{_bindir}/monodocer
618%attr(755,root,root) %{_bindir}/monodocs2html
619%attr(755,root,root) %{_bindir}/monodocs2slashdoc
620%attr(755,root,root) %{_bindir}/mdvalidater
7bad922f 621%attr(755,root,root) %{_prefix}/lib/mono/1.0/mod.exe
622%attr(755,root,root) %{_prefix}/lib/mono/2.0/mdoc.exe
e9945d9e 623%{_prefix}/lib/mono/gac/monodoc
7bad922f 624%dir %{_prefix}/lib/mono/monodoc
625%{_prefix}/lib/monodoc/*
e9945d9e 626%{_pkgconfigdir}/monodoc.pc
627%{_mandir}/man1/mdassembler.1*
628%{_mandir}/man1/mdoc*.1*
629%{_mandir}/man1/monodocer.1*
630%{_mandir}/man1/monodocs2html.1*
631%{_mandir}/man1/mdvalidater.1*
632%{_mandir}/man5/mdoc.5*
633
4d9455d0 634%if %{with static_libs}
8aa3dace 635%files static
636%defattr(644,root,root,755)
5114c445
JB
637%if %{with mint}
638%{_libdir}/libmint.a
639%else
640%{_libdir}/libmono.a
641%{_libdir}/libmono-profiler-aot.a
642%{_libdir}/libmono-profiler-cov.a
7b0dd1f7 643%{_libdir}/libmono-profiler-logging.a
5114c445 644%endif
4d9455d0 645%endif
This page took 0.200109 seconds and 4 git commands to generate.