]> git.pld-linux.org Git - packages/mono.git/blame - mono.spec
- exclude monodoc gac in mono- package
[packages/mono.git] / mono.spec
CommitLineData
39176ea5 1#
fef1a4c5 2# NOTE: Makefiles are broken, build could stop long time after first fatal error
245657c9
MM
3#
4# Conditional build:
fef1a4c5 5%bcond_without tls # don't use TLS (which requires recent 2.4.x or 2.6 kernel)
4d9455d0 6%bcond_without static_libs # don't build static libraries
8cabdc4d 7%bcond_with bootstrap # don't require mono-devel to find req/prov
75873ca6 8%bcond_with mint # build mint instead of mono VM (JIT) [broken]
245657c9 9#
75873ca6
JB
10%ifnarch %{ix86} %{x8664} alpha arm ia64 ppc s390 s390x sparc sparcv9 sparc64
11# JIT not supported on hppa
a465d985 12%define with_mint 1
f1c5438d 13%endif
5114c445 14%define glib_ver 1:2.4
8cabdc4d 15#
728c2265 16Summary: Common Language Infrastructure implementation
d1081961 17Summary(pl.UTF-8): Implementacja Common Language Infrastructure
728c2265 18Name: mono
ca59b162 19Version: 2.4
e6c59841 20Release: 0.9
5114c445 21License: LGPL (VM), GPL (C# compilers), MIT X11 with GPL additions (classes, tools)
728c2265 22Group: Development/Languages
0f6bc6e4
JB
23# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
24Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
ca59b162 25# Source0-md5: da2bf1c0aba2958d26c5e8a9a49fd9d1
ddb02eae
JB
26Patch0: %{name}-alpha-float.patch
27Patch1: %{name}-mint.patch
28Patch2: %{name}-sonames.patch
3cdc32b9
JB
29Patch3: %{name}-awk.patch
30Patch4: %{name}-console-no-utf8-bom.patch
5114c445 31Patch5: %{name}-pc.patch
0f6bc6e4 32Patch6: %{name}-ARG_MAX.patch
68174c6e 33URL: http://www.mono-project.com/
39176ea5 34%if %(test -r /dev/random; echo $?)
96185d3a
JB
35BuildRequires: ACCESSIBLE_/dev/random
36%endif
8aa3dace 37BuildRequires: autoconf
38BuildRequires: automake
3c4b0944 39BuildRequires: bison
5114c445 40BuildRequires: glib2-devel >= %{glib_ver}
f7c57864 41BuildRequires: libtool
609d5e15 42%{!?with_bootstrap:BuildRequires: mono-devel >= 1.1.8.3-2}
f7c57864 43BuildRequires: pkgconfig
71415791 44BuildRequires: rpmbuild(macros) >= 1.213
2ca5ca77 45BuildRequires: rpmbuild(monoautodeps)
8c34c74b 46Suggests: binfmt-detector
5114c445 47# for System.Drawing
7b0dd1f7 48Suggests: libgdiplus >= 2.0
e19321c3 49ExclusiveArch: %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
1de8200d
JB
50# plain i386 is not supported; mono uses cmpxchg/xadd which require i486
51ExcludeArch: i386
728c2265
AM
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
ad29385a 54%define _rpmlibdir /usr/lib/rpm
55
baf6636c 56# debugger doesn't work with stripped mono
57%define _noautostrip .*/mono
58
39176ea5 59%if %{without bootstrap}
d0023a38 60%define __mono_provides %{_rpmlibdir}/mono-find-provides
61%define __mono_requires %{_rpmlibdir}/mono-find-requires
62%endif
63
728c2265
AM
64%description
65The Common Language Infrastructure platform. Microsoft has created a
66new development platform. The highlights of this new development
67platform are:
86d7bbf3 68- A runtime environment that provides garbage collection, threading
728c2265 69 and a virtual machine specification (The Virtual Execution System,
8aa3dace 70 VES),
71- A comprehensive class library,
728c2265 72- A new language, C#. Very similar to Java, C# allows programmers to
8aa3dace 73 use all the features available on the .NET runtime,
728c2265
AM
74- A language specification that compilers can follow if they want to
75 generate classes and code that can interoperate with other programming
8aa3dace 76 languages (The Common Language Specification: CLS).
728c2265 77
39176ea5 78%{?with_tls:This version was built with TLS __thread.}
245657c9 79
a86cd9c8
JR
80%description -l pl.UTF-8
81Platforma CLI (Common Language Infrastructure). Microsoft stworzył
82nową platformę developerską. Zalety tej platformy to:
83- środowisko, które dostarcza garbage collector, wątki oraz
84 specyfikację maszyny wirtualnej (The Virtual Execution System, VES),
85- bibliotekę klas,
86- nowy język, C#. Bardzo podobny do Javy, C# pozwala programistom na
87 używanie wszystkich możliwości dostarczanych przez platformę .NET,
88- specyfikacja dla kompilatorów, które chcą generować kod
89 współpracujący z innymi językami programowania (The Common Language
8aa3dace 90 Specification: CLS).
91
a86cd9c8 92%{?with_tls:Ta wersja została zbudowana z TLS __thread.}
245657c9 93
8aa3dace 94%package devel
95Summary: Development resources for mono
d1081961 96Summary(pl.UTF-8): Zasoby programisty do mono
5114c445 97License: LGPL (VM), MIT X11 with GPL additions (classes, tools)
8aa3dace 98Group: Development/Libraries
76e7cb31 99Requires: %{name} = %{version}-%{release}
5114c445 100Requires: glib2-devel >= %{glib_ver}
8aa3dace 101
102%description devel
103Development resources for mono.
104
a86cd9c8 105%description devel -l pl.UTF-8
18ff84b2
MM
106Zasoby programisty dla mono.
107
5dab3216 108%package debug
109Summary: Mono libraries debugging resources
d1081961 110Summary(pl.UTF-8): Pliki umożliwiające debugowanie bibliotek mono
5dab3216 111Group: Development/Libraries
112Requires: %{name} = %{version}-%{release}
113
114%description debug
115Mono libraries debugging resources.
116
a86cd9c8
JR
117%description debug -l pl.UTF-8
118Pliki umożliwiające debugowanie bibliotek mono.
5dab3216 119
18ff84b2
MM
120%package csharp
121Summary: C# compiler for mono
d1081961 122Summary(pl.UTF-8): Kompilator C# dla mono
5114c445 123License: GPL
18ff84b2 124Group: Development/Languages
76e7cb31 125Requires: %{name}-devel = %{version}-%{release}
18ff84b2
MM
126
127%description csharp
128C# compiler for mono.
129
a86cd9c8 130%description csharp -l pl.UTF-8
18ff84b2
MM
131Kompilator C# dla mono.
132
133%package ilasm
134Summary: ILasm compiler for mono
d1081961 135Summary(pl.UTF-8): Kompilator ILasm dla mono
5114c445
JB
136# implied
137License: MIT X11
18ff84b2 138Group: Development/Languages
76e7cb31 139Requires: %{name}-devel = %{version}-%{release}
6ec58c77 140Provides: ilasm
141Obsoletes: pnet-compiler-ilasm
18ff84b2
MM
142
143%description ilasm
144ILasm compiler for mono.
145
a86cd9c8 146%description ilasm -l pl.UTF-8
18ff84b2 147Kompilator ILasm dla mono.
71c7a580 148
245657c9
MM
149%package jscript
150Summary: jscript compiler for mono
d1081961 151Summary(pl.UTF-8): Kompilator jscript dla mono
5114c445 152License: MIT X11
245657c9
MM
153Group: Development/Languages
154Requires: %{name}-devel = %{version}-%{release}
155
156%description jscript
157jscript compiler for mono.
158
a86cd9c8 159%description jscript -l pl.UTF-8
245657c9
MM
160Kompilator jscript dla mono.
161
8aa3dace 162%package static
163Summary: Static mono library
d1081961 164Summary(pl.UTF-8): Statyczna biblioteka mono
5114c445 165License: LGPL
8aa3dace 166Group: Development/Libraries
76e7cb31 167Requires: %{name}-devel = %{version}-%{release}
8aa3dace 168
169%description static
170Static mono library.
171
a86cd9c8 172%description static -l pl.UTF-8
71c7a580
JB
173Statyczna biblioteka mono.
174
ea0e88d4
MM
175%package jay
176Summary: Yacc-like parser generator for Java and C#
d1081961 177Summary(pl.UTF-8): Podobny do Yacca generator parserów dla Javy i C#
5114c445 178License: BSD
ea0e88d4
MM
179Group: Development/Tools
180
181%description jay
182Yacc-like parser generator for Java and C#.
183
a86cd9c8
JR
184%description jay -l pl.UTF-8
185Podobny do Yacca generator parserów dla Javy i C#.
ea0e88d4 186
f327d485
MM
187%package compat-links
188Summary: Mono compatibility links
d1081961 189Summary(pl.UTF-8): Dowiązania dla kompatybilności
5114c445
JB
190# resgen license
191License: MIT X11
f327d485
MM
192Group: Development/Languages
193Requires: %{name}-devel = %{version}-%{release}
194
195%description compat-links
196This package contains links to binaries with names used in .NET and
197dotGNU.
198
a86cd9c8
JR
199%description compat-links -l pl.UTF-8
200Pakiet ten zawiera dowiązania do programów o nazwach używanych w .NET
f327d485
MM
201oraz dotGNU.
202
728c2265 203%prep
245657c9 204%setup -q
ddb02eae 205%patch0 -p1
24b388af 206%patch1 -p1
b3bdc9af 207%patch2 -p1
3cdc32b9 208%patch3 -p1
4a893061 209%patch4 -p1
ca59b162 210#%patch5 -p1
0f6bc6e4 211%patch6 -p1
394cba3f 212
5114c445
JB
213# for jay
214cat >>mcs/build/config-default.make <<EOF
215CC = %{__cc}
216CFLAGS = %{rpmcflags}
217EOF
218
728c2265 219%build
7f02b7bf
JB
220cp -f /usr/share/automake/config.sub .
221cp -f /usr/share/automake/config.sub libgc
18ff84b2
MM
222%{__libtoolize}
223%{__aclocal}
245657c9 224%{__autoheader}
18ff84b2
MM
225%{__autoconf}
226%{__automake}
245657c9
MM
227cd libgc
228%{__libtoolize}
229%{__aclocal}
230%{__autoconf}
231%{__automake}
232cd ..
233
5114c445
JB
234# -DUSE_COMPILER_TLS is passed to libgc by main configure, but our
235# CPPFLAGS override that CPPFLAGS
236CPPFLAGS="-DUSE_LIBC_PRIVATE_SYMBOLS -DUSE_COMPILER_TLS"
0eeed8fb 237%configure \
f1c5438d 238 %{!?with_static_libs:--disable-static} \
91164168 239 --enable-fast-install \
f1c5438d 240 --with-gc=included \
245657c9 241 --with-icu=no \
f1c5438d
JB
242 --with-interp=%{?with_mint:yes}%{!?with_mint:no} \
243 --with-jit=%{?with_mint:no}%{!?with_mint:yes} \
244 --with-preview=yes \
fef1a4c5 245 --with-tls=%{?with_tls:__thread}%{!?with_tls:pthread}
0eeed8fb 246
a317f685
JB
247# mint uses heap to make trampolines, which need to be executable
248# there is mprotect(...,PROT_EXEC) for ppc/s390, but not used
249# (ifdef NEED_MPROTECT, which is never defined)
250# in fact the flag should be "-Wl,-z,execheap" for libmint, but:
251# -z execheap doesn't seem to do anything currently
252# -z execstack for library makes only stack executable, but not heap
24b469a9 253%{__make} -j1 \
a317f685 254 mint_LDFLAGS="-Wl,-z,execheap -Wl,-z,execstack"
728c2265
AM
255
256%install
257rm -rf $RPM_BUILD_ROOT
ad29385a 258install -d $RPM_BUILD_ROOT%{_rpmlibdir}
728c2265 259
24b469a9 260%{__make} -j1 install \
866e5301 261 DESTDIR=$RPM_BUILD_ROOT
b11f008f 262
65a9c4dc 263strip --strip-debug $RPM_BUILD_ROOT%{_bindir}/mono
264
ea0e88d4 265rm -f $RPM_BUILD_ROOT%{_datadir}/jay/[A-Z]*
728c2265 266
18ff84b2
MM
267# this way we can run rpmbuild -bi several times, and directories
268# have more meaningful name.
269rm -rf pld-doc
e6c59841 270install -d pld-doc/{webpage,notes}
5385129f 271cp -a web/* pld-doc/webpage
03ad8b19 272cp -a docs/* pld-doc/notes
18ff84b2 273rm -f pld-doc/*/Makefile*
728c2265 274
245657c9
MM
275rm -rf $RPM_BUILD_ROOT%{_datadir}/libgc-mono
276
5114c445
JB
277mv -f $RPM_BUILD_ROOT%{_bindir}/mono-find-* $RPM_BUILD_ROOT%{_rpmlibdir}
278
279# loadable modules
280rm $RPM_BUILD_ROOT%{_libdir}/lib{MonoPosixHelper,MonoSupportW,ikvm-native}.{la,a}
ad29385a 281
728c2265
AM
282%clean
283rm -rf $RPM_BUILD_ROOT
284
71c7a580
JB
285%post -p /sbin/ldconfig
286%postun -p /sbin/ldconfig
287
728c2265
AM
288%files
289%defattr(644,root,root,755)
4ffe85ea 290%doc AUTHORS ChangeLog NEWS README pld-doc/*
f1c5438d 291%if %{with mint}
245657c9 292%attr(755,root,root) %{_bindir}/mint
f1c5438d
JB
293%else
294%attr(755,root,root) %{_bindir}/mono
48941467 295%endif
840f8203 296%attr(755,root,root) %{_bindir}/caspol
5114c445
JB
297%attr(755,root,root) %{_bindir}/cert2spc
298%attr(755,root,root) %{_bindir}/certmgr
299%attr(755,root,root) %{_bindir}/chktrust
48cd6fab 300%attr(755,root,root) %{_bindir}/dtd2rng
e6c59841 301%attr(755,root,root) %{_bindir}/gacutil1
5114c445 302%attr(755,root,root) %{_bindir}/gacutil
7b0dd1f7 303%attr(755,root,root) %{_bindir}/gacutil2
4f35821b 304%attr(755,root,root) %{_bindir}/httpcfg
305%attr(755,root,root) %{_bindir}/installvst
5114c445
JB
306%attr(755,root,root) %{_bindir}/makecert
307%attr(755,root,root) %{_bindir}/mconfig
308%attr(755,root,root) %{_bindir}/mkbundle
7b0dd1f7 309%attr(755,root,root) %{_bindir}/mkbundle1
5114c445 310%attr(755,root,root) %{_bindir}/mkbundle2
840f8203 311%attr(755,root,root) %{_bindir}/mono-service
48cd6fab 312%attr(755,root,root) %{_bindir}/mono-service2
f3b0e346 313%attr(755,root,root) %{_bindir}/mono-test-install
48cd6fab 314%attr(755,root,root) %{_bindir}/mono-xmltool
840f8203 315%attr(755,root,root) %{_bindir}/mozroots
5114c445
JB
316%attr(755,root,root) %{_bindir}/secutil
317%attr(755,root,root) %{_bindir}/setreg
8ef557a4 318%attr(755,root,root) %{_bindir}/sgen
5114c445
JB
319%attr(755,root,root) %{_bindir}/signcode
320%attr(755,root,root) %{_bindir}/sn
321%if %{with mint}
322%attr(755,root,root) %{_libdir}/libmint.so.*.*.*
323%attr(755,root,root) %ghost %{_libdir}/libmint.so.0
324%else
325%attr(755,root,root) %{_libdir}/libmono.so.*.*.*
326%attr(755,root,root) %ghost %{_libdir}/libmono.so.0
327%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so.*.*.*
328%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-aot.so.0
329%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so.*.*.*
330%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-cov.so.0
7b0dd1f7 331%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so.*.*.*
332%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-logging.so.0
5114c445 333%endif
2c1ff86a 334%attr(755,root,root) %{_libdir}/libMonoPosixHelper.so
ff3439a4 335%attr(755,root,root) %{_libdir}/libMonoSupportW.so
2c1ff86a 336%attr(755,root,root) %{_libdir}/libikvm-native.so
f1c5438d
JB
337%dir %{_prefix}/lib/mono
338%dir %{_prefix}/lib/mono/1.0
5114c445
JB
339%{_prefix}/lib/mono/1.0/*.dll
340%attr(755,root,root) %{_prefix}/lib/mono/1.0/caspol.exe
341%attr(755,root,root) %{_prefix}/lib/mono/1.0/cert2spc.exe
342%attr(755,root,root) %{_prefix}/lib/mono/1.0/certmgr.exe
343%attr(755,root,root) %{_prefix}/lib/mono/1.0/chktrust.exe
344%attr(755,root,root) %{_prefix}/lib/mono/1.0/culevel.exe
345%attr(755,root,root) %{_prefix}/lib/mono/1.0/gacutil.exe
f3b0e346 346%attr(755,root,root) %{_prefix}/lib/mono/1.0/installutil.exe
5114c445
JB
347%attr(755,root,root) %{_prefix}/lib/mono/1.0/installvst.exe
348%attr(755,root,root) %{_prefix}/lib/mono/1.0/mkbundle.exe
349%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-service.exe
350%attr(755,root,root) %{_prefix}/lib/mono/1.0/mozroots.exe
351%attr(755,root,root) %{_prefix}/lib/mono/1.0/secutil.exe
352%attr(755,root,root) %{_prefix}/lib/mono/1.0/setreg.exe
353%attr(755,root,root) %{_prefix}/lib/mono/1.0/signcode.exe
354%attr(755,root,root) %{_prefix}/lib/mono/1.0/sn.exe
f1c5438d 355%dir %{_prefix}/lib/mono/2.0
5114c445 356%{_prefix}/lib/mono/2.0/*.dll
7b0dd1f7 357%attr(755,root,root) %{_prefix}/lib/mono/2.0/gacutil.exe
5114c445 358%attr(755,root,root) %{_prefix}/lib/mono/2.0/httpcfg.exe
f3b0e346 359%attr(755,root,root) %{_prefix}/lib/mono/2.0/installutil.exe
5114c445
JB
360%attr(755,root,root) %{_prefix}/lib/mono/2.0/mconfig.exe
361%attr(755,root,root) %{_prefix}/lib/mono/2.0/mkbundle.exe
362%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-service.exe
363%attr(755,root,root) %{_prefix}/lib/mono/2.0/sgen.exe
7b0dd1f7 364%attr(755,root,root) %{_prefix}/lib/mono/2.0/xsd.exe
f3b0e346 365%dir %{_prefix}/lib/mono/2.1
366%{_prefix}/lib/mono/2.1/*.dll
367%attr(755,root,root) %{_prefix}/lib/mono/2.1/smcs.exe
368%dir %{_prefix}/lib/mono/3.5
369%{_prefix}/lib/mono/3.5/*.dll
6d20487b 370%dir %{_prefix}/lib/mono/compat-1.0
5114c445 371%{_prefix}/lib/mono/compat-1.0/*.dll
6d20487b 372%dir %{_prefix}/lib/mono/compat-2.0
5114c445 373%{_prefix}/lib/mono/compat-2.0/*.dll
f1c5438d 374%{_prefix}/lib/mono/gac
5dab3216 375%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
5114c445
JB
376%{_mandir}/man1/cert2spc.1*
377%{_mandir}/man1/certmgr.1*
245657c9
MM
378%{_mandir}/man1/chktrust.1*
379%{_mandir}/man1/gacutil.1*
4a893061 380%{_mandir}/man1/httpcfg.1*
5385129f 381%{_mandir}/man1/makecert.1*
5114c445 382%{_mandir}/man1/mconfig.1*
245657c9
MM
383%{_mandir}/man1/mkbundle.1*
384%{_mandir}/man1/mint.1*
385%{_mandir}/man1/mono.1*
386%{_mandir}/man1/mono-service.1*
840f8203 387%{_mandir}/man1/mozroots.1*
5385129f 388%{_mandir}/man1/secutil.1*
5385129f 389%{_mandir}/man1/setreg.1*
8ef557a4 390%{_mandir}/man1/sgen.1*
245657c9
MM
391%{_mandir}/man1/signcode.1*
392%{_mandir}/man1/sn.1*
245657c9 393%{_mandir}/man5/mono-config.5*
fdd46781 394%dir %{_sysconfdir}/mono
f1c5438d 395%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/browscap.ini
f3b0e346 396%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/config
5114c445
JB
397%dir %{_sysconfdir}/mono/mconfig
398%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/mconfig/config.xml
245657c9 399%dir %{_sysconfdir}/mono/1.0
f1c5438d 400%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 401%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/machine.config
245657c9 402%dir %{_sysconfdir}/mono/2.0
f1c5438d 403%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 404%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/machine.config
405%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/settings.map
48cd6fab 406%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/web.config
7b0dd1f7 407%dir %{_sysconfdir}/mono/2.0/Browsers
408%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
8aa3dace 409
9f4cf2f1 410%exclude %{_prefix}/lib/mono/gac/Microsoft.JScript
411%exclude %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
412%exclude %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
504c4464 413%exclude %{_prefix}/lib/mono/gac/monodoc
9f4cf2f1 414
ea0e88d4
MM
415%files jay
416%defattr(644,root,root,755)
245657c9 417%doc mcs/jay/{ACKNOWLEDGEMENTS,ChangeLog,NEW_FEATURES,NOTES,README,README.jay}
ea0e88d4
MM
418%attr(755,root,root) %{_bindir}/jay
419%dir %{_datadir}/jay
420%{_datadir}/jay/skeleton*
421%{_mandir}/man1/jay.1*
422
245657c9
MM
423%files jscript
424%defattr(644,root,root,755)
425%attr(755,root,root) %{_bindir}/mjs
5114c445 426%attr(755,root,root) %{_prefix}/lib/mono/1.0/mjs.exe
9f4cf2f1 427%{_prefix}/lib/mono/gac/Microsoft.JScript
428%{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
429%{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
5dab3216 430%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
245657c9 431
f327d485
MM
432%files compat-links
433%defattr(644,root,root,755)
434%attr(755,root,root) %{_bindir}/resgen
7b0dd1f7 435%attr(755,root,root) %{_bindir}/resgen1
3d1af25b 436%attr(755,root,root) %{_bindir}/resgen2
f327d485 437
8aa3dace 438%files devel
439%defattr(644,root,root,755)
5114c445 440%attr(755,root,root) %{_bindir}/al
7b0dd1f7 441%attr(755,root,root) %{_bindir}/al1
5114c445
JB
442%attr(755,root,root) %{_bindir}/al2
443%attr(755,root,root) %{_bindir}/cilc
444%attr(755,root,root) %{_bindir}/disco
994ec6f9 445%attr(755,root,root) %{_bindir}/dtd2xsd
5114c445 446%attr(755,root,root) %{_bindir}/genxs
7b0dd1f7 447%attr(755,root,root) %{_bindir}/genxs1
994ec6f9 448%attr(755,root,root) %{_bindir}/macpack
39d58cda 449%attr(755,root,root) %{_bindir}/mono-api-info
e6c59841 450%attr(755,root,root) %{_bindir}/mono-cil-strip
245657c9 451%attr(755,root,root) %{_bindir}/monodis
2affc12a 452%attr(755,root,root) %{_bindir}/monograph
613285b2 453%attr(755,root,root) %{_bindir}/monolinker
5114c445 454%attr(755,root,root) %{_bindir}/monop
7b0dd1f7 455%attr(755,root,root) %{_bindir}/monop1
5114c445
JB
456%attr(755,root,root) %{_bindir}/monop2
457%attr(755,root,root) %{_bindir}/mono-shlib-cop
ff3439a4 458%attr(755,root,root) %{_bindir}/nunit-console
48cd6fab 459%attr(755,root,root) %{_bindir}/nunit-console2
18ff84b2 460%attr(755,root,root) %{_bindir}/pedump
994ec6f9 461%attr(755,root,root) %{_bindir}/permview
462%attr(755,root,root) %{_bindir}/prj2make
613285b2 463%attr(755,root,root) %{_bindir}/smcs
5114c445
JB
464%attr(755,root,root) %{_bindir}/soapsuds
465%attr(755,root,root) %{_bindir}/sqlsharp
466%attr(755,root,root) %{_bindir}/wsdl
7b0dd1f7 467%attr(755,root,root) %{_bindir}/wsdl1
5114c445 468%attr(755,root,root) %{_bindir}/wsdl2
4ffe85ea 469%attr(755,root,root) %{_bindir}/xbuild
5114c445 470%attr(755,root,root) %{_bindir}/xsd
7b0dd1f7 471%attr(755,root,root) %{_bindir}/xsd2
f1c5438d
JB
472%if %{with mint}
473%attr(755,root,root) %{_libdir}/libmint.so
5114c445 474%{_libdir}/libmint.la
f1c5438d 475%else
2c1ff86a 476%attr(755,root,root) %{_libdir}/libmono.so
5114c445 477%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so
2c1ff86a 478%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so
7b0dd1f7 479%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so
5114c445
JB
480%{_libdir}/libmono.la
481%{_libdir}/libmono-profiler-aot.la
482%{_libdir}/libmono-profiler-cov.la
7b0dd1f7 483%{_libdir}/libmono-profiler-logging.la
f1c5438d 484%endif
5114c445
JB
485%attr(755,root,root) %{_prefix}/lib/mono/1.0/al.exe
486%attr(755,root,root) %{_prefix}/lib/mono/1.0/browsercaps-updater.exe
487%attr(755,root,root) %{_prefix}/lib/mono/1.0/cilc.exe
488%attr(755,root,root) %{_prefix}/lib/mono/1.0/disco.exe
489%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2rng.exe
490%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2xsd.exe
491%attr(755,root,root) %{_prefix}/lib/mono/1.0/genxs.exe
492%attr(755,root,root) %{_prefix}/lib/mono/1.0/ictool.exe
493%attr(755,root,root) %{_prefix}/lib/mono/1.0/macpack.exe
494%attr(755,root,root) %{_prefix}/lib/mono/1.0/makecert.exe
e6c59841 495%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-cil-strip.exe
5114c445
JB
496%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-xmltool.exe
497%attr(755,root,root) %{_prefix}/lib/mono/1.0/monolinker.exe
498%attr(755,root,root) %{_prefix}/lib/mono/1.0/monop.exe
499%attr(755,root,root) %{_prefix}/lib/mono/1.0/nunit-console.exe
500%{_prefix}/lib/mono/1.0/nunit-console.exe.config
501%attr(755,root,root) %{_prefix}/lib/mono/1.0/permview.exe
502%attr(755,root,root) %{_prefix}/lib/mono/1.0/prj2make.exe
503%attr(755,root,root) %{_prefix}/lib/mono/1.0/resgen.exe
504%attr(755,root,root) %{_prefix}/lib/mono/1.0/soapsuds.exe
5114c445
JB
505%attr(755,root,root) %{_prefix}/lib/mono/1.0/wsdl.exe
506%attr(755,root,root) %{_prefix}/lib/mono/1.0/xsd.exe
507%attr(755,root,root) %{_prefix}/lib/mono/2.0/al.exe
508%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-api-info.exe
e6c59841 509%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-shlib-cop.exe
510%{_prefix}/lib/mono/2.0/mono-shlib-cop.exe.config
5114c445
JB
511%attr(755,root,root) %{_prefix}/lib/mono/2.0/monop.exe
512%attr(755,root,root) %{_prefix}/lib/mono/2.0/nunit-console.exe
513%{_prefix}/lib/mono/2.0/nunit-console.exe.config
514%attr(755,root,root) %{_prefix}/lib/mono/2.0/resgen.exe
e6c59841 515%attr(755,root,root) %{_prefix}/lib/mono/2.0/sqlsharp.exe
5114c445
JB
516%attr(755,root,root) %{_prefix}/lib/mono/2.0/wsdl.exe
517%attr(755,root,root) %{_prefix}/lib/mono/2.0/xbuild.exe
518%{_prefix}/lib/mono/2.0/xbuild.rsp
4a893061 519%{_prefix}/lib/mono/2.0/MSBuild
5114c445
JB
520%{_prefix}/lib/mono/2.0/Microsoft.Build.xsd
521%{_prefix}/lib/mono/2.0/Microsoft.CSharp.targets
522%{_prefix}/lib/mono/2.0/Microsoft.Common.targets
523%{_prefix}/lib/mono/2.0/Microsoft.VisualBasic.targets
524%{_prefix}/lib/mono/2.0/Microsoft.Common.tasks
525%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
526%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
4a893061 527%{_datadir}/%{name}-1.0
5114c445
JB
528%{_pkgconfigdir}/cecil.pc
529%{_pkgconfigdir}/dotnet.pc
7b0dd1f7 530%{_pkgconfigdir}/dotnet35.pc
5114c445
JB
531%{_pkgconfigdir}/mono-cairo.pc
532%{_pkgconfigdir}/mono-nunit.pc
533%if %{with mint}
534%{_pkgconfigdir}/mint.pc
535%else
536%{_pkgconfigdir}/mono.pc
537%endif
7b0dd1f7 538%{_pkgconfigdir}/smcs.pc
4a893061 539%{_includedir}/%{name}-1.0
ff3439a4 540%{_mandir}/man1/al.1*
c8f3b110 541%{_mandir}/man1/cilc.1*
994ec6f9 542%{_mandir}/man1/disco.1*
543%{_mandir}/man1/dtd2xsd.1*
e0aee78b 544%{_mandir}/man1/genxs.1*
994ec6f9 545%{_mandir}/man1/macpack.1*
2affc12a 546%{_mandir}/man1/monodis.1*
613285b2 547%{_mandir}/man1/monolinker.1*
994ec6f9 548%{_mandir}/man1/monop.1*
549%{_mandir}/man1/mono-shlib-cop.1*
2affc12a 550%{_mandir}/man1/monostyle.1*
613285b2 551%{_mandir}/man1/mono-xmltool.1*
994ec6f9 552%{_mandir}/man1/oldmono.1*
5114c445 553%{_mandir}/man1/permview.1*
994ec6f9 554%{_mandir}/man1/prj2make.1*
613285b2 555%{_mandir}/man1/resgen.1*
994ec6f9 556%{_mandir}/man1/soapsuds.1*
18ff84b2 557%{_mandir}/man1/sqlsharp.1*
ff112d9b 558%{_mandir}/man1/wsdl.1*
a66172db 559%{_mandir}/man1/xsd.1*
18ff84b2 560
b6aa60a1
JB
561%files debug
562%defattr(644,root,root,755)
563%{_prefix}/lib/mono/1.0/*.mdb
564%{_prefix}/lib/mono/2.0/*.mdb
f3b0e346 565%{_prefix}/lib/mono/2.1/*.mdb
b6aa60a1
JB
566%{_prefix}/lib/mono/gac/*/*/*.mdb
567
18ff84b2 568%files csharp
609883c4 569%defattr(644,root,root,755)
e6c59841 570%attr(755,root,root) %{_bindir}/csharp
a66172db 571%attr(755,root,root) %{_bindir}/mcs
7b0dd1f7 572%attr(755,root,root) %{_bindir}/mcs1
a66172db 573%attr(755,root,root) %{_bindir}/gmcs
5114c445
JB
574%attr(755,root,root) %{_prefix}/lib/mono/1.0/mcs.exe
575%{_prefix}/lib/mono/1.0/mcs.exe.config
576%attr(755,root,root) %{_prefix}/lib/mono/2.0/gmcs.exe
577%{_prefix}/lib/mono/2.0/gmcs.exe.config
e6c59841 578%attr(755,root,root) %{_prefix}/lib/mono/2.0/csharp.exe
18ff84b2 579%{_mandir}/man1/mcs.1*
e6c59841 580%{_mandir}/man1/csharp.1*
18ff84b2 581
18ff84b2 582%files ilasm
609883c4 583%defattr(644,root,root,755)
5114c445 584%attr(755,root,root) %{_bindir}/ilasm
7b0dd1f7 585%attr(755,root,root) %{_bindir}/ilasm1
5114c445
JB
586%attr(755,root,root) %{_bindir}/ilasm2
587%attr(755,root,root) %{_prefix}/lib/mono/1.0/ilasm.exe
588%attr(755,root,root) %{_prefix}/lib/mono/2.0/ilasm.exe
c8f3b110 589%{_mandir}/man1/ilasm.1*
8aa3dace 590
4d9455d0 591%if %{with static_libs}
8aa3dace 592%files static
593%defattr(644,root,root,755)
5114c445
JB
594%if %{with mint}
595%{_libdir}/libmint.a
596%else
597%{_libdir}/libmono.a
598%{_libdir}/libmono-profiler-aot.a
599%{_libdir}/libmono-profiler-cov.a
7b0dd1f7 600%{_libdir}/libmono-profiler-logging.a
5114c445 601%endif
4d9455d0 602%endif
This page took 0.162556 seconds and 4 git commands to generate.