]> git.pld-linux.org Git - packages/mono.git/blame - mono.spec
- package mono-api-* scripts in -devel
[packages/mono.git] / mono.spec
CommitLineData
39176ea5
ER
1# TODO
2# - sanitize .pc files paths:
3# $ head /usr/lib64/pkgconfig/mono.pc
4# prefix=${pcfiledir}/../..
5# exec_prefix=${pcfiledir}/../..
6# libdir=${prefix}/lib64
7# includedir=${prefix}/include/mono-1.0
8#
fef1a4c5 9# NOTE: Makefiles are broken, build could stop long time after first fatal error
245657c9
MM
10#
11# Conditional build:
fef1a4c5 12%bcond_without tls # don't use TLS (which requires recent 2.4.x or 2.6 kernel)
4d9455d0 13%bcond_without static_libs # don't build static libraries
8cabdc4d 14%bcond_with bootstrap # don't require mono-devel to find req/prov
75873ca6 15%bcond_with mint # build mint instead of mono VM (JIT) [broken]
245657c9 16#
75873ca6
JB
17%ifnarch %{ix86} %{x8664} alpha arm ia64 ppc s390 s390x sparc sparcv9 sparc64
18# JIT not supported on hppa
a465d985 19%define with_mint 1
f1c5438d 20%endif
75873ca6 21%define _glibver 1:2.4
8cabdc4d 22#
728c2265 23Summary: Common Language Infrastructure implementation
d1081961 24Summary(pl.UTF-8): Implementacja Common Language Infrastructure
728c2265 25Name: mono
613285b2 26Version: 1.2.5
a49141f4 27Release: 1
245657c9 28License: GPL/LGPL/MIT
728c2265 29Group: Development/Languages
39176ea5 30# Source0Download: http://go-mono.com/sources-stable/
7d5baf64 31Source0: http://www.go-mono.com/sources/mono/%{name}-%{version}.tar.bz2
32# Source0-md5: 03a6d15fbf447a7807cc402dc8f64036
ddb02eae
JB
33Patch0: %{name}-alpha-float.patch
34Patch1: %{name}-mint.patch
35Patch2: %{name}-sonames.patch
3cdc32b9
JB
36Patch3: %{name}-awk.patch
37Patch4: %{name}-console-no-utf8-bom.patch
38Patch5: %{name}-g_thread_init.patch
68174c6e 39URL: http://www.mono-project.com/
39176ea5 40%if %(test -r /dev/random; echo $?)
96185d3a
JB
41BuildRequires: ACCESSIBLE_/dev/random
42%endif
8aa3dace 43BuildRequires: autoconf
44BuildRequires: automake
3c4b0944 45BuildRequires: bison
2c1ff86a 46BuildRequires: glib2-devel >= %{_glibver}
f7c57864 47BuildRequires: libtool
609d5e15 48%{!?with_bootstrap:BuildRequires: mono-devel >= 1.1.8.3-2}
f7c57864 49BuildRequires: pkgconfig
71415791 50BuildRequires: rpmbuild(macros) >= 1.213
2ca5ca77 51BuildRequires: rpmbuild(monoautodeps)
446b74e3 52Requires: binfmt-detector
4a893061 53Requires: libgdiplus >= 1.2.3
5ba8acd1 54ExclusiveArch: %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9 sparc64
1de8200d
JB
55# plain i386 is not supported; mono uses cmpxchg/xadd which require i486
56ExcludeArch: i386
728c2265
AM
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
ad29385a 59%define _rpmlibdir /usr/lib/rpm
60
baf6636c 61# debugger doesn't work with stripped mono
62%define _noautostrip .*/mono
63
39176ea5 64%if %{without bootstrap}
d0023a38 65%define __mono_provides %{_rpmlibdir}/mono-find-provides
66%define __mono_requires %{_rpmlibdir}/mono-find-requires
67%endif
68
728c2265
AM
69%description
70The Common Language Infrastructure platform. Microsoft has created a
71new development platform. The highlights of this new development
72platform are:
86d7bbf3 73- A runtime environment that provides garbage collection, threading
728c2265 74 and a virtual machine specification (The Virtual Execution System,
8aa3dace 75 VES),
76- A comprehensive class library,
728c2265 77- A new language, C#. Very similar to Java, C# allows programmers to
8aa3dace 78 use all the features available on the .NET runtime,
728c2265
AM
79- A language specification that compilers can follow if they want to
80 generate classes and code that can interoperate with other programming
8aa3dace 81 languages (The Common Language Specification: CLS).
728c2265 82
39176ea5 83%{?with_tls:This version was built with TLS __thread.}
245657c9 84
a86cd9c8
JR
85%description -l pl.UTF-8
86Platforma CLI (Common Language Infrastructure). Microsoft stworzył
87nową platformę developerską. Zalety tej platformy to:
88- środowisko, które dostarcza garbage collector, wątki oraz
89 specyfikację maszyny wirtualnej (The Virtual Execution System, VES),
90- bibliotekę klas,
91- nowy język, C#. Bardzo podobny do Javy, C# pozwala programistom na
92 używanie wszystkich możliwości dostarczanych przez platformę .NET,
93- specyfikacja dla kompilatorów, które chcą generować kod
94 współpracujący z innymi językami programowania (The Common Language
8aa3dace 95 Specification: CLS).
96
a86cd9c8 97%{?with_tls:Ta wersja została zbudowana z TLS __thread.}
245657c9 98
8aa3dace 99%package devel
100Summary: Development resources for mono
d1081961 101Summary(pl.UTF-8): Zasoby programisty do mono
8aa3dace 102Group: Development/Libraries
76e7cb31 103Requires: %{name} = %{version}-%{release}
2c1ff86a 104Requires: glib2-devel >= %{_glibver}
8aa3dace 105
106%description devel
107Development resources for mono.
108
a86cd9c8 109%description devel -l pl.UTF-8
18ff84b2
MM
110Zasoby programisty dla mono.
111
5dab3216 112%package debug
113Summary: Mono libraries debugging resources
d1081961 114Summary(pl.UTF-8): Pliki umożliwiające debugowanie bibliotek mono
5dab3216 115Group: Development/Libraries
116Requires: %{name} = %{version}-%{release}
117
118%description debug
119Mono libraries debugging resources.
120
a86cd9c8
JR
121%description debug -l pl.UTF-8
122Pliki umożliwiające debugowanie bibliotek mono.
5dab3216 123
18ff84b2
MM
124%package csharp
125Summary: C# compiler for mono
d1081961 126Summary(pl.UTF-8): Kompilator C# dla mono
18ff84b2 127Group: Development/Languages
76e7cb31 128Requires: %{name}-devel = %{version}-%{release}
18ff84b2
MM
129
130%description csharp
131C# compiler for mono.
132
a86cd9c8 133%description csharp -l pl.UTF-8
18ff84b2
MM
134Kompilator C# dla mono.
135
136%package ilasm
137Summary: ILasm compiler for mono
d1081961 138Summary(pl.UTF-8): Kompilator ILasm dla mono
18ff84b2 139Group: Development/Languages
76e7cb31 140Requires: %{name}-devel = %{version}-%{release}
6ec58c77 141Provides: ilasm
142Obsoletes: pnet-compiler-ilasm
18ff84b2
MM
143
144%description ilasm
145ILasm compiler for mono.
146
a86cd9c8 147%description ilasm -l pl.UTF-8
18ff84b2 148Kompilator ILasm dla mono.
71c7a580 149
245657c9
MM
150%package jscript
151Summary: jscript compiler for mono
d1081961 152Summary(pl.UTF-8): Kompilator jscript dla mono
245657c9
MM
153Group: Development/Languages
154Requires: %{name}-devel = %{version}-%{release}
155
156%description jscript
157jscript compiler for mono.
158
a86cd9c8 159%description jscript -l pl.UTF-8
245657c9
MM
160Kompilator jscript dla mono.
161
8aa3dace 162%package static
163Summary: Static mono library
d1081961 164Summary(pl.UTF-8): Statyczna biblioteka mono
8aa3dace 165Group: Development/Libraries
76e7cb31 166Requires: %{name}-devel = %{version}-%{release}
8aa3dace 167
168%description static
169Static mono library.
170
a86cd9c8 171%description static -l pl.UTF-8
71c7a580
JB
172Statyczna biblioteka mono.
173
ea0e88d4
MM
174%package jay
175Summary: Yacc-like parser generator for Java and C#
d1081961 176Summary(pl.UTF-8): Podobny do Yacca generator parserów dla Javy i C#
ea0e88d4
MM
177Group: Development/Tools
178
179%description jay
180Yacc-like parser generator for Java and C#.
181
a86cd9c8
JR
182%description jay -l pl.UTF-8
183Podobny do Yacca generator parserów dla Javy i C#.
ea0e88d4 184
f327d485
MM
185%package compat-links
186Summary: Mono compatibility links
d1081961 187Summary(pl.UTF-8): Dowiązania dla kompatybilności
f327d485
MM
188Group: Development/Languages
189Requires: %{name}-devel = %{version}-%{release}
190
191%description compat-links
192This package contains links to binaries with names used in .NET and
193dotGNU.
194
a86cd9c8
JR
195%description compat-links -l pl.UTF-8
196Pakiet ten zawiera dowiązania do programów o nazwach używanych w .NET
f327d485
MM
197oraz dotGNU.
198
728c2265 199%prep
245657c9 200%setup -q
ddb02eae 201%patch0 -p1
24b388af 202%patch1 -p1
b3bdc9af 203%patch2 -p1
3cdc32b9 204%patch3 -p1
4a893061 205%patch4 -p1
f7c87ae9 206%patch5 -p1
394cba3f 207
728c2265 208%build
7f02b7bf
JB
209cp -f /usr/share/automake/config.sub .
210cp -f /usr/share/automake/config.sub libgc
18ff84b2
MM
211%{__libtoolize}
212%{__aclocal}
245657c9 213%{__autoheader}
18ff84b2
MM
214%{__autoconf}
215%{__automake}
245657c9
MM
216cd libgc
217%{__libtoolize}
218%{__aclocal}
219%{__autoconf}
220%{__automake}
221cd ..
222
cff23ab8 223CPPFLAGS="-DUSE_LIBC_PRIVATE_SYMBOLS"
0eeed8fb 224%configure \
f1c5438d 225 %{!?with_static_libs:--disable-static} \
91164168 226 --enable-fast-install \
f1c5438d 227 --with-gc=included \
245657c9 228 --with-icu=no \
f1c5438d
JB
229 --with-interp=%{?with_mint:yes}%{!?with_mint:no} \
230 --with-jit=%{?with_mint:no}%{!?with_mint:yes} \
231 --with-preview=yes \
fef1a4c5 232 --with-tls=%{?with_tls:__thread}%{!?with_tls:pthread}
0eeed8fb 233
a317f685
JB
234# mint uses heap to make trampolines, which need to be executable
235# there is mprotect(...,PROT_EXEC) for ppc/s390, but not used
236# (ifdef NEED_MPROTECT, which is never defined)
237# in fact the flag should be "-Wl,-z,execheap" for libmint, but:
238# -z execheap doesn't seem to do anything currently
239# -z execstack for library makes only stack executable, but not heap
24b469a9 240%{__make} -j1 \
a317f685 241 mint_LDFLAGS="-Wl,-z,execheap -Wl,-z,execstack"
728c2265
AM
242
243%install
244rm -rf $RPM_BUILD_ROOT
ad29385a 245install -d $RPM_BUILD_ROOT%{_rpmlibdir}
728c2265 246
24b469a9 247%{__make} -j1 install \
866e5301 248 DESTDIR=$RPM_BUILD_ROOT
b11f008f 249
65a9c4dc 250strip --strip-debug $RPM_BUILD_ROOT%{_bindir}/mono
251
ea0e88d4 252rm -f $RPM_BUILD_ROOT%{_datadir}/jay/[A-Z]*
728c2265 253
18ff84b2
MM
254# this way we can run rpmbuild -bi several times, and directories
255# have more meaningful name.
256rm -rf pld-doc
257mkdir -p pld-doc/{webpage,notes}
5385129f 258cp -a web/* pld-doc/webpage
03ad8b19 259cp -a docs/* pld-doc/notes
18ff84b2 260rm -f pld-doc/*/Makefile*
728c2265 261
245657c9
MM
262rm -rf $RPM_BUILD_ROOT%{_datadir}/libgc-mono
263
ad29385a 264mv -f $RPM_BUILD_ROOT%{_bindir}/mono-find* $RPM_BUILD_ROOT%{_rpmlibdir}
265
728c2265
AM
266%clean
267rm -rf $RPM_BUILD_ROOT
268
71c7a580
JB
269%post -p /sbin/ldconfig
270%postun -p /sbin/ldconfig
271
728c2265
AM
272%files
273%defattr(644,root,root,755)
4ffe85ea 274%doc AUTHORS ChangeLog NEWS README pld-doc/*
f1c5438d 275%if %{with mint}
245657c9 276%attr(755,root,root) %{_bindir}/mint
f1c5438d
JB
277%else
278%attr(755,root,root) %{_bindir}/mono
48941467 279%endif
840f8203 280%attr(755,root,root) %{_bindir}/caspol
245657c9 281%attr(755,root,root) %{_bindir}/cert*
26f2f2f5 282%attr(755,root,root) %{_bindir}/chktrust*
48cd6fab 283%attr(755,root,root) %{_bindir}/dtd2rng
245657c9 284%attr(755,root,root) %{_bindir}/gacutil*
4f35821b 285%attr(755,root,root) %{_bindir}/httpcfg
286%attr(755,root,root) %{_bindir}/installvst
5385129f 287%attr(755,root,root) %{_bindir}/makecert*
245657c9 288%attr(755,root,root) %{_bindir}/mkbundle*
840f8203 289%attr(755,root,root) %{_bindir}/mono-service
48cd6fab 290%attr(755,root,root) %{_bindir}/mono-service2
291%attr(755,root,root) %{_bindir}/mono-xmltool
840f8203 292%attr(755,root,root) %{_bindir}/mozroots
245657c9 293%attr(755,root,root) %{_bindir}/secutil*
5385129f 294%attr(755,root,root) %{_bindir}/setreg*
8ef557a4 295%attr(755,root,root) %{_bindir}/sgen
245657c9
MM
296%attr(755,root,root) %{_bindir}/signcode*
297%attr(755,root,root) %{_bindir}/sn*
0eeed8fb 298%attr(755,root,root) %{_libdir}/lib*.so.*.*
2c1ff86a 299%attr(755,root,root) %{_libdir}/libMonoPosixHelper.so
ff3439a4 300%attr(755,root,root) %{_libdir}/libMonoSupportW.so
2c1ff86a 301%attr(755,root,root) %{_libdir}/libikvm-native.so
f1c5438d
JB
302%dir %{_prefix}/lib/mono
303%dir %{_prefix}/lib/mono/1.0
304%dir %{_prefix}/lib/mono/2.0
6d20487b 305%dir %{_prefix}/lib/mono/compat-1.0
306%dir %{_prefix}/lib/mono/compat-2.0
f1c5438d
JB
307%attr(755,root,root) %{_prefix}/lib/mono/*.*/*.dll
308%attr(755,root,root) %{_prefix}/lib/mono/1.0/cert*
309%attr(755,root,root) %{_prefix}/lib/mono/1.0/chktrust*
4f35821b 310%attr(755,root,root) %{_prefix}/lib/mono/1.0/culevel*
f1c5438d 311%attr(755,root,root) %{_prefix}/lib/mono/1.0/gacutil*
4f35821b 312%attr(755,root,root) %{_prefix}/lib/mono/1.0/installvst*
f1c5438d 313%attr(755,root,root) %{_prefix}/lib/mono/1.0/mkbundle*
840f8203 314%attr(755,root,root) %{_prefix}/lib/mono/1.0/mozroots*
f1c5438d
JB
315%attr(755,root,root) %{_prefix}/lib/mono/1.0/secutil*
316%attr(755,root,root) %{_prefix}/lib/mono/1.0/setreg*
317%attr(755,root,root) %{_prefix}/lib/mono/1.0/signcode*
318%attr(755,root,root) %{_prefix}/lib/mono/1.0/sn*
319%attr(755,root,root) %{_prefix}/lib/mono/1.0/caspol*
320%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-service*
4f35821b 321%attr(755,root,root) %{_prefix}/lib/mono/2.0/httpcfg*
7e3aee8d 322%attr(755,root,root) %{_prefix}/lib/mono/2.0/mkbundle*
99f430c1 323%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-service*
8ef557a4 324%attr(755,root,root) %{_prefix}/lib/mono/2.0/sgen*
5dab3216 325%exclude %{_prefix}/lib/mono/1.0/*.mdb
f1c5438d 326%{_prefix}/lib/mono/gac
5dab3216 327%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
5385129f 328%{_mandir}/man1/cert*.1*
245657c9
MM
329%{_mandir}/man1/chktrust.1*
330%{_mandir}/man1/gacutil.1*
4a893061 331%{_mandir}/man1/httpcfg.1*
5385129f 332%{_mandir}/man1/makecert.1*
245657c9
MM
333%{_mandir}/man1/mkbundle.1*
334%{_mandir}/man1/mint.1*
335%{_mandir}/man1/mono.1*
336%{_mandir}/man1/mono-service.1*
840f8203 337%{_mandir}/man1/mozroots.1*
5385129f 338%{_mandir}/man1/secutil.1*
5385129f 339%{_mandir}/man1/setreg.1*
8ef557a4 340%{_mandir}/man1/sgen.1*
245657c9
MM
341%{_mandir}/man1/signcode.1*
342%{_mandir}/man1/sn.1*
343%{_mandir}/man1/permview.1*
344%{_mandir}/man5/mono-config.5*
fdd46781 345%dir %{_sysconfdir}/mono
f1c5438d
JB
346%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/config
347%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/browscap.ini
245657c9 348%dir %{_sysconfdir}/mono/1.0
f1c5438d
JB
349%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/machine.config
350%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
245657c9 351%dir %{_sysconfdir}/mono/2.0
f1c5438d
JB
352%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/machine.config
353%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
48cd6fab 354%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/web.config
8aa3dace 355
9f4cf2f1 356%exclude %{_prefix}/lib/mono/gac/Microsoft.JScript
357%exclude %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
358%exclude %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
359
ea0e88d4
MM
360%files jay
361%defattr(644,root,root,755)
245657c9 362%doc mcs/jay/{ACKNOWLEDGEMENTS,ChangeLog,NEW_FEATURES,NOTES,README,README.jay}
ea0e88d4
MM
363%attr(755,root,root) %{_bindir}/jay
364%dir %{_datadir}/jay
365%{_datadir}/jay/skeleton*
366%{_mandir}/man1/jay.1*
367
245657c9
MM
368%files jscript
369%defattr(644,root,root,755)
370%attr(755,root,root) %{_bindir}/mjs
f1c5438d 371%attr(755,root,root) %{_prefix}/lib/mono/1.0/mjs*
5dab3216 372%exclude %{_prefix}/lib/mono/1.0/*.mdb
9f4cf2f1 373%{_prefix}/lib/mono/gac/Microsoft.JScript
374%{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
375%{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
5dab3216 376%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
245657c9 377
f327d485
MM
378%files compat-links
379%defattr(644,root,root,755)
380%attr(755,root,root) %{_bindir}/resgen
3d1af25b 381%attr(755,root,root) %{_bindir}/resgen2
f327d485 382
8aa3dace 383%files devel
384%defattr(644,root,root,755)
245657c9
MM
385%attr(755,root,root) %{_bindir}/al*
386%attr(755,root,root) %{_bindir}/cilc*
387%attr(755,root,root) %{_bindir}/disco*
994ec6f9 388%attr(755,root,root) %{_bindir}/dtd2xsd
245657c9 389%attr(755,root,root) %{_bindir}/genxs*
994ec6f9 390%attr(755,root,root) %{_bindir}/macpack
39d58cda
JB
391%attr(755,root,root) %{_bindir}/mono-api-diff
392%attr(755,root,root) %{_bindir}/mono-api-info
393%attr(755,root,root) %{_bindir}/mono-api-info2
245657c9 394%attr(755,root,root) %{_bindir}/monodis
2affc12a 395%attr(755,root,root) %{_bindir}/monograph
613285b2 396%attr(755,root,root) %{_bindir}/monolinker
245657c9 397%attr(755,root,root) %{_bindir}/monop*
994ec6f9 398%attr(755,root,root) %{_bindir}/mono-shlib-cop*
ff3439a4 399%attr(755,root,root) %{_bindir}/nunit-console
48cd6fab 400%attr(755,root,root) %{_bindir}/nunit-console2
18ff84b2 401%attr(755,root,root) %{_bindir}/pedump
994ec6f9 402%attr(755,root,root) %{_bindir}/permview
403%attr(755,root,root) %{_bindir}/prj2make
613285b2 404%attr(755,root,root) %{_bindir}/smcs
ff112d9b 405%attr(755,root,root) %{_bindir}/soapsuds*
245657c9
MM
406%attr(755,root,root) %{_bindir}/sqlsharp*
407%attr(755,root,root) %{_bindir}/wsdl*
4ffe85ea 408%attr(755,root,root) %{_bindir}/xbuild
245657c9 409%attr(755,root,root) %{_bindir}/xsd*
f1c5438d
JB
410%if %{with mint}
411%attr(755,root,root) %{_libdir}/libmint.so
412%else
2c1ff86a
KK
413%attr(755,root,root) %{_libdir}/libmono.so
414%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so
f1c5438d 415%endif
a3e92bcf 416%{_libdir}/lib*.la
f1c5438d
JB
417%attr(755,root,root) %{_prefix}/lib/mono/1.0/al*
418%attr(755,root,root) %{_prefix}/lib/mono/1.0/browsercaps-updater*
419%attr(755,root,root) %{_prefix}/lib/mono/1.0/cilc*
420%attr(755,root,root) %{_prefix}/lib/mono/1.0/CorCompare*
421%attr(755,root,root) %{_prefix}/lib/mono/1.0/disco*
48cd6fab 422%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2rng*
f1c5438d
JB
423%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2xsd*
424%attr(755,root,root) %{_prefix}/lib/mono/1.0/genxs*
425%attr(755,root,root) %{_prefix}/lib/mono/1.0/ictool*
426%attr(755,root,root) %{_prefix}/lib/mono/1.0/macpack*
ff3439a4 427%attr(755,root,root) %{_prefix}/lib/mono/1.0/makecert*
f1c5438d 428%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-api-*
613285b2 429%attr(755,root,root) %{_prefix}/lib/mono/1.0/monolinker*
f1c5438d
JB
430%attr(755,root,root) %{_prefix}/lib/mono/1.0/monop*
431%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-shlib-cop*
48cd6fab 432%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-xmltool*
ff3439a4 433%attr(755,root,root) %{_prefix}/lib/mono/1.0/nunit-console*
f1c5438d
JB
434%attr(755,root,root) %{_prefix}/lib/mono/1.0/permview*
435%attr(755,root,root) %{_prefix}/lib/mono/1.0/prj2make*
436%attr(755,root,root) %{_prefix}/lib/mono/1.0/resgen*
437%attr(755,root,root) %{_prefix}/lib/mono/1.0/soapsuds*
438%attr(755,root,root) %{_prefix}/lib/mono/1.0/sqlsharp*
439%attr(755,root,root) %{_prefix}/lib/mono/1.0/wsdl*
440%attr(755,root,root) %{_prefix}/lib/mono/1.0/xsd*
4a893061 441%attr(755,root,root) %{_prefix}/lib/mono/2.0/al*
f1c5438d 442%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-api-info*
ff3439a4 443%attr(755,root,root) %{_prefix}/lib/mono/2.0/monop*
444%attr(755,root,root) %{_prefix}/lib/mono/2.0/nunit-console*
3d1af25b 445%attr(755,root,root) %{_prefix}/lib/mono/2.0/resgen*
f1c5438d 446%attr(755,root,root) %{_prefix}/lib/mono/2.0/wsdl*
4ffe85ea 447%attr(755,root,root) %{_prefix}/lib/mono/2.0/xbuild*
4a893061 448%{_prefix}/lib/mono/2.0/MSBuild
449%{_prefix}/lib/mono/2.0/*.xsd
450%{_prefix}/lib/mono/2.0/*.targets
451%{_prefix}/lib/mono/2.0/*.tasks
5dab3216 452%exclude %{_prefix}/lib/mono/1.0/*.mdb
453%exclude %{_prefix}/lib/mono/2.0/*.mdb
f1c5438d 454%attr(755,root,root) %{_rpmlibdir}/mono-find*
4a893061 455%{_datadir}/%{name}-1.0
0eeed8fb 456%{_pkgconfigdir}/*.pc
4a893061 457%{_includedir}/%{name}-1.0
ff3439a4 458%{_mandir}/man1/al.1*
c8f3b110 459%{_mandir}/man1/cilc.1*
994ec6f9 460%{_mandir}/man1/disco.1*
461%{_mandir}/man1/dtd2xsd.1*
e0aee78b 462%{_mandir}/man1/genxs.1*
994ec6f9 463%{_mandir}/man1/macpack.1*
2affc12a
MM
464%{_mandir}/man1/monoburg.1*
465%{_mandir}/man1/monodis.1*
613285b2 466%{_mandir}/man1/monolinker.1*
994ec6f9 467%{_mandir}/man1/monop.1*
468%{_mandir}/man1/mono-shlib-cop.1*
2affc12a 469%{_mandir}/man1/monostyle.1*
613285b2 470%{_mandir}/man1/mono-xmltool.1*
994ec6f9 471%{_mandir}/man1/oldmono.1*
472%{_mandir}/man1/prj2make.1*
613285b2 473%{_mandir}/man1/resgen.1*
994ec6f9 474%{_mandir}/man1/soapsuds.1*
18ff84b2 475%{_mandir}/man1/sqlsharp.1*
ff112d9b 476%{_mandir}/man1/wsdl.1*
a66172db 477%{_mandir}/man1/xsd.1*
18ff84b2 478
b6aa60a1
JB
479%files debug
480%defattr(644,root,root,755)
481%{_prefix}/lib/mono/1.0/*.mdb
482%{_prefix}/lib/mono/2.0/*.mdb
483%{_prefix}/lib/mono/gac/*/*/*.mdb
484
18ff84b2 485%files csharp
609883c4 486%defattr(644,root,root,755)
a66172db
MM
487%attr(755,root,root) %{_bindir}/mcs
488%attr(755,root,root) %{_bindir}/gmcs
f1c5438d
JB
489%attr(755,root,root) %{_prefix}/lib/mono/1.0/mcs.exe*
490%attr(755,root,root) %{_prefix}/lib/mono/2.0/gmcs.exe*
5dab3216 491%exclude %{_prefix}/lib/mono/1.0/*.mdb
492%exclude %{_prefix}/lib/mono/2.0/*.mdb
18ff84b2
MM
493%{_mandir}/man1/mcs.1*
494
18ff84b2 495%files ilasm
609883c4 496%defattr(644,root,root,755)
18ff84b2 497%attr(755,root,root) %{_bindir}/ilasm*
f1c5438d 498%attr(755,root,root) %{_prefix}/lib/mono/1.0/ilasm*
4ffe85ea 499%attr(755,root,root) %{_prefix}/lib/mono/2.0/ilasm*
5dab3216 500%exclude %{_prefix}/lib/mono/1.0/*.mdb
501%exclude %{_prefix}/lib/mono/2.0/*.mdb
c8f3b110 502%{_mandir}/man1/ilasm.1*
8aa3dace 503
4d9455d0 504%if %{with static_libs}
8aa3dace 505%files static
506%defattr(644,root,root,755)
507%{_libdir}/lib*.a
4d9455d0 508%endif
This page took 0.180197 seconds and 4 git commands to generate.