]> git.pld-linux.org Git - packages/mono.git/blame - mono.spec
- updated to 1.9.1
[packages/mono.git] / mono.spec
CommitLineData
39176ea5 1#
fef1a4c5 2# NOTE: Makefiles are broken, build could stop long time after first fatal error
245657c9
MM
3#
4# Conditional build:
fef1a4c5 5%bcond_without tls # don't use TLS (which requires recent 2.4.x or 2.6 kernel)
4d9455d0 6%bcond_without static_libs # don't build static libraries
8cabdc4d 7%bcond_with bootstrap # don't require mono-devel to find req/prov
75873ca6 8%bcond_with mint # build mint instead of mono VM (JIT) [broken]
245657c9 9#
75873ca6
JB
10%ifnarch %{ix86} %{x8664} alpha arm ia64 ppc s390 s390x sparc sparcv9 sparc64
11# JIT not supported on hppa
a465d985 12%define with_mint 1
f1c5438d 13%endif
5114c445 14%define glib_ver 1:2.4
8cabdc4d 15#
728c2265 16Summary: Common Language Infrastructure implementation
d1081961 17Summary(pl.UTF-8): Implementacja Common Language Infrastructure
728c2265 18Name: mono
0f6bc6e4 19Version: 1.9.1
5114c445
JB
20Release: 1
21License: LGPL (VM), GPL (C# compilers), MIT X11 with GPL additions (classes, tools)
728c2265 22Group: Development/Languages
0f6bc6e4
JB
23# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
24Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
25# Source0-md5: 6610c3b999d791553a9dc21059ca9d35
ddb02eae
JB
26Patch0: %{name}-alpha-float.patch
27Patch1: %{name}-mint.patch
28Patch2: %{name}-sonames.patch
3cdc32b9
JB
29Patch3: %{name}-awk.patch
30Patch4: %{name}-console-no-utf8-bom.patch
5114c445 31Patch5: %{name}-pc.patch
0f6bc6e4 32Patch6: %{name}-ARG_MAX.patch
68174c6e 33URL: http://www.mono-project.com/
39176ea5 34%if %(test -r /dev/random; echo $?)
96185d3a
JB
35BuildRequires: ACCESSIBLE_/dev/random
36%endif
8aa3dace 37BuildRequires: autoconf
38BuildRequires: automake
3c4b0944 39BuildRequires: bison
5114c445 40BuildRequires: glib2-devel >= %{glib_ver}
f7c57864 41BuildRequires: libtool
609d5e15 42%{!?with_bootstrap:BuildRequires: mono-devel >= 1.1.8.3-2}
f7c57864 43BuildRequires: pkgconfig
71415791 44BuildRequires: rpmbuild(macros) >= 1.213
2ca5ca77 45BuildRequires: rpmbuild(monoautodeps)
8c34c74b 46Suggests: binfmt-detector
5114c445
JB
47# for System.Drawing
48Suggests: libgdiplus >= 1.2.6
e19321c3 49ExclusiveArch: %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
1de8200d
JB
50# plain i386 is not supported; mono uses cmpxchg/xadd which require i486
51ExcludeArch: i386
728c2265
AM
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
ad29385a 54%define _rpmlibdir /usr/lib/rpm
55
baf6636c 56# debugger doesn't work with stripped mono
57%define _noautostrip .*/mono
58
39176ea5 59%if %{without bootstrap}
d0023a38 60%define __mono_provides %{_rpmlibdir}/mono-find-provides
61%define __mono_requires %{_rpmlibdir}/mono-find-requires
62%endif
63
728c2265
AM
64%description
65The Common Language Infrastructure platform. Microsoft has created a
66new development platform. The highlights of this new development
67platform are:
86d7bbf3 68- A runtime environment that provides garbage collection, threading
728c2265 69 and a virtual machine specification (The Virtual Execution System,
8aa3dace 70 VES),
71- A comprehensive class library,
728c2265 72- A new language, C#. Very similar to Java, C# allows programmers to
8aa3dace 73 use all the features available on the .NET runtime,
728c2265
AM
74- A language specification that compilers can follow if they want to
75 generate classes and code that can interoperate with other programming
8aa3dace 76 languages (The Common Language Specification: CLS).
728c2265 77
39176ea5 78%{?with_tls:This version was built with TLS __thread.}
245657c9 79
a86cd9c8
JR
80%description -l pl.UTF-8
81Platforma CLI (Common Language Infrastructure). Microsoft stworzył
82nową platformę developerską. Zalety tej platformy to:
83- środowisko, które dostarcza garbage collector, wątki oraz
84 specyfikację maszyny wirtualnej (The Virtual Execution System, VES),
85- bibliotekę klas,
86- nowy język, C#. Bardzo podobny do Javy, C# pozwala programistom na
87 używanie wszystkich możliwości dostarczanych przez platformę .NET,
88- specyfikacja dla kompilatorów, które chcą generować kod
89 współpracujący z innymi językami programowania (The Common Language
8aa3dace 90 Specification: CLS).
91
a86cd9c8 92%{?with_tls:Ta wersja została zbudowana z TLS __thread.}
245657c9 93
8aa3dace 94%package devel
95Summary: Development resources for mono
d1081961 96Summary(pl.UTF-8): Zasoby programisty do mono
5114c445 97License: LGPL (VM), MIT X11 with GPL additions (classes, tools)
8aa3dace 98Group: Development/Libraries
76e7cb31 99Requires: %{name} = %{version}-%{release}
5114c445 100Requires: glib2-devel >= %{glib_ver}
8aa3dace 101
102%description devel
103Development resources for mono.
104
a86cd9c8 105%description devel -l pl.UTF-8
18ff84b2
MM
106Zasoby programisty dla mono.
107
5dab3216 108%package debug
109Summary: Mono libraries debugging resources
d1081961 110Summary(pl.UTF-8): Pliki umożliwiające debugowanie bibliotek mono
5dab3216 111Group: Development/Libraries
112Requires: %{name} = %{version}-%{release}
113
114%description debug
115Mono libraries debugging resources.
116
a86cd9c8
JR
117%description debug -l pl.UTF-8
118Pliki umożliwiające debugowanie bibliotek mono.
5dab3216 119
18ff84b2
MM
120%package csharp
121Summary: C# compiler for mono
d1081961 122Summary(pl.UTF-8): Kompilator C# dla mono
5114c445 123License: GPL
18ff84b2 124Group: Development/Languages
76e7cb31 125Requires: %{name}-devel = %{version}-%{release}
18ff84b2
MM
126
127%description csharp
128C# compiler for mono.
129
a86cd9c8 130%description csharp -l pl.UTF-8
18ff84b2
MM
131Kompilator C# dla mono.
132
133%package ilasm
134Summary: ILasm compiler for mono
d1081961 135Summary(pl.UTF-8): Kompilator ILasm dla mono
5114c445
JB
136# implied
137License: MIT X11
18ff84b2 138Group: Development/Languages
76e7cb31 139Requires: %{name}-devel = %{version}-%{release}
6ec58c77 140Provides: ilasm
141Obsoletes: pnet-compiler-ilasm
18ff84b2
MM
142
143%description ilasm
144ILasm compiler for mono.
145
a86cd9c8 146%description ilasm -l pl.UTF-8
18ff84b2 147Kompilator ILasm dla mono.
71c7a580 148
245657c9
MM
149%package jscript
150Summary: jscript compiler for mono
d1081961 151Summary(pl.UTF-8): Kompilator jscript dla mono
5114c445 152License: MIT X11
245657c9
MM
153Group: Development/Languages
154Requires: %{name}-devel = %{version}-%{release}
155
156%description jscript
157jscript compiler for mono.
158
a86cd9c8 159%description jscript -l pl.UTF-8
245657c9
MM
160Kompilator jscript dla mono.
161
8aa3dace 162%package static
163Summary: Static mono library
d1081961 164Summary(pl.UTF-8): Statyczna biblioteka mono
5114c445 165License: LGPL
8aa3dace 166Group: Development/Libraries
76e7cb31 167Requires: %{name}-devel = %{version}-%{release}
8aa3dace 168
169%description static
170Static mono library.
171
a86cd9c8 172%description static -l pl.UTF-8
71c7a580
JB
173Statyczna biblioteka mono.
174
ea0e88d4
MM
175%package jay
176Summary: Yacc-like parser generator for Java and C#
d1081961 177Summary(pl.UTF-8): Podobny do Yacca generator parserów dla Javy i C#
5114c445 178License: BSD
ea0e88d4
MM
179Group: Development/Tools
180
181%description jay
182Yacc-like parser generator for Java and C#.
183
a86cd9c8
JR
184%description jay -l pl.UTF-8
185Podobny do Yacca generator parserów dla Javy i C#.
ea0e88d4 186
f327d485
MM
187%package compat-links
188Summary: Mono compatibility links
d1081961 189Summary(pl.UTF-8): Dowiązania dla kompatybilności
5114c445
JB
190# resgen license
191License: MIT X11
f327d485
MM
192Group: Development/Languages
193Requires: %{name}-devel = %{version}-%{release}
194
195%description compat-links
196This package contains links to binaries with names used in .NET and
197dotGNU.
198
a86cd9c8
JR
199%description compat-links -l pl.UTF-8
200Pakiet ten zawiera dowiązania do programów o nazwach używanych w .NET
f327d485
MM
201oraz dotGNU.
202
728c2265 203%prep
245657c9 204%setup -q
ddb02eae 205%patch0 -p1
24b388af 206%patch1 -p1
b3bdc9af 207%patch2 -p1
3cdc32b9 208%patch3 -p1
4a893061 209%patch4 -p1
f7c87ae9 210%patch5 -p1
0f6bc6e4 211%patch6 -p1
394cba3f 212
5114c445
JB
213# for jay
214cat >>mcs/build/config-default.make <<EOF
215CC = %{__cc}
216CFLAGS = %{rpmcflags}
217EOF
218
728c2265 219%build
7f02b7bf
JB
220cp -f /usr/share/automake/config.sub .
221cp -f /usr/share/automake/config.sub libgc
18ff84b2
MM
222%{__libtoolize}
223%{__aclocal}
245657c9 224%{__autoheader}
18ff84b2
MM
225%{__autoconf}
226%{__automake}
245657c9
MM
227cd libgc
228%{__libtoolize}
229%{__aclocal}
230%{__autoconf}
231%{__automake}
232cd ..
233
5114c445
JB
234# -DUSE_COMPILER_TLS is passed to libgc by main configure, but our
235# CPPFLAGS override that CPPFLAGS
236CPPFLAGS="-DUSE_LIBC_PRIVATE_SYMBOLS -DUSE_COMPILER_TLS"
0eeed8fb 237%configure \
f1c5438d 238 %{!?with_static_libs:--disable-static} \
91164168 239 --enable-fast-install \
f1c5438d 240 --with-gc=included \
245657c9 241 --with-icu=no \
f1c5438d
JB
242 --with-interp=%{?with_mint:yes}%{!?with_mint:no} \
243 --with-jit=%{?with_mint:no}%{!?with_mint:yes} \
244 --with-preview=yes \
fef1a4c5 245 --with-tls=%{?with_tls:__thread}%{!?with_tls:pthread}
0eeed8fb 246
a317f685
JB
247# mint uses heap to make trampolines, which need to be executable
248# there is mprotect(...,PROT_EXEC) for ppc/s390, but not used
249# (ifdef NEED_MPROTECT, which is never defined)
250# in fact the flag should be "-Wl,-z,execheap" for libmint, but:
251# -z execheap doesn't seem to do anything currently
252# -z execstack for library makes only stack executable, but not heap
24b469a9 253%{__make} -j1 \
a317f685 254 mint_LDFLAGS="-Wl,-z,execheap -Wl,-z,execstack"
728c2265
AM
255
256%install
257rm -rf $RPM_BUILD_ROOT
ad29385a 258install -d $RPM_BUILD_ROOT%{_rpmlibdir}
728c2265 259
24b469a9 260%{__make} -j1 install \
866e5301 261 DESTDIR=$RPM_BUILD_ROOT
b11f008f 262
65a9c4dc 263strip --strip-debug $RPM_BUILD_ROOT%{_bindir}/mono
264
ea0e88d4 265rm -f $RPM_BUILD_ROOT%{_datadir}/jay/[A-Z]*
728c2265 266
18ff84b2
MM
267# this way we can run rpmbuild -bi several times, and directories
268# have more meaningful name.
269rm -rf pld-doc
270mkdir -p pld-doc/{webpage,notes}
5385129f 271cp -a web/* pld-doc/webpage
03ad8b19 272cp -a docs/* pld-doc/notes
18ff84b2 273rm -f pld-doc/*/Makefile*
728c2265 274
245657c9
MM
275rm -rf $RPM_BUILD_ROOT%{_datadir}/libgc-mono
276
5114c445
JB
277mv -f $RPM_BUILD_ROOT%{_bindir}/mono-find-* $RPM_BUILD_ROOT%{_rpmlibdir}
278
279# loadable modules
280rm $RPM_BUILD_ROOT%{_libdir}/lib{MonoPosixHelper,MonoSupportW,ikvm-native}.{la,a}
ad29385a 281
728c2265
AM
282%clean
283rm -rf $RPM_BUILD_ROOT
284
71c7a580
JB
285%post -p /sbin/ldconfig
286%postun -p /sbin/ldconfig
287
728c2265
AM
288%files
289%defattr(644,root,root,755)
4ffe85ea 290%doc AUTHORS ChangeLog NEWS README pld-doc/*
f1c5438d 291%if %{with mint}
245657c9 292%attr(755,root,root) %{_bindir}/mint
f1c5438d
JB
293%else
294%attr(755,root,root) %{_bindir}/mono
48941467 295%endif
840f8203 296%attr(755,root,root) %{_bindir}/caspol
5114c445
JB
297%attr(755,root,root) %{_bindir}/cert2spc
298%attr(755,root,root) %{_bindir}/certmgr
299%attr(755,root,root) %{_bindir}/chktrust
48cd6fab 300%attr(755,root,root) %{_bindir}/dtd2rng
5114c445 301%attr(755,root,root) %{_bindir}/gacutil
4f35821b 302%attr(755,root,root) %{_bindir}/httpcfg
303%attr(755,root,root) %{_bindir}/installvst
5114c445
JB
304%attr(755,root,root) %{_bindir}/makecert
305%attr(755,root,root) %{_bindir}/mconfig
306%attr(755,root,root) %{_bindir}/mkbundle
307%attr(755,root,root) %{_bindir}/mkbundle2
840f8203 308%attr(755,root,root) %{_bindir}/mono-service
48cd6fab 309%attr(755,root,root) %{_bindir}/mono-service2
f3b0e346 310%attr(755,root,root) %{_bindir}/mono-test-install
48cd6fab 311%attr(755,root,root) %{_bindir}/mono-xmltool
840f8203 312%attr(755,root,root) %{_bindir}/mozroots
5114c445
JB
313%attr(755,root,root) %{_bindir}/secutil
314%attr(755,root,root) %{_bindir}/setreg
8ef557a4 315%attr(755,root,root) %{_bindir}/sgen
5114c445
JB
316%attr(755,root,root) %{_bindir}/signcode
317%attr(755,root,root) %{_bindir}/sn
318%if %{with mint}
319%attr(755,root,root) %{_libdir}/libmint.so.*.*.*
320%attr(755,root,root) %ghost %{_libdir}/libmint.so.0
321%else
322%attr(755,root,root) %{_libdir}/libmono.so.*.*.*
323%attr(755,root,root) %ghost %{_libdir}/libmono.so.0
324%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so.*.*.*
325%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-aot.so.0
326%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so.*.*.*
327%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-cov.so.0
328%endif
2c1ff86a 329%attr(755,root,root) %{_libdir}/libMonoPosixHelper.so
ff3439a4 330%attr(755,root,root) %{_libdir}/libMonoSupportW.so
2c1ff86a 331%attr(755,root,root) %{_libdir}/libikvm-native.so
f1c5438d
JB
332%dir %{_prefix}/lib/mono
333%dir %{_prefix}/lib/mono/1.0
5114c445
JB
334%{_prefix}/lib/mono/1.0/*.dll
335%attr(755,root,root) %{_prefix}/lib/mono/1.0/caspol.exe
336%attr(755,root,root) %{_prefix}/lib/mono/1.0/cert2spc.exe
337%attr(755,root,root) %{_prefix}/lib/mono/1.0/certmgr.exe
338%attr(755,root,root) %{_prefix}/lib/mono/1.0/chktrust.exe
339%attr(755,root,root) %{_prefix}/lib/mono/1.0/culevel.exe
340%attr(755,root,root) %{_prefix}/lib/mono/1.0/gacutil.exe
f3b0e346 341%attr(755,root,root) %{_prefix}/lib/mono/1.0/installutil.exe
5114c445
JB
342%attr(755,root,root) %{_prefix}/lib/mono/1.0/installvst.exe
343%attr(755,root,root) %{_prefix}/lib/mono/1.0/mkbundle.exe
344%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-service.exe
345%attr(755,root,root) %{_prefix}/lib/mono/1.0/mozroots.exe
346%attr(755,root,root) %{_prefix}/lib/mono/1.0/secutil.exe
347%attr(755,root,root) %{_prefix}/lib/mono/1.0/setreg.exe
348%attr(755,root,root) %{_prefix}/lib/mono/1.0/signcode.exe
349%attr(755,root,root) %{_prefix}/lib/mono/1.0/sn.exe
350%attr(755,root,root) %{_prefix}/lib/mono/1.0/transform.exe
f1c5438d 351%dir %{_prefix}/lib/mono/2.0
5114c445
JB
352%{_prefix}/lib/mono/2.0/*.dll
353%attr(755,root,root) %{_prefix}/lib/mono/2.0/httpcfg.exe
f3b0e346 354%attr(755,root,root) %{_prefix}/lib/mono/2.0/installutil.exe
5114c445
JB
355%attr(755,root,root) %{_prefix}/lib/mono/2.0/mconfig.exe
356%attr(755,root,root) %{_prefix}/lib/mono/2.0/mkbundle.exe
357%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-service.exe
358%attr(755,root,root) %{_prefix}/lib/mono/2.0/sgen.exe
f3b0e346 359%dir %{_prefix}/lib/mono/2.1
360%{_prefix}/lib/mono/2.1/*.dll
361%attr(755,root,root) %{_prefix}/lib/mono/2.1/smcs.exe
362%dir %{_prefix}/lib/mono/3.5
363%{_prefix}/lib/mono/3.5/*.dll
6d20487b 364%dir %{_prefix}/lib/mono/compat-1.0
5114c445 365%{_prefix}/lib/mono/compat-1.0/*.dll
6d20487b 366%dir %{_prefix}/lib/mono/compat-2.0
5114c445 367%{_prefix}/lib/mono/compat-2.0/*.dll
f1c5438d 368%{_prefix}/lib/mono/gac
5dab3216 369%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
5114c445
JB
370%{_mandir}/man1/cert2spc.1*
371%{_mandir}/man1/certmgr.1*
245657c9
MM
372%{_mandir}/man1/chktrust.1*
373%{_mandir}/man1/gacutil.1*
4a893061 374%{_mandir}/man1/httpcfg.1*
5385129f 375%{_mandir}/man1/makecert.1*
5114c445 376%{_mandir}/man1/mconfig.1*
245657c9
MM
377%{_mandir}/man1/mkbundle.1*
378%{_mandir}/man1/mint.1*
379%{_mandir}/man1/mono.1*
380%{_mandir}/man1/mono-service.1*
840f8203 381%{_mandir}/man1/mozroots.1*
5385129f 382%{_mandir}/man1/secutil.1*
5385129f 383%{_mandir}/man1/setreg.1*
8ef557a4 384%{_mandir}/man1/sgen.1*
245657c9
MM
385%{_mandir}/man1/signcode.1*
386%{_mandir}/man1/sn.1*
245657c9 387%{_mandir}/man5/mono-config.5*
fdd46781 388%dir %{_sysconfdir}/mono
f1c5438d 389%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/browscap.ini
f3b0e346 390%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/config
5114c445
JB
391%dir %{_sysconfdir}/mono/mconfig
392%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/mconfig/config.xml
245657c9 393%dir %{_sysconfdir}/mono/1.0
f1c5438d 394%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 395%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/machine.config
245657c9 396%dir %{_sysconfdir}/mono/2.0
f1c5438d 397%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 398%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/machine.config
399%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/settings.map
48cd6fab 400%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/web.config
8aa3dace 401
9f4cf2f1 402%exclude %{_prefix}/lib/mono/gac/Microsoft.JScript
403%exclude %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
404%exclude %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
405
ea0e88d4
MM
406%files jay
407%defattr(644,root,root,755)
245657c9 408%doc mcs/jay/{ACKNOWLEDGEMENTS,ChangeLog,NEW_FEATURES,NOTES,README,README.jay}
ea0e88d4
MM
409%attr(755,root,root) %{_bindir}/jay
410%dir %{_datadir}/jay
411%{_datadir}/jay/skeleton*
412%{_mandir}/man1/jay.1*
413
245657c9
MM
414%files jscript
415%defattr(644,root,root,755)
416%attr(755,root,root) %{_bindir}/mjs
5114c445 417%attr(755,root,root) %{_prefix}/lib/mono/1.0/mjs.exe
9f4cf2f1 418%{_prefix}/lib/mono/gac/Microsoft.JScript
419%{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
420%{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
5dab3216 421%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
245657c9 422
f327d485
MM
423%files compat-links
424%defattr(644,root,root,755)
425%attr(755,root,root) %{_bindir}/resgen
3d1af25b 426%attr(755,root,root) %{_bindir}/resgen2
f327d485 427
8aa3dace 428%files devel
429%defattr(644,root,root,755)
5114c445
JB
430%attr(755,root,root) %{_bindir}/al
431%attr(755,root,root) %{_bindir}/al2
432%attr(755,root,root) %{_bindir}/cilc
433%attr(755,root,root) %{_bindir}/disco
994ec6f9 434%attr(755,root,root) %{_bindir}/dtd2xsd
5114c445 435%attr(755,root,root) %{_bindir}/genxs
994ec6f9 436%attr(755,root,root) %{_bindir}/macpack
39d58cda
JB
437%attr(755,root,root) %{_bindir}/mono-api-diff
438%attr(755,root,root) %{_bindir}/mono-api-info
439%attr(755,root,root) %{_bindir}/mono-api-info2
245657c9 440%attr(755,root,root) %{_bindir}/monodis
2affc12a 441%attr(755,root,root) %{_bindir}/monograph
613285b2 442%attr(755,root,root) %{_bindir}/monolinker
5114c445
JB
443%attr(755,root,root) %{_bindir}/monop
444%attr(755,root,root) %{_bindir}/monop2
445%attr(755,root,root) %{_bindir}/mono-shlib-cop
ff3439a4 446%attr(755,root,root) %{_bindir}/nunit-console
48cd6fab 447%attr(755,root,root) %{_bindir}/nunit-console2
18ff84b2 448%attr(755,root,root) %{_bindir}/pedump
994ec6f9 449%attr(755,root,root) %{_bindir}/permview
450%attr(755,root,root) %{_bindir}/prj2make
613285b2 451%attr(755,root,root) %{_bindir}/smcs
5114c445
JB
452%attr(755,root,root) %{_bindir}/soapsuds
453%attr(755,root,root) %{_bindir}/sqlsharp
454%attr(755,root,root) %{_bindir}/wsdl
455%attr(755,root,root) %{_bindir}/wsdl2
4ffe85ea 456%attr(755,root,root) %{_bindir}/xbuild
5114c445 457%attr(755,root,root) %{_bindir}/xsd
f1c5438d
JB
458%if %{with mint}
459%attr(755,root,root) %{_libdir}/libmint.so
5114c445 460%{_libdir}/libmint.la
f1c5438d 461%else
2c1ff86a 462%attr(755,root,root) %{_libdir}/libmono.so
5114c445 463%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so
2c1ff86a 464%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so
5114c445
JB
465%{_libdir}/libmono.la
466%{_libdir}/libmono-profiler-aot.la
467%{_libdir}/libmono-profiler-cov.la
f1c5438d 468%endif
5114c445
JB
469%attr(755,root,root) %{_prefix}/lib/mono/1.0/CorCompare.exe
470%attr(755,root,root) %{_prefix}/lib/mono/1.0/al.exe
471%attr(755,root,root) %{_prefix}/lib/mono/1.0/browsercaps-updater.exe
472%attr(755,root,root) %{_prefix}/lib/mono/1.0/cilc.exe
473%attr(755,root,root) %{_prefix}/lib/mono/1.0/disco.exe
474%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2rng.exe
475%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2xsd.exe
476%attr(755,root,root) %{_prefix}/lib/mono/1.0/genxs.exe
477%attr(755,root,root) %{_prefix}/lib/mono/1.0/ictool.exe
478%attr(755,root,root) %{_prefix}/lib/mono/1.0/macpack.exe
479%attr(755,root,root) %{_prefix}/lib/mono/1.0/makecert.exe
480%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-api-diff.exe
481%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-api-info.exe
482%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-shlib-cop.exe
483%{_prefix}/lib/mono/1.0/mono-shlib-cop.exe.config
484%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-xmltool.exe
485%attr(755,root,root) %{_prefix}/lib/mono/1.0/monolinker.exe
486%attr(755,root,root) %{_prefix}/lib/mono/1.0/monop.exe
487%attr(755,root,root) %{_prefix}/lib/mono/1.0/nunit-console.exe
488%{_prefix}/lib/mono/1.0/nunit-console.exe.config
489%attr(755,root,root) %{_prefix}/lib/mono/1.0/permview.exe
490%attr(755,root,root) %{_prefix}/lib/mono/1.0/prj2make.exe
491%attr(755,root,root) %{_prefix}/lib/mono/1.0/resgen.exe
492%attr(755,root,root) %{_prefix}/lib/mono/1.0/soapsuds.exe
493%attr(755,root,root) %{_prefix}/lib/mono/1.0/sqlsharp.exe
494%attr(755,root,root) %{_prefix}/lib/mono/1.0/wsdl.exe
495%attr(755,root,root) %{_prefix}/lib/mono/1.0/xsd.exe
496%attr(755,root,root) %{_prefix}/lib/mono/2.0/al.exe
497%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-api-info.exe
498%attr(755,root,root) %{_prefix}/lib/mono/2.0/monop.exe
499%attr(755,root,root) %{_prefix}/lib/mono/2.0/nunit-console.exe
500%{_prefix}/lib/mono/2.0/nunit-console.exe.config
501%attr(755,root,root) %{_prefix}/lib/mono/2.0/resgen.exe
502%attr(755,root,root) %{_prefix}/lib/mono/2.0/wsdl.exe
503%attr(755,root,root) %{_prefix}/lib/mono/2.0/xbuild.exe
504%{_prefix}/lib/mono/2.0/xbuild.rsp
4a893061 505%{_prefix}/lib/mono/2.0/MSBuild
5114c445
JB
506%{_prefix}/lib/mono/2.0/Microsoft.Build.xsd
507%{_prefix}/lib/mono/2.0/Microsoft.CSharp.targets
508%{_prefix}/lib/mono/2.0/Microsoft.Common.targets
509%{_prefix}/lib/mono/2.0/Microsoft.VisualBasic.targets
510%{_prefix}/lib/mono/2.0/Microsoft.Common.tasks
511%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
512%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
4a893061 513%{_datadir}/%{name}-1.0
5114c445
JB
514%{_pkgconfigdir}/cecil.pc
515%{_pkgconfigdir}/dotnet.pc
516%{_pkgconfigdir}/mono-cairo.pc
517%{_pkgconfigdir}/mono-nunit.pc
518%if %{with mint}
519%{_pkgconfigdir}/mint.pc
520%else
521%{_pkgconfigdir}/mono.pc
522%endif
4a893061 523%{_includedir}/%{name}-1.0
ff3439a4 524%{_mandir}/man1/al.1*
c8f3b110 525%{_mandir}/man1/cilc.1*
994ec6f9 526%{_mandir}/man1/disco.1*
527%{_mandir}/man1/dtd2xsd.1*
e0aee78b 528%{_mandir}/man1/genxs.1*
994ec6f9 529%{_mandir}/man1/macpack.1*
2affc12a
MM
530%{_mandir}/man1/monoburg.1*
531%{_mandir}/man1/monodis.1*
613285b2 532%{_mandir}/man1/monolinker.1*
994ec6f9 533%{_mandir}/man1/monop.1*
534%{_mandir}/man1/mono-shlib-cop.1*
2affc12a 535%{_mandir}/man1/monostyle.1*
613285b2 536%{_mandir}/man1/mono-xmltool.1*
994ec6f9 537%{_mandir}/man1/oldmono.1*
5114c445 538%{_mandir}/man1/permview.1*
994ec6f9 539%{_mandir}/man1/prj2make.1*
613285b2 540%{_mandir}/man1/resgen.1*
994ec6f9 541%{_mandir}/man1/soapsuds.1*
18ff84b2 542%{_mandir}/man1/sqlsharp.1*
ff112d9b 543%{_mandir}/man1/wsdl.1*
a66172db 544%{_mandir}/man1/xsd.1*
18ff84b2 545
b6aa60a1
JB
546%files debug
547%defattr(644,root,root,755)
548%{_prefix}/lib/mono/1.0/*.mdb
549%{_prefix}/lib/mono/2.0/*.mdb
f3b0e346 550%{_prefix}/lib/mono/2.1/*.mdb
b6aa60a1
JB
551%{_prefix}/lib/mono/gac/*/*/*.mdb
552
18ff84b2 553%files csharp
609883c4 554%defattr(644,root,root,755)
a66172db
MM
555%attr(755,root,root) %{_bindir}/mcs
556%attr(755,root,root) %{_bindir}/gmcs
5114c445
JB
557%attr(755,root,root) %{_prefix}/lib/mono/1.0/mcs.exe
558%{_prefix}/lib/mono/1.0/mcs.exe.config
559%attr(755,root,root) %{_prefix}/lib/mono/2.0/gmcs.exe
560%{_prefix}/lib/mono/2.0/gmcs.exe.config
18ff84b2
MM
561%{_mandir}/man1/mcs.1*
562
18ff84b2 563%files ilasm
609883c4 564%defattr(644,root,root,755)
5114c445
JB
565%attr(755,root,root) %{_bindir}/ilasm
566%attr(755,root,root) %{_bindir}/ilasm2
567%attr(755,root,root) %{_prefix}/lib/mono/1.0/ilasm.exe
568%attr(755,root,root) %{_prefix}/lib/mono/2.0/ilasm.exe
c8f3b110 569%{_mandir}/man1/ilasm.1*
8aa3dace 570
4d9455d0 571%if %{with static_libs}
8aa3dace 572%files static
573%defattr(644,root,root,755)
5114c445
JB
574%if %{with mint}
575%{_libdir}/libmint.a
576%else
577%{_libdir}/libmono.a
578%{_libdir}/libmono-profiler-aot.a
579%{_libdir}/libmono-profiler-cov.a
580%endif
4d9455d0 581%endif
This page took 0.177681 seconds and 4 git commands to generate.