]> git.pld-linux.org Git - packages/mirall.git/blame - mirall.spec
- Added mirall-nautilus to include nautilus extension.
[packages/mirall.git] / mirall.spec
CommitLineData
cb614e78
CM
1# TODO:
2# * Fix ocsync packaging for and fix plugin dependencies here
3# * Fix and package lang stuff
4f43928d 4# * Package ruby gem based cli
cb614e78
CM
5Summary: Desktop file sync client for directory sharing and syncronization
6Name: mirall
7e798e7f 7Version: 1.7.0
f579b640 8Release: 0.2
cb614e78
CM
9License: GPL v2
10Group: Libraries
7e798e7f
LM
11Source0: https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.bz2
12# Source0-md5: f662f4510ef26b5484f754304f8d9295
cb614e78 13URL: http://www.owncloud.org
955cac42
CM
14BuildRequires: QtGui-devel
15BuildRequires: QtTest-devel
16BuildRequires: QtWebKit-devel
3257bfa3 17BuildRequires: QtKeychain-devel
cb614e78
CM
18BuildRequires: check
19BuildRequires: cmake
20BuildRequires: doxygen
955cac42 21BuildRequires: kde4-icons-oxygen
cb614e78 22BuildRequires: libstdc++-devel
78fcaef9 23BuildRequires: qt4-build
65738447 24BuildRequires: qt4-linguist
cb614e78 25Requires: iproute2
955cac42 26Requires: kde4-icons-oxygen
cb614e78 27Requires: net-tools
cb614e78
CM
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
955cac42
CM
31Mirall is the the QT baesd frontend desktop client for owncloud using
32ocsync as a backend.
cb614e78 33
f579b640
LM
34%package nautilus
35Summary: A nautilus extension for %{name}
cb614e78 36Group: Applications
cb614e78 37Requires: %{name} = %{version}-%{release}
f579b640 38Requires: nautilus-python
cb614e78 39
f579b640
LM
40%description nautilus
41A mirall extension to nautilus file browser.
cb614e78
CM
42
43%package devel
44Summary: Header files for %{name}
45Requires: %{name} = %{version}-%{release}
46
47%description devel
48Header files for %{name}
49
50%prep
51%setup -q
52
53%build
54if test ! -e "build"; then
55 %{__mkdir} build
56fi
57
58cd build
59
60%cmake \
61 -DCSYNC_INCLUDE_PATH=%{_includedir}/ocsync \
62 -DCMAKE_C_FLAGS:STRING="%{optflags}" \
63 -DCMAKE_CXX_FLAGS:STRING="%{optflags}" \
64 -DCMAKE_SKIP_RPATH=ON \
65 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
66 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
67 -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
68 -DPREFIX=%{_prefix} \
69 -DSYSCONFDIR=%{_sysconfdir} \
70 $RPM_BUILD_ROOT/%{name}-%{version} \
71 ..
72
73%{__make}
74%{__make} doc
75
76cd ..
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81cd build
82
83%{__make} install \
84 DESTDIR=$RPM_BUILD_ROOT
85
3257bfa3
LM
86mv ${RPM_BUILD_ROOT}/%{_libdir}/owncloud/* ${RPM_BUILD_ROOT}/%{_libdir}/
87rmdir ${RPM_BUILD_ROOT}/%{_libdir}/owncloud
88
cb614e78
CM
89%clean
90rm -rf $RPM_BUILD_ROOT
91
4f43928d
CM
92%post -p /sbin/ldconfig
93%postun -p /sbin/ldconfig
94
cb614e78
CM
95%files
96%defattr(644,root,root,755)
3257bfa3 97%doc README.md COPYING ChangeLog
cb614e78 98%attr(755,root,root) %{_bindir}/owncloud
3257bfa3 99%attr(755,root,root) %{_bindir}/owncloudcmd
cb614e78
CM
100%dir %{_sysconfdir}/ownCloud
101%{_sysconfdir}/ownCloud/sync-exclude.lst
102%attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
4f43928d 103%ghost %{_libdir}/libowncloudsync.so.0
3257bfa3 104%attr(755,root,root) %{_libdir}/libocsync.so.*
cb614e78 105%{_desktopdir}/owncloud.desktop
f579b640 106%{_iconsdir}/hicolor/*/apps/own*.png
3257bfa3
LM
107%dir %{_datadir}/owncloud
108%dir %{_datadir}/owncloud/i18n
109%{_datadir}/owncloud/i18n/*
cb614e78
CM
110
111%files devel
955cac42 112%defattr(644,root,root,755)
cb614e78 113%attr(755,root,root) %{_libdir}/libowncloudsync.so
3257bfa3
LM
114%attr(755,root,root) %{_libdir}/libocsync.so
115%{_libdir}/libhttpbf.a
116%{_includedir}/httpbf.h
117%dir %{_includedir}/owncloudsync
118%dir %{_includedir}/owncloudsync/mirall
119%dir %{_includedir}/owncloudsync/creds
120%{_includedir}/owncloudsync/mirall/*
121%{_includedir}/owncloudsync/creds/*
cb614e78 122
f579b640
LM
123%files nautilus
124%defattr(644,root,root,755)
125%{_datadir}/nautilus-python/extensions/*.py
126
This page took 0.094411 seconds and 4 git commands to generate.