]> git.pld-linux.org Git - packages/mesa-demos.git/blame - mesa-demos.spec
- updated to 8.3.0
[packages/mesa-demos.git] / mesa-demos.spec
CommitLineData
0dfdf502
JB
1#
2# Conditional build:
3%bcond_without egl # EGL utilities
4%bcond_without gles1 # GLESv1 utilities
5%bcond_without gles2 # GLESv2 utilities
b645648f 6%bcond_with openvg # OpenVG utilities
0dfdf502
JB
7%bcond_without wayland # Wayland support
8
309f5fea
JR
9Summary: Mesa Demos source code
10Summary(pl.UTF-8): Kod źródłowy programów demonstrujących dla bibliotek Mesa
11Name: mesa-demos
88d18436
JB
12Version: 8.3.0
13Release: 1
309f5fea
JR
14License: various (MIT, SGI, GPL - see copyright notes in sources)
15Group: Development/Libraries
16Source0: ftp://ftp.freedesktop.org/pub/mesa/demos/%{version}/%{name}-%{version}.tar.bz2
88d18436 17# Source0-md5: 628e75c23c17394f11a316c36f8e4164
309f5fea 18URL: http://www.mesa3d.org/
0dfdf502 19%{?with_egl:BuildRequires: EGL-devel}
223e6363 20BuildRequires: Mesa-libgbm-devel
0dfdf502 21%{?with_wayland:BuildRequires: Mesa-libwayland-egl-devel}
defae254
JB
22BuildRequires: OpenGL-GLU-devel
23BuildRequires: OpenGL-devel
5fc1d099 24BuildRequires: OpenGL-glut-devel
0dfdf502
JB
25%{?with_gles1:BuildRequires: OpenGLESv1-devel}
26%{?with_gles2:BuildRequires: OpenGLESv2-devel}
27%{?with_openvg:BuildRequires: OpenVG-devel}
223e6363
JB
28BuildRequires: freetype-devel >= 2
29BuildRequires: glew-devel >= 1.5.4
0dfdf502 30%{?with_egl:BuildRequires: libdrm-devel}
a9ebec15 31BuildRequires: pkgconfig
32BuildRequires: rpm-pythonprov
0dfdf502 33%{?with_wayland:BuildRequires: wayland-devel}
309f5fea
JR
34BuildRequires: xorg-lib-libX11-devel
35BuildRequires: xorg-lib-libXext-devel
36Requires: OpenGL-devel
5fc1d099 37Requires: OpenGL-glut-devel
309f5fea
JR
38Obsoletes: Mesa-demos
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42Demonstration programs for the Mesa libraries in source code form.
43
44%description -l pl.UTF-8
45Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
46
47%package -n mesa-utils
48Summary: OpenGL utilities from Mesa3D
49Summary(pl.UTF-8): Programy narzędziowe OpenGL z projektu Mesa3D
50License: MIT
51Group: X11/Applications/Graphics
52Obsoletes: Mesa-utils
309f5fea
JR
53
54%description -n mesa-utils
55OpenGL utilities from Mesa3D: glxgears and glxinfo.
56
57%description -n mesa-utils -l pl.UTF-8
58Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
59
0dfdf502
JB
60%package -n mesa-utils-egl
61Summary: EGL utilities from Mesa3D
62Summary(pl.UTF-8): Programy narzędziowe EGL z projektu Mesa3D
63License: MIT
64Group: Applications/Graphics
65
66%description -n mesa-utils-egl
67EGL utilities from Mesa3D: eglgears and eglinfo.
68
69%description -n mesa-utils-egl -l pl.UTF-8
70Programy narzędziowe EGL z projektu Mesa3D: eglgears i eglinfo.
71
72%package -n mesa-utils-gles1
73Summary: OpenGLESv1 utilities from Mesa3D
74Summary(pl.UTF-8): Programy narzędziowe OpenGLESv1 z projektu Mesa3D
75License: MIT
76Group: Applications/Graphics
77
78%description -n mesa-utils-gles1
79OpenGLESv1 utilities from Mesa3D: es1gears and es1_info.
80
81%description -n mesa-utils-gles1 -l pl.UTF-8
82Programy narzędziowe OpenGLESv1 z projektu Mesa3D: es1gears i
83es1_info.
84
85%package -n mesa-utils-gles2
86Summary: OpenGLESv2 utilities from Mesa3D
87Summary(pl.UTF-8): Programy narzędziowe OpenGLESv2 z projektu Mesa3D
88License: MIT
89Group: Applications/Graphics
90
91%description -n mesa-utils-gles2
92OpenGLESv2 utilities from Mesa3D: es2gears and es2_info.
93
94%description -n mesa-utils-gles2 -l pl.UTF-8
95Programy narzędziowe OpenGLESv2 z projektu Mesa3D: es2gears i
96es2_info.
97
98%package -n mesa-utils-openvg
99Summary: OpenVG utilities from Mesa3D
100Summary(pl.UTF-8): Programy narzędziowe OpenVG z projektu Mesa3D
101License: MIT
102Group: Applications/Graphics
103
104%description -n mesa-utils-openvg
105OpenVG utilities from Mesa3D.
106
107%description -n mesa-utils-openvg -l pl.UTF-8
108Programy narzędziowe OpenVG z projektu Mesa3D.
109
309f5fea
JR
110%prep
111%setup -q
112
113%build
defae254 114%configure \
0dfdf502
JB
115 %{!?with_egl:--disable-egl} \
116 %{!?with_gles1:--disable-gles1} \
117 %{!?with_gles2:--disable-gles2} \
118 --disable-silent-rules \
119 %{!?with_openvg:--disable-vg} \
120 %{?with_egl:--enable-wayland}
309f5fea
JR
121
122# we only want glxinfo and glxgears to be built here
123%{__make} -C src/xdemos
124
0dfdf502
JB
125%if %{with egl}
126%{__make} -C src/egl
127%endif
128
309f5fea
JR
129%install
130rm -rf $RPM_BUILD_ROOT
131install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
132
133install -p src/xdemos/{glxinfo,glxgears} $RPM_BUILD_ROOT%{_bindir}
0dfdf502 134%if %{with egl}
88d18436 135install -p src/egl/opengl/{eglinfo,eglgears_x11,peglgears} $RPM_BUILD_ROOT%{_bindir}
0dfdf502
JB
136%if %{with gles1}
137install -p src/egl/opengles1/es1_info $RPM_BUILD_ROOT%{_bindir}
0dfdf502
JB
138install -p src/egl/opengles1/gears_x11 $RPM_BUILD_ROOT%{_bindir}/es1gears_x11
139%endif
140%if %{with gles2}
88d18436 141install -p src/egl/opengles2/{es2_info,es2gears_x11} $RPM_BUILD_ROOT%{_bindir}
0dfdf502
JB
142%if %{with wayland}
143install -p src/egl/opengles2/es2gears_wayland $RPM_BUILD_ROOT%{_bindir}
144%endif
145%endif
146%if %{with openvg}
88d18436 147install -p src/egl/openvg/{lion,sp}_x11 $RPM_BUILD_ROOT%{_bindir}
0dfdf502
JB
148%endif
149%endif
309f5fea
JR
150
151cp -a * $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
5fc1d099 152%{__make} -C $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} distclean
309f5fea
JR
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%files
158%defattr(644,root,root,755)
159%{_examplesdir}/%{name}-%{version}
160
161%files -n mesa-utils
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_bindir}/glxgears
164%attr(755,root,root) %{_bindir}/glxinfo
0dfdf502
JB
165
166%if %{with egl}
167%files -n mesa-utils-egl
168%defattr(644,root,root,755)
0dfdf502
JB
169%attr(755,root,root) %{_bindir}/eglgears_x11
170%attr(755,root,root) %{_bindir}/eglinfo
171%attr(755,root,root) %{_bindir}/peglgears
172%endif
173
174%if %{with egl} && %{with gles1}
175%files -n mesa-utils-gles1
176%defattr(644,root,root,755)
177%attr(755,root,root) %{_bindir}/es1_info
0dfdf502
JB
178%attr(755,root,root) %{_bindir}/es1gears_x11
179%endif
180
181%if %{with egl} && %{with gles2}
182%files -n mesa-utils-gles2
183%defattr(644,root,root,755)
184%attr(755,root,root) %{_bindir}/es2_info
0dfdf502
JB
185%attr(755,root,root) %{_bindir}/es2gears_x11
186%if %{with wayland}
187%attr(755,root,root) %{_bindir}/es2gears_wayland
188%endif
189%endif
190
191%if %{with egl} && %{with openvg}
192%files -n mesa-utils-openvg
193%defattr(644,root,root,755)
0dfdf502 194%attr(755,root,root) %{_bindir}/lion_x11
0dfdf502
JB
195%attr(755,root,root) %{_bindir}/sp_x11
196%endif
This page took 0.072185 seconds and 4 git commands to generate.