]> git.pld-linux.org Git - packages/mdds.git/blame - mdds.spec
- pl
[packages/mdds.git] / mdds.spec
CommitLineData
dbe2120a 1Summary: A collection of multi-dimensional data structures and indexing algorithms
021b4724 2Summary(pl.UTF-8): Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
dbe2120a 3Name: mdds
7a3941f7 4Version: 0.6.0
dbe2120a
AM
5Release: 1
6License: MIT
7Group: Development/Libraries
021b4724 8#Source0Download: https://code.google.com/p/multidimalgorithm/downloads/list
dbe2120a 9Source0: http://multidimalgorithm.googlecode.com/files/%{name}_%{version}.tar.bz2
7a3941f7
AM
10# Source0-md5: 3e89a35f253a4f1c7de68c57d851ef38
11Patch0: 0001-Fixes-build-breakage-on-Debian.patch
12Patch1: 0001-fix-linking-error-with-boost-1.50.patch
13Patch2: 0001-help-compiler-select-the-right-overload-of-vector-in.patch
021b4724 14URL: http://code.google.com/p/multidimalgorithm/
dbe2120a
AM
15BuildRequires: boost-devel
16BuildArch: noarch
843e0754 17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
dbe2120a
AM
18
19%description
20A collection of multi-dimensional data structures and indexing
21algorithms.
22
23It implements the following data structures:
24- segment tree
25- flat segment tree
26- rectangle set
27- point quad tree
28- mixed type matrix
29
021b4724
JB
30%description -l pl.UTF-8
31Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
32Zaimplementowane są następujące struktury danych:
33- drzewo segmentowe
34- płaskie drzewo segmentowe
35- zbiór prostokątów
36- drzewo czwórkowe (quadtree) dla punktów
37- macierz mieszana
38
dbe2120a 39%package devel
021b4724
JB
40Summary: A collection of multi-dimensional data structures and indexing algorithms
41Summary(pl.UTF-8): Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
dbe2120a
AM
42Group: Development/Libraries
43Requires: boost-devel
44
45%description devel
021b4724
JB
46A collection of multi-dimensional data structures and indexing
47algorithms.
48
49It implements the following data structures:
50- segment tree
51- flat segment tree
52- rectangle set
53- point quad tree
54- mixed type matrix
55
56%description devel -l pl.UTF-8
57Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
58Zaimplementowane są następujące struktury danych:
59- drzewo segmentowe
60- płaskie drzewo segmentowe
61- zbiór prostokątów
62- drzewo czwórkowe (quadtree) dla punktów
63- macierz mieszana
dbe2120a 64
dbe2120a
AM
65%prep
66%setup -q -n %{name}_%{version}
7a3941f7
AM
67%patch0 -p1
68%patch1 -p1
69%patch2 -p1
70
dbe2120a
AM
71# this is only used in tests
72sed -i -e '/^CPPFLAGS/s/-Wall.*-std/%{rpmcflags} -std/' Makefile.in
73
dbe2120a 74%build
021b4724
JB
75# we can switch from boost to c++0x (the default) if sufficiently new C++11 compliant g++ is enforced
76%configure \
77 --with-hash-container=boost
dbe2120a
AM
78%{__make}
79
80%install
81rm -rf $RPM_BUILD_ROOT
843e0754
ER
82install -d $RPM_BUILD_ROOT%{_includedir}/mdds
83cp -a include/mdds/* $RPM_BUILD_ROOT%{_includedir}/mdds
dbe2120a
AM
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files devel
89%defattr(644,root,root,755)
dbe2120a 90%doc AUTHORS COPYING NEWS README
843e0754 91%{_includedir}/mdds
This page took 0.122301 seconds and 4 git commands to generate.