]> git.pld-linux.org Git - packages/marco.git/blame - mate-window-manager.spec
add -libs subpackage, so -devel doesn't require actual wm
[packages/marco.git] / mate-window-manager.spec
CommitLineData
ad92460f
ER
1# TODO
2# - subpackages for themes (see metacity.spec)
ad92460f
ER
3Summary: MATE Desktop window manager
4Name: mate-window-manager
5Version: 1.5.2
0af0c20f 6Release: 0.5
ad92460f
ER
7License: LGPLv2+ and GPLv2+
8Group: X11/Window Managers
ad92460f
ER
9Source0: http://pub.mate-desktop.org/releases/1.5/%{name}-%{version}.tar.xz
10# https://bugzilla.gnome.org/show_bug.cgi?id=622517
11Patch0: Allow-breaking-out-from-maximization-during-mouse.patch
12# https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/583847
13Patch1: initialise_all_workspace_names.patch
14# upstream patch
15# https://github.com/mate-desktop/mate-window-manager/commit/6404a98fb79e7bb4c3e9c5ca9919e12c946679d7
16Patch2: 0001-fix-startup-rendering-effect-with-composite-enabled.patch
91ab70d8 17URL: http://mate-desktop.org/
ad92460f
ER
18BuildRequires: desktop-file-utils
19BuildRequires: mate-common
20BuildRequires: mate-dialogs
21BuildRequires: pkgconfig(MateCORBA-2.0)
22BuildRequires: pkgconfig(gsettings-desktop-schemas)
23BuildRequires: pkgconfig(gtk+-2.0)
24BuildRequires: pkgconfig(ice)
25BuildRequires: pkgconfig(libcanberra)
26BuildRequires: pkgconfig(libcanberra-gtk)
27BuildRequires: pkgconfig(libsoup-2.4)
28BuildRequires: pkgconfig(libstartup-notification-1.0)
29BuildRequires: pkgconfig(mate-doc-utils)
30BuildRequires: pkgconfig(sm)
31BuildRequires: pkgconfig(xdamage)
91ab70d8
ER
32BuildRequires: tar >= 1:1.22
33BuildRequires: xz
0af0c20f 34Requires: %{name}-libs = %{version}-%{release}
ad92460f
ER
35Requires: glib2 >= 1:2.26.0
36Requires: gsettings-desktop-schemas
8446ed7d 37Suggests: mate-control-center
ad92460f
ER
38Requires(post): /sbin/ldconfig
39Obsoletes: mate-window-manager-libs < 1.4.1-2
40# http://bugzilla.redhat.com/873342
41#Provides: firstboot(windowmanager) = mate-window-manager
0af0c20f 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ad92460f
ER
43
44%description
45MATE Desktop window manager
46
0af0c20f
ER
47%package libs
48Summary: marco library
49Summary(pl.UTF-8): marco biblioteka
50Group: X11/Libraries
51
52%description libs
53This package contains libraries for MATE window manager.
54
55%description libs -l pl.UTF-8
56Pakiet zawierający biblioteki zarządcy okien MATE.
57
ad92460f
ER
58%package devel
59Summary: Development files for mate-window-manager
60Group: Development/Libraries
0af0c20f 61Requires: %{name}-libs = %{version}-%{release}
ad92460f
ER
62
63%description devel
64Development files for mate-window-manager
65
66%prep
67%setup -q
68%patch0 -p1
69#patch1 -p1
70%patch2 -p1
ad92460f
ER
71
72%build
08d66458 73NOCONFIGURE=1 ./autogen.sh
ad92460f
ER
74%configure \
75 --disable-static \
76 --disable-scrollkeeper \
77 --with-gnu-ld \
78 --with-gtk=2.0 \
79 --with-x
80
81%{__make} \
82 V=1
83
84%install
85rm -rf $RPM_BUILD_ROOT
86%{__make} install \
87 DESTDIR=$RPM_BUILD_ROOT
88
89find $RPM_BUILD_ROOT -name '*.la' -exec rm -vf {} ';'
90
91desktop-file-install \
92 --remove-category="MATE" \
93 --delete-original \
94 --dir=$RPM_BUILD_ROOT%{_desktopdir} \
95$RPM_BUILD_ROOT%{_desktopdir}/marco.desktop
96
97%find_lang %{name} --all-name
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post
103/sbin/ldconfig
104%glib_compile_schemas
105
106%postun
107/sbin/ldconfig
108%glib_compile_schemas
109
110%files -f %{name}.lang
111%defattr(644,root,root,755)
112%doc AUTHORS COPYING README
113%attr(755,root,root) %{_bindir}/marco
114%attr(755,root,root) %{_bindir}/marco-message
115%{_desktopdir}/marco.desktop
116%{_datadir}/themes/ClearlooksRe
117%{_datadir}/themes/Dopple-Left
118%{_datadir}/themes/Dopple
119%{_datadir}/themes/DustBlue
120%{_datadir}/themes/Spidey-Left
121%{_datadir}/themes/Spidey
122%{_datadir}/themes/Splint-Left
123%{_datadir}/themes/Splint
124%{_datadir}/themes/WinMe
125%{_datadir}/themes/eOS
126%{_datadir}/marco
127%{_datadir}/mate-control-center/keybindings/50-marco*.xml
128%{_datadir}/mate/help/creating-marco-themes/C/creating-marco-themes.xml
129%{_datadir}/mate/wm-properties
130%{_datadir}/glib-2.0/schemas/org.mate.marco.gschema.xml
131%{_mandir}/man1/marco.1.*
132%{_mandir}/man1/marco-message.1.*
133
ad92460f
ER
134# XXX find proper packages
135%dir %{_datadir}/mate-control-center
136%dir %{_datadir}/mate-control-center/keybindings
137%dir %{_datadir}/mate/help/creating-marco-themes
138%dir %{_datadir}/mate/help/creating-marco-themes/C
139
0af0c20f
ER
140%files libs
141%defattr(644,root,root,755)
142%attr(755,root,root) %{_libdir}/libmarco-private.so.*.*.*
143%ghost %{_libdir}/libmarco-private.so.0
144
ad92460f
ER
145%files devel
146%defattr(644,root,root,755)
147%attr(755,root,root) %{_bindir}/marco-theme-viewer
148%attr(755,root,root) %{_bindir}/marco-window-demo
149%{_includedir}/marco-1
150%{_libdir}/libmarco-private.so
151%{_pkgconfigdir}/libmarco-private.pc
152%{_mandir}/man1/marco-theme-viewer.1.*
153%{_mandir}/man1/marco-window-demo.1.*
This page took 0.1309 seconds and 4 git commands to generate.