]> git.pld-linux.org Git - packages/mate-panel.git/blame - mate-panel.spec
- suggest mate-settings-daemon, it makes icons appear correctly in menus
[packages/mate-panel.git] / mate-panel.spec
CommitLineData
e6840e88
ER
1# TODO
2# - docs broken, like mate-desktop
3# fix gtk-doc building (probably missing some dtd's)
4#xsltproc -o mate-applet-clock-C.omf --stringparam db2omf.basename mate-applet-clock --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/mate/help" --stringparam db2omf.omf_in "/home/users/glen/rpm/packages/BUILD.i686-linux/mate-panel-1.5.3/help/clock/mate-applet-clock.omf.in" `/usr/bin/pkg-config --variable db2omf mate-doc-utils` C/mate-applet-clock.xml || { rm -f "mate-applet-clock-C.omf"; exit 1; }
5#if ! test -d ar/; then mkdir ar/; fi
6#if [ -f "C/mate-applet-clock.xml" ]; then d="../"; else d="/home/users/glen/rpm/packages/BUILD.i686-linux/mate-panel-1.5.3/help/clock/"; fi; \
7#mo="ar/ar.mo"; \
8#if [ -f "${mo}" ]; then mo="../${mo}"; else mo="/home/users/glen/rpm/packages/BUILD.i686-linux/mate-panel-1.5.3/help/clock/${mo}"; fi; \
9#(cd ar/ && \
10# `which xml2po` -m docbook -e -t "${mo}" \
11# "${d}C/mate-applet-clock.xml" > mate-applet-clock.xml.tmp && \
12# cp mate-applet-clock.xml.tmp mate-applet-clock.xml && rm -f mate-applet-clock.xml.tmp)
13#runtime error
14#xsltApplyStylesheet: saving to mate-applet-clock-C.omf may not be possible
15#make[3]: *** [mate-applet-clock-C.omf] Error 1
16#make[3]: *** Waiting for unfinished jobs....
17#Making all in mate-panel-applet
18#make[4]: Entering directory `/home/users/glen/rpm/BUILD/i686-linux/mate-panel-1.5.3/doc/reference/mate-panel-applet'
19# DOC Scanning header files
20# DOC Introspecting gobjects
21#libtool: link: cannot find the library `../../../libmate-panel-applet/libmate-panel-applet-3.la' or unhandled argument `../../../libmate-panel-applet/libmate-panel-applet-3.la'
22#Linking of scanner failed:
23#make[4]: *** [scan-build.stamp] Error 1
24#make[4]: Leaving directory `/home/users/
25# - check direct deps:
26#mate-panel-1.5.3-0.1.i686 marks mate-menus-libs-1.5.0-1.i686 (cap libmate-menu.so.2)
27#mate-panel-1.5.3-0.1.i686 marks mate-panel-libs-1.5.3-0.1.i686 (cap libmate-panel-applet-4.so.1)
28#mate-panel-1.5.3-0.1.i686 marks libmateweather-1.5.0-1.i686 (cap libmateweather.so.1)
29#mate-panel-1.5.3-0.1.i686 marks libmatewnck-1.5.0-1.i686 (cap libmatewnck.so.0)
30# - apidoc subpackage
33f7c726
ER
31# - panel does not start:
32#(mate-panel:7862): GLib-GIO-ERROR **: Settings schema 'org.mate.caja.desktop' is not installed
e6840e88
ER
33
34# Conditional build:
35%bcond_with doc # gtk doc. broken
36
37Summary: MATE Desktop panel applets
38Name: mate-panel
39Version: 1.5.3
40Release: 0.1
41# libs are LGPLv2+ applications GPLv2+
42License: GPL v2+
43Group: X11/Applications
44URL: http://mate-desktop.org
45Source0: http://pub.mate-desktop.org/releases/1.5/%{name}-%{version}.tar.xz
46# Source0-md5: 72029cbcd38bee447df92c8774452bf3
47BuildRequires: desktop-file-utils
48BuildRequires: icon-naming-utils
49BuildRequires: mate-common
50BuildRequires: pkgconfig(dbus-glib-1)
51BuildRequires: pkgconfig(dconf)
52BuildRequires: pkgconfig(gobject-introspection-1.0)
53BuildRequires: pkgconfig(gsettings-desktop-schemas)
54BuildRequires: pkgconfig(gtk+-2.0)
55BuildRequires: pkgconfig(libcanberra)
56BuildRequires: pkgconfig(libmate-menu)
57BuildRequires: pkgconfig(libmatewnck)
58BuildRequires: pkgconfig(libnm-gtk)
59BuildRequires: pkgconfig(librsvg-2.0)
60BuildRequires: pkgconfig(mate-desktop-2.0)
61%{?with_apidoc:BuildRequires: pkgconfig(mate-doc-utils)}
62BuildRequires: pkgconfig(mateweather)
63BuildRequires: pkgconfig(pango)
64BuildRequires: pkgconfig(sm)
65BuildRequires: pkgconfig(x11)
66BuildRequires: popt-devel
67BuildRequires: tar >= 1:1.22
68BuildRequires: xz
69Requires: %{name}-libs = %{version}-%{release}
70Requires: glib2 >= 1:2.26.0
71Requires: gsettings-desktop-schemas
72# needed as nothing else requires it
73Requires: desktop-file-utils
74Requires: gtk-update-icon-cache
75Requires: mate-session-manager
2d1ecf41 76Suggests: mate-settings-daemon
e6840e88
ER
77# for fish
78Requires: fortune-mod
79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81%description
82MATE Desktop panel applets
83
84%package libs
85Summary: Shared libraries for mate-panel
86License: LGPL v2+
87Group: Libraries
88Requires: %{name} = %{version}-%{release}
89
90%description libs
91Shared libraries for libmate-desktop
92
93%package devel
94Summary: Development files for mate-panel
95Group: Development/Libraries
96Requires: %{name}-libs = %{version}-%{release}
97
98%description devel
99Development files for mate-panel
100
101%prep
102%setup -q
103
104%build
105NOCONFIGURE=1 ./autogen.sh
106# libexecdir needed for gnome conflicts
107%configure \
108 --disable-scrollkeeper \
109 --disable-static \
110 --disable-schemas-compile \
111 --with-x \
112 --enable-network-manager \
113 --libexecdir=%{_libexecdir}/mate-panel \
114 --with-html-dir=%{_gtkdocdir} \
115 %{?with_doc:--enable-gtk-doc} \
116 --enable-introspection
117
118%{__make} \
119 V=1
120
121%install
122rm -rf $RPM_BUILD_ROOT
123%{__make} install \
124 DESTDIR=$RPM_BUILD_ROOT
125
126rm -fv $RPM_BUILD_ROOT%{_libdir}/lib*.la
127
128desktop-file-install \
129 --remove-category="MATE" \
130 --add-category="X-Mate" \
131 --dir=$RPM_BUILD_ROOT%{_desktopdir} \
132$RPM_BUILD_ROOT%{_desktopdir}/mate-panel.desktop
133
134%find_lang %{name}
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post
140%update_icon_cache hicolor
141%update_desktop_database
142%glib_compile_schemas
143
144%postun
145%update_icon_cache hicolor
146%update_desktop_database
147%glib_compile_schemas
148
149%post libs -p /sbin/ldconfig
150%postun libs -p /sbin/ldconfig
151
152%files -f %{name}.lang
153%defattr(644,root,root,755)
154%doc AUTHORS COPYING README
155%attr(755,root,root) %{_bindir}/mate-desktop-item-edit
156%attr(755,root,root) %{_bindir}/mate-panel
157%attr(755,root,root) %{_bindir}/mate-panel-test-applets
158%{_mandir}/man1/*
159%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
160%{_libexecdir}/mate-panel
161%{_datadir}/glib-2.0/schemas/org.mate.panel.*.xml
162%{_desktopdir}/mate-panel.desktop
163%{_datadir}/dbus-1/services/org.mate.panel.*.service
164%{_datadir}/omf/mate-applet-fish
165%{_datadir}/omf/mate-applet-clock
166%{_iconsdir}/hicolor/*/*/*
167%{_datadir}/mate/help/mate-applet-clock
168%{_datadir}/mate/help/mate-applet-fish
169%{_datadir}/mate-panel
170%{_datadir}/mate-panelrc
171
172%files libs
173%defattr(644,root,root,755)
174%doc COPYING.LIB
175%attr(755,root,root) %{_libdir}/libmate-panel-applet-4.so.*.*.*
176%ghost %{_libdir}/libmate-panel-applet-4.so.1
177
178%files devel
179%defattr(644,root,root,755)
180%{_libdir}/libmate-panel-applet-4.so
181%{_includedir}/mate-panel-4.0
182%{_pkgconfigdir}/libmatepanelapplet-4.0.pc
183%{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
184# apidoc
185%{_gtkdocdir}/mate-panel-applet
This page took 0.127547 seconds and 4 git commands to generate.