]> git.pld-linux.org Git - packages/lyx.git/blame - lyx.spec
- up to 2.0.8
[packages/lyx.git] / lyx.spec
CommitLineData
d72908d8 1# TODO:
2# - tex deps (tetex-tex-babel seems to be required, but I'm not sure)
29201be9
SS
3#
4# Conditional build:
58e0dfc8 5%bcond_without system_boost # build with included boost-1.36
29201be9 6#
1b62fbcd 7Summary: A WYSIWYM frontend to LaTeX
b5e8599f
ER
8Summary(pl.UTF-8): Nakładka WYSIWYM na LaTeXa
9Summary(pt_BR.UTF-8): Editor de Textos para ambiente Desktop
adb3314c 10Name: lyx
c48ea935
AM
11Version: 2.0.8
12Release: 1
cc09df86 13Epoch: 1
b23e7393 14License: GPL v2+
1b62fbcd 15Group: Applications/Publishing/TeX
c0ca5849 16Source0: http://ftp.lyx.org/pub/lyx/stable/2.0.x/%{name}-%{version}.tar.xz
c48ea935 17# Source0-md5: ea575447107a4c7511c06e082fbd2619
d10c5671 18Source1: %{name}.desktop
20773763 19Source2: %{name}.png
055aeaf7 20URL: http://www.lyx.org/
bf997472 21BuildRequires: QtGui-devel
d1ce6164 22BuildRequires: aiksaurus-devel
852c8005
SS
23BuildRequires: aspell-devel
24BuildRequires: autoconf >= 2.59-9
25BuildRequires: automake
29201be9 26%{?with_system_boost:BuildRequires: boost-devel >= 1.35.0}
619b025d 27BuildRequires: gettext-devel
055aeaf7 28BuildRequires: libstdc++-devel
f3479de0 29BuildRequires: pkgconfig
619b025d 30BuildRequires: qt4-build
cdbe0761 31BuildRequires: rpm-pythonprov
2120267e 32BuildRequires: sed >= 4.0
e275a572 33BuildRequires: xorg-lib-libX11-devel
cdbe0761 34Requires(post,postun): tetex
1b62fbcd 35Requires: gv
170c0281 36Requires: python-modules
d72908d8 37Requires: tetex-format-latex
055aeaf7
JB
38Requires: tetex-latex
39Requires: xdvi
0954a273 40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
adb3314c 41
f05d6e39
JB
42%define texmfdir %{_datadir}/texmf
43
1805b0b6 44%description
d10c5671 45LyX is a modern approach of writing documents with a computer which
46breaks with the tradition of the obsolete typewriter concept. It is
47designed for people who want a professional output with a minimum of
48time effort, without becoming specialists in typesetting. Compared to
49common word processors LyX will increase the productivity a lot, since
50most of the typesetting will be done by the computer, not the author.
51With LyX the author can concentrate on the contents of his writing,
52since the computer will take care of the look.
1b62fbcd 53
885e1ebc
JR
54%description -l pl.UTF-8
55LyX jest nowoczesnym narzędziem służącym do pisania dokumentów
56łamiącym dotychczasową, przestarzałą tradycję maszyny do pisania. LyX
57został zaprojektowany dla ludzi, którzy chcą tworzyć profesjonalne
58dokumenty przy jak najmniejszym nakładzie czasowym bez konieczności
59bycia specjalistą w składzie tekstów. LyX pozwala autorowi skupić się
60na zawartości dokumentu podczas gdy komputer zajmie się całą resztą.
1805b0b6 61
885e1ebc
JR
62%description -l pt_BR.UTF-8
63Lyx é uma forma moderna de escrever documentos com um computador sem
64que isso quebre os conceitos de uso de uma máquina de escrever
65tradicional. Ele é feito para pessoas que necessitam de um resultado
66profissional com um mínimo de esforço, sem também ser um especialista
67em fontes. Comparado com um editor de textos padrão, LyX é um editor
68de textos que irá aumentar a produtividade visto que as fontes serão
69selecionadas pelo editor, não pelo digitador.
cc09df86 70
1805b0b6 71%prep
72%setup -q
569643cd 73
1805b0b6 74%build
33d5ce3f 75cat config/*.m4 > acinclude.m4
e275a572
JB
76%{__aclocal} -I m4
77%{__autoconf}
78%{__autoheader}
79%{__automake}
f0729241 80%configure \
8d4ef6cb 81 --disable-silent-rules \
0b5c1e4c 82 %{?debug:--enable-debug} \
7208737d 83 --enable-nls \
29201be9 84 %{?with_system_boost:--without-included-boost} \
0b5c1e4c
KK
85 --without-included-gettext \
86 --with-qt4-dir=%{_libdir}/qt4 \
c0ca5849 87 --with-frontend=qt4
30ad323d 88
50b900c8 89%{__make} all
1805b0b6 90
91%install
92rm -rf $RPM_BUILD_ROOT
569643cd 93install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
f05d6e39 94 $RPM_BUILD_ROOT%{texmfdir}/tex/latex
adb3314c 95
f05d6e39
JB
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
d10c5671 98
569643cd 99install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
ad20ab7f 100install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
d10c5671 101
f05d6e39 102ln -sf %{_datadir}/lyx/tex $RPM_BUILD_ROOT%{texmfdir}/tex/latex/lyx
d10c5671 103
b23e7393 104%{__sed} -i -e 's,#! /usr/bin/env python,#!/usr/bin/python,' $RPM_BUILD_ROOT%{_datadir}/lyx/configure.py
2120267e 105
0cb20aec 106%find_lang %{name}
107
ad20ab7f
JB
108%clean
109rm -rf $RPM_BUILD_ROOT
110
1805b0b6 111%post
44b80f16 112umask 022
f05d6e39
JB
113/usr/bin/texhash
114cd %{_datadir}/lyx
2120267e 115./configure.py > /dev/null || :
1805b0b6 116if [ -f lyxrc.defaults ]; then
44b80f16 117 cp -p lyxrc.defaults lyxrc
1805b0b6 118fi
119
120%preun
f05d6e39 121if [ "$1" = "0" ]; then
b23e7393 122 %{__rm} -f %{_datadir}/lyx/{lyxrc.defaults,lyxrc*}
123 %{__rm} -f %{_datadir}/lyx/{doc/LaTeXConfig.lyx,packages.lst}
f05d6e39
JB
124fi
125
126%postun
127umask 022
128/usr/bin/texhash
1805b0b6 129
0cb20aec 130%files -f %{name}.lang
e0cff8f0 131%defattr(644,root,root,755)
eb9019bc 132%doc ANNOUNCE README NEWS
d10c5671 133%attr(755,root,root) %{_bindir}/*
f05d6e39 134%dir %{texmfdir}/tex/latex/lyx
a14f5ed6 135%dir %{_datadir}/lyx
a6482ea0 136%dir %{_datadir}/lyx/commands
a14f5ed6
JB
137%{_datadir}/lyx/CREDITS
138%{_datadir}/lyx/bind
139%{_datadir}/lyx/chkconfig.ltx
a6482ea0 140%{_datadir}/lyx/commands/default.def
6b8f90ca 141%{_datadir}/lyx/doc/clipart
a14f5ed6
JB
142%attr(755,root,root) %{_datadir}/lyx/configure*
143%dir %{_datadir}/lyx/doc
144%{_datadir}/lyx/doc/[A-Z]*
4048bbbf 145%{_datadir}/lyx/doc/biblio
a6482ea0 146%lang(ca) %{_datadir}/lyx/doc/ca
6b8f90ca
SS
147%lang(cs) %{_datadir}/lyx/doc/cs
148%lang(da) %{_datadir}/lyx/doc/da
149%lang(de) %{_datadir}/lyx/doc/de
3066fbb3 150%lang(el) %{_datadir}/lyx/doc/el
6b8f90ca
SS
151%lang(es) %{_datadir}/lyx/doc/es
152%lang(eu) %{_datadir}/lyx/doc/eu
153%lang(fr) %{_datadir}/lyx/doc/fr
58b05a71 154%lang(gl) %{_datadir}/lyx/doc/gl
6b8f90ca
SS
155%lang(he) %{_datadir}/lyx/doc/he
156%lang(hu) %{_datadir}/lyx/doc/hu
24e37cc0 157%lang(id) %{_datadir}/lyx/doc/id
6b8f90ca 158%lang(it) %{_datadir}/lyx/doc/it
a6482ea0 159%lang(ja) %{_datadir}/lyx/doc/ja
6b8f90ca
SS
160%lang(nb) %{_datadir}/lyx/doc/nb
161%lang(nl) %{_datadir}/lyx/doc/nl
162%lang(pl) %{_datadir}/lyx/doc/pl
163%lang(pt) %{_datadir}/lyx/doc/pt
164%lang(ro) %{_datadir}/lyx/doc/ro
165%lang(ru) %{_datadir}/lyx/doc/ru
166%lang(sk) %{_datadir}/lyx/doc/sk
167%lang(sl) %{_datadir}/lyx/doc/sl
168%lang(sv) %{_datadir}/lyx/doc/sv
a6482ea0 169%lang(uk) %{_datadir}/lyx/doc/uk
3066fbb3 170%lang(zh_CN) %{_datadir}/lyx/doc/zh_CN
ec867db3 171%{_datadir}/lyx/autocorrect
a14f5ed6
JB
172%{_datadir}/lyx/encodings
173%{_datadir}/lyx/examples
174%{_datadir}/lyx/external_templates
6b8f90ca 175%{_datadir}/lyx/fonts/
a14f5ed6
JB
176%{_datadir}/lyx/images
177%{_datadir}/lyx/kbd
178%{_datadir}/lyx/languages
179%{_datadir}/lyx/layouts
c0ca5849 180%{_datadir}/lyx/layouttranslations
a14f5ed6 181%attr(755,root,root) %{_datadir}/lyx/lyx2lyx
a14f5ed6
JB
182%attr(755,root,root) %{_datadir}/lyx/scripts
183%{_datadir}/lyx/symbols
cfc9bd82 184%{_datadir}/lyx/syntax.default
a14f5ed6
JB
185%{_datadir}/lyx/templates
186%{_datadir}/lyx/tex
a14f5ed6 187%{_datadir}/lyx/ui
f24ee4c7 188%{_datadir}/lyx/unicodesymbols
0f1067b7 189%{_mandir}/man*/*
569643cd 190%{_desktopdir}/*.desktop
ec47df1f 191%{_pixmapsdir}/*
This page took 0.114684 seconds and 4 git commands to generate.