]> git.pld-linux.org Git - packages/lvm2.git/blame - lvm2.spec
- updated to 2.02.106
[packages/lvm2.git] / lvm2.spec
CommitLineData
e3a928dc 1# TODO
e3a928dc 2# - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
5f0ee085 3# - --with-replicators (=internal/shared/none, default is none)?
1b67453e 4#
99958222 5# Conditional build:
8b89021c 6%bcond_with initrd # don't build initrd version
fe052975
JR
7%bcond_without uClibc # link initrd version with uClibc
8%bcond_with dietlibc # link initrd version with dietlibc
5f0ee085 9%bcond_with glibc # link initrd version with static GLIBC
7e873dd0 10%bcond_without cluster # disable all cluster support (clvmd&cmirrord)
43435358 11%bcond_without lvmetad # disable lvmetad
c70b42f6
JR
12%bcond_without selinux # disable SELinux
13
4a323c26 14%ifarch sparc64 sparc
c70b42f6 15%define with_glibc 1
66800f6a 16%endif
c70b42f6
JR
17
18# if one of the *libc is enabled disable default dietlibc
19%if %{with dietlibc} && %{with uClibc}
20%undefine with_dietlibc
21%endif
22
f1e27504 23# with glibc disables default dietlibc
c70b42f6
JR
24%if %{with glibc} && %{with dietlibc}
25%undefine with_dietlibc
26%endif
27
f1e27504
ER
28# fallback is glibc if neither alternatives are enabled
29%if %{without dietlibc} && %{without uClibc}
30%define with_glibc 1
31%endif
32
5672aa67 33Summary: The new version of Logical Volume Manager for Linux
6536e848 34Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa
7e72c866 35Name: lvm2
0442bdaf
JB
36Version: 2.02.106
37Release: 1
0a81c260 38License: GPL v2 and LGPL v2.1
7e72c866 39Group: Applications/System
dc5d0e77 40Source0: ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
0442bdaf 41# Source0-md5: 77f84279fb649b3dc4edad1c6d1a1b0e
c386faf9 42Source1: %{name}-tmpfiles.conf
0d673991
JK
43Source2: clvmd.service
44Source3: clvmd.sysconfig
7210a095 45Patch0: %{name}-selinux.patch
c70b42f6 46Patch1: %{name}-diet.patch
9a00e98a 47Patch2: device-mapper-dmsetup-export.patch
4cb4934b 48Patch3: %{name}-pld_init.patch
b747c17a 49Patch4: dl-dlsym.patch
4cb4934b
JK
50Patch5: %{name}-wrapper.patch
51Patch6: %{name}-lvm_path.patch
7d8cfaa5 52Patch7: %{name}-sd_notify.patch
105f82c3 53Patch8: %{name}-clvmd_cmd_timeout.patch
14fc1988 54Patch9: device-mapper-dmsetup-deps-export.patch
dc5d0e77 55URL: http://sources.redhat.com/lvm2/
5f0ee085 56BuildRequires: autoconf >= 2.61
7e72c866 57BuildRequires: automake
0dc2b8f2 58%{?with_selinux:BuildRequires: libselinux-devel >= 1.10}
e4a12efb 59%{?with_selinux:BuildRequires: libsepol-devel}
5f0ee085 60BuildRequires: ncurses-devel
3657a56d 61BuildRequires: pkgconfig
5f0ee085 62BuildRequires: readline-devel
b5640c74 63BuildRequires: rpmbuild(macros) >= 1.647
e55d5c02 64BuildRequires: udev-devel >= 1:143
1ccfba6c 65%if %{with initrd}
fa9e8aeb 66%if %{with dietlibc}
39c8d1d5 67BuildRequires: dietlibc-static >= 2:0.32-7
fa9e8aeb
AM
68BuildConflicts: device-mapper-dietlibc
69%endif
b64b85c5
ER
70%if %{with glibc}
71%{?with_selinux:BuildRequires: libselinux-static}
72%{?with_selinux:BuildRequires: libsepol-static}
73%endif
c70b42f6
JR
74%{?with_glibc:BuildRequires: glibc-static}
75%{?with_uClibc:BuildRequires: uClibc-static >= 2:0.9.29}
1ccfba6c 76%endif
7e873dd0 77%if %{with cluster}
5f0ee085 78BuildRequires: corosync-devel
4cb4934b 79BuildRequires: dlm-devel >= 3.99.5
7d8cfaa5 80BuildRequires: systemd-devel
5f0ee085 81%endif
b5640c74 82Requires(post,preun,postun): systemd-units >= 38
0a81c260 83Requires(post,postun): /sbin/chkconfig
b167057a 84Requires: device-mapper >= %{version}-%{release}
0dc2b8f2 85%{?with_selinux:Requires: libselinux >= 1.10}
b5640c74 86Requires: systemd-units >= 38
1534f04d
ER
87# doesn't work with 2.4 kernels
88Requires: uname(release) >= 2.6
25b6b609 89Obsoletes: lvm
c35cea65 90Obsoletes: lvm2-systemd
7e72c866
JR
91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93%define _sbindir /sbin
9ab13f24 94%define _usrsbindir /usr/sbin
7e72c866 95
0fbd6aae
ER
96# changing CFLAGS in the middle confuses confcache
97%undefine configure_cache
98
87a7d834
ER
99# borken on AC
100%define filterout_ld -Wl,--as-needed
101
4cb4934b
JK
102# causes: undefined reference to `__stack_chk_fail_local'
103%define filterout_c -fstack-protector
104
c70b42f6
JR
105# for some reason known only to rpm there must be "\\|" not "\|" here
106%define dietarch %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
107%define dietlibdir %{_prefix}/lib/dietlibc/lib-%{dietarch}
108
f8fa85d0
PS
109%define skip_post_check_so '.*libdevmapper-event-lvm2.so.*'
110
7e72c866
JR
111%description
112This package includes a number of utilities for creating, checking,
113and repairing logical volumes.
114
68d45726
JR
115%description -l pl.UTF-8
116Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
117logicznych wolumenów dyskowych (LVM2).
7e72c866 118
7e72c866 119%package initrd
5672aa67 120Summary: The new version of Logical Volume Manager for Linux - initrd version
6536e848 121Summary(pl.UTF-8): Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
7e72c866 122Group: Base
16ddcbd0 123Conflicts: geninitrd < 10000.18
7e72c866
JR
124
125%description initrd
126This package includes a number of utilities for creating, checking,
127and repairing logical volumes - staticaly linked for initrd.
128
68d45726
JR
129%description initrd -l pl.UTF-8
130Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
131logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
7e72c866
JR
132potrzeby initrd.
133
7e873dd0
JK
134%package clvmd
135Summary: Cluster LVM daemon
136Summary(pl.UTF-8): Demon clustra LVM
137Group: Applications/System
1aa2f585 138Requires: %{name} = %{version}-%{release}
7e873dd0
JK
139
140%description clvmd
4cb4934b
JK
141clvmd is the daemon that distributes LVM metadata updates around a
142cluster. It must be running on all nodes in the cluster and will give
143an error if a node in the cluster does not have this daemon running.
7e873dd0
JK
144
145%description clvmd -l pl.UTF-8
146clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
4cb4934b
JK
147Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
148węzeł w klastrze nie ma tego demona uruchomionego.
7e873dd0
JK
149
150%package cmirrord
151Summary: Cluster mirror log daemon
152Group: Applications/System
1aa2f585 153Requires: %{name} = %{version}-%{release}
7e873dd0
JK
154
155%description cmirrord
4cb4934b
JK
156cmirrord is the daemon that tracks mirror log information in a
157cluster. It is specific to device-mapper based mirrors (and by
158extension, LVM cluster mirrors). Cluster mirrors are not possible
159without this daemon running.
7e873dd0 160
4cb4934b
JK
161This daemon relies on the cluster infrastructure provided by the
162Cluster MANager (CMAN), which must be set up and running in order for
163cmirrord to function.
7e873dd0 164
e55d5c02
JB
165%package resource-agents
166Summary: OCF Resource Agents for LVM2 processes
167Summary(pl.UTF-8): Agenci OCF do monitorowania procesów LVM2
168Group: Applications/System
169Requires: %{name} = %{version}-%{release}
170Requires: resource-agents
171
172%description resource-agents
173OCF Resource Agents for LVM2 processes.
174
175%description resource-agents -l pl.UTF-8
176Agenci OCF do monitorowania procesów LVM2.
177
b167057a
AM
178%package -n device-mapper
179Summary: Userspace support for the device-mapper
180Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
181Group: Base
e7dd8435 182Requires(post,postun): /sbin/ldconfig
798d7327 183Requires(post,preun,postun): systemd-units >= 38
b5640c74 184Requires: systemd-units >= 38
b167057a
AM
185
186%description -n device-mapper
187The goal of this driver is to support volume management. The driver
188enables the definition of new block devices composed of ranges of
189sectors of existing devices. This can be used to define disk
190partitions - or logical volumes. This light-weight kernel component
191can support user-space tools for logical volume management.
192
193%description -n device-mapper -l pl.UTF-8
194Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
195włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
196sektorów na istniejących urządzeniach. Może to być wykorzystane do
197definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
198składnik jądra może wspierać działające w przestrzeni użytkownika
199narzędzia do zarządzania logicznymi wolumenami.
200
201%package -n device-mapper-devel
202Summary: Header files and development documentation for %{name}
203Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do %{name}
204Group: Development/Libraries
205Requires: device-mapper = %{version}-%{release}
206%if %{with selinux}
207Requires: libselinux-devel
208Requires: libsepol-devel
209%endif
210
211%description -n device-mapper-devel
212Header files and development documentation for %{name}.
213
214%description -n device-mapper-devel -l pl.UTF-8
215Pliki nagłówkowe i dokumentacja do %{name}.
216
217%package -n device-mapper-static
218Summary: Static devmapper library
219Summary(pl.UTF-8): Statyczna biblioteka devmapper
220License: LGPL v2.1
221Group: Development/Libraries
dc900ced 222Requires: device-mapper-devel = %{version}-%{release}
b167057a
AM
223
224%description -n device-mapper-static
225Static devmapper library.
226
227%description -n device-mapper-static -l pl.UTF-8
228Statyczna biblioteka devmapper.
229
c70b42f6
JR
230%package -n device-mapper-dietlibc
231Summary: Static devmapper library built with dietlibc
232Summary(pl.UTF-8): Statyczna biblioteka devmapper zbudowana z dietlibc
233License: LGPL v2.1
234Group: Development/Libraries
235Requires: device-mapper-devel = %{version}-%{release}
236
237%description -n device-mapper-dietlibc
238Static devmapper library built with dietlibc.
239
240%description -n device-mapper-dietlibc -l pl.UTF-8
241Statyczna biblioteka devmapper zbudowana z dietlibc.
242
4a323c26
JR
243%package -n device-mapper-initrd
244Summary: Userspace support for the device-mapper - initrd version
245Summary(pl.UTF-8): Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
246Group: Base
247Obsoletes: device-mapper-initrd-devel
1f7434e8 248Conflicts: geninitrd < 10000.10
4a323c26
JR
249
250%description -n device-mapper-initrd
251The goal of this driver is to support volume management. The driver
252enables the definition of new block devices composed of ranges of
253sectors of existing devices. This can be used to define disk
254partitions - or logical volumes. This light-weight kernel component
255can support user-space tools for logical volume management.
256
257This package contains dmsetup program linked staticaly for use in
258initrd.
259
260%description -n device-mapper-initrd -l pl.UTF-8
261Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
262włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
263sektorów na istniejących urządzeniach. Może to być wykorzystane do
264definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
265składnik jądra może wspierać działające w przestrzeni użytkownika
266narzędzia do zarządzania logicznymi wolumenami.
267
268Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
269potrzeby initrd.
270
7e72c866 271%prep
ec2de926 272%setup -q -n LVM2.%{version}
7210a095 273%{?with_selinux:%patch0 -p1}
c70b42f6 274%patch1 -p1
9a00e98a 275%patch2 -p1
f0dab9f1 276%patch3 -p1
b747c17a 277%patch4 -p1
b08139b7 278%patch5 -p1
eaa437a5 279%patch6 -p1
7d8cfaa5 280%patch7 -p1
105f82c3 281%patch8 -p1
14fc1988 282%patch9 -p1
b167057a 283
39c8d1d5 284# do not force --export-symbol linker option for e.g. statically linked executables
b5eb9717
PS
285# -rdynamic compiler option drives linker in the right way.
286%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
287
7e72c866 288%build
87a7d834
ER
289%if %{with initrd}
290echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
291%endif
242ffb9a 292cp -f /usr/share/automake/config.sub autoconf
7e72c866
JR
293%{__aclocal}
294%{__autoconf}
295
99958222 296%if %{with initrd}
6c31051f
PS
297%{?with_glibc:export CC="%{__cc}"}
298%{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
4cbea9f4 299%{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
6c31051f 300
9bdab2f4 301%configure \
a5702977 302 ac_cv_lib_dl_dlopen=no \
eaa437a5 303 %{?with_uClibc:ac_cv_func_siginterrupt=no} \
4c78aede 304 %{?debug:--enable-debug} \
43435358
JB
305 --disable-nls \
306 --disable-readline \
307 --enable-selinux%{!?with_glibc:=no} \
9bdab2f4 308 --enable-static_link \
69688a46 309 --with-lvm1=internal \
43435358 310 --with-optimisation="%{rpmcflags} -Os"
c70b42f6 311# glibc version links with normal static libdevicemapper which has selinux enabled
260d6858 312# and we need to keep these in sync between device-mapper and lvm2
4c78aede
ER
313
314%{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
0402cba0 315%{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
ec2de926 316
c7bbf0c8
AM
317%{__make} -j1 -C include
318%{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
319%{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
4cb4934b 320%{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
2afef789 321%{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
69688a46 322mv -f tools/lvm.static initrd-lvm
4a323c26 323mv -f tools/dmsetup.static initrd-dmsetup
7cef5d95
AM
324
325# check if tools works
326for tool in initrd-lvm initrd-dmsetup; do
cfa41a73 327 LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
7cef5d95 328 if [ $rc -gt 127 ]; then
cfa41a73 329 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
7cef5d95
AM
330 exit 1
331 fi
332done
333
334
c70b42f6 335%{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
9bdab2f4 336%{__make} clean
6c31051f
PS
337
338unset CC
7e72c866
JR
339%endif
340
9d0d1d5f 341%configure \
6e7a47a9 342 --enable-applib \
b167057a 343 --enable-cmdlib \
43435358 344 %{?debug:--enable-debug} \
b167057a 345 --enable-dmeventd \
43435358
JB
346 --enable-fsadm \
347 %{?with_lvmetad:--enable-lvmetad} \
e55d5c02 348 --enable-ocf \
43435358
JB
349 --enable-readline \
350 %{!?with_selinux:--disable-selinux} \
b167057a 351 --enable-pkgconfig \
5f0ee085
JB
352 --enable-udev_sync \
353 --enable-udev_rules \
43435358 354 --with-cluster=internal \
7e873dd0 355%if %{with cluster}
4cb4934b
JK
356 --with-clvmd=corosync \
357 --enable-cmirrord \
5cf18a89 358%endif
43435358
JB
359 --with-dmeventd-path=%{_sbindir}/dmeventd \
360 --with-interface=ioctl \
607d2229 361 --with-lvm1=internal \
43435358
JB
362 --with-mirrors=internal \
363 --with-optimisation="%{rpmcflags}" \
607d2229
AM
364 --with-pool=internal \
365 --with-snapshots=internal \
43435358 366 --with-systemdsystemunitdir=%{systemdunitdir} \
b5640c74 367 --with-thin=internal \
e55d5c02
JB
368 --with-thin-check=%{_sbindir}/thin_check \
369 --with-thin-dump=%{_sbindir}/thin_dump \
370 --with-thin-repair=%{_sbindir}/thin_repair \
589f4db4 371 --with-udev-prefix=/ \
43435358 372 --with-usrlibdir=%{_libdir}
589f4db4 373
b167057a 374%{__make} -j1
c7bbf0c8 375%{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
7e72c866
JR
376
377%install
378rm -rf $RPM_BUILD_ROOT
0d673991 379install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
c70b42f6 380%{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
7e72c866 381
9b82b6a5 382%{__make} install install_system_dirs install_systemd_units install_initscripts \
7e72c866 383 DESTDIR=$RPM_BUILD_ROOT \
1ccfba6c
AM
384 OWNER="" \
385 GROUP=""
7e72c866 386
4cb4934b 387install -d $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
798d7327 388cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
9b82b6a5 389
0d673991 390%if %{with cluster}
798d7327
ER
391cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
392cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
0d673991
JK
393%endif
394
b167057a
AM
395mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
396for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
397 lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
398 slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
399 ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
400done
401
1cfc154f
JR
402touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
403
88c67b5b
JR
404%if %{with initrd}
405install -d $RPM_BUILD_ROOT%{_libdir}/initrd
a3569314
ER
406install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
407install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
7e72c866 408
a3569314 409%{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
1306038e 410%endif
c70b42f6 411
a3569314 412cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
b167057a 413
7e72c866
JR
414%clean
415rm -rf $RPM_BUILD_ROOT
416
6e7a47a9
AM
417%post
418/sbin/chkconfig --add lvm2-monitor
419%service lvm2-monitor restart
c35cea65 420%systemd_post lvm2-monitor.service
4cb4934b
JK
421/sbin/chkconfig --add blk-availability
422# no service blk-availability restart
423%systemd_post blk-availability.service
c35cea65
JR
424
425%preun
426%systemd_preun lvm2-monitor.service
4cb4934b 427%systemd_preun blk-availability.service
6e7a47a9
AM
428
429%postun
430if [ "$1" = "0" ]; then
431 %service lvm2-monitor stop
432 /sbin/chkconfig --del lvm2-monitor
4cb4934b
JK
433 #no service blk-availability stop
434 /sbin/chkconfig --del blk-availability
6e7a47a9 435fi
c35cea65 436%systemd_reload
6e7a47a9 437
c35cea65
JR
438%triggerpostun -- %{name} < 2.02.94-1
439%systemd_trigger lvm2-monitor.service
b167057a 440
c35cea65
JR
441%post -n device-mapper
442/sbin/ldconfig
443%systemd_post dm-event.socket
9b82b6a5 444
c35cea65
JR
445%preun -n device-mapper
446%systemd_preun dm-event.socket dm-event.service
9b82b6a5 447
c35cea65
JR
448%postun -n device-mapper
449/sbin/ldconfig
9b82b6a5
BZ
450%systemd_reload
451
c35cea65
JR
452%triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
453%systemd_trigger dm-event.socket
454
161d6a19
JK
455%post clvmd
456/sbin/chkconfig --add clvmd
457# no service restart - it breaks current locks!
458export NORESTART=1
459%systemd_post clvmd.service
460# re-exec instead
461/usr/sbin/clvmd -S 2>/dev/null || :
462
463%preun clvmd
464%systemd_preun clvmd.service
465
466%postun clvmd
467if [ "$1" = "0" ]; then
468 %service clvmd stop
469 /sbin/chkconfig --del clvmd
470fi
471%systemd_reload
472
7e72c866
JR
473%files
474%defattr(644,root,root,755)
e6ac7970 475%doc README WHATS_NEW doc/*
4cb4934b 476%attr(755,root,root) %{_sbindir}/blkdeactivate
86418c14
JB
477%attr(755,root,root) %{_sbindir}/fsadm
478%attr(755,root,root) %{_sbindir}/lv*
479%attr(755,root,root) %{_sbindir}/pv*
480%attr(755,root,root) %{_sbindir}/vg*
86418c14 481%{_mandir}/man5/lvm.conf.5*
0442bdaf 482%{_mandir}/man7/lvmthin.7*
4cb4934b 483%{_mandir}/man8/blkdeactivate.8*
86418c14
JB
484%{_mandir}/man8/fsadm.8*
485%{_mandir}/man8/lv*.8*
486%{_mandir}/man8/pv*.8*
487%{_mandir}/man8/vg*.8*
99958222 488%attr(750,root,root) %dir %{_sysconfdir}/lvm
2316bf4d 489%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
e55d5c02
JB
490%attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
491%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/default.profile
ac328eef 492%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
43435358
JB
493%if %{with lvmetad}
494/lib/udev/rules.d/69-dm-lvm-metad.rules
495%endif
c35cea65 496%{_sysconfdir}/tmpfiles.d/lvm2.conf
4cb4934b 497%{systemdunitdir}/blk-availability.service
43435358
JB
498%if %{with lvmetad}
499%{systemdunitdir}/lvm2-lvmetad.service
500%{systemdunitdir}/lvm2-lvmetad.socket
501%endif
502%{systemdunitdir}/lvm2-monitor.service
503%{systemdunitdir}/lvm2-pvscan@.service
6e7a47a9
AM
504%dir %{_sysconfdir}/lvm/cache
505%ghost %{_sysconfdir}/lvm/cache/.cache
4cb4934b 506%attr(754,root,root) /etc/rc.d/init.d/blk-availability
43435358
JB
507%if %{with lvmetad}
508%attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
509%endif
6e7a47a9 510%attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
5388840f 511%dir %attr(700,root,root) /var/run/lvm
7e873dd0
JK
512
513%if %{with cluster}
514%files clvmd
515%defattr(644,root,root,755)
516%attr(755,root,root) %{_usrsbindir}/clvmd
517%attr(754,root,root) /etc/rc.d/init.d/clvmd
0d673991 518%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
0442bdaf 519%attr(755,root,root) /lib/systemd/lvm2-cluster-activation
0d673991 520%{systemdunitdir}/clvmd.service
0442bdaf
JB
521%{systemdunitdir}/lvm2-cluster-activation.service
522%{systemdunitdir}/lvm2-clvmd.service
7e873dd0
JK
523%{_mandir}/man8/clvmd.8*
524
7e873dd0
JK
525%files cmirrord
526%defattr(644,root,root,755)
527%attr(755,root,root) %{_usrsbindir}/cmirrord
7e873dd0 528%attr(754,root,root) /etc/rc.d/init.d/cmirrord
0442bdaf
JB
529%{systemdunitdir}/lvm2-cmirrord.service
530%{_mandir}/man8/cmirrord.8*
7e873dd0 531%endif
7e72c866 532
e55d5c02
JB
533%files resource-agents
534%defattr(644,root,root,755)
535%dir %{_prefix}/lib/ocf/resource.d/lvm2
536%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
537
b167057a
AM
538%files -n device-mapper
539%defattr(644,root,root,755)
540%doc *_DM
c35cea65
JR
541%{systemdunitdir}/dm-event.service
542%{systemdunitdir}/dm-event.socket
589f4db4
JR
543/lib/udev/rules.d/10-dm.rules
544/lib/udev/rules.d/11-dm-lvm.rules
545/lib/udev/rules.d/13-dm-disk.rules
546/lib/udev/rules.d/95-dm-notify.rules
b167057a
AM
547%attr(755,root,root) %{_sbindir}/dmeventd
548%attr(755,root,root) %{_sbindir}/dmsetup
549%attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
6e7a47a9 550%attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
b167057a 551%attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
1306038e
AM
552%dir %{_libdir}/device-mapper
553%attr(755,root,root) %{_libdir}/device-mapper/*.so
bece12dd 554%attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
b167057a 555%{_mandir}/man8/dmsetup.8*
f0dab9f1 556%{_mandir}/man8/dmeventd.8*
b167057a
AM
557
558%files -n device-mapper-devel
559%defattr(644,root,root,755)
bece12dd
JR
560%attr(755,root,root) %{_libdir}/libdevmapper.so
561%attr(755,root,root) %{_libdir}/libdevmapper-event.so
6e7a47a9 562%attr(755,root,root) %{_libdir}/liblvm2app.so
b167057a
AM
563%attr(755,root,root) %{_libdir}/liblvm2cmd.so
564%{_includedir}/libdevmapper*.h
6e7a47a9 565%{_includedir}/lvm2app.h
b167057a
AM
566%{_includedir}/lvm2cmd.h
567%{_pkgconfigdir}/devmapper*.pc
6e7a47a9 568%{_pkgconfigdir}/lvm2app.pc
b167057a
AM
569
570%files -n device-mapper-static
571%defattr(644,root,root,755)
572%{_libdir}/libdevmapper*.a
573
1306038e 574%if %{with initrd}
c70b42f6
JR
575%if %{with dietlibc}
576%files -n device-mapper-dietlibc
577%defattr(644,root,root,755)
578%{dietlibdir}/libdevmapper.a
579%endif
580
4a323c26
JR
581%files -n device-mapper-initrd
582%defattr(644,root,root,755)
88c67b5b 583%attr(755,root,root) %{_libdir}/initrd/dmsetup
4a323c26 584
7e72c866
JR
585%files initrd
586%defattr(644,root,root,755)
88c67b5b 587%attr(755,root,root) %{_libdir}/initrd/lvm
7e72c866 588%endif
This page took 0.202276 seconds and 4 git commands to generate.