]> git.pld-linux.org Git - packages/lsb-release.git/blame - lsb-release.spec
initial support for aarch64
[packages/lsb-release.git] / lsb-release.spec
CommitLineData
4c003edb 1
fce3c435
ER
2# Define this to link to which library version eg. /lib64/ld-lsb-x86-64.so.3
3%define lsbsover 3
1d41436e 4
899ced3a
JP
5%ifarch aarch64
6%global archname aarch64
7%global ldso ld-linux-aarch64.so.1
8%global lsbldso ld-lsb-aarch64.so
9%endif
4c003edb
ER
10%ifarch %{ix86}
11%define archname ia32
fce3c435
ER
12%define ldso ld-linux.so.2
13%define lsbldso ld-lsb.so
4c003edb
ER
14%endif
15%ifarch ia64
16%define archname ia64
fce3c435
ER
17%define ldso ld-linux-ia64.so.2
18%define lsbldso ld-lsb-ia64.so
4c003edb
ER
19%endif
20%ifarch ppc
21%define archname ppc32
fce3c435
ER
22%define ldso ld.so.1
23%define lsbldso ld-lsb-ppc32.so
4c003edb
ER
24%endif
25%ifarch ppc64
26%define archname ppc64
fce3c435
ER
27%define ldso ld64.so.1
28%define lsbldso ld-lsb-ppc64.so
4c003edb
ER
29%endif
30%ifarch s390
31%define archname s390
fce3c435
ER
32%define ldso ld.so.1
33%define lsbldso ld-lsb-s390.so
4c003edb
ER
34%endif
35%ifarch s390x
36%define archname s390x
fce3c435
ER
37%define ldso ld64.so.1
38%define lsbldso ld-lsb-s390x.so
4c003edb
ER
39%endif
40%ifarch %{x8664}
41%define archname amd64
fce3c435
ER
42%define ldso ld-linux-x86-64.so.2
43%define lsbldso ld-lsb-x86-64.so
4c003edb
ER
44%endif
45
65916f1f
JR
46%ifarch x32
47%define archname x32
48%define ldso ld-linux-x32.so.2
49%define lsbldso ld-lsb-x32.so
50%endif
51
899ced3a 52%ifarch ia64 ppc64 s390x x86_64 aarch64
fce3c435
ER
53%define qual ()(64bit)
54%else
65916f1f
JR
55%ifarch x32
56%define qual ()(x32bit)
57%else
fce3c435
ER
58%define qual %{nil}
59%endif
65916f1f 60%endif
fce3c435
ER
61
62Summary: LSB base libraries support for PLD Linux
63Summary(pl.UTF-8): Narzędzia LSB (Linux Standard Base)
64Name: lsb-release
65Version: 4.0
45a09d50 66Release: 2
fce3c435
ER
67License: GPL v2+
68Group: Base
69#Source0: http://dl.sourceforge.net/lsb/%{name}-2.0.tar.gz
70Source0: %{name}-2.0.tar.bz2
71# Source0-md5: cf40f5c02016bc61db03591cc3ea1ca2
72Patch0: %{name}-make.patch
73URL: http://www.linuxbase.org/
74BuildRequires: help2man
75BuildRequires: rpm >= 4.4.9-56
76BuildRequires: util-linux
77Requires: coreutils
78Requires: glibc
79Requires: util-linux
899ced3a 80ExclusiveArch: %{ix86} ia64 %{x8664} x32 ppc ppc64 s390 s390x aarch64
fce3c435
ER
81# dependency for primary LSB application for v1.3
82Provides: lsb = %{version}
83# dependency for primary LSB application for v2.0 and v3.0
84Provides: lsb-core-%{archname} = %{version}
85Provides: lsb-core-noarch = %{version}
86BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88# no payload
89%define _enable_debug_packages 0
90
17e7047e 91%description
bcf47b5c
JB
92LSB version query program. This program forms part of the required
93functionality of the LSB (Linux Standard Base) specification.
4c003edb
ER
94
95The program queries the installed state of the distribution to display
96certain properties such as the version of the LSB against which the
97distribution claims compliance as well. It can also attempt to display
98the name and release of the distribution along with an identifier of
99who produces the distribution.
17e7047e 100
bcf47b5c
JB
101%description -l pl.UTF-8
102Program do sprawdzania wersji LSB. Stanowi część wymaganej
103funkcjonalności specyfikacji LSB (Linux Standard Base).
104
105Program sprawdza stan instalacji dystrybucji, wyświetlając określone
106właściwości, takie jak wersja LSB z którą zgodna ma być dystrybucja.
107Może także próbować wyświetlić nazwę i wersję dystrybucji wraz z
108identyfikatorem producenta.
109
fce3c435
ER
110%package graphics
111Summary: LSB graphics libraries support for PLD Linux
112Group: Base
113Requires: %{name} = %{version}-%{release}
114Provides: lsb-graphics-%{archname} = %{version}
115Provides: lsb-graphics-noarch = %{version}
116
117%description graphics
118The Linux Standard Base (LSB) Graphics Specifications define
119components that are required to be present on an LSB conforming
120system.
121
122%package printing
123Summary: LSB printing libraries support for PLD Linux
124Group: Base
125Provides: lsb-printing-%{archname} = %{version}
126Provides: lsb-printing-noarch = %{version}
127
128%description printing
129The Linux Standard Base (LSB) Printing Specifications define
130components that are required to be present on an LSB conforming
131system.
132
17e7047e 133%prep
4c003edb 134%setup -q -n %{name}-2.0
17e7047e
ER
135%patch0 -p1
136
137%build
138%{__make}
139
140%install
141rm -rf $RPM_BUILD_ROOT
142%{__make} install \
143 DESTDIR=$RPM_BUILD_ROOT
144
4c003edb
ER
145install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d
146cat > $RPM_BUILD_ROOT%{_sysconfdir}/lsb-release << 'EOF'
bcf47b5c 147LSB_VERSION=lsb-%{version}-%{archname}:lsb-%{version}-noarch
4c003edb 148DISTRIB_ID=PLD
56951643
ER
149DISTRIB_DESCRIPTION="PLD Linux"
150%if "%{pld_release}" == "ac"
151DISTRIB_RELEASE=2.0
152DISTRIB_CODENAME=Ac
153%endif
154%if "%{pld_release}" == "th"
4c003edb
ER
155DISTRIB_RELEASE=3.0
156DISTRIB_CODENAME=Th
56951643 157%endif
4c003edb 158EOF
56951643
ER
159%if "%{pld_release}" == "ti"
160exit 1
161%endif
ac0b0c4c
PZ
162touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/core-%{version}-%{archname}
163touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/core-%{version}-noarch
164touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/graphics-%{version}-%{archname}
165touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/graphics-%{version}-noarch
fce3c435
ER
166touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/printing-%{version}-%{archname}
167touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/printing-%{version}-noarch
168
169install -d $RPM_BUILD_ROOT/%{_lib}
170ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.%{lsbsover}
4c003edb 171
17e7047e
ER
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175%files
176%defattr(644,root,root,755)
fce3c435 177%attr(755,root,root) /%{_lib}/%{lsbldso}.%{lsbsover}
17e7047e
ER
178%attr(755,root,root) %{_bindir}/lsb_release
179%{_mandir}/man1/lsb_release.1*
fce3c435
ER
180%{_sysconfdir}/lsb-release
181%dir %{_sysconfdir}/%{name}.d
182# These files are needed because they shows which LSB we're supporting now,
183# for example, if core-3.1-noarch exists, it means we are supporting LSB3.1 now
184%{_sysconfdir}/%{name}.d/core*
185
186%files graphics
187%defattr(644,root,root,755)
188%{_sysconfdir}/%{name}.d/graphics*
189
190%files printing
191%defattr(644,root,root,755)
192%{_sysconfdir}/%{name}.d/printing*
This page took 0.103853 seconds and 4 git commands to generate.