]> git.pld-linux.org Git - packages/llvm-libcxx.git/blame - llvm-libcxx.spec
- updated cmake version
[packages/llvm-libcxx.git] / llvm-libcxx.spec
CommitLineData
82a35335
JB
1#
2# Conditional build:
3%bcond_with gnu # GNU libstdc++/libsupc++ ABI instead of LLVM libcxxabi
4#
5Summary: LibC++ - C++ standard library from LLVM project
6Summary(pl.UTF-8): LibC++ - biblioteka standardowa C++ z projektu LLVM
7Name: llvm-libcxx
76d0d499 8Version: 3.9.0
82a35335
JB
9Release: 1
10License: MIT or BSD-like
11Group: Libraries
5926edea 12#Source0Download: http://llvm.org/releases/download.html
82a35335 13Source0: http://llvm.org/releases/%{version}/libcxx-%{version}.src.tar.xz
76d0d499 14# Source0-md5: 0a11efefd864ce6f321194e441f7e569
f97f72f9 15URL: http://libcxx.llvm.org/
908067b5 16BuildRequires: cmake >= 3.4.3
82a35335
JB
17BuildRequires: rpmbuild(macros) >= 1.605
18%if %{with gnu}
19BuildRequires: libstdc++-devel
20%else
21BuildRequires: llvm-libcxxabi-devel
22%endif
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26libc++ is a new implementation of the C++ standard library, targeting
27C++11.
28
29%description -l pl.UTF-8
30libc++ to nowa implementacja biblioteki standardowej C++ ze wskazaniem
31na standard C++11.
32
33%package devel
34Summary: Header files of LLVM LibC++ library
35Summary(pl.UTF-8): Pliki nagłówkowe biblioteki LLVM LibC++
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38%if %{with gnu}
39Requires: libstdc++-devel
40%else
41Requires: llvm-libcxxabi-devel
42%endif
43
44%description devel
45Header files of LLVM LibC++ library.
46
47%description devel -l pl.UTF-8
48Pliki nagłówkowe biblioteki LLVM LibC++.
49
50%prep
51%setup -q -n libcxx-%{version}.src
52
53%build
54install -d build
55cd build
800c4e33 56libsubdir=%{_lib}
82a35335 57%cmake .. \
800c4e33
JB
58 -DLIBCXX_ENABLE_CXX1Y=ON \
59 -DLIBCXX_LIBDIR_SUFFIX="${libsubdir#lib}" \
82a35335
JB
60%if %{with gnu}
61 -DLIBCXX_CXX_ABI=libstdc++ \
800c4e33 62 -DLIBCXX_CXX_ABI_INCLUDE_PATHS="%{_includedir}/c++/%{cxx_version};%{_includedir}/c++/%{cxx_version}/%{_host}"
82a35335 63%else
5926edea 64 -DLIBCXX_CXX_ABI=libcxxabi \
800c4e33 65 -DLIBCXX_CXX_ABI_INCLUDE_PATHS="%{_includedir}/libcxxabi"
82a35335
JB
66%endif
67
68%{__make}
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73%{__make} -C build install \
74 DESTDIR=$RPM_BUILD_ROOT
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post -p /sbin/ldconfig
80%postun -p /sbin/ldconfig
81
82%files
83%defattr(644,root,root,755)
84%doc CREDITS.TXT LICENSE.TXT
85%attr(755,root,root) %{_libdir}/libc++.so.*.*
86%attr(755,root,root) %ghost %{_libdir}/libc++.so.1
87
88%files devel
89%defattr(644,root,root,755)
90%attr(755,root,root) %{_libdir}/libc++.so
91%dir %{_includedir}/c++
92%{_includedir}/c++/v1
This page took 0.048022 seconds and 4 git commands to generate.