]> git.pld-linux.org Git - packages/lldpd.git/blame - lldpd.spec
builds
[packages/lldpd.git] / lldpd.spec
CommitLineData
02b06a19
PG
1## TODO:
2# - separate package with client and daemon (possible?)
3
4Summary: Implementation of IEEE 802.1AB, EDP and CDP
5Summary(pl.UTF-8): Implementacja IEEE 802.1AB, EDP oraz CDP
9c8bdeec
PG
6Name: lldpd
7Version: 0.5.7
8Release: 0.1
9License: GPL
10Group: Networking
9c8bdeec 11Source0: http://media.luffy.cx/files/lldpd/%{name}-%{version}.tar.gz
02b06a19 12# Source0-md5: 3db3a80fa6a384cd59e9d6a42ce7b630
9c8bdeec
PG
13#Source2: %{name}-lldpd.init
14#Source3: %{name}-lldpd.sysconfig
15#Source4: %{name}-lldpd.service
16URL: https://github.com/vincentbernat/lldpd/wiki
17BuildRequires: autoconf >= 1.5
18BuildRequires: automake
19BuildRequires: libconfuse-devel
20Requires(post,preun,postun): systemd-units >= 38
21Requires: systemd-units >= 38
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25LLDP (Link Layer Discovery Protocol) (also known as 802.1ab) is an
26industry standard protocol designed to supplant proprietary Link-Layer
27protocols such as Extreme's EDP (Extreme Discovery Protocol) and CDP
28(Cisco Discovery Protocol). The goal of LLDP is to provide an
29inter-vendor compatible mechanism to deliver Link-Layer notifications
30to adjacent network devices.
31
32lldpd is a lldp daemon for GNU/Linux and implements both reception and
33sending. It supports both LLDP and LLDP-MED (contributed by Michael
34Hanig). It also implements an SNMP subagent for net-snmp to get local
35and remote LLDP information. The LLDP MIB is partially implemented but
36the most useful tables are here.
37
38lldpd supports bridge, vlan and bonding. bonding need to be done on
39real physical devices, not on bridges, vlans, etc. However, vlans can
40be mapped on the bonding device. You can bridge vlan but not add vlans
41on bridges. More complex setups may give false results.
42
43%prep
44%setup -q
45
46%build
9c8bdeec
PG
47%configure
48%{__make}
49
50%install
51rm -rf $RPM_BUILD_ROOT
02b06a19 52#install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{systemdunitdir}}
9c8bdeec
PG
53
54%{__make} install \
55 DESTDIR=$RPM_BUILD_ROOT
56
57#install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/lldpd
58#install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/lldpd
59#install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/lldpd.service
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%post
65/sbin/chkconfig --add lldpd
66%service lldpd restart "LLDP Daemon"
67%systemd_post lldpd.service
68
69%preun
70if [ "$1" = "0" ]; then
71 %service lldpd stop
72 /sbin/chkconfig --del lldpd
73fi
74%systemd_preun lldpd.service
75
76%postun
77%systemd_reload
78
79%triggerpostun -- openlldp < 0.4
80%systemd_trigger lldpd.service
81
82%files
83%defattr(644,root,root,755)
02b06a19 84%doc CHANGELOG README.md
9c8bdeec
PG
85#%attr(754,root,root) /etc/rc.d/init.d/lldpd
86#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lldpd
87#%{systemdunitdir}/lldpd.service
02b06a19
PG
88%attr(755,root,root) %{_sbindir}/lldpd
89%attr(755,root,root) %{_sbindir}/lldpctl
90%{_mandir}/man8/lldpd.8*
91%{_mandir}/man8/lldpctl.8*
92
This page took 0.047781 seconds and 4 git commands to generate.