]> git.pld-linux.org Git - packages/litecoin.git/blame - litecoin.spec
- rel 5, fix building qith qt 5.15
[packages/litecoin.git] / litecoin.spec
CommitLineData
d8766286 1Summary: Litecoin is a peer-to-peer currency
02fa6eee 2Summary(pl.UTF-8): Litecoin - waluta peer-to-peer
d8766286 3Name: litecoin
2f0e7ae9 4Version: 0.17.1
a01bc00d 5Release: 5
02fa6eee 6License: MIT
d8766286 7Group: X11/Applications
3ec6a0cf
JB
8#Sourrce0Download: https://github.com/litecoin-project/litecoin/releases
9Source0: https://download.litecoin.org/litecoin-%{version}/src/%{name}-%{version}.tar.gz
2f0e7ae9 10# Source0-md5: 7a486f0b5edcbbe3ea959ae8877e9672
a01bc00d 11Patch0: qt-5.15.patch
9719e2ba 12URL: http://www.litecoin.org/
2f0e7ae9
JB
13BuildRequires: Qt5Core-devel >= 5.4
14BuildRequires: Qt5DBus-devel >= 4
15BuildRequires: Qt5Gui-devel >= 4
16BuildRequires: Qt5Network-devel >= 4
17BuildRequires: Qt5Widgets-devel >= 4
18BuildRequires: autoconf >= 2.60
19BuildRequires: automake
02fa6eee
JB
20BuildRequires: boost-devel >= 1.49
21BuildRequires: db-cxx-devel >= 4.8
22BuildRequires: gettext-tools
2f0e7ae9 23BuildRequires: libevent-devel >= 2
02fa6eee
JB
24BuildRequires: libstdc++-devel >= 6:4.7
25BuildRequires: libtool >= 2:2
2f0e7ae9 26BuildRequires: libunivalue-devel >= 1.0.4
d8766286
AM
27BuildRequires: miniupnpc-devel >= 1.5
28BuildRequires: openssl-devel
02fa6eee 29BuildRequires: pkgconfig
3ec6a0cf 30BuildRequires: python3 >= 1:3.4
02fa6eee 31BuildRequires: protobuf-devel
d8766286 32BuildRequires: qrencode-devel
2f0e7ae9
JB
33BuildRequires: qt5-linguist >= 5.4
34BuildRequires: qt5-qmake >= 5.4
02fa6eee 35BuildRequires: zeromq-devel >= 4
2f0e7ae9 36Requires: libunivalue >= 1.0.4
d8766286
AM
37Requires: perl-base
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
9719e2ba
ER
41Litecoin is a peer-to-peer currency. Peer-to-peer means that no
42central authority issues new money or tracks transactions. These tasks
43are managed collectively by the network.
d8766286 44
02fa6eee
JB
45%description -l pl.UTF-8
46Litecoin to waluta peer-to-peer. Oznacza to, że nie ma centralnej
47instytucji emitującej nowe pieniądze czy śledzącej transakcje. Zadania
48te są zarządzane kolektywnie przez sieć.
49
d8766286
AM
50%package qt
51Summary: Qt-based Litecoin Wallet
02fa6eee 52Summary(pl.UTF-8): Portfel na litecoiny oparty na Qt
d8766286 53Group: X11/Applications
02fa6eee 54Requires: %{name} = %{version}-%{release}
d8766286
AM
55
56%description qt
57Qt-based Litecoin Wallet.
58
02fa6eee
JB
59%description qt -l pl.UTF-8
60Portfel na litecoiny oparty na Qt.
61
d8766286
AM
62%prep
63%setup -q
a01bc00d 64%patch0 -p1
d8766286
AM
65
66%build
02fa6eee
JB
67%{__libtoolize}
68%{__aclocal} -I build-aux/m4
69%{__autoconf}
70%{__autoheader}
71%{__automake}
2d02f65f
JB
72cd src/secp256k1
73%{__libtoolize}
74%{__aclocal} -I build-aux/m4
75%{__autoconf}
76%{__autoheader}
77%{__automake}
78cd ../..
14f2443c
AM
79%configure \
80 --disable-shared \
81 --disable-silent-rules \
14f2443c 82 --with-boost \
2f0e7ae9 83 --with-gui=qt5 \
02fa6eee
JB
84 --with-incompatible-bdb \
85 --with-miniupnpc \
86 --with-qrencode \
87 --with-qtdbus \
88 --with-system-univalue
14f2443c 89%{__make}
d8766286
AM
90
91%install
92rm -rf $RPM_BUILD_ROOT
14f2443c 93install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_datadir}/kde4/services}
d8766286 94
14f2443c
AM
95%{__make} install \
96 DESTDIR=$RPM_BUILD_ROOT
97
02fa6eee
JB
98# shared disabled, development packages present in bitcoin.spec and feathercoin.spec
99%{__rm} -r $RPM_BUILD_ROOT{%{_libdir}/libbitcoinconsensus.*,%{_includedir}/bitcoinconsensus.h,%{_pkgconfigdir}/libbitcoinconsensus.pc}
100
3ec6a0cf
JB
101# see contrib/rpm/bitcoin.spec
102
103cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/litecoin-qt.desktop
104[Desktop Entry]
105Encoding=UTF-8
8e1b8717 106Name=Litecoin
3ec6a0cf
JB
107Comment=Litecoin P2P Cryptocurrency
108Comment[fr]=Litecoin, monnaie virtuelle cryptographique pair à pair
109Comment[pl]=Litecoin - kryptowaluta P2P
110Comment[tr]=Litecoin, eşten eşe kriptografik sanal para birimi
111Exec=litecoin-qt %u
112Terminal=false
113Type=Application
8e1b8717
JB
114Icon=bitcoin
115MimeType=x-scheme-handler/litecoin;
3ec6a0cf
JB
116Categories=Office;Finance;
117EOF
118
119cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/litecoin-qt.protocol
120[Protocol]
121exec=litecoin-qt '%u'
122protocol=litecoin
123input=none
124output=none
125helper=true
126listing=
127reading=false
128writing=false
129makedir=false
130deleting=false
131EOF
132
133cp -p share/pixmaps/bitcoin.ico $RPM_BUILD_ROOT%{_pixmapsdir}
134cp -p share/pixmaps/nsis-*.bmp $RPM_BUILD_ROOT%{_pixmapsdir}
d8766286
AM
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%files
140%defattr(644,root,root,755)
3ec6a0cf 141%doc COPYING doc/{README,REST-interface,assets-attribution,benchmarking,bips,dependencies,dnsseed-policy,reduce-traffic,release-notes*,shared-libraries,tor,zmq}.md doc/release-notes
d8766286 142%attr(755,root,root) %{_bindir}/litecoind
14f2443c
AM
143%attr(755,root,root) %{_bindir}/litecoin-cli
144%attr(755,root,root) %{_bindir}/litecoin-tx
3ec6a0cf
JB
145%{_mandir}/man1/litecoin-cli.1*
146%{_mandir}/man1/litecoin-tx.1*
147%{_mandir}/man1/litecoind.1*
d8766286
AM
148
149%files qt
150%defattr(644,root,root,755)
151%attr(755,root,root) %{_bindir}/litecoin-qt
152%{_datadir}/kde4/services/litecoin-qt.protocol
153%{_desktopdir}/litecoin-qt.desktop
3ec6a0cf
JB
154%{_pixmapsdir}/bitcoin.ico
155%{_pixmapsdir}/nsis-*.bmp
156%{_mandir}/man1/litecoin-qt.1*
This page took 0.149055 seconds and 4 git commands to generate.