]> git.pld-linux.org Git - packages/linux-kvm.git/blame - linux-kvm.spec
- fix build
[packages/linux-kvm.git] / linux-kvm.spec
CommitLineData
d02aea84 1# TODO: use linux tarball when kernel 3.1 is released
b9e70b54 2%define rel 9
d02aea84
AM
3%define snap 20110726
4Summary: Native Linux KVM tool
5Name: linux-kvm
6Version: 3.1
3458cc33 7Release: 0.%{snap}.%{rel}
d02aea84
AM
8License: GPL v2
9Group: Applications/System
10# git://github.com/penberg/linux-kvm.git
11Source0: %{name}-%{version}-%{snap}.tar.bz2
12# Source0-md5: b0b94a75d915f70ae14a089ddc7d7abb
b9e70b54 13Patch0: fix-types.patch
1f366553 14BuildRequires: binutils-devel
d02aea84
AM
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18The goal of this tool is to provide a clean, from-scratch, lightweight
19KVM host tool implementation that can boot Linux guest images (just a
20hobby, won't be big and professional like QEMU) with no BIOS
21dependencies and with only the minimal amount of legacy device
22emulation.
23
24%prep
25%setup -q -n %{name}
b9e70b54 26%patch0 -p1
d02aea84
AM
27
28%build
29%{__make} -C tools/kvm \
30 CC="%{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags}" \
b9e70b54 31 WERROR=0 \
d02aea84
AM
32 V=1
33
34%install
35rm -rf $RPM_BUILD_ROOT
36
37install -d $RPM_BUILD_ROOT%{_sbindir}
38
39install tools/kvm/kvm $RPM_BUILD_ROOT%{_sbindir}
40
41%clean
42rm -rf $RPM_BUILD_ROOT
43
44%files
45%defattr(644,root,root,755)
46%doc tools/kvm/Documentation/* tools/kvm/README
47%attr(755,root,root) %{_sbindir}/kvm
This page took 0.095023 seconds and 4 git commands to generate.