]> git.pld-linux.org Git - packages/linux-gpib.git/blame - linux-gpib.spec
- fix patching
[packages/linux-gpib.git] / linux-gpib.spec
CommitLineData
d4054fe9 1#
d4054fe9 2# Conditional build:
2ee896be 3%bcond_without kernel # kernel modules
25beb8e8
JB
4%bcond_without drivers_isa # ISA kernel drivers [ix86 only]
5%bcond_without drivers_pcmcia # PCMCIA support in kernel drivers
6%bcond_without drivers_usb # USB kernel drivers
2ee896be
JB
7%bcond_without userspace # userspace packages
8%bcond_without verbose # verbose modules build (V=1)
df990a65 9
2ee896be 10%bcond_without docs # documentation build
08f3bc97 11%bcond_with hotplug # legacy hotplug support
2ee896be 12%bcond_without static_libs # static library
91dbb874 13%bcond_without guile # guile binding
2ee896be 14%bcond_without perl # Perl binding
b3693ec1 15%bcond_with php # PHP binding
2ee896be
JB
16%bcond_without python # Python binding
17%bcond_without tcl # Tcl binding
df990a65 18
4c4f156c
JR
19# The goal here is to have main, userspace, package built once with
20# simple release number, and only rebuild kernel packages with kernel
21# version as part of release number, without the need to bump release
22# with every kernel change.
23%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24%{error:kernel and userspace cannot be built at the same time on PLD builders}
25exit 1
26%endif
27
25beb8e8
JB
28%ifnarch %{ix86}
29%undefine with_drivers_isa
30%undefine with_drivers_pcmcia
31%endif
4c4f156c 32
76a67c9a
JB
33%include /usr/lib/rpm/macros.perl
34%define php_name php%{?php_suffix}
4c4f156c 35
55cbc6e3 36%define rel 1
4c4f156c 37%define pname linux-gpib
2ee896be
JB
38Summary: GPIB (IEEE 488) Linux support
39Summary(pl.UTF-8): Obsługa GPIB (IEEE 488) dla Linuksa
4c4f156c 40Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
55cbc6e3 41Version: 4.3.0
2d0c8827 42Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
2ee896be 43License: GPL v2+
cc64c2aa 44Group: Applications/System
996e3d04 45Source0: http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
55cbc6e3 46# Source0-md5: 3085422695baf210b866601db6108860
4c4f156c
JR
47Patch2: %{pname}-python.patch
48Patch3: %{pname}-perl.patch
49Patch4: %{pname}-firmwaredir.patch
50Patch5: %{pname}-guile2.patch
51Patch6: %{pname}-php7.patch
82a3ed18 52Patch8: kernel-5.2.patch
d4054fe9 53URL: http://linux-gpib.sourceforge.net/
2ee896be
JB
54BuildRequires: autoconf >= 2.50
55BuildRequires: automake
56BuildRequires: libtool
57BuildRequires: rpmbuild(macros) >= 1.614
d4054fe9 58%if %{with kernel}
2ee896be 59BuildRequires: kernel-module-build >= 3:2.6.8
d4054fe9 60%endif
2ee896be
JB
61%if %{with userspace}
62BuildRequires: bison
63%{?with_docs:BuildRequires: docbook-utils}
64BuildRequires: flex
91dbb874 65%{?with_guile:BuildRequires: guile-devel >= 1.4}
df990a65 66%{?with_perl:BuildRequires: perl-devel}
76a67c9a 67%{?with_php:BuildRequires: %{php_name}-devel >= 3:5}
2ee896be
JB
68%{?with_python:BuildRequires: python-devel >= 2}
69BuildRequires: readline-devel
df990a65 70%{?with_tcl:BuildRequires: tcl-devel}
2ee896be 71%endif
4c4f156c 72Requires: %{pname}-libs = %{version}-%{release}
4ffc9310
JB
73# for agilent_82357a and ni_usb_gpib
74Suggests: fxload
75# for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
76Suggests: linux-gpib-firmware
d4054fe9 77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79%description
cc64c2aa 80The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
d4054fe9 81
bc9733fa
JR
82%description -l pl.UTF-8
83Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
d4054fe9 84
08f3bc97
JB
85%package hotplug
86Summary: Linux GPIB support for legacy USB hotplug
87Summary(pl.UTF-8): Obsługa Linux GPIB dla starego systemu hotplug USB
88Group: Applications/System
4c4f156c 89Requires: %{pname} = %{version}-%{release}
08f3bc97
JB
90Requires: hotplug
91
92%description hotplug
93Linux GPIB support for legacy USB hotplug.
94
95%description hotplug -l pl.UTF-8
96Obsługa Linux GPIB dla starego systemu hotplug USB.
97
2ee896be
JB
98%package libs
99Summary: Shared GPIB library
100Summary(pl.UTF-8): Biblioteka współdzielona GPIB
101Group: Libraries
d7b3679a 102
2ee896be
JB
103%description libs
104Shared GPIB library.
105
106%description libs -l pl.UTF-8
107Biblioteka współdzielona GPIB.
108
109%package devel
110Summary: Header file for GPIB library
111Summary(pl.UTF-8): Plik nagłówkowy biblioteki GPIB
112Group: Development/Libraries
4c4f156c 113Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
114
115%description devel
116Header file for GPIB library.
117
118%description devel -l pl.UTF-8
119Plik nagłówkowy biblioteki GPIB.
120
121%package static
122Summary: Static GPIB library
123Summary(pl.UTF-8): Biblioteka statyczna GPIB
124Group: Development/Libraries
4c4f156c 125Requires: %{pname}-devel = %{version}-%{release}
2ee896be
JB
126
127%description static
128Static GPIB library.
129
130%description static -l pl.UTF-8
131Biblioteka statyczna GPIB.
132
91dbb874
JB
133%package -n guile-gpib
134Summary: Guile bindings for GPIB library
135Summary(pl.UTF-8): Wiązania Guile do biblioteki GPIB
136Group: Development/Languages/Perl
4c4f156c 137Requires: %{pname}-libs = %{version}-%{release}
91dbb874
JB
138Requires: guile-libs
139
140%description -n guile-gpib
141Guile bindings for GPIB library.
142
143%description -n guile-gpib -l pl.UTF-8
144Wiązania Guile do biblioteki GPIB.
145
2ee896be
JB
146%package -n perl-gpib
147Summary: Perl bindings for GPIB library
148Summary(pl.UTF-8): Wiązania Perla do biblioteki GPIB
149Group: Development/Languages/Perl
4c4f156c 150Requires: %{pname}-libs = %{version}-%{release}
d7b3679a 151
2ee896be
JB
152%description -n perl-gpib
153Perl bindings for GPIB library.
d7b3679a 154
2ee896be
JB
155%description -n perl-gpib -l pl.UTF-8
156Wiązania Perla do biblioteki GPIB.
d7b3679a 157
76a67c9a
JB
158%package -n %{php_name}-gpib
159Summary: PHP bindings for GPIB library
160Summary(pl.UTF-8): Wiązania PHP do biblioteki GPIB
161Group: Development/Languages/PHP
162Provides: php(gpib) = %{version}
4c4f156c 163Requires: %{pname}-libs = %{version}-%{release}
76a67c9a
JB
164%{?requires_php_extension}
165
166%description -n %{php_name}-gpib
167PHP bindings for GPIB library.
168
169%description -n %{php_name}-gpib -l pl.UTF-8
170Wiązania PHP do biblioteki GPIB.
171
2ee896be
JB
172%package -n python-gpib
173Summary: Python bindings for GPIB library
174Summary(pl.UTF-8): Wiązania Pythona do biblioteki GPIB
175Group: Libraries/Python
4c4f156c 176Requires: %{pname}-libs = %{version}-%{release}
2ee896be 177Requires: python-libs
d7b3679a 178
2ee896be
JB
179%description -n python-gpib
180Python bindings for GPIB library.
181
182%description -n python-gpib -l pl.UTF-8
183Wiązania Pythona do biblioteki GPIB.
184
185%package -n tcl-gpib
186Summary: Tcl bindings for GPIB library
187Summary(pl.UTF-8): Wiązania Tcl-a do biblioteki GPIB
188Group: Libraries
4c4f156c 189Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
190Requires: tcl
191
192%description -n tcl-gpib
193Tcl bindings for GPIB library.
194
195%description -n tcl-gpib -l pl.UTF-8
196Wiązania Tcl-a do biblioteki GPIB.
197
198%package doc
199Summary: Linux-GPIB tools and library documentation
200Summary(pl.UTF-8): Dokumentacja narzędzi i biblioteki Linux-GPIB
201License: GFDL v1.2+ or GPL v2+
202Group: Documentation
203
204%description doc
205Linux-GPIB tools and library documentation.
206
207%description doc -l pl.UTF-8
208Dokumentacja narzędzi i biblioteki Linux-GPIB.
209
210%define kernel_pkg()\
211%package -n kernel%{_alt_kernel}-gpib\
212Summary: Linux GPIB drivers\
213Summary(pl.UTF-8): Sterowniki GPIB dla Linuksa\
214Release: %{rel}@%{_kernel_ver_str}\
215Group: Base/Kernel\
216Requires(post,postun): /sbin/depmod\
217%requires_releq_kernel\
218Requires(postun): %releq_kernel\
219\
220%description -n kernel%{_alt_kernel}-gpib\
221This package contains Linux drivers for GPIB (IEEE 488) hardware.\
222\
223%description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
224Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
225\
226%if %{with kernel}\
227%files -n kernel%{_alt_kernel}-gpib\
228%defattr(644,root,root,755)\
229/lib/modules/%{_kernel_ver}/kernel/gpib\
230%endif\
231\
232%post -n kernel%{_alt_kernel}-gpib\
233%depmod %{_kernel_ver}\
234\
235%postun -n kernel%{_alt_kernel}-gpib\
236%depmod %{_kernel_ver}\
237%{nil}
238
239%define build_kernel_pkg()\
55cbc6e3 240%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
2ee896be 241cd drivers/gpib\
82a3ed18
JR
242%ifarch %{ix86}\
243%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
244%else\
25beb8e8 245%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 246%endif\
b69cc3e0 247cd ../..\
2ee896be
JB
248%{nil}
249
250%define install_kernel_pkg()\
251%{nil}
252
253%{?with_kernel:%{expand:%create_kernel_packages}}
d7b3679a 254
d4054fe9 255%prep
996e3d04 256%setup -q -n %{pname}-%{version}
16f00101
JR
257%if %{with userspace}
258tar xzf linux-gpib-user-%{version}.tar.gz
259cd linux-gpib-user-%{version}
2ee896be
JB
260%patch2 -p1
261%patch3 -p1
08f3bc97 262%patch4 -p1
91dbb874 263%patch5 -p1
16f00101
JR
264#%patch6 -p1
265cd ..
266%endif
267
268%if %{with kernel}
269tar xzf linux-gpib-kernel-%{version}.tar.gz
270cd linux-gpib-kernel-%{version}
5e300ced
JR
271%ifarch %{ix86}
272%patch8 -p1
273%endif
16f00101 274%endif
d7b3679a 275
d4054fe9 276%build
16f00101
JR
277%if %{with userspace}
278cd linux-gpib-user-%{version}
302b72f6
JR
279%{__libtoolize}
280%{__aclocal}
281%{__autoconf}
282%{__autoheader}
283%{__automake}
91dbb874 284%if %{with guile}
d53b2ad5 285CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
91dbb874 286%endif
d7b3679a 287%configure \
55cbc6e3 288 --with-udev-libdir=/lib/udev \
25beb8e8
JB
289 %{?with_drivers_isa:--enable-isa} \
290 %{?with_drivers_pcmcia:--enable-pcmcia} \
2ee896be
JB
291 %{!?with_docs:--disable-documentation} \
292 %{!?with_guile:--disable-guile-binding} \
293 %{!?with_perl:--disable-perl-binding} \
294 %{!?with_php:--disable-php-binding} \
295 %{!?with_python:--disable-python-binding} \
296 %{?with_static_libs:--enable-static} \
16f00101 297 %{!?with_tcl:--disable-tcl-binding}
d7b3679a 298
9e3b7024 299%{__make}
16f00101 300cd ..
2ee896be 301%endif
d7b3679a 302
2ee896be 303%if %{with kernel}
16f00101 304cd linux-gpib-kernel-%{version}
2ee896be
JB
305%{expand:%build_kernel_packages}
306%endif
d4054fe9 307
308%install
309rm -rf $RPM_BUILD_ROOT
2ee896be 310install -d $RPM_BUILD_ROOT%{_examplesdir}
d4054fe9 311
8eefbf3b 312%if %{with kernel}
16f00101 313cd linux-gpib-kernel-%{version}
2ee896be
JB
314%{expand:%install_kernel_packages}
315cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
302b72f6 316cd ..
8eefbf3b
MWP
317%endif
318
d4054fe9 319%if %{with userspace}
302b72f6
JR
320cd linux-gpib-user-%{version}
321%{__make} install \
08f3bc97
JB
322 DESTDIR=$RPM_BUILD_ROOT \
323 HOTPLUG_USB_CONF_DIR=/lib/udev \
324 UDEV_RULES_DIR=/lib/udev/rules.d \
325 USB_FIRMWARE_DIR=/lib/firmware
25beb8e8
JB
326
327%if %{with hotplug}
08f3bc97
JB
328# use udev paths as base and legacy hotplug as addon (not the opposite)
329install -d $RPM_BUILD_ROOT/etc/hotplug/usb
330%{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
331ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
332ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
25beb8e8 333%endif
2ee896be
JB
334
335# obsoleted by pkg-config
336%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
337
91dbb874
JB
338%if %{with guile}
339%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
340%if %{with static_libs}
341%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
342%endif
343%endif
344
2ee896be
JB
345%if %{with perl}
346%{__make} -C language/perl pure_install \
347 DESTDIR=$RPM_BUILD_ROOT
76a67c9a 348
2ee896be 349cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
76a67c9a 350
2ee896be
JB
351%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
352%endif
353
76a67c9a
JB
354%if %{with php}
355install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
356cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
357; Enable gpib extension module
358extension=gpib_php.so
359EOF
360
361%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
362%if %{with static_libs}
363%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
364%endif
365%endif
366
2ee896be
JB
367%if %{with python}
368%py_postclean
369%endif
370
371%if %{with tcl}
372cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
76a67c9a 373
2ee896be
JB
374%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
375%if %{with static_libs}
376%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
377%endif
378%endif
379
380%if %{with docs}
381# packaged as %doc
302b72f6 382%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
d4054fe9 383%endif
82a3ed18 384%endif
d4054fe9 385
d4054fe9 386%clean
387rm -rf $RPM_BUILD_ROOT
388
2ee896be
JB
389%post libs -p /sbin/ldconfig
390%postun libs -p /sbin/ldconfig
d4054fe9 391
91dbb874
JB
392%post -n guile-gpib -p /sbin/ldconfig
393%postun -n guile-gpib -p /sbin/ldconfig
394
395%post -n tcl-gpib -p /sbin/ldconfig
396%postun -n tcl-gpib -p /sbin/ldconfig
397
76a67c9a
JB
398%post -n %{php_name}-gpib
399%php_webserver_restart
400
401%postun -n %{php_name}-gpib
402if [ "$1" = 0 ]; then
403 %php_webserver_restart
404fi
405
2ee896be
JB
406%if %{with userspace}
407%files
408%defattr(644,root,root,755)
302b72f6 409%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
2ee896be
JB
410%attr(755,root,root) %{_bindir}/ibterm
411%attr(755,root,root) %{_bindir}/ibtest
412%attr(755,root,root) %{_sbindir}/gpib_config
55cbc6e3 413/lib/udev/rules.d/98-gpib-generic.rules
08f3bc97 414/lib/udev/rules.d/99-agilent_82357a.rules
08f3bc97 415/lib/udev/rules.d/99-ni_usb_gpib.rules
55cbc6e3
JR
416%attr(755,root,root) /lib/udev/gpib_udev_config
417%attr(755,root,root) /lib/udev/gpib_udev_fxloader
418%attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
08f3bc97
JB
419
420%if %{with hotplug}
421%files hotplug
422%defattr(644,root,root,755)
2ee896be
JB
423%attr(755,root,root) /etc/hotplug/usb/agilent_82357a
424%attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
425/etc/hotplug/usb/agilent_82357a.usermap
426/etc/hotplug/usb/ni_usb_gpib.usermap
08f3bc97 427%endif
d4054fe9 428
2ee896be 429%files libs
0e4898e2 430%defattr(644,root,root,755)
302b72f6 431%doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
2ee896be
JB
432%attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
433%attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
434
435%files devel
436%defattr(644,root,root,755)
437%attr(755,root,root) %{_libdir}/libgpib.so
438%{_includedir}/gpib
439%{_pkgconfigdir}/libgpib.pc
440
441%if %{with static_libs}
442%files static
443%defattr(644,root,root,755)
444%{_libdir}/libgpib.a
445%endif
446
91dbb874
JB
447%if %{with guile}
448%files -n guile-gpib
449%defattr(644,root,root,755)
996e3d04 450%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
91dbb874
JB
451%attr(755,root,root) %{_libdir}/libgpib-guile.so
452%endif
453
2ee896be
JB
454%if %{with perl}
455%files -n perl-gpib
456%defattr(644,root,root,755)
302b72f6 457%doc linux-gpib-user-%{version}/language/perl/{Changes,README}
2ee896be
JB
458%{perl_vendorarch}/LinuxGpib.pm
459%dir %{perl_vendorarch}/auto/LinuxGpib
460%attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
461%{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
462%{_mandir}/man3/LinuxGpib.3pm*
463%{_examplesdir}/perl-gpib-%{version}
464%endif
465
76a67c9a
JB
466%if %{with php}
467%files -n %{php_name}-gpib
468%defattr(644,root,root,755)
469%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
996e3d04 470%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
76a67c9a
JB
471%attr(755,root,root) %{php_extensiondir}/gpib_php.so
472%endif
473
2ee896be
JB
474%if %{with python}
475%files -n python-gpib
476%defattr(644,root,root,755)
302b72f6 477%doc linux-gpib-user-%{version}/language/python/README
2ee896be
JB
478%attr(755,root,root) %{py_sitedir}/gpib.so
479%{py_sitedir}/Gpib.py[co]
480%{py_sitedir}/gpib-1.0-py*.egg-info
481%endif
482
483%if %{with tcl}
484%files -n tcl-gpib
485%defattr(644,root,root,755)
302b72f6 486%doc linux-gpib-user-%{version}/language/tcl/README
996e3d04 487%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
2ee896be
JB
488%attr(755,root,root) %{_libdir}/libgpib_tcl.so
489%{_examplesdir}/tcl-gpib-%{version}
490%endif
491
492%if %{with docs}
493%files doc
494%defattr(644,root,root,755)
302b72f6 495%doc linux-gpib-user-%{version}/doc/doc_html/*
2ee896be 496%endif
1fc85825 497%endif
This page took 0.18416 seconds and 4 git commands to generate.