]> git.pld-linux.org Git - packages/libvirt-sandbox.git/blame - libvirt-sandbox.spec
- fix python shebang
[packages/libvirt-sandbox.git] / libvirt-sandbox.spec
CommitLineData
f3e37857
JB
1Summary: API for building application sandboxes using libvirt
2Summary(pl.UTF-8): API do tworzenia sandboksów aplikacyjnych przy użyciu libvirt
3Name: libvirt-sandbox
2a03b063 4Version: 0.6.0
8206b04c 5Release: 2
f3e37857
JB
6License: LGPL v2.1+
7Group: Libraries
8Source0: ftp://libvirt.org/libvirt/sandbox/%{name}-%{version}.tar.gz
2a03b063 9# Source0-md5: 546eb0caaa79d50a723adf58f32da87f
f3e37857 10URL: http://libvirt.org/
d92f10e1 11BuildRequires: gettext-tools
8a54692b 12BuildRequires: glib2-devel >= 1:2.32.0
2a03b063
JB
13# ldd
14BuildRequires: glibc-misc
15BuildRequires: glibc-static
f3e37857
JB
16BuildRequires: gobject-introspection-devel >= 0.10.8
17BuildRequires: gtk-doc >= 1.10
4dddd6ff 18BuildRequires: intltool >= 0.35.0
f3e37857 19BuildRequires: libcap-ng-devel >= 0.4.0
817bd0bc 20BuildRequires: libselinux-devel
dacae2a0 21BuildRequires: libvirt-devel >= 1.0.2
2a03b063 22BuildRequires: libvirt-glib-devel >= 0.2.1
f3e37857
JB
23BuildRequires: pkgconfig
24BuildRequires: sed >= 4.0
2a03b063
JB
25BuildRequires: xz-devel >= 1:5.0.0
26BuildRequires: xz-static >= 1:5.0.0
27BuildRequires: zlib-devel >= 1.2.0
28BuildRequires: zlib-static >= 1.2.0
8a54692b 29Requires: glib2 >= 1:2.32.0
f3e37857 30Requires: libcap-ng >= 0.4.0
dacae2a0 31Requires: libvirt >= 1.0.2
2a03b063 32Requires: libvirt-glib >= 0.2.1
f3e37857
JB
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36The libvirt-sandbox package provides an API for building application
37sandboxes using libvirt. Sandboxes can be based on either container or
38machine based virtualization technology. Also included is a simple
39command line tool for launching sandboxes for arbitrary commands.
40
41%description -l pl.UTF-8
42Libvirt-sandbox udostępnia API do tworzenia sandboksów ("piaskownic")
43aplikacyjnych przy użyciu libvirt. Sandboksy mogą być oparte na
44wirtualizacji kontenera lub maszyny. Dołączone są także proste
45narzędzia uruchamiane z linii poleceń do uruchamiania sandboksów
46dowolnych poleceń.
47
48%package devel
49Summary: Header files for libvirt-sandbox library
50Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvirt-sandbox
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
8a54692b 53Requires: glib2-devel >= 1:2.32.0
dacae2a0 54Requires: libvirt-devel >= 1.0.2
2a03b063 55Requires: libvirt-glib-devel >= 0.2.1
f3e37857
JB
56
57%description devel
58Header files for libvirt-sandbox library.
59
60%description devel -l pl.UTF-8
61Pliki nagłówkowe biblioteki libvirt-sandbox.
62
63%package static
64Summary: Static libvirt-sandbox library
65Summary(pl.UTF-8): Statyczna biblioteka libvirt-sandbox
66Group: Development/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68
69%description static
70Static libvirt-sandbox library.
71
72%description static -l pl.UTF-8
73Statyczna biblioteka libvirt-sandbox.
74
75%package -n bash-completion-libvirt-sandbox
76Summary: Bash completion rules for libvirt-sandbox
77Summary(pl.UTF-8): Bashowe uzupełnianie poleceń dla pakietu libvirt-sandbox
78Group: Applications/Shells
79Requires: %{name} = %{version}-%{release}
4dddd6ff 80Requires: bash-completion >= 2.0
871d9a76
ER
81%if "%{_rpmversion}" >= "5"
82BuildArch: noarch
83%endif
f3e37857
JB
84
85%description -n bash-completion-libvirt-sandbox
86Bash completion rules for virt-sandbox-service command.
87
88%description -n bash-completion-libvirt-sandbox -l pl.UTF-8
89Bashowe uzupełnianie parametrów dla polecenia virt-sandbox-service.
90
91%prep
92%setup -q
93
94# what is it? seems not required
95%{__sed} -i -e '/Requires: sandbox-2.0/d' libvirt-sandbox-1.0.pc.in
96
8206b04c
JR
97%{__sed} -E -i -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
98 bin/virt-sandbox-service
99
f3e37857
JB
100%build
101%configure \
102 --disable-silent-rules \
103 --with-html-dir=%{_gtkdocdir}
104%{__make}
105
106%install
107rm -rf $RPM_BUILD_ROOT
755bcace 108
f3e37857
JB
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT
111
112# obsoleted by pkg-config
113%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt-sandbox-1.0.la
114# just placeholder, useless in RPM
115%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/libvirt-sandbox/scratch/README
116
4dddd6ff
JB
117%find_lang %{name}
118
f3e37857
JB
119%clean
120rm -rf $RPM_BUILD_ROOT
121
4dddd6ff 122%files -f %{name}.lang
f3e37857 123%defattr(644,root,root,755)
8a54692b 124%doc AUTHORS ChangeLog NEWS README TODO
f3e37857
JB
125%attr(755,root,root) %{_bindir}/virt-sandbox
126%attr(755,root,root) %{_bindir}/virt-sandbox-service
127%attr(755,root,root) %{_libdir}/libvirt-sandbox-1.0.so.*.*.*
2a03b063 128%attr(755,root,root) %ghost %{_libdir}/libvirt-sandbox-1.0.so.5
f3e37857
JB
129%{_libdir}/girepository-1.0/LibvirtSandbox-1.0.typelib
130%attr(755,root,root) %{_libexecdir}/libvirt-sandbox-init-common
131%attr(755,root,root) %{_libexecdir}/libvirt-sandbox-init-lxc
132%attr(755,root,root) %{_libexecdir}/libvirt-sandbox-init-qemu
8a54692b 133%attr(755,root,root) %{_libexecdir}/virt-sandbox-service-util
f3e37857
JB
134%dir %{_sysconfdir}/libvirt-sandbox
135%dir %{_sysconfdir}/libvirt-sandbox/scratch
136%dir %{_sysconfdir}/libvirt-sandbox/services
755bcace 137%config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/virt-sandbox-service.logrotate
f3e37857
JB
138%{_mandir}/man1/virt-sandbox.1*
139%{_mandir}/man1/virt-sandbox-service.1*
dacae2a0 140%{_mandir}/man1/virt-sandbox-service-*.1*
f3e37857
JB
141
142%files devel
143%defattr(644,root,root,755)
144%attr(755,root,root) %{_libdir}/libvirt-sandbox-1.0.so
145%{_includedir}/libvirt-sandbox-1.0
146%{_pkgconfigdir}/libvirt-sandbox-1.0.pc
147%{_datadir}/gir-1.0/LibvirtSandbox-1.0.gir
148%{_gtkdocdir}/Libvirt-sandbox
149
150%files static
151%defattr(644,root,root,755)
152%{_libdir}/libvirt-sandbox-1.0.a
153
154%files -n bash-completion-libvirt-sandbox
155%defattr(644,root,root,755)
4dddd6ff 156%{_datadir}/bash-completion/completions/virt-sandbox-service
This page took 0.091413 seconds and 4 git commands to generate.