]> git.pld-linux.org Git - packages/libtorrent.git/blame - libtorrent.spec
- updated to 0.13.8
[packages/libtorrent.git] / libtorrent.spec
CommitLineData
375b25b5
KK
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
e3c6d985 4%bcond_without ipv6 # disable IPv6 support
375b25b5 5#
f2ca030d 6Summary: LibTorrent - a BitTorrent library written in C++ for Unix
bd348243 7Summary(pl.UTF-8): LibTorrent - biblioteka BitTorrenta napisana w C++ dla Uniksa
f2ca030d 8Name: libtorrent
017c7b50 9# keep stable line, see URL below
9eb6269f
AG
10Version: 0.13.8
11Release: 1
84fe40de 12Epoch: 1
c7190a9a 13License: GPL v2+
f2ca030d 14Group: Libraries
55ec7f79 15Source0: http://rtorrent.net/downloads/%{name}-%{version}.tar.gz
9eb6269f 16# Source0-md5: ca02e624fde0d704780085987010f99a
f3547b0f 17Patch0: %{name}-client_list.patch
4d925a97 18Patch1: %{name}-build.patch
9e8c8320 19URL: https://github.com/rakshasa/rtorrent/wiki
f9a933d6 20BuildRequires: autoconf >= 2.50
fd14c138 21BuildRequires: automake
e175d55e 22BuildRequires: cppunit-devel >= 1.9.6
ca0459ae
JB
23BuildRequires: libstdc++-devel
24BuildRequires: libtool >= 2:2
e4e1ab6e 25BuildRequires: openssl-devel >= 0.9.7d
f2ca030d 26BuildRequires: pkgconfig
55ec7f79 27BuildRequires: zlib-devel
f2ca030d
KK
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
a7c7e499
ER
31LibTorrent is a BitTorrent library written in C++ for *nix, with a
32focus on high performance and good code. The library differentiates
33itself from other implementations by transfering directly from file
34pages to the network stack. On high-bandwidth connections it is able
35to seed at 3 times the speed of the official client.
f2ca030d 36
ac2d8d9c 37%description -l pl.UTF-8
f6340f5a 38LibTorrent to biblioteka BitTorrenta napisana w C++ dla Uniksa. Jest
ac2d8d9c
JR
39zaprojektowana aby uniknąć nadmiarowego kopiowania buforów i danych,
40będącego wadą większości (wszystkich?) innych implementacji
41BitTorrenta. Biblioteka jest jednowątkowa, klient obsługuje pętlę
f6340f5a
JB
42select.
43
f2ca030d
KK
44%package devel
45Summary: Development files for libtorrent
bd348243 46Summary(pl.UTF-8): Pliki programistyczne libtorrent
f2ca030d 47Group: Development/Libraries
84fe40de 48Requires: %{name} = %{epoch}:%{version}-%{release}
ca0459ae 49Requires: libstdc++-devel
bae8c60c 50Requires: openssl-devel >= 0.9.7d
55ec7f79 51Requires: zlib-devel
f2ca030d
KK
52
53%description devel
54Development files for libtorrent.
55
ac2d8d9c 56%description devel -l pl.UTF-8
f2ca030d
KK
57Pliki programistyczne libtorrent.
58
59%package static
60Summary: Static libtorrent library
bd348243 61Summary(pl.UTF-8): Statyczna biblioteka libtorrent
f2ca030d 62Group: Development/Libraries
ad866d2e 63Requires: %{name}-devel = %{epoch}:%{version}-%{release}
f2ca030d
KK
64
65%description static
66Static libtorrent library.
67
ac2d8d9c 68%description static -l pl.UTF-8
f2ca030d
KK
69Statyczna biblioteka libtorrent.
70
71%prep
a97435eb
ER
72v=%{version}; IFS=.; set -- $v
73if [ $(($2 % 2)) = 0 ]; then
74 echo "WARNING Version %{version} is probably unstable, check it first!"
75 exit 1
76fi
f2ca030d 77%setup -q
f3547b0f 78%patch0 -p1
4d925a97 79%patch1 -p1
f9a933d6 80
f2ca030d 81%build
f9a933d6 82%{__libtoolize}
c8eed48f
PS
83%{__aclocal} -I scripts
84%{__autoconf}
f9a933d6
JB
85%{__autoheader}
86%{__automake}
c8eed48f 87
f2ca030d 88%configure \
e3c6d985 89 --%{?with_ipv6:en}%{!?with_ipv6:dis}able-ipv6 \
f2ca030d 90 --%{?debug:en}%{!?debug:dis}able-debug \
9e8c8320 91 %{?with_static_libs:--enable-static} \
90230e93
AM
92%ifarch i386 i486
93 --disable-instrumentation
94%endif
c8eed48f 95
f2ca030d
KK
96%{__make}
97
98%install
99rm -rf $RPM_BUILD_ROOT
100
101%{__make} install \
102 DESTDIR=$RPM_BUILD_ROOT
103
f2ca030d
KK
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
e23f3e19 112%doc AUTHORS README
f2ca030d 113%attr(755,root,root) %{_libdir}/libtorrent.so.*.*.*
9eb6269f 114%attr(755,root,root) %ghost %{_libdir}/libtorrent.so.21
f2ca030d
KK
115
116%files devel
117%defattr(644,root,root,755)
118%attr(755,root,root) %{_libdir}/libtorrent.so
119%{_libdir}/libtorrent.la
120%{_includedir}/torrent
121%{_pkgconfigdir}/libtorrent.pc
122
375b25b5 123%if %{with static_libs}
f2ca030d
KK
124%files static
125%defattr(644,root,root,755)
126%{_libdir}/libtorrent.a
375b25b5 127%endif
This page took 0.110567 seconds and 4 git commands to generate.