]> git.pld-linux.org Git - packages/libsndfile.git/blame - libsndfile.spec
- rel 2
[packages/libsndfile.git] / libsndfile.spec
CommitLineData
e991aa6f
SS
1# TODO:
2# - compare flac.patch with Fedora/Gentoo equivalent
3# - who needs sndfile-regtest?
19550c7f
KK
4#
5# Conditional build:
e991aa6f 6%bcond_with regtest # build sndfile-regtest program
19550c7f 7%bcond_without static_libs # don't build static library
55badcef 8%bcond_without tests # don't build tests
19550c7f 9#
1dcb9798 10Summary: C library for reading and writing files containing sampled sound
99339b5d 11Summary(pl.UTF-8): Biblioteka obsługi plików dźwiękowych
1dcb9798 12Name: libsndfile
5f0a3024 13Version: 1.0.20
aa295afd 14Release: 2
a438ce96 15License: LGPL v2.1+
2a9e2d9d 16Vendor: Erik de Castro Lopo <erikd@zip.com.au>
1dcb9798 17Group: Development/Libraries
900cee8f 18Source0: http://www.mega-nerd.com/libsndfile/%{name}-%{version}.tar.gz
5f0a3024 19# Source0-md5: e0553e12c7a467af44693e95e2eac668
02b014db 20Patch0: octave32.patch
f967ffbb 21URL: http://www.mega-nerd.com/libsndfile/
19550c7f 22BuildRequires: alsa-lib-devel
238da168 23BuildRequires: autoconf >= 2.54
16af1fdc 24BuildRequires: automake
9bec58c8 25BuildRequires: fftw3-devel
92edf427 26BuildRequires: flac-devel >= 1.1.3
9bec58c8 27BuildRequires: gcc-fortran
e6c01697 28BuildRequires: jack-audio-connection-kit-devel
4db6538e 29BuildRequires: lapack-devel
55badcef 30%{?with_tests:BuildRequires: libstdc++-devel}
487276e9 31BuildRequires: libtool
e6c01697 32BuildRequires: libvorbis-devel
03d66581 33BuildRequires: octave-devel
19550c7f 34BuildRequires: pkgconfig
55badcef 35BuildRequires: sed >= 4.0
e991aa6f 36%{?with_regtest:BuildRequires: sqlite3-devel}
3d5577b2 37Obsoletes: libsndfile1
ae214341 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1dcb9798
AM
39
40%description
a6cdcff3 41Libsndfile is a C library for reading and writing files containing
42sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format)
43through one standard library interface.
1dcb9798 44
66b8034c
JR
45%description -l pl.UTF-8
46Libsndfile to biblioteką napisaną w C, służąca do czytania i
47zapisywania plików zawierających zsamplowany dźwięk (np. w formacie MS
a6cdcff3 48Windows WAV czy Apple/SGI AIFF) poprzez jednolity, standardowy
49interfejs.
0ee4787d 50
1dcb9798
AM
51%package devel
52Summary: libsndfile header files and development documentation
99339b5d 53Summary(pl.UTF-8): Pliki nagłówkowe oraz dokumentacja do libsndfile
1dcb9798 54Group: Development/Libraries
f967ffbb 55Requires: %{name} = %{version}-%{release}
900cee8f 56Requires: flac-devel >= 1.1.1
3d5577b2 57Obsoletes: libsndfile1-devel
1dcb9798
AM
58
59%description devel
60Header files and development documentation for libsndfile.
61
66b8034c
JR
62%description devel -l pl.UTF-8
63Pliki nagłówkowe oraz dokumentacja do biblioteki libsndfile.
1dcb9798
AM
64
65%package static
66Summary: libsndfile static libraries
99339b5d 67Summary(pl.UTF-8): Biblioteki statyczne libsndfile
1dcb9798 68Group: Development/Libraries
f967ffbb 69Requires: %{name}-devel = %{version}-%{release}
1dcb9798
AM
70
71%description static
72libsndfile static libraries.
73
66b8034c 74%description static -l pl.UTF-8
1dcb9798
AM
75Biblioteki statyczne libsndfile.
76
bcbe612a
SZ
77%package octave
78Summary: libsndfile modules for octave
99339b5d 79Summary(pl.UTF-8): Moduły libsndfile dla octave
bcbe612a 80Group: Applications/Math
b171006e 81Requires: %{name} = %{version}-%{release}
bcbe612a
SZ
82Requires: octave
83
84%description octave
912639bd 85A couple of script files for loading, saving, and playing sound files
86from within Octave.
bcbe612a 87
66b8034c
JR
88%description octave -l pl.UTF-8
89Kilka skryptów Octave do ładowania, zapisywania i odtwarzania plików
90dźwiękowych.
bcbe612a 91
e991aa6f
SS
92%package progs
93Summary: libsndfile utility programs
94Summary(pl.UTF-8): Narzędzia korzystające z biblioteki libsndfile
9549b058 95Group: Applications/Sound
373e2ff9 96Requires: %{name} = %{version}-%{release}
e991aa6f
SS
97
98%description progs
99libsndfile utility programs:
100- sndfile-convert − convert a sound files from one format to another
101- sndfile-info − display information about a sound file
102- sndfile-play − play a sound file
103
104%description progs -l pl.UTF-8
105Narzędzia z biblioteki libsndfile:
106- sndfile-convert - kowertertuje pliki dźwiękowe
107- sndfile-info - wyświetla informacje o pliku dźwiękowym
108- sndfile-play - odtwarza pliki dźwiękowe
109
1dcb9798
AM
110%prep
111%setup -q
02b014db 112%patch0 -p1
1dcb9798 113
55badcef
KK
114%if %{without tests}
115%{__sed} -i 's, tests$,,' Makefile.am
116%endif
117
1dcb9798 118%build
92de6080 119%{__libtoolize}
03d66581 120%{__aclocal} -I M4
4a72fafe 121%{__autoconf}
4a72fafe 122%{__automake}
19550c7f
KK
123%configure \
124 %{!?with_static_libs:--disable-static} \
e991aa6f 125 %{!?with_regtest:--disable-sqlite}
19550c7f 126
8af0f3e0 127%{__make}
e991aa6f 128%{?with_tests: %{__make} test}
1dcb9798
AM
129
130%install
131rm -rf $RPM_BUILD_ROOT
0ee4787d 132
9c3ecd17
PG
133%{__make} install \
134 DESTDIR=$RPM_BUILD_ROOT
0ee4787d 135
8c0d9fea
JB
136rm -rf $RPM_BUILD_ROOT%{_docdir}/libsndfile1-dev
137
1dcb9798
AM
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
143
144%files
145%defattr(644,root,root,755)
5f0a3024 146%doc AUTHORS ChangeLog NEWS README
69842c69
JB
147%attr(755,root,root) %{_libdir}/libsndfile.so.*.*.*
148%attr(755,root,root) %ghost %{_libdir}/libsndfile.so.1
1dcb9798
AM
149
150%files devel
151%defattr(644,root,root,755)
3b7944d6 152%doc doc/*.html doc/*.jpg doc/new_file_type.HOWTO
92edf427
JB
153%attr(755,root,root) %{_libdir}/libsndfile.so
154%{_libdir}/libsndfile.la
155%{_includedir}/sndfile.h*
156%{_pkgconfigdir}/sndfile.pc
1dcb9798 157
19550c7f 158%if %{with static_libs}
1dcb9798 159%files static
a6cdcff3 160%defattr(644,root,root,755)
92edf427 161%{_libdir}/libsndfile.a
19550c7f 162%endif
bcbe612a
SZ
163
164%files octave
165%defattr(644,root,root,755)
69842c69
JB
166%{_datadir}/octave/site/m/sndfile_*.m
167%dir %{_libdir}/octave/*/site/oct/*/sndfile
168%{_libdir}/octave/*/site/oct/*/sndfile/PKG_ADD
169%attr(755,root,root) %{_libdir}/octave/*/site/oct/*/sndfile/sndfile.oct
e991aa6f
SS
170
171%files progs
172%defattr(644,root,root,755)
03d66581 173%attr(755,root,root) %{_bindir}/sndfile-*
e991aa6f 174%{_mandir}/man1/sndfile-*.1*
This page took 0.069966 seconds and 4 git commands to generate.