]> git.pld-linux.org Git - packages/libsndfile.git/blame - libsndfile.spec
- fix build with octave 4.0
[packages/libsndfile.git] / libsndfile.spec
CommitLineData
e991aa6f 1# TODO:
e991aa6f 2# - who needs sndfile-regtest?
19550c7f
KK
3#
4# Conditional build:
e991aa6f 5%bcond_with regtest # build sndfile-regtest program
c0533da4 6%bcond_without octave # don't build octave binding
19550c7f 7%bcond_without static_libs # don't build static library
55badcef 8%bcond_without tests # don't build tests
19550c7f 9#
1dcb9798 10Summary: C library for reading and writing files containing sampled sound
99339b5d 11Summary(pl.UTF-8): Biblioteka obsługi plików dźwiękowych
1dcb9798 12Name: libsndfile
4f3fc1b8 13Version: 1.0.25
c0533da4 14Release: 10
a438ce96 15License: LGPL v2.1+
8b67e6cc 16Group: Libraries
4f0a289c 17Source0: http://www.mega-nerd.com/libsndfile/files/%{name}-%{version}.tar.gz
4f3fc1b8 18# Source0-md5: e2b7bb637e01022c7d20f95f9c3990a2
02b014db 19Patch0: octave32.patch
c0533da4 20Patch1: %{name}-link.patch
f967ffbb 21URL: http://www.mega-nerd.com/libsndfile/
19550c7f 22BuildRequires: alsa-lib-devel
4f0a289c 23BuildRequires: autoconf >= 2.57
16af1fdc 24BuildRequires: automake
4f0a289c 25BuildRequires: flac-devel >= 1.2.1
9bec58c8 26BuildRequires: gcc-fortran
4f0a289c 27BuildRequires: libogg-devel >= 2:1.1.3
55badcef 28%{?with_tests:BuildRequires: libstdc++-devel}
487276e9 29BuildRequires: libtool
4f0a289c
JB
30BuildRequires: libvorbis-devel >= 1:1.2.3
31%{?with_octave:BuildRequires: octave-devel}
19550c7f 32BuildRequires: pkgconfig
55badcef 33BuildRequires: sed >= 4.0
4f0a289c 34%{?with_regtest:BuildRequires: sqlite3-devel >= 3.2}
7005f73b
JB
35Requires: flac >= 1.2.1
36Requires: libogg >= 2:1.1.3
37Requires: libvorbis >= 1:1.2.3
3d5577b2 38Obsoletes: libsndfile1
ae214341 39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1dcb9798
AM
40
41%description
a6cdcff3 42Libsndfile is a C library for reading and writing files containing
43sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format)
44through one standard library interface.
1dcb9798 45
66b8034c
JR
46%description -l pl.UTF-8
47Libsndfile to biblioteką napisaną w C, służąca do czytania i
48zapisywania plików zawierających zsamplowany dźwięk (np. w formacie MS
a6cdcff3 49Windows WAV czy Apple/SGI AIFF) poprzez jednolity, standardowy
50interfejs.
0ee4787d 51
1dcb9798
AM
52%package devel
53Summary: libsndfile header files and development documentation
99339b5d 54Summary(pl.UTF-8): Pliki nagłówkowe oraz dokumentacja do libsndfile
1dcb9798 55Group: Development/Libraries
f967ffbb 56Requires: %{name} = %{version}-%{release}
4f0a289c 57Requires: flac-devel >= 1.2.1
7005f73b
JB
58Requires: libogg-devel >= 2:1.1.3
59Requires: libvorbis-devel >= 1:1.2.3
3d5577b2 60Obsoletes: libsndfile1-devel
1dcb9798
AM
61
62%description devel
63Header files and development documentation for libsndfile.
64
66b8034c
JR
65%description devel -l pl.UTF-8
66Pliki nagłówkowe oraz dokumentacja do biblioteki libsndfile.
1dcb9798
AM
67
68%package static
69Summary: libsndfile static libraries
99339b5d 70Summary(pl.UTF-8): Biblioteki statyczne libsndfile
1dcb9798 71Group: Development/Libraries
f967ffbb 72Requires: %{name}-devel = %{version}-%{release}
1dcb9798
AM
73
74%description static
75libsndfile static libraries.
76
66b8034c 77%description static -l pl.UTF-8
1dcb9798
AM
78Biblioteki statyczne libsndfile.
79
e991aa6f
SS
80%package progs
81Summary: libsndfile utility programs
82Summary(pl.UTF-8): Narzędzia korzystające z biblioteki libsndfile
9549b058 83Group: Applications/Sound
373e2ff9 84Requires: %{name} = %{version}-%{release}
e991aa6f
SS
85
86%description progs
87libsndfile utility programs:
4f0a289c
JB
88- sndfile-convert - convert a sound files from one format to another
89- sndfile-info - display information about a sound file
90- sndfile-play - play a sound file
e991aa6f
SS
91
92%description progs -l pl.UTF-8
93Narzędzia z biblioteki libsndfile:
94- sndfile-convert - kowertertuje pliki dźwiękowe
95- sndfile-info - wyświetla informacje o pliku dźwiękowym
96- sndfile-play - odtwarza pliki dźwiękowe
97
7005f73b
JB
98%package -n octave-sndfile
99Summary: sndfile module for Octave
100Summary(pl.UTF-8): Moduł sndfile dla Octave
101Group: Applications/Math
102Requires: %{name} = %{version}-%{release}
103Requires: octave
104Obsoletes: libsndfile-octave
105
106%description -n octave-sndfile
107A couple of script files for loading, saving, and playing sound files
108from within Octave.
109
110%description -n octave-sndfile -l pl.UTF-8
111Kilka skryptów Octave do ładowania, zapisywania i odtwarzania plików
112dźwiękowych.
113
1dcb9798
AM
114%prep
115%setup -q
02b014db 116%patch0 -p1
c0533da4 117%patch1 -p1
1dcb9798 118
55badcef
KK
119%if %{without tests}
120%{__sed} -i 's, tests$,,' Makefile.am
121%endif
122
1dcb9798 123%build
92de6080 124%{__libtoolize}
03d66581 125%{__aclocal} -I M4
4a72fafe 126%{__autoconf}
4a72fafe 127%{__automake}
19550c7f 128%configure \
c0533da4
JB
129 --disable-silent-rules \
130 %{!?with_regtest:--disable-sqlite} \
131 %{!?with_static_libs:--disable-static}
132
133%{__make}
19550c7f 134
c0533da4 135%{?with_tests:%{__make} test}
1dcb9798
AM
136
137%install
138rm -rf $RPM_BUILD_ROOT
0ee4787d 139
9c3ecd17
PG
140%{__make} install \
141 DESTDIR=$RPM_BUILD_ROOT
0ee4787d 142
7005f73b 143%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libsndfile1-dev
8c0d9fea 144
1dcb9798
AM
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post -p /sbin/ldconfig
149%postun -p /sbin/ldconfig
150
151%files
152%defattr(644,root,root,755)
5f0a3024 153%doc AUTHORS ChangeLog NEWS README
69842c69
JB
154%attr(755,root,root) %{_libdir}/libsndfile.so.*.*.*
155%attr(755,root,root) %ghost %{_libdir}/libsndfile.so.1
1dcb9798
AM
156
157%files devel
158%defattr(644,root,root,755)
3b7944d6 159%doc doc/*.html doc/*.jpg doc/new_file_type.HOWTO
92edf427
JB
160%attr(755,root,root) %{_libdir}/libsndfile.so
161%{_libdir}/libsndfile.la
162%{_includedir}/sndfile.h*
163%{_pkgconfigdir}/sndfile.pc
1dcb9798 164
19550c7f 165%if %{with static_libs}
1dcb9798 166%files static
a6cdcff3 167%defattr(644,root,root,755)
92edf427 168%{_libdir}/libsndfile.a
19550c7f 169%endif
bcbe612a 170
7005f73b
JB
171%files progs
172%defattr(644,root,root,755)
173%attr(755,root,root) %{_bindir}/sndfile-*
174%{_mandir}/man1/sndfile-*.1*
175
4f0a289c 176%if %{with octave}
7005f73b 177%files -n octave-sndfile
bcbe612a 178%defattr(644,root,root,755)
69842c69
JB
179%{_datadir}/octave/site/m/sndfile_*.m
180%dir %{_libdir}/octave/*/site/oct/*/sndfile
181%{_libdir}/octave/*/site/oct/*/sndfile/PKG_ADD
182%attr(755,root,root) %{_libdir}/octave/*/site/oct/*/sndfile/sndfile.oct
4f0a289c 183%endif
This page took 0.11213 seconds and 4 git commands to generate.