]> git.pld-linux.org Git - packages/librhtv.git/blame - librhtv.spec
- chmod 0755 librhtv.so.2.2.1 for debuginfo.
[packages/librhtv.git] / librhtv.spec
CommitLineData
682ae7e7 1Summary: Unix port of Borland TurboVision library
daeaddf3 2Summary(pl.UTF-8): Uniksowa wersja biblioteki TurboVision Borlanda
682ae7e7 3Name: librhtv
d9f8c41d 4Version: 2.2.1
d1d2c16b 5Release: 3
2e2c883b 6License: Borland, some modifications are BSD-like licensed (generally free)
682ae7e7 7Group: Libraries
d9f8c41d 8Source0: http://download.sourceforge.net/tvision/rhtvision_%{version}-1.tar.gz
9# Source0-md5: 46b815d86bbbb2f9b112b11f63e2f5a6
aac82b43 10Patch0: %{name}-nolowlevelgarbage.patch
d9f8c41d 11Patch1: %{name}-fcntl.patch
12Patch2: %{name}-ncurses.patch
f0c034a2 13Patch3: format-security.patch
fc8a39a8 14Patch4: infinite-loop.patch
aac82b43 15URL: http://tvision.sourceforge.net/
d9f8c41d 16BuildRequires: xorg-lib-libX11-devel
682ae7e7 17BuildRequires: gpm-devel
f18913d0 18BuildRequires: libstdc++-devel
682ae7e7 19BuildRequires: ncurses-devel
aac82b43 20BuildRequires: perl-base
682ae7e7
JB
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Turbo Vision (or TV, for short) is a library that provides an
25application framework. With TV you can write a beautiful
26object-oriented character-mode user interface in a short time.
27
28TV is available in C++ and Pascal and is a product of Borland
29International. It was developed to run on MS-DOS systems, but today it
30is available for many other platforms (ported by independent
31programmers).
32
33This port is based on the Borland 2.0 version with fixes.
34
6039244a 35%description -l pl.UTF-8
682ae7e7 36Uniksowa wersja biblioteki TurboVision 2.0 Borlanda. TurboVision jest
6039244a 37obiektową biblioteką do okienkowych interfejsów użytkownika w trybie
682ae7e7
JB
38tekstowym.
39
40%package devel
41Summary: %{name} header files
daeaddf3 42Summary(pl.UTF-8): Pliki nagłówkowe %{name}
682ae7e7 43Group: Development/Libraries
7a105039 44Requires: %{name} = %{version}-%{release}
682ae7e7
JB
45
46%description devel
47rhtvision header files.
48
6039244a
JR
49%description devel -l pl.UTF-8
50Pliki nagłówkowe rhtvision.
682ae7e7
JB
51
52%package static
53Summary: Static %{name} libraries
daeaddf3 54Summary(pl.UTF-8): Biblioteki statyczne %{name}
682ae7e7 55Group: Development/Libraries
7a105039 56Requires: %{name}-devel = %{version}-%{release}
682ae7e7
JB
57
58%description static
59Static rhtvision libraries.
60
6039244a 61%description static -l pl.UTF-8
682ae7e7
JB
62Biblioteki statyczne rhtvision.
63
64%prep
65%setup -q -n tvision
0e0bbc2c 66%patch0 -p1
82f5c103 67%patch1 -p1
d9f8c41d 68%patch2 -p1
f0c034a2 69%patch3 -p1
fc8a39a8 70%patch4 -p1
682ae7e7
JB
71
72%build
aac82b43
JB
73%{__perl} config.pl \
74 --prefix=%{_prefix} \
d9f8c41d 75 --cflags="%{rpmcflags} -I/usr/include/ncursesw" \
76 --cxxflags="%{rpmcflags} -fno-exceptions -I/usr/include/ncursesw" \
f0c034a2 77 --X11lib="X11 Xmu" \
6ebcb362
WF
78 --with-debug \
79 %{?debug:--debug}
682ae7e7
JB
80
81%{__make} \
e071c183
ER
82 RHIDE_GCC="%{__cc}" \
83 RHIDE_GXX="%{__cxx}" \
f0c034a2 84 RHIDE_LDFLAGS="%{rpmldflags} -shared -Wl,-soname,librhtv.so.2" \
8be59a02 85 libdir=%{_libdir}
682ae7e7
JB
86
87%install
88rm -rf $RPM_BUILD_ROOT
aac82b43 89install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
682ae7e7
JB
90
91%{__make} install \
8be59a02
JB
92 prefix=$RPM_BUILD_ROOT%{_prefix} \
93 libdir=$RPM_BUILD_ROOT%{_libdir}
682ae7e7 94
f0c034a2 95cd $RPM_BUILD_ROOT%{_libdir}
0c4a542b 96ln -sf librhtv.so.%{version} librhtv.so.2
d1d2c16b 97chmod 0755 librhtv.so.%{version}
f0c034a2
WF
98cd -
99
b904017e 100# let's create new rhide.env
682ae7e7
JB
101cat > examples/rhide.env <<EOF
102RHIDE_GCC=gcc
f18913d0 103RHIDE_GXX=g++
682ae7e7
JB
104RHIDE_LD=gcc
105RHIDE_AR=ar
aac82b43
JB
106RHIDE_ARFLAGS=rcs
107RHIDE_OS_CFLAGS=%{rpmcflags} -Wall
108RHIDE_OS_CXXFLAGS=%{rpmcflags} -Wall
109RHIDE_STDINC=/usr/include /usr/X11R6/include /usr/include/ncurses
682ae7e7 110TVSRC=%{_includedir}/rhtvision
aac82b43 111RHIDE_OS_LIBS=stdc++
682ae7e7 112TVOBJ=
aac82b43
JB
113STDCPP_LIB=-lstdc++
114SHARED_CODE_OPTION=-fPIC
682ae7e7
JB
115EOF
116
117cd examples
aac82b43 118%{__perl} patchenv.pl
682ae7e7
JB
119cd ..
120
5511054f 121cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
aac82b43 122
d548cb6f 123%find_lang tvision%{version}
682ae7e7 124
682ae7e7
JB
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post -p /sbin/ldconfig
129%postun -p /sbin/ldconfig
130
d548cb6f 131%files -f tvision%{version}.lang
682ae7e7 132%defattr(644,root,root,755)
4bb4c50d 133%doc readme.txt TODO borland.txt
0c4a542b
JB
134%attr(755,root,root) %{_libdir}/librhtv.so.*.*.*
135%attr(755,root,root) %ghost %{_libdir}/librhtv.so.2
682ae7e7
JB
136
137%files devel
138%defattr(644,root,root,755)
568f6097 139%doc doc/*.txt doc/*.html
aac82b43 140%attr(755,root,root) %{_bindir}/rhtv-config
0c4a542b
JB
141%attr(755,root,root) %{_libdir}/librhtv.so
142%{_libdir}/libtvfintl.a
143%{_includedir}/rhtvision
aac82b43 144%{_examplesdir}/%{name}-%{version}
682ae7e7
JB
145
146%files static
147%defattr(644,root,root,755)
0c4a542b 148%{_libdir}/librhtv.a
This page took 0.104736 seconds and 4 git commands to generate.