]> git.pld-linux.org Git - packages/librevenge.git/blame - librevenge.spec
- updated to 0.0.5
[packages/librevenge.git] / librevenge.spec
CommitLineData
4f693921
JB
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4%bcond_without gdb # GDB pretty printers
4a8f62a5 5
4f693921
JB
6Summary: Library for generic document converters
7Summary(pl.UTF-8): Biblioteka dla ogólnych konwerterów dokumentów
8Name: librevenge
11024907
JB
9Version: 0.0.5
10Release: 1
4f693921
JB
11License: MPL v2.0 or LGPL v2.1+
12Group: Libraries
11024907
JB
13Source0: https://downloads.sourceforge.net/libwpd/%{name}-%{version}.tar.xz
14# Source0-md5: c6e629dfb9557a6a2cd4309b31eddfa8
4f693921
JB
15URL: https://sourceforge.net/p/libwpd/wiki/librevenge/
16BuildRequires: autoconf >= 2.65
17BuildRequires: automake >= 1:1.11
18BuildRequires: boost-devel >= 1.20
7a99d348 19BuildRequires: cppunit-devel
4f693921 20BuildRequires: doxygen
11024907 21BuildRequires: libstdc++-devel >= 6:4.7
4f693921
JB
22BuildRequires: libtool >= 2:2
23BuildRequires: pkgconfig
24%{?with_gdb:BuildRequires: python-modules}
25BuildRequires: rpmbuild(macros) >= 1.234
26BuildRequires: tar >= 1:1.22
27BuildRequires: xz
28BuildRequires: zlib-devel
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32librevenge is a base library for writing document import filters. It
33has interfaces for text documents, vector graphics, spreadsheets and
34presentations.
35
36%description -l pl.UTF-8
37librevenge to biblioteka podstawowa do pisania filtrów importujących
38dokumenty. Zawiera interfejsy dla dokumentów tekstowych, grafiki
39wektorowej, arkuszy kalkulacyjnych oraz prezentacji.
40
41%package devel
42Summary: Header files for librevenge library
43Summary(pl.UTF-8): Pliki nagłówkowe biblioteki librevenge
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
11024907 46Requires: libstdc++-devel >= 6:4.7
4f693921
JB
47
48%description devel
49Header files for librevenge library.
50
51%description devel -l pl.UTF-8
52Pliki nagłówkowe biblioteki librevenge.
53
54%package static
55Summary: Static librevenge library
56Summary(pl.UTF-8): Statyczna biblioteka librevenge
57Group: Development/Libraries
58Requires: %{name}-devel = %{version}-%{release}
59
60%description static
61Static librevenge library.
62
63%description static -l pl.UTF-8
64Statyczna biblioteka librevenge.
65
66%package apidocs
67Summary: API documentation for librevenge library
68Summary(pl.UTF-8): Dokumentacja API biblioteki librevenge
69Group: Documentation
4a8f62a5 70BuildArch: noarch
4f693921
JB
71
72%description apidocs
73API documentation for librevenge library.
74
75%description apidocs -l pl.UTF-8
76Dokumentacja API biblioteki librevenge.
77
78%package gdb
79Summary: GDB Python pretty printers for librevenge types
80Summary(pl.UTF-8): Skrypty Pythona dla GDB do ładnego wypisywania typów librevenge
81Group: Development/Debuggers
82Requires: gdb
83
84%description gdb
85GDB Python pretty printers for librevenge types.
86
87%description gdb -l pl.UTF-8
88Skrypty Pythona dla GDB do ładnego wypisywania typów librevenge.
89
90%prep
91%setup -q
92
93%build
94%{__libtoolize}
95%{__aclocal}
96%{__autoconf}
97%{__autoheader}
98%{__automake}
99%configure \
100 %{?with_gdb:--enable-pretty-printers} \
101 %{?with_static_libs:--enable-static} \
8e0755f9 102 --disable-werror \
4f693921
JB
103 --disable-silent-rules
104%{__make}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT
111
4a8f62a5 112%{__rm} -r $RPM_BUILD_ROOT%{_docdir}
4f693921
JB
113%{__rm} $RPM_BUILD_ROOT%{_libdir}/librevenge-*.la
114
115%if %{with gdb}
116%py_comp $RPM_BUILD_ROOT%{_datadir}/librevenge/python/librevenge
117%py_ocomp $RPM_BUILD_ROOT%{_datadir}/librevenge/python/librevenge
118%py_postclean %{_datadir}/librevenge/python/librevenge
119%endif
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files
128%defattr(644,root,root,755)
129%doc AUTHORS ChangeLog NEWS README
130%attr(755,root,root) %{_libdir}/librevenge-0.0.so.*.*.*
131%attr(755,root,root) %ghost %{_libdir}/librevenge-0.0.so.0
132%attr(755,root,root) %{_libdir}/librevenge-generators-0.0.so.*.*.*
133%attr(755,root,root) %ghost %{_libdir}/librevenge-generators-0.0.so.0
134%attr(755,root,root) %{_libdir}/librevenge-stream-0.0.so.*.*.*
135%attr(755,root,root) %ghost %{_libdir}/librevenge-stream-0.0.so.0
136
137%files devel
138%defattr(644,root,root,755)
139%attr(755,root,root) %{_libdir}/librevenge-0.0.so
140%attr(755,root,root) %{_libdir}/librevenge-generators-0.0.so
141%attr(755,root,root) %{_libdir}/librevenge-stream-0.0.so
142%{_includedir}/librevenge-0.0
143%{_pkgconfigdir}/librevenge-0.0.pc
144%{_pkgconfigdir}/librevenge-generators-0.0.pc
145%{_pkgconfigdir}/librevenge-stream-0.0.pc
146
147%if %{with static_libs}
148%files static
149%defattr(644,root,root,755)
150%{_libdir}/librevenge-0.0.a
151%{_libdir}/librevenge-generators-0.0.a
152%{_libdir}/librevenge-stream-0.0.a
153%endif
154
155%files apidocs
156%defattr(644,root,root,755)
157%doc docs/doxygen/html/*
158
159%if %{with gdb}
160%files gdb
161%defattr(644,root,root,755)
11024907
JB
162%{_datadir}/gdb/auto-load/%{_libdir}/librevenge-0.0-gdb.py
163%{_datadir}/gdb/auto-load/%{_libdir}/librevenge-stream-0.0-gdb.py
4f693921
JB
164%dir %{_datadir}/librevenge
165%{_datadir}/librevenge/python
166%endif
This page took 0.100204 seconds and 4 git commands to generate.