]> git.pld-linux.org Git - packages/libredwg.git/blame - libredwg.spec
rebuild with perl 5.32
[packages/libredwg.git] / libredwg.spec
CommitLineData
c1f16d1a
JB
1Summary: LibreDWG - free implementation of the DWG file format
2Summary(pl.UTF-8): LibreDWG - wolnodostępna implementacja formatu plików DWG
3Name: libredwg
912a3222 4Version: 0.12.4
c2574b20 5Release: 2
c1f16d1a
JB
6License: GPL v3+
7Group: Libraries
8Source0: https://ftp.gnu.org/gnu/libredwg/%{name}-%{version}.tar.xz
912a3222 9# Source0-md5: 9aba1400b02db931f4ee8a1155fd2376
9467f20e
JB
10Patch0: %{name}-info.patch
11Patch1: %{name}-python.patch
912a3222 12Patch2: %{name}-sh.patch
c1f16d1a
JB
13URL: http://www.gnu.org/software/libredwg/
14BuildRequires: autoconf >= 2.61
15BuildRequires: automake >= 1:1.14
16BuildRequires: bash
17BuildRequires: doxygen
18BuildRequires: libtool >= 2:2
19BuildRequires: libxml2-devel >= 2.0
20BuildRequires: pcre2-8-devel
21BuildRequires: pcre2-16-devel
22BuildRequires: perl-devel
23BuildRequires: pkgconfig
24BuildRequires: pslib-devel
25BuildRequires: python-devel >= 1:2.7
26BuildRequires: rpm-perlprov
27BuildRequires: rpm-pythonprov
28BuildRequires: sed >= 4.0
29BuildRequires: swig-python >= 1.3.17
30BuildRequires: tar >= 1:1.22
31BuildRequires: texinfo
32BuildRequires: xz
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36LibreDWG is a free C library to read DWG files. DWG is a file format
37created in the 70's for the emerging CAD applications. Currently it
38is the native file format of AutoCAD, a proprietary CAD program
39developed by AutoDesk.
40
41%description -l pl.UTF-8
42LibreDWG to wolnodostępna biblioteka C do odczytu plików DWG. DWG to
43format plików powstały w latach 70. dla powstających aplikacji CAD.
44Obecnie jest to natywny format AutoCAD-a - własnościowego programu
45CAD rozwijanego przez firmę AutoDesk.
46
47%package devel
48Summary: Header files for LibreDWG library
49Summary(pl.UTF-8): Pliki nagłówkowe biblioteki LibreDWG
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52# dwg.h file
53Conflicts: libdwg-devel
54
55%description devel
56Header files for LibreDWG library.
57
58%description devel -l pl.UTF-8
59Pliki nagłówkowe biblioteki LibreDWG.
60
61%package static
62Summary: Static LibreDWG library
63Summary(pl.UTF-8): Statyczna biblioteka LibreDWG
64Group: Development/Libraries
65Requires: %{name}-devel = %{version}-%{release}
66
67%description static
68Static LibreDWG library.
69
70%description static -l pl.UTF-8
71Statyczna biblioteka LibreDWG.
72
73%package -n perl-libredwg
74Summary: Perl interface for LibreDWG library
75Summary(pl.UTF-8): Interfejs Perla do biblioteki LibreDWG
76Group: Development/Languages/Perl
77Requires: %{name} = %{version}-%{release}
78
79%description -n perl-libredwg
80Perl interface for LibreDWG library.
81
82%description -n perl-libredwg -l pl.UTF-8
83Interfejs Perla do biblioteki LibreDWG.
84
85%package -n python-libredwg
86Summary: Python interface for LibreDWG library
87Summary(pl.UTF-8): Interfejs Pythona do biblioteki LibreDWG
88Group: Development/Languages/Perl
89Requires: %{name} = %{version}-%{release}
90
91%description -n python-libredwg
92Python interface for LibreDWG library.
93
94%description -n python-libredwg -l pl.UTF-8
95Interfejs Pythona do biblioteki LibreDWG.
96
97%prep
98%setup -q
99%patch0 -p1
100%patch1 -p1
912a3222 101%patch2 -p1
c1f16d1a
JB
102
103# no git-version-gen in release tarball
104%{__sed} -i -e 's/m4_esyscmd.*git-version-gen.*/[%{version}],/' configure.ac
105
610080b3
JB
106# disable when not running tests
107%{__sed} -i -e '/^check_PROGRAMS/ s/ llvmfuzz_standalone//' examples/Makefile.am
108
c1f16d1a
JB
109%build
110%{__libtoolize}
111%{__aclocal} -I m4
112%{__autoconf}
113%{__autoheader}
114%{__automake}
115%configure \
116 --disable-silent-rules \
117 --with-perl-install=vendor
118
119%{__make}
120
121%install
122rm -rf $RPM_BUILD_ROOT
123
124%{__make} install \
125 DESTDIR=$RPM_BUILD_ROOT
126
127# obsoleted by pkg-config
128%{__rm} $RPM_BUILD_ROOT%{_libdir}/libredwg.la
129
130%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_LibreDWG.la
131%py_postclean
132
9467f20e
JB
133# just example, nothing really useful
134install -d $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
135%{__mv} $RPM_BUILD_ROOT%{_datadir}/load_dwg.py $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
136# packaged as %doc
137%{__rm} $RPM_BUILD_ROOT%{_datadir}/dwgadd.example
138
c1f16d1a
JB
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%post -p /sbin/ldconfig
143%postun -p /sbin/ldconfig
144
145%post devel -p /sbin/postshell
146-/usr/sbin/fix-info-dir -c %{_infodir}
147
148%postun devel -p /sbin/postshell
149-/usr/sbin/fix-info-dir -c %{_infodir}
150
151%files
152%defattr(644,root,root,755)
9467f20e 153%doc AUTHORS ChangeLog NEWS README TODO examples/dwgadd.example
c1f16d1a
JB
154%attr(755,root,root) %{_bindir}/dwg2SVG
155%attr(755,root,root) %{_bindir}/dwg2dxf
156%attr(755,root,root) %{_bindir}/dwg2ps
9467f20e 157%attr(755,root,root) %{_bindir}/dwgadd
c1f16d1a
JB
158%attr(755,root,root) %{_bindir}/dwgbmp
159%attr(755,root,root) %{_bindir}/dwgfilter
160%attr(755,root,root) %{_bindir}/dwggrep
161%attr(755,root,root) %{_bindir}/dwglayers
162%attr(755,root,root) %{_bindir}/dwgread
163%attr(755,root,root) %{_bindir}/dwgrewrite
164%attr(755,root,root) %{_bindir}/dwgwrite
165%attr(755,root,root) %{_bindir}/dxf2dwg
166%attr(755,root,root) %{_bindir}/dxfwrite
167%attr(755,root,root) %{_libdir}/libredwg.so.*.*.*
168%attr(755,root,root) %ghost %{_libdir}/libredwg.so.0
169%{_mandir}/man1/dwg2SVG.1*
170%{_mandir}/man1/dwg2dxf.1*
171%{_mandir}/man1/dwg2ps.1*
9467f20e 172%{_mandir}/man1/dwgadd.1*
c1f16d1a
JB
173%{_mandir}/man1/dwgbmp.1*
174%{_mandir}/man1/dwgfilter.1*
175%{_mandir}/man1/dwggrep.1*
176%{_mandir}/man1/dwglayers.1*
177%{_mandir}/man1/dwgread.1*
178%{_mandir}/man1/dwgrewrite.1*
179%{_mandir}/man1/dwgwrite.1*
180%{_mandir}/man1/dxf2dwg.1*
181%{_mandir}/man1/dxfwrite.1*
9467f20e 182%{_mandir}/man5/dwgadd.5*
c1f16d1a
JB
183
184%files devel
185%defattr(644,root,root,755)
186%attr(755,root,root) %{_libdir}/libredwg.so
187%{_includedir}/dwg.h
188%{_includedir}/dwg_api.h
189%{_pkgconfigdir}/libredwg.pc
190%{_infodir}/LibreDWG.info*
191
192%files static
193%defattr(644,root,root,755)
194%{_libdir}/libredwg.a
195
196%files -n perl-libredwg
197%defattr(644,root,root,755)
198%{perl_vendorarch}/LibreDWG.pm
199%dir %{perl_vendorarch}/auto
200%dir %{perl_vendorarch}/auto/LibreDWG
201%attr(755,root,root) %{perl_vendorarch}/auto/LibreDWG/LibreDWG.so
202
203%files -n python-libredwg
204%defattr(644,root,root,755)
205%attr(755,root,root) %{py_sitedir}/_LibreDWG.so
206%{py_sitescriptdir}/LibreDWG.py[co]
9467f20e 207%{_examplesdir}/python-libredwg-%{version}
This page took 0.119887 seconds and 4 git commands to generate.