]> git.pld-linux.org Git - packages/libredwg.git/blame - libredwg.spec
- updated to 0.12
[packages/libredwg.git] / libredwg.spec
CommitLineData
c1f16d1a
JB
1Summary: LibreDWG - free implementation of the DWG file format
2Summary(pl.UTF-8): LibreDWG - wolnodostępna implementacja formatu plików DWG
3Name: libredwg
9467f20e 4Version: 0.12
c1f16d1a
JB
5Release: 1
6License: GPL v3+
7Group: Libraries
8Source0: https://ftp.gnu.org/gnu/libredwg/%{name}-%{version}.tar.xz
9467f20e
JB
9# Source0-md5: 5b102e8684333622819cc74dc8a76118
10Patch0: %{name}-info.patch
11Patch1: %{name}-python.patch
c1f16d1a
JB
12URL: http://www.gnu.org/software/libredwg/
13BuildRequires: autoconf >= 2.61
14BuildRequires: automake >= 1:1.14
15BuildRequires: bash
16BuildRequires: doxygen
17BuildRequires: libtool >= 2:2
18BuildRequires: libxml2-devel >= 2.0
19BuildRequires: pcre2-8-devel
20BuildRequires: pcre2-16-devel
21BuildRequires: perl-devel
22BuildRequires: pkgconfig
23BuildRequires: pslib-devel
24BuildRequires: python-devel >= 1:2.7
25BuildRequires: rpm-perlprov
26BuildRequires: rpm-pythonprov
27BuildRequires: sed >= 4.0
28BuildRequires: swig-python >= 1.3.17
29BuildRequires: tar >= 1:1.22
30BuildRequires: texinfo
31BuildRequires: xz
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35LibreDWG is a free C library to read DWG files. DWG is a file format
36created in the 70's for the emerging CAD applications. Currently it
37is the native file format of AutoCAD, a proprietary CAD program
38developed by AutoDesk.
39
40%description -l pl.UTF-8
41LibreDWG to wolnodostępna biblioteka C do odczytu plików DWG. DWG to
42format plików powstały w latach 70. dla powstających aplikacji CAD.
43Obecnie jest to natywny format AutoCAD-a - własnościowego programu
44CAD rozwijanego przez firmę AutoDesk.
45
46%package devel
47Summary: Header files for LibreDWG library
48Summary(pl.UTF-8): Pliki nagłówkowe biblioteki LibreDWG
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51# dwg.h file
52Conflicts: libdwg-devel
53
54%description devel
55Header files for LibreDWG library.
56
57%description devel -l pl.UTF-8
58Pliki nagłówkowe biblioteki LibreDWG.
59
60%package static
61Summary: Static LibreDWG library
62Summary(pl.UTF-8): Statyczna biblioteka LibreDWG
63Group: Development/Libraries
64Requires: %{name}-devel = %{version}-%{release}
65
66%description static
67Static LibreDWG library.
68
69%description static -l pl.UTF-8
70Statyczna biblioteka LibreDWG.
71
72%package -n perl-libredwg
73Summary: Perl interface for LibreDWG library
74Summary(pl.UTF-8): Interfejs Perla do biblioteki LibreDWG
75Group: Development/Languages/Perl
76Requires: %{name} = %{version}-%{release}
77
78%description -n perl-libredwg
79Perl interface for LibreDWG library.
80
81%description -n perl-libredwg -l pl.UTF-8
82Interfejs Perla do biblioteki LibreDWG.
83
84%package -n python-libredwg
85Summary: Python interface for LibreDWG library
86Summary(pl.UTF-8): Interfejs Pythona do biblioteki LibreDWG
87Group: Development/Languages/Perl
88Requires: %{name} = %{version}-%{release}
89
90%description -n python-libredwg
91Python interface for LibreDWG library.
92
93%description -n python-libredwg -l pl.UTF-8
94Interfejs Pythona do biblioteki LibreDWG.
95
96%prep
97%setup -q
98%patch0 -p1
99%patch1 -p1
c1f16d1a
JB
100
101# no git-version-gen in release tarball
102%{__sed} -i -e 's/m4_esyscmd.*git-version-gen.*/[%{version}],/' configure.ac
103
104%build
105%{__libtoolize}
106%{__aclocal} -I m4
107%{__autoconf}
108%{__autoheader}
109%{__automake}
110%configure \
111 --disable-silent-rules \
112 --with-perl-install=vendor
113
114%{__make}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119%{__make} install \
120 DESTDIR=$RPM_BUILD_ROOT
121
122# obsoleted by pkg-config
123%{__rm} $RPM_BUILD_ROOT%{_libdir}/libredwg.la
124
125%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_LibreDWG.la
126%py_postclean
127
9467f20e
JB
128# just example, nothing really useful
129install -d $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
130%{__mv} $RPM_BUILD_ROOT%{_datadir}/load_dwg.py $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
131# packaged as %doc
132%{__rm} $RPM_BUILD_ROOT%{_datadir}/dwgadd.example
133
c1f16d1a
JB
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post -p /sbin/ldconfig
138%postun -p /sbin/ldconfig
139
140%post devel -p /sbin/postshell
141-/usr/sbin/fix-info-dir -c %{_infodir}
142
143%postun devel -p /sbin/postshell
144-/usr/sbin/fix-info-dir -c %{_infodir}
145
146%files
147%defattr(644,root,root,755)
9467f20e 148%doc AUTHORS ChangeLog NEWS README TODO examples/dwgadd.example
c1f16d1a
JB
149%attr(755,root,root) %{_bindir}/dwg2SVG
150%attr(755,root,root) %{_bindir}/dwg2dxf
151%attr(755,root,root) %{_bindir}/dwg2ps
9467f20e 152%attr(755,root,root) %{_bindir}/dwgadd
c1f16d1a
JB
153%attr(755,root,root) %{_bindir}/dwgbmp
154%attr(755,root,root) %{_bindir}/dwgfilter
155%attr(755,root,root) %{_bindir}/dwggrep
156%attr(755,root,root) %{_bindir}/dwglayers
157%attr(755,root,root) %{_bindir}/dwgread
158%attr(755,root,root) %{_bindir}/dwgrewrite
159%attr(755,root,root) %{_bindir}/dwgwrite
160%attr(755,root,root) %{_bindir}/dxf2dwg
161%attr(755,root,root) %{_bindir}/dxfwrite
162%attr(755,root,root) %{_libdir}/libredwg.so.*.*.*
163%attr(755,root,root) %ghost %{_libdir}/libredwg.so.0
164%{_mandir}/man1/dwg2SVG.1*
165%{_mandir}/man1/dwg2dxf.1*
166%{_mandir}/man1/dwg2ps.1*
9467f20e 167%{_mandir}/man1/dwgadd.1*
c1f16d1a
JB
168%{_mandir}/man1/dwgbmp.1*
169%{_mandir}/man1/dwgfilter.1*
170%{_mandir}/man1/dwggrep.1*
171%{_mandir}/man1/dwglayers.1*
172%{_mandir}/man1/dwgread.1*
173%{_mandir}/man1/dwgrewrite.1*
174%{_mandir}/man1/dwgwrite.1*
175%{_mandir}/man1/dxf2dwg.1*
176%{_mandir}/man1/dxfwrite.1*
9467f20e 177%{_mandir}/man5/dwgadd.5*
c1f16d1a
JB
178
179%files devel
180%defattr(644,root,root,755)
181%attr(755,root,root) %{_libdir}/libredwg.so
182%{_includedir}/dwg.h
183%{_includedir}/dwg_api.h
184%{_pkgconfigdir}/libredwg.pc
185%{_infodir}/LibreDWG.info*
186
187%files static
188%defattr(644,root,root,755)
189%{_libdir}/libredwg.a
190
191%files -n perl-libredwg
192%defattr(644,root,root,755)
193%{perl_vendorarch}/LibreDWG.pm
194%dir %{perl_vendorarch}/auto
195%dir %{perl_vendorarch}/auto/LibreDWG
196%attr(755,root,root) %{perl_vendorarch}/auto/LibreDWG/LibreDWG.so
197
198%files -n python-libredwg
199%defattr(644,root,root,755)
200%attr(755,root,root) %{py_sitedir}/_LibreDWG.so
201%{py_sitescriptdir}/LibreDWG.py[co]
9467f20e 202%{_examplesdir}/python-libredwg-%{version}
This page took 0.086958 seconds and 4 git commands to generate.