]> git.pld-linux.org Git - packages/libredwg.git/blame - libredwg.spec
BR: help2man
[packages/libredwg.git] / libredwg.spec
CommitLineData
c1f16d1a
JB
1Summary: LibreDWG - free implementation of the DWG file format
2Summary(pl.UTF-8): LibreDWG - wolnodostępna implementacja formatu plików DWG
3Name: libredwg
945692a7
JB
4Version: 0.12.5
5Release: 1
c1f16d1a
JB
6License: GPL v3+
7Group: Libraries
8Source0: https://ftp.gnu.org/gnu/libredwg/%{name}-%{version}.tar.xz
945692a7 9# Source0-md5: 3cb1ec853a665b74924ac417698589d7
9467f20e
JB
10Patch0: %{name}-info.patch
11Patch1: %{name}-python.patch
c1f16d1a
JB
12URL: http://www.gnu.org/software/libredwg/
13BuildRequires: autoconf >= 2.61
14BuildRequires: automake >= 1:1.14
15BuildRequires: bash
16BuildRequires: doxygen
06b62e7a 17BuildRequires: help2man
c1f16d1a
JB
18BuildRequires: libtool >= 2:2
19BuildRequires: libxml2-devel >= 2.0
20BuildRequires: pcre2-8-devel
21BuildRequires: pcre2-16-devel
22BuildRequires: perl-devel
23BuildRequires: pkgconfig
24BuildRequires: pslib-devel
25BuildRequires: python-devel >= 1:2.7
26BuildRequires: rpm-perlprov
27BuildRequires: rpm-pythonprov
28BuildRequires: sed >= 4.0
29BuildRequires: swig-python >= 1.3.17
30BuildRequires: tar >= 1:1.22
31BuildRequires: texinfo
32BuildRequires: xz
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36LibreDWG is a free C library to read DWG files. DWG is a file format
37created in the 70's for the emerging CAD applications. Currently it
38is the native file format of AutoCAD, a proprietary CAD program
39developed by AutoDesk.
40
41%description -l pl.UTF-8
42LibreDWG to wolnodostępna biblioteka C do odczytu plików DWG. DWG to
43format plików powstały w latach 70. dla powstających aplikacji CAD.
44Obecnie jest to natywny format AutoCAD-a - własnościowego programu
45CAD rozwijanego przez firmę AutoDesk.
46
47%package devel
48Summary: Header files for LibreDWG library
49Summary(pl.UTF-8): Pliki nagłówkowe biblioteki LibreDWG
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52# dwg.h file
53Conflicts: libdwg-devel
54
55%description devel
56Header files for LibreDWG library.
57
58%description devel -l pl.UTF-8
59Pliki nagłówkowe biblioteki LibreDWG.
60
61%package static
62Summary: Static LibreDWG library
63Summary(pl.UTF-8): Statyczna biblioteka LibreDWG
64Group: Development/Libraries
65Requires: %{name}-devel = %{version}-%{release}
66
67%description static
68Static LibreDWG library.
69
70%description static -l pl.UTF-8
71Statyczna biblioteka LibreDWG.
72
73%package -n perl-libredwg
74Summary: Perl interface for LibreDWG library
75Summary(pl.UTF-8): Interfejs Perla do biblioteki LibreDWG
76Group: Development/Languages/Perl
77Requires: %{name} = %{version}-%{release}
78
79%description -n perl-libredwg
80Perl interface for LibreDWG library.
81
82%description -n perl-libredwg -l pl.UTF-8
83Interfejs Perla do biblioteki LibreDWG.
84
85%package -n python-libredwg
86Summary: Python interface for LibreDWG library
87Summary(pl.UTF-8): Interfejs Pythona do biblioteki LibreDWG
88Group: Development/Languages/Perl
89Requires: %{name} = %{version}-%{release}
90
91%description -n python-libredwg
92Python interface for LibreDWG library.
93
94%description -n python-libredwg -l pl.UTF-8
95Interfejs Pythona do biblioteki LibreDWG.
96
97%prep
98%setup -q
99%patch0 -p1
100%patch1 -p1
c1f16d1a
JB
101
102# no git-version-gen in release tarball
103%{__sed} -i -e 's/m4_esyscmd.*git-version-gen.*/[%{version}],/' configure.ac
104
610080b3
JB
105# disable when not running tests
106%{__sed} -i -e '/^check_PROGRAMS/ s/ llvmfuzz_standalone//' examples/Makefile.am
107
c1f16d1a
JB
108%build
109%{__libtoolize}
110%{__aclocal} -I m4
111%{__autoconf}
112%{__autoheader}
113%{__automake}
114%configure \
115 --disable-silent-rules \
116 --with-perl-install=vendor
117
945692a7
JB
118# programs/dwg2ps.1 is missing in dist as of 0.12.5
119%{__make} -C src
120%{__make} -C programs regen-man
121
c1f16d1a
JB
122%{__make}
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127%{__make} install \
128 DESTDIR=$RPM_BUILD_ROOT
129
130# obsoleted by pkg-config
131%{__rm} $RPM_BUILD_ROOT%{_libdir}/libredwg.la
132
133%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_LibreDWG.la
134%py_postclean
135
9467f20e
JB
136# just example, nothing really useful
137install -d $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
138%{__mv} $RPM_BUILD_ROOT%{_datadir}/load_dwg.py $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
139# packaged as %doc
140%{__rm} $RPM_BUILD_ROOT%{_datadir}/dwgadd.example
141
c1f16d1a
JB
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%post -p /sbin/ldconfig
146%postun -p /sbin/ldconfig
147
148%post devel -p /sbin/postshell
149-/usr/sbin/fix-info-dir -c %{_infodir}
150
151%postun devel -p /sbin/postshell
152-/usr/sbin/fix-info-dir -c %{_infodir}
153
154%files
155%defattr(644,root,root,755)
9467f20e 156%doc AUTHORS ChangeLog NEWS README TODO examples/dwgadd.example
c1f16d1a
JB
157%attr(755,root,root) %{_bindir}/dwg2SVG
158%attr(755,root,root) %{_bindir}/dwg2dxf
159%attr(755,root,root) %{_bindir}/dwg2ps
9467f20e 160%attr(755,root,root) %{_bindir}/dwgadd
c1f16d1a
JB
161%attr(755,root,root) %{_bindir}/dwgbmp
162%attr(755,root,root) %{_bindir}/dwgfilter
163%attr(755,root,root) %{_bindir}/dwggrep
164%attr(755,root,root) %{_bindir}/dwglayers
165%attr(755,root,root) %{_bindir}/dwgread
166%attr(755,root,root) %{_bindir}/dwgrewrite
167%attr(755,root,root) %{_bindir}/dwgwrite
168%attr(755,root,root) %{_bindir}/dxf2dwg
169%attr(755,root,root) %{_bindir}/dxfwrite
170%attr(755,root,root) %{_libdir}/libredwg.so.*.*.*
171%attr(755,root,root) %ghost %{_libdir}/libredwg.so.0
172%{_mandir}/man1/dwg2SVG.1*
173%{_mandir}/man1/dwg2dxf.1*
174%{_mandir}/man1/dwg2ps.1*
9467f20e 175%{_mandir}/man1/dwgadd.1*
c1f16d1a
JB
176%{_mandir}/man1/dwgbmp.1*
177%{_mandir}/man1/dwgfilter.1*
178%{_mandir}/man1/dwggrep.1*
179%{_mandir}/man1/dwglayers.1*
180%{_mandir}/man1/dwgread.1*
181%{_mandir}/man1/dwgrewrite.1*
182%{_mandir}/man1/dwgwrite.1*
183%{_mandir}/man1/dxf2dwg.1*
184%{_mandir}/man1/dxfwrite.1*
9467f20e 185%{_mandir}/man5/dwgadd.5*
c1f16d1a
JB
186
187%files devel
188%defattr(644,root,root,755)
189%attr(755,root,root) %{_libdir}/libredwg.so
190%{_includedir}/dwg.h
191%{_includedir}/dwg_api.h
192%{_pkgconfigdir}/libredwg.pc
193%{_infodir}/LibreDWG.info*
194
195%files static
196%defattr(644,root,root,755)
197%{_libdir}/libredwg.a
198
199%files -n perl-libredwg
200%defattr(644,root,root,755)
201%{perl_vendorarch}/LibreDWG.pm
202%dir %{perl_vendorarch}/auto
203%dir %{perl_vendorarch}/auto/LibreDWG
204%attr(755,root,root) %{perl_vendorarch}/auto/LibreDWG/LibreDWG.so
205
206%files -n python-libredwg
207%defattr(644,root,root,755)
208%attr(755,root,root) %{py_sitedir}/_LibreDWG.so
209%{py_sitescriptdir}/LibreDWG.py[co]
9467f20e 210%{_examplesdir}/python-libredwg-%{version}
This page took 0.140346 seconds and 4 git commands to generate.