]> git.pld-linux.org Git - packages/libmemcached.git/blame - libmemcached.spec
- rebuild with libevent 2.1.9
[packages/libmemcached.git] / libmemcached.spec
CommitLineData
b3eb527f 1#
a7fb1d55
AM
2# TODO:
3# m4 macros from pandora-build (http://code.launchpad.net/pandora-build)
4#
b3eb527f 5# Conditional build
6%bcond_without static_libs # don't build static library
e1d032be 7
a76bb5e7 8Summary: memcached client library
623bd9c9 9Summary(pl.UTF-8): Blblioteka kliencka memcached
a76bb5e7 10Name: libmemcached
1a91d275 11Version: 1.0.18
0c42653e 12Release: 3
a76bb5e7
AG
13License: BSD
14Group: Libraries
1a91d275
JB
15Source0: https://launchpad.net/libmemcached/1.0/%{version}/+download/%{name}-%{version}.tar.gz
16# Source0-md5: b3958716b4e53ddc5992e6c49d97e819
5cb40f55 17URL: http://libmemcached.org/
99aa0066 18BuildRequires: cyrus-sasl-devel
ba8924c1 19BuildRequires: libevent-devel
a76bb5e7 20BuildRequires: libstdc++-devel
a76bb5e7 21BuildRequires: perl-tools-pod
b048042d 22BuildRequires: sphinx-pdg
a76bb5e7
AG
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26libmemcached is a C and C++ client library to the memcached server
27(http://danga.com/memcached). It has been designed to be light on
28memory usage, thread safe, and provide full access to server side
29methods.
30
31%description -l pl.UTF-8
32libmemcached to biblioteka kliencka serwera memcached
33(http://danga.com/memcached) dla języków C/C++. Została zaprojektowana
34z myślą o niewielkim zużyciu pamięci, bezpieczeństwe i pełnym dostępie
35do metod po stronie serwera.
36
37%package devel
38Summary: Header files for memcached library
39Summary(pl.UTF-8): Pliki nagłówkowe biblioteki memcached
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
bc883c5c 42Requires: cyrus-sasl-devel
a76bb5e7
AG
43
44%description devel
45Header files for memcached library.
46
47%description devel -l pl.UTF-8
48Pliki nagłówkowe biblioteki memcached.
49
50%package static
51Summary: Static memcached library
52Summary(pl.UTF-8): Statyczna biblioteka memcached
53Group: Development/Libraries
54Requires: %{name}-devel = %{version}-%{release}
55
56%description static
57Static memcached library.
58
59%description static -l pl.UTF-8
60Statyczna biblioteka memcached.
61
62%prep
63%setup -q
5cfce8bb 64
a76bb5e7 65%build
a76bb5e7 66%configure \
b048042d
JB
67 PTHREAD_CFLAGS="-pthread" \
68 PTHREAD_LIBS="-lpthread" \
69 --enable-dtrace \
e1d032be 70 --enable-libmemcachedprotocol \
b048042d
JB
71 --disable-silent-rules \
72 %{?with_static_libs:--enable-static} \
a76bb5e7 73 --with-memcached=no # disable memcached detection, we're not doing tests
1a91d275 74
a76bb5e7
AG
75%{__make}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%{__make} install \
81 DESTDIR=$RPM_BUILD_ROOT
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -p /sbin/ldconfig
87%postun -p /sbin/ldconfig
88
89%files
90%defattr(644,root,root,755)
91%doc AUTHORS ChangeLog NEWS README THANKS TODO
c909e202 92%attr(755,root,root) %{_bindir}/memcapable
93%attr(755,root,root) %{_bindir}/memcat
94%attr(755,root,root) %{_bindir}/memcp
95%attr(755,root,root) %{_bindir}/memdump
96%attr(755,root,root) %{_bindir}/memerror
a7fb1d55 97%attr(755,root,root) %{_bindir}/memexist
c909e202 98%attr(755,root,root) %{_bindir}/memflush
f922b7a0 99%attr(755,root,root) %{_bindir}/memparse
80bcd255 100%attr(755,root,root) %{_bindir}/memping
c909e202 101%attr(755,root,root) %{_bindir}/memrm
102%attr(755,root,root) %{_bindir}/memslap
103%attr(755,root,root) %{_bindir}/memstat
a7fb1d55 104%attr(755,root,root) %{_bindir}/memtouch
ba8924c1 105%attr(755,root,root) %{_libdir}/libhashkit.so.*.*.*
c909e202 106%attr(755,root,root) %{_libdir}/libmemcached.so.*.*.*
107%attr(755,root,root) %{_libdir}/libmemcachedprotocol.so.*.*.*
108%attr(755,root,root) %{_libdir}/libmemcachedutil.so.*.*.*
e1d032be
ER
109%attr(755,root,root) %ghost %{_libdir}/libhashkit.so.2
110%attr(755,root,root) %ghost %{_libdir}/libmemcached.so.11
e1c5f7f8
ER
111%attr(755,root,root) %ghost %{_libdir}/libmemcachedprotocol.so.0
112%attr(755,root,root) %ghost %{_libdir}/libmemcachedutil.so.2
c909e202 113%{_mandir}/man1/mem*.1*
a76bb5e7
AG
114
115%files devel
116%defattr(644,root,root,755)
ba8924c1 117%attr(755,root,root) %{_libdir}/libhashkit.so
118%attr(755,root,root) %{_libdir}/libmemcached.so
119%attr(755,root,root) %{_libdir}/libmemcachedprotocol.so
120%attr(755,root,root) %{_libdir}/libmemcachedutil.so
121%{_libdir}/libhashkit.la
c909e202 122%{_libdir}/libmemcached.la
123%{_libdir}/libmemcachedprotocol.la
124%{_libdir}/libmemcachedutil.la
ba8924c1 125%{_includedir}/libhashkit
e1d032be 126%{_includedir}/libhashkit-1.0
a76bb5e7 127%{_includedir}/libmemcached
e1d032be
ER
128%{_includedir}/libmemcached-1.0
129%{_includedir}/libmemcachedprotocol-0.0
130%{_includedir}/libmemcachedutil-1.0
c909e202 131%{_pkgconfigdir}/libmemcached.pc
e1d032be 132%{_aclocaldir}/ax_libmemcached.m4
b048042d
JB
133%{_mandir}/man3/hashkit_*.3*
134%{_mandir}/man3/libhashkit.3*
135%{_mandir}/man3/libmemcached*.3*
136%{_mandir}/man3/memcached*.3*
a76bb5e7 137
b3eb527f 138%if %{with static_libs}
a76bb5e7
AG
139%files static
140%defattr(644,root,root,755)
ba8924c1 141%{_libdir}/libhashkit.a
142%{_libdir}/libmemcached.a
143%{_libdir}/libmemcachedprotocol.a
144%{_libdir}/libmemcachedutil.a
b3eb527f 145%endif
This page took 0.145326 seconds and 4 git commands to generate.