]> git.pld-linux.org Git - packages/libgta.git/blame - libgta.spec
- updated to 1.0.4
[packages/libgta.git] / libgta.spec
CommitLineData
7b8e8637
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4#
5Summary: Library to read and write Generic Tagged Arrays (GTAs)
6Summary(pl.UTF-8): Biblioteka od odczytu i zapisu GTA (ogólnych tablic etykietowanych)
7Name: libgta
9dcdc7d9 8Version: 1.0.4
7b8e8637
JB
9Release: 1
10License: LGPL v2.1+
11Group: Libraries
12Source0: http://download.savannah.nongnu.org/releases/gta/%{name}-%{version}.tar.xz
9dcdc7d9 13# Source0-md5: 8208e29dc8d932053bb451356f73ef75
7b8e8637
JB
14URL: http://gta.nongnu.org/libgta.html
15BuildRequires: bzip2-devel
16%{?with_apidocs:BuildRequires: doxygen}
17BuildRequires: tar >= 1:1.22
18BuildRequires: xz
19BuildRequires: xz-devel
20BuildRequires: zlib-devel
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Libgta is a portable library that implements the Generic Tagged Array
25(GTA) file format. This file format has the following features:
26
27* GTAs can store any kind of data in multidimensional arrays
28* GTAs can optionally use simple tags to store rich metadata
29* GTAs are streamable, which allows direct reading from and writing to
30 pipes, network sockets, and other non-seekable media
31* GTAs can use ZLIB, BZIP2, or XZ compression, allowing a tradeoff
32 between compression/decompression speed and compression ratio
33* Uncompressed GTA files allow easy out-of-core data access for very
34 large arrays.
35
36%description -l pl.UTF-8
37libgta to przenośna biblioteka zawierająca implementację formatu GTA
38(Generic Tagged Array - ogólnych tablic etykietowanych). Format ten ma
39następujące cechy:
40- może przechowywać dowolny rodzaj danych w tablicach wielowymiarowych
41- opcjonalnie może wykorzystywać proste etykiety do przechowywania
42 bogatych metadanych
43- daje się obrabiać strumieniowo, co pozwala na bezpośredni odczyt i
44 zapis do potoków, gniazd sieciowych i innych nośników nie
45 obsługujących przewijania
46- może wykorzystywać kompresję ZLIB, BZIP2 lub XZ, pozwalając na
47 kompromis między szybkością kompresji/dekompresji a współczynnikiem
48 upakowania
49- w przypadku nieskompresowanych plików możliwy jest łatwy dostęp do
50 danych nawet dla bardzo dużych tablic.
51
52%package devel
53Summary: Header files for GTA library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GTA
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: bzip2-devel
58Requires: xz-devel
59Requires: zlib-devel
60
61%description devel
62Header files for GTA library.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe biblioteki GTA.
66
67%package static
68Summary: Static GTA library
69Summary(pl.UTF-8): Statyczna biblioteka GTA
70Group: Development/Libraries
71Requires: %{name}-devel = %{version}-%{release}
72
73%description static
74Static GTA library.
75
76%description static -l pl.UTF-8
77Statyczna biblioteka GTA.
78
79%package apidocs
80Summary: GTA API documentation
81Summary(pl.UTF-8): Dokumentacja API biblioteki GTA
82Group: Documentation
83
84%description apidocs
85API and internal documentation for GTA library.
86
87%description apidocs -l pl.UTF-8
88Dokumentacja API biblioteki GTA.
89
90%prep
91%setup -q
92
93%build
94%configure \
95 %{!?with_apidocs:--disable-reference} \
96 --disable-silent-rules
97%{__make}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102%{__make} install \
103 DESTDIR=$RPM_BUILD_ROOT
104
ff44cc0d 105install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_datadir}/cmake/Modules}
7b8e8637 106mv $RPM_BUILD_ROOT%{_docdir}/%{name}/example-*.c* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
ff44cc0d 107mv $RPM_BUILD_ROOT%{_docdir}/%{name}/FindGTA.cmake $RPM_BUILD_ROOT%{_datadir}/cmake/Modules
7b8e8637 108# packaged in -apidocs
95eef7bd 109%{?with_apidocs:%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/reference}
7b8e8637
JB
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
119%doc AUTHORS ChangeLog README
120%attr(755,root,root) %{_libdir}/libgta.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libgta.so.0
122
123%files devel
124%defattr(644,root,root,755)
125%attr(755,root,root) %{_libdir}/libgta.so
126%{_includedir}/gta
127%{_pkgconfigdir}/gta.pc
ff44cc0d 128%{_datadir}/cmake/Modules/FindGTA.cmake
7b8e8637
JB
129%{_examplesdir}/%{name}-%{version}
130
131%files static
132%defattr(644,root,root,755)
133%{_libdir}/libgta.a
134
135%if %{with apidocs}
136%files apidocs
137%defattr(644,root,root,755)
138%doc doc/reference/*.{css,html,js,png}
139%endif
This page took 0.093538 seconds and 4 git commands to generate.