]> git.pld-linux.org Git - packages/libdap.git/blame - libdap.spec
- updated to 3.18.1
[packages/libdap.git] / libdap.spec
CommitLineData
8610fb1e
SS
1#
2# Conditional build:
3%bcond_with tests # perform tests
4#
6f533976 5Summary: OPeNDAP C++ implementation of the Data Access Protocol
f2f7e628 6Summary(pl.UTF-8): OPeNDAP - implementacja w C++ protokołu DAP (Data Access Protocol)
6f533976 7Name: libdap
8b65bf36 8Version: 3.18.1
0f9a5662 9Release: 1
6f533976
JB
10License: LGPL v2.1+
11Group: Libraries
8b65bf36
JB
12Source0: https://www.opendap.org/pub/source/%{name}-%{version}.tar.gz
13# Source0-md5: 9bdca37f89dca3e1df2239ceb32f74a8
14URL: https://www.opendap.org/
d4851992 15BuildRequires: autoconf >= 2.63
13d381f4 16BuildRequires: automake
d4851992 17BuildRequires: bison >= 3.0
8610fb1e 18%{?with_tests:BuildRequires: cppunit-devel >= 1.12.0}
17de3823 19BuildRequires: curl-devel >= 7.19.0
d4851992 20BuildRequires: flex
6f533976 21BuildRequires: libstdc++-devel
13d381f4 22BuildRequires: libtool >= 2:1.5
022efda4 23BuildRequires: libuuid-devel
17de3823 24BuildRequires: libxml2-devel >= 1:2.7.0
3fd8b88f 25BuildRequires: pkgconfig
17de3823
JB
26Requires: curl >= 7.19.0
27Requires: libxml2 >= 1:2.7.0
6f533976
JB
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31This package contains the OPeNDAP C++ implementation of the Data
32Access Protocol version 2 (DAP2) with some extensions that will be
33part of DAP3.
34
35The DAP2 is used to provide a uniform way of accessing a variety of
36different types of data across the Internet. It was originally part of
37the DODS and then NVODS projects. The focus of those projects was
38access to Earth-Science data, so much of the software developed using
39the DAP2 to date has centered on that discipline. However, the DAP2
40data model is very general (and similar to a modern structured
41programming language) so it can be applied to a wide variety of
42fields.
43
29e78ab8
JR
44%description -l pl.UTF-8
45Ten pakiet zawiera OPeNDAP - implementację w C++ protokołu dostępu do
6f533976 46danych Data Access Protocol w wersji 2 (DAP2) z pewnymi
29e78ab8 47rozszerzeniami, które będą częścią DAP3.
6f533976 48
29e78ab8
JR
49DAP2 ma za zadanie udostępnienie jednolitego sposobu dostępu do wielu
50różnych rodzajów danych w Internecie. Był oryginalnie częścią
51projektów DODS, a następnie NVODS. Projekty te skupiały się na
52dostępie do danych Earth-Science, więc większość programów
53tworzonych przy użyciu DAP2 była związana z tą dyscypliną nauki.
54Jednak model danych DAP2 jest bardzo ogólny (i podobny do
55współczesnych strukturalnych języków programowania), więc może
56dotyczyć wielu różnych dziedzin.
6f533976
JB
57
58%package devel
59Summary: Header files for OPeNDAP library
f2f7e628 60Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OPeNDAP
6f533976
JB
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
17de3823 63Requires: curl-devel >= 7.19.0
6f533976 64Requires: libstdc++-devel
e2d5390f 65Requires: libuuid-devel
17de3823 66Requires: libxml2-devel >= 1:2.7.0
6f533976
JB
67
68%description devel
69Header files for OPeNDAP library.
70
29e78ab8
JR
71%description devel -l pl.UTF-8
72Pliki nagłówkowe biblioteki OPeNDAP.
6f533976
JB
73
74%package static
75Summary: Static OPeNDAP library
f2f7e628 76Summary(pl.UTF-8): Statyczna biblioteka OPeNDAP
6f533976
JB
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79
80%description static
81Static OPeNDAP library.
82
29e78ab8 83%description static -l pl.UTF-8
6f533976
JB
84Statyczna biblioteka OPeNDAP.
85
86%prep
87%setup -q
88
89%build
13d381f4
JB
90%{__libtoolize}
91%{__aclocal} -I conf -I gl/m4
92%{__autoconf}
93%{__autoheader}
94%{__automake}
6f533976
JB
95%configure
96%{__make}
97
8610fb1e
SS
98%{?with_tests:%{__make} check}
99
6f533976
JB
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
17de3823
JB
106# obsoleted by pkg-config
107%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdap*.la
59e726b7 108
6f533976
JB
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post -p /sbin/ldconfig
113%postun -p /sbin/ldconfig
114
115%files
116%defattr(644,root,root,755)
117%doc COPYRIGHT_* NEWS README*
118%attr(755,root,root) %{_bindir}/getdap
d4851992 119%attr(755,root,root) %{_bindir}/getdap4
6f533976 120%attr(755,root,root) %{_libdir}/libdap.so.*.*.*
0f9a5662 121%attr(755,root,root) %ghost %{_libdir}/libdap.so.23
7791d8a4 122%attr(755,root,root) %{_libdir}/libdapclient.so.*.*.*
17de3823 123%attr(755,root,root) %ghost %{_libdir}/libdapclient.so.6
7791d8a4 124%attr(755,root,root) %{_libdir}/libdapserver.so.*.*.*
3420be39 125%attr(755,root,root) %ghost %{_libdir}/libdapserver.so.7
c16357f8 126%{_mandir}/man1/getdap.1*
d4851992 127%{_mandir}/man1/getdap4.1*
6f533976
JB
128
129%files devel
130%defattr(644,root,root,755)
131%attr(755,root,root) %{_bindir}/dap-config
7791d8a4 132%attr(755,root,root) %{_bindir}/dap-config-pkgconfig
6f533976 133%attr(755,root,root) %{_libdir}/libdap.so
7791d8a4
JR
134%attr(755,root,root) %{_libdir}/libdapclient.so
135%attr(755,root,root) %{_libdir}/libdapserver.so
3859979b 136%{_libdir}/libtest-types.a
6f533976 137%{_includedir}/libdap
7791d8a4
JR
138%{_pkgconfigdir}/libdap.pc
139%{_pkgconfigdir}/libdapclient.pc
140%{_pkgconfigdir}/libdapserver.pc
3420be39 141%{_aclocaldir}/libdap.m4
e2d5390f 142%{_mandir}/man1/dap-config.1*
6f533976
JB
143
144%files static
145%defattr(644,root,root,755)
146%{_libdir}/libdap.a
7791d8a4
JR
147%{_libdir}/libdapclient.a
148%{_libdir}/libdapserver.a
This page took 0.138654 seconds and 4 git commands to generate.