]> git.pld-linux.org Git - packages/libconfini.git/blame - libconfini.spec
- updated to 1.8.3
[packages/libconfini.git] / libconfini.spec
CommitLineData
f90ff42c
AG
1Summary: simple INI parsing library
2Summary(pl.UTF-8): prosta biblioteka analizy plików INI
3Name: libconfini
12bb20c4 4Version: 1.8.3
f90ff42c
AG
5Release: 1
6License: GPL v3
7Group: Libraries
8Source0: https://github.com/madmurphy/libconfini/archive/%{version}.tar.gz
12bb20c4 9# Source0-md5: fdca218f2c7700e3c689f7b6da0845fd
f90ff42c
AG
10URL: https://madmurphy.github.io/libconfini/html/index.html
11BuildRequires: autoconf
12BuildRequires: automake
13BuildRequires: intltool
14BuildRequires: libtool
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18libconfini is the ultimate and most consistent INI file parser library
19written in C. It focuses on standardization and parsing exactness and
20is at ease with almost every type of file containing key/value pairs.
21
22The library is fast and suitable for embedded systems. Its algorithms
23are written from scratch and do not depend on any external library,
24except for the C standard headers stdio.h, stdlib.h and stdint.h.
25
26Rather than storing the parsed data, libconfini gives the developer
27the freedom to choose what to do with them through a custom callback
28invoked for each INI node read. The API has been designed to be
29powerful, flexible and simple to use.
30
31With libconfini you will find in INI files the same serialization
32power you would normally find in other heavily structured formats
33(such as JXON, YAML, TOML), but with the advantage of using the most
34human-readable configuration format ever invented (thanks to their
35informal status, INI files are indeed more fluid and human-readable
36than formats explicitly designed with this purpose, such as YAML and
37TOML).
38
39%description -l pl.UTF-8
40libconfini to najlepsza i najbardziej spójna biblioteka analizatorów
41plików INI napisana w języku C. Skupia się ona na standaryzacji i
42analizie dokładności i jest łatwa w prawie każdym typie pliku
43zawierającego pary klucz / wartość.
44
45Biblioteka jest szybka i odpowiednia dla systemów wbudowanych. Jego
46algorytmy są napisane od podstaw i nie zależą od żadnej zewnętrznej
47biblioteki, z wyjątkiem standardowych nagłówków C stdio.h, stdlib.h i
48stdint.h.
49
50Zamiast przechowywać przeanalizowane dane, libconfini daje
51programistom swobodę wyboru, co z nimi zrobić za pomocą
52niestandardowego wywołania zwrotnego wywoływanego dla każdego
53czytanego węzła INI. Interfejs API został zaprojektowany tak, aby był
54wydajny, elastyczny i prosty w użyciu.
55
56Z libconfini znajdziesz w plikach INI tę samą moc serializacji, jaką
57zwykle można znaleźć w innych silnie ustrukturyzowanych formatach
58(takich jak JXON, YAML, TOML), ale z zaletą użycia najbardziej
59czytelnego formatu konfiguracji, jaki kiedykolwiek wymyślono (dzięki
60ich status nieformalny, pliki INI są rzeczywiście bardziej płynne i
61czytelne dla człowieka niż formaty wyraźnie zaprojektowane w tym celu,
62takie jak YAML i TOML).
63
64%package devel
65Summary: Header files for %{name} library
66Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69
70%description devel
71Header files for %{name} library.
72
73%description devel -l pl.UTF-8
74Pliki nagłówkowe biblioteki %{name}.
75
76%package static
77Summary: Static %{name} library
78Summary(pl.UTF-8): Statyczna biblioteka %{name}
79Group: Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81
82%description static
83Static %{name} library.
84
85%description static -l pl.UTF-8
86Statyczna biblioteka %{name}.
87
88%prep
89%setup -q
90
91%build
92%{__libtoolize}
93%{__aclocal}
94%{__autoconf}
f90ff42c
AG
95%{__automake}
96%configure
97%{__make}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102%{__make} install \
103 DESTDIR=$RPM_BUILD_ROOT
104
105rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post -p /sbin/ldconfig
111%postun -p /sbin/ldconfig
112
113%files
114%defattr(644,root,root,755)
115%doc AUTHORS ChangeLog* MANUAL.md NEWS RATIONALE.md README* examples/ docs/html docs/manual.html
116%attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
117%attr(755,root,root) %ghost %{_libdir}/%{name}.so.0
118
119%files devel
120%defattr(644,root,root,755)
121%attr(755,root,root) %{_libdir}/%{name}.so
122%{_mandir}/man3/IniDispatch.3*
123%{_mandir}/man3/IniFormat.3*
124%{_mandir}/man3/IniStatistics.3*
125%{_mandir}/man3/confini.h.3*
126%{_mandir}/man3/libconfini.3*
127%{_libdir}/libconfini.la
128%{_includedir}/confini.h
c541b0a7 129%{_pkgconfigdir}/libconfini-1.8.pc
f90ff42c
AG
130
131%files static
132%defattr(644,root,root,755)
133%{_libdir}/%{name}.a
This page took 0.224237 seconds and 4 git commands to generate.