]> git.pld-linux.org Git - packages/libcap-ng.git/blame - libcap-ng.spec
- updated to 0.7.1
[packages/libcap-ng.git] / libcap-ng.spec
CommitLineData
a97a426a
JK
1#
2# Conditional build:
3%bcond_without python # build without python bindings
4#
9a73f910
JB
5Summary: Next Generation of POSIX capabilities library
6Summary(pl.UTF-8): Biblioteka POSIX capabilities nowej generacji
7Name: libcap-ng
dc886141 8Version: 0.7.1
7a591dee 9Release: 1
9a73f910
JB
10License: LGPL v2.1+ (library), GPL v2+ (utilities)
11Group: Libraries
12Source0: http://people.redhat.com/sgrubb/libcap-ng/%{name}-%{version}.tar.gz
dc886141 13# Source0-md5: de15a38ebd7c48d782c9e370f50cf5ba
e64f4261 14Patch0: vserver.patch
9a73f910
JB
15URL: http://people.redhat.com/sgrubb/libcap-ng/
16BuildRequires: attr-devel
131c6123 17BuildRequires: automake
e64f4261 18BuildRequires: linux-libc-headers >= 7:2.6.33.1
9a73f910
JB
19BuildRequires: python-devel
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.219
a97a426a 22%{?with_python:BuildRequires: swig-python}
9a73f910
JB
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26The libcap-ng library should make programming with POSIX capabilities
27easier. The library has some utilities to help you analyse a system
28for apps that may have too much privileges.
29
30%description -l pl.UTF-8
31Biblioteka libcap-ng powinna uczynić programowanie POSIX-owych
32capabilities łatwiejszym. Zawiera narzędzia pomagające w analizie
33systemu pod kątem aplikacji posiadających zbyt duże uprawnienia.
34
35%package devel
36Summary: Header files for libcap-ng library
37Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libcap-ng
38License: LGPL v2.1+
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41Requires: linux-libc-headers >= 7:2.6.26
42
43%description devel
44Header files for libcap-ng library.
45
46%description devel -l pl.UTF-8
47Pliki nagłówkowe biblioteki libcap-ng.
48
49%package static
50Summary: Static libcap-ng library
51Summary(pl.UTF-8): Statyczna biblioteka libcap-ng
52License: LGPL v2.1+
53Group: Development/Libraries
54Requires: %{name}-devel = %{version}-%{release}
55
56%description static
57Static libcap-ng library.
58
59%description static -l pl.UTF-8
60Statyczna biblioteka libcap-ng.
61
62%package utils
63Summary: Utilities for analysing and setting file capabilities
64Summary(pl.UTF-8): Narzędzia do analizy i ustawiania capabilities dla plików
65License: GPL v2+
66Group: Applications/System
67Requires: %{name} = %{version}-%{release}
68
69%description utils
70This package contains applications to analyse the POSIX capabilities
71of all the program running on a system. It also lets you set the file
72system based capabilities.
73
d92d486f 74%description utils -l pl.UTF-8
9a73f910
JB
75Ten pakiet zawiera aplikacje do analizy POSIX-owych capabilities
76wszystkich programów działających w systemie; pozwala także ustawiać
77capabilities w systemie plików.
78
79%package -n python-capng
80Summary: Python interface to libcap-ng library
81Summary(pl.UTF-8): Pythonowy interfejs do biblioteki libcap-ng
82Group: Libraries/Python
83Requires: %{name} = %{version}-%{release}
84%pyrequires_eq python-libs
85
86%description -n python-capng
87Python interface to libcap-ng library.
88
89%description -n python-capng -l pl.UTF-8
90Pythonowy interfejs do biblioteki libcap-ng.
91
92%prep
93%setup -q
e64f4261 94%patch0 -p1
9a73f910
JB
95
96%build
97%configure
98%{__make}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
106install -d $RPM_BUILD_ROOT/%{_lib}
107mv $RPM_BUILD_ROOT%{_libdir}/libcap-ng.so.* $RPM_BUILD_ROOT/%{_lib}
667d74fd 108ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcap-ng.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libcap-ng.so
9a73f910 109
a97a426a 110%if %{with python}
9a73f910 111%py_postclean
7a591dee 112%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_capng.la
a97a426a 113%endif
9a73f910
JB
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
120
121%files
122%defattr(644,root,root,755)
123%doc AUTHORS ChangeLog README
124%attr(755,root,root) /%{_lib}/libcap-ng.so.*.*.*
125%attr(755,root,root) %ghost /%{_lib}/libcap-ng.so.0
126
127%files devel
128%defattr(644,root,root,755)
129%attr(755,root,root) %{_libdir}/libcap-ng.so
130%{_libdir}/libcap-ng.la
131%{_includedir}/cap-ng.h
132%{_pkgconfigdir}/libcap-ng.pc
133%{_aclocaldir}/cap-ng.m4
134%{_mandir}/man3/capng_*.3*
135
136%files static
137%defattr(644,root,root,755)
138%{_libdir}/libcap-ng.a
139
140%files utils
141%defattr(644,root,root,755)
142%attr(755,root,root) %{_bindir}/captest
143%attr(755,root,root) %{_bindir}/filecap
144%attr(755,root,root) %{_bindir}/netcap
145%attr(755,root,root) %{_bindir}/pscap
146%{_mandir}/man8/captest.8*
147%{_mandir}/man8/filecap.8*
148%{_mandir}/man8/netcap.8*
149%{_mandir}/man8/pscap.8*
150
a97a426a 151%if %{with python}
9a73f910
JB
152%files -n python-capng
153%defattr(644,root,root,755)
154%attr(755,root,root) %{py_sitedir}/_capng.so
155%{py_sitedir}/capng.py[co]
a97a426a 156%endif
This page took 0.095003 seconds and 4 git commands to generate.