]> git.pld-linux.org Git - packages/libSavitar.git/blame - libSavitar.spec
rebuild with python 3.10
[packages/libSavitar.git] / libSavitar.spec
CommitLineData
e332c088
JR
1Summary: C++ implementation of 3mf loading with SIP Python bindings
2Name: libSavitar
c79a5a61 3Version: 2.7.0
4a59f837 4Release: 5
e332c088
JR
5License: AGPLv3+
6Group: Libraries
c79a5a61
JR
7Source0: https://github.com/Ultimaker/libSavitar/archive/%{version}/%{name}-%{version}.tar.gz
8# Source0-md5: 584cd4f3dacdcdbe69edcd42b83a4c6c
e332c088 9Patch0: no-pugixml.patch
c79a5a61
JR
10Patch1: system-pugixml.patch
11Patch2: lib-suffix.patch
12Patch3: PyQt5-sip.patch
e332c088
JR
13URL: https://github.com/Ultimaker/libSavitar
14BuildRequires: cmake
15BuildRequires: libstdc++-devel
16BuildRequires: pugixml-devel
17BuildRequires: python3-devel
18BuildRequires: python3-sip-devel
19BuildRequires: sip
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Savitar is a C++ implementation of 3mf loading with SIP Python
24bindings. 3mf is a 3D printing file format.
25
26%package devel
27# The cmake scripts are BSD
28Summary: Development files for libsavitar
29License: AGPLv3+ and BSD
30Group: Development/Libraries
31Requires: %{name} = %{version}-%{release}
32
33%description devel
34Savitar is a C++ implementation of 3mf loading with SIP Python
35bindings. 3mf is a 3D printing file format.
36
37Development files.
38
39%package -n python3-savitar
40Summary: Python 3 libSavitar bindings
41Group: Libraries/Python
42Requires: %{name} = %{version}-%{release}
43
44%description -n python3-savitar
45Savitar is a C++ implementation of 3mf loading with SIP Python
46bindings. 3mf is a 3D printing file format.
47
48The Python bindings.
49
50%prep
c79a5a61 51%setup -q
e332c088
JR
52%patch0 -p1
53%patch1 -p1
54%patch2 -p1
c79a5a61 55%patch3 -p1
e332c088
JR
56
57%build
58mkdir build
59cd build
60%{cmake} .. \
61 -DCMAKE_SKIP_RPATH:BOOL=ON
62%{__make}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66
67%{__make} -C build install \
68 DESTDIR=$RPM_BUILD_ROOT
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%post -p /sbin/ldconfig
74%postun -p /sbin/ldconfig
75
76%files
77%defattr(644,root,root,755)
78%doc README.md
79%attr(755,root,root) %{_libdir}/libSavitar.so.*.*.*
80%attr(755,root,root) %ghost %{_libdir}/libSavitar.so.0
81
82%files devel
83%defattr(644,root,root,755)
84%attr(755,root,root) %{_libdir}/libSavitar.so
85%{_includedir}/Savitar
86%{_libdir}/cmake/Savitar
87
88%files -n python3-savitar
89%defattr(644,root,root,755)
90%doc README.md
91%attr(755,root,root) %{py3_sitedir}/Savitar.so
This page took 0.069116 seconds and 4 git commands to generate.