]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- up to 4.4.5
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
5869f11d 7%bcond_without dante # Dante-based SOCKS support
db510deb
AM
8# broken currently https://www.dnssec-tools.org/trac/ticket/173
9%bcond_with dnssec # DNSSEC local validation
5869f11d 10#
117d16ec 11%if %{with ssl}
12%define with_openssl 1
13%endif
14
4f313d5c 15%if %{with gnutls} && %{with ssl}
117d16ec 16%undefine with_openssl
4f313d5c 17%endif
117d16ec 18
aa601f68 19Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
20Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
21Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
22Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
23Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 24Name: lftp
0956b838 25Version: 4.4.5
7811b157 26Release: 1
474948d1 27License: GPL v3+
4e6de64c 28Group: Applications/Networking
7811b157 29Source0: ftp://ftp.yar.ru/pub/source/lftp/%{name}-%{version}.tar.xz
0956b838 30# Source0-md5: f4f81016c961e4438ebe1e1ee7a0ae97
e84c29c9 31Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 32# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 33Source2: %{name}.desktop
fbf2ab8a 34Source3: %{name}-icon.png
5bf73c23
JB
35Patch0: %{name}-makefile.patch
36Patch1: %{name}-m4.patch
37Patch2: aliases.patch
afc7c8ba 38# maintained by me, sent upstream from time to time --qboosh
5bf73c23 39Patch3: %{name}-pl.po-update.patch
bce12c75 40Patch4: lftp-4.3.8-gets.patch
5869f11d 41Patch5: %{name}-am.patch
0d6c2643 42URL: http://lftp.yar.ru/
7e9d0681 43BuildRequires: autoconf >= 2.60
2a2b7922 44BuildRequires: automake
5869f11d
JB
45%{?with_dante:BuildRequires: dante-devel}
46%{?with_dnssec:BuildRequires: dnssec-tools-devel}
5bf73c23 47BuildRequires: expat-devel
404c9e4b 48BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 49%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 50BuildRequires: libstdc++-devel
6b77b6dc 51BuildRequires: libtool >= 1:1.4.2-9
eb634329 52BuildRequires: ncurses-devel >= 5.2
117d16ec 53%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 54BuildRequires: pkgconfig
eb634329 55BuildRequires: readline-devel >= 4.2
7bf4d9a3 56BuildRequires: tar >= 1:1.22
57BuildRequires: xz
4502d222 58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 59
fed66524 60%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
61%if %{_gcc_ver} == 2
62%define __cxx "%{__cc}"
63%endif
f544d322 64
0fcf33fd 65%description
aa601f68 66LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 67advantages over other FTP clients are reliability and ability to
c37d8459 68perform tasks in background. It will reconnect and reget the file
69being transferred if the connection broke. You can start a transfer in
b25ac3f9 70background and continue browsing on the FTP site. It does this all in
c37d8459 71one process. When you have started background jobs and feel you are
72done, you can just exit lftp and it automatically moves to nohup mode
73and completes the transfers. It has also such nice features as reput
74and mirror.
0fcf33fd 75
29127d3f 76%description -l pl.UTF-8
aa601f68 77Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
78połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
79ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
80połączenia po tym jak się wylogujesz. Program ten honoruje komendy
81powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
82jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 83
29127d3f
JR
84%description -l pt_BR.UTF-8
85O lftp é um programa de transferência de arquivos por linha de
aa601f68 86comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
87HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
88tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 89o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 90
0fcf33fd 91%prep
6588894c 92%setup -q
5bf73c23 93%patch0 -p1
43f4d1c2 94%patch1 -p1
ec7a935e 95%patch2 -p1
7184e6aa 96%patch3 -p1
bce12c75 97%patch4 -p1
5869f11d 98%patch5 -p1
a41e3bec 99
33b4fdae
AM
100%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
101
0fcf33fd 102%build
dc2417fa 103%{__libtoolize}
07e8f8cb 104%{__gettextize}
29f4b0b0 105%{__aclocal} -I m4
cbf16d8c 106%{__autoconf}
107%{__automake}
8ad8d289 108CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 109%configure \
d2c1e0b5 110 --without-included-regex \
5869f11d 111 --with-dnssec-local-validation%{!?with_dnssec:=no} \
9f24e3d9 112 --with-modules \
5869f11d 113 --with-socksdante%{!?with_dante:=no} \
117d16ec 114 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
115 --with%{!?with_gnutls:out}-gnutls
116
3579d696 117%{__make}
0fcf33fd 118
119%install
120rm -rf $RPM_BUILD_ROOT
10a3b210 121install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
122%{__make} install \
123 DESTDIR=$RPM_BUILD_ROOT
be14979d 124
f1bf5d4a
ER
125cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
126cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
127cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 128
e84c29c9 129bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
130%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
131%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 132
df169521 133%find_lang %{name}
165ff9f8 134
0fcf33fd 135%clean
136rm -rf $RPM_BUILD_ROOT
137
43f4d1c2
JB
138%post -p /sbin/ldconfig
139%postun -p /sbin/ldconfig
140
df169521 141%files -f %{name}.lang
be14979d 142%defattr(644,root,root,755)
e84c29c9 143%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 144%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
145%attr(755,root,root) %{_bindir}/lftp
146%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 147%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
148%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
149%dir %{_libdir}/lftp
d81e41f6 150%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 151%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
152%{_mandir}/man1/lftp.1*
153%{_mandir}/man1/lftpget.1*
154%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 155%{_mandir}/man5/lftp.conf.5*
10a3b210 156%{_desktopdir}/lftp.desktop
c37d8459 157%{_pixmapsdir}/lftp.png
This page took 0.061948 seconds and 4 git commands to generate.