]> git.pld-linux.org Git - packages/letsencrypt.sh.git/blame - letsencrypt.sh.spec
Force http/1.1 to workaround http/2 headers case
[packages/letsencrypt.sh.git] / letsencrypt.sh.spec
CommitLineData
1780cc1f
ER
1Summary: letsencrypt/acme client implemented as a shell-script
2Name: letsencrypt.sh
eccbe1cf 3Version: 0.2.0
8e85f472 4Release: 5
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
7Source0: https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
eccbe1cf 8# Source0-md5: 74974ab79d6879b92ba353bbf3d1257e
eb6aa75d
ER
9Source1: apache.conf
10Source2: lighttpd.conf
3c33d40b 11Source3: config.sh
8f670f9f 12Source4: domains.txt
5765eca7 13Source5: hook.sh
a0535a11 14Source6: crontab
f5fc6721 15Patch0: pld.patch
f4d4983b 16Patch1: letsencrypt.sh-agrurl.patch
8e85f472 17Patch2: curl1.1.patch
1780cc1f
ER
18URL: https://github.com/lukas2511/letsencrypt.sh
19BuildRequires: rpmbuild(macros) >= 1.713
a0535a11 20Requires: crondaemon
1780cc1f
ER
21Requires: curl
22Requires: grep
23Requires: mktemp
60120665 24Requires: openssl-tools
1780cc1f 25Requires: sed
eb6aa75d 26Requires: webapps
9f9f4d8c
ER
27Suggests: webserver(access)
28Suggests: webserver(alias)
1780cc1f
ER
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
eb6aa75d
ER
32%define _webapps /etc/webapps
33%define _webapp %{name}
34%define _sysconfdir %{_webapps}/%{_webapp}
35%define _appdir %{_datadir}/%{_webapp}
36
1780cc1f
ER
37%description
38This is a client for signing certificates with an ACME-server
39(currently only provided by letsencrypt) implemented as a relatively
40simple bash-script.
41
42Current features:
43- Signing of a list of domains
44- Signing of a CSR
45- Renewal if a certificate is about to expire or SAN (subdomains)
46 changed
47- Certificate revocation
48
49%prep
50%setup -q
f5fc6721 51%patch0 -p1
f4d4983b 52%patch1 -p1
8e85f472 53%patch2 -p1
1780cc1f
ER
54
55%install
56rm -rf $RPM_BUILD_ROOT
a0535a11 57install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{acme-challenges,certs},/etc/cron.d}
eb6aa75d
ER
58
59install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
eb6aa75d
ER
60cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
61cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
3c33d40b 62cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
8f670f9f 63cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
a0535a11 64cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/letsencrypt
5765eca7 65install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 66cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f
ER
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
eb6aa75d
ER
71%triggerin -- apache1 < 1.3.37-3, apache1-base
72%webapp_register apache %{_webapp}
73
74%triggerun -- apache1 < 1.3.37-3, apache1-base
75%webapp_unregister apache %{_webapp}
76
77%triggerin -- apache < 2.2.0, apache-base
78%webapp_register httpd %{_webapp}
79
80%triggerun -- apache < 2.2.0, apache-base
81%webapp_unregister httpd %{_webapp}
82
83%triggerin -- lighttpd
84%webapp_register lighttpd %{_webapp}
85
86%triggerun -- lighttpd
87%webapp_unregister lighttpd %{_webapp}
88
1780cc1f
ER
89%files
90%defattr(644,root,root,755)
91%doc README.md CHANGELOG LICENSE
a0535a11 92%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/letsencrypt
7410a329 93%dir %attr(750,root,http) %{_sysconfdir}
a113aaf6 94%dir %attr(700,root,root) %{_sysconfdir}/certs
eb6aa75d
ER
95%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
96%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
97%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
3c33d40b 98%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
8f670f9f 99%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
5765eca7 100%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
eb6aa75d
ER
101# challenges written here from letsencrypt.sh, need to be readable by webserver
102%dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
7410a329
ER
103
104%attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.07203 seconds and 4 git commands to generate.