]> git.pld-linux.org Git - packages/lal-frame.git/blame - lal-frame.spec
rebuild with python 3.10
[packages/lal-frame.git] / lal-frame.spec
CommitLineData
46059d55
JB
1# TODO: framec support (BR: pkgconfig(framecppc) >= 2.0.0)
2Summary: LAL wrapping of the LILO/Virgo Frame library
3Summary(pl.UTF-8): Obudowanie LAL do biblioteki LILO/Virgo Frame
4Name: lal-frame
6872b688 5Version: 1.5.5
4853bc9f 6Release: 2
46059d55
JB
7License: GPL v2+
8Group: Libraries
9Source0: http://software.ligo.org/lscsoft/source/lalsuite/lalframe-%{version}.tar.xz
6872b688 10# Source0-md5: ec22d5d44122dcda02d1ce67757ed121
46059d55
JB
11Patch0: %{name}-env.patch
12URL: https://wiki.ligo.org/DASWG/LALSuite
13BuildRequires: autoconf >= 2.63
14BuildRequires: automake >= 1:1.11
15BuildRequires: lal-devel >= 6.18.0
6872b688 16BuildRequires: libframe-devel >= 8.41.5
46059d55
JB
17BuildRequires: libstdc++-devel
18BuildRequires: libtool >= 2:2
19BuildRequires: octave-devel >= 1:3.2.0
20BuildRequires: pkgconfig
6872b688
JR
21BuildRequires: python3-devel
22BuildRequires: python3-numpy-devel
46059d55
JB
23BuildRequires: swig >= 3.0.12
24BuildRequires: swig-python >= 2.0.12
25BuildRequires: tar >= 1:1.22
26BuildRequires: xz
27BuildRequires: zlib-devel
28Requires: lal >= 6.18.0
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32LAL wrapping of the LILO/Virgo Frame library.
33
34%description -l pl.UTF-8
35Obudowanie LAL do biblioteki LILO/Virgo Frame.
36
37%package devel
38Summary: Header files for lal-frame library
39Summary(pl.UTF-8): Pliki nagłówkowe biblioteki lal-frame
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: lal-devel >= 6.18.0
43Requires: libframe-devel
44
45%description devel
46Header files for lal-frame library.
47
48%description devel -l pl.UTF-8
49Pliki nagłówkowe biblioteki lal-frame.
50
51%package static
52Summary: Static lal-frame library
53Summary(pl.UTF-8): Statyczna biblioteka lal-frame
54Group: Development/Libraries
55Requires: %{name}-devel = %{version}-%{release}
56
57%description static
58Static lal-frame library.
59
60%description static -l pl.UTF-8
61Statyczna biblioteka lal-frame.
62
63%package -n octave-lalframe
64Summary: Octave interface for LAL Frame
65Summary(pl.UTF-8): Interfejs Octave do biblioteki LAL Frame
66Group: Applications/Math
67Requires: %{name} = %{version}-%{release}
68Requires: octave-lal >= 6.18.0
69
70%description -n octave-lalframe
71Octave interface for LAL Frame.
72
73%description -n octave-lalframe -l pl.UTF-8
74Interfejs Octave do biblioteki LAL Frame.
75
6872b688 76%package -n python3-lalframe
46059d55
JB
77Summary: Python bindings for LAL Frame
78Summary(pl.UTF-8): Wiązania Pythona do biblioteki LAL Frame
79Group: Libraries/Python
80Requires: %{name} = %{version}-%{release}
6872b688
JR
81Requires: python3-lal >= 6.18.0
82Requires: python3-modules >= 1:2.6
46059d55 83
6872b688 84%description -n python3-lalframe
46059d55
JB
85Python bindings for LAL Frame.
86
6872b688 87%description -n python3-lalframe -l pl.UTF-8
46059d55
JB
88Wiązania Pythona do biblioteki LAL Frame.
89
90%prep
91%setup -q -n lalframe-%{version}
92%patch0 -p1
93
94%build
95%{__libtoolize}
96%{__aclocal} -I gnuscripts
97%{__autoconf}
98%{__autoheader}
99%{__automake}
100%configure \
101 --disable-silent-rules \
102 --enable-swig
103%{__make}
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108%{__make} install \
109 DESTDIR=$RPM_BUILD_ROOT
110
111# obsoleted by pkg-config
112%{__rm} $RPM_BUILD_ROOT%{_libdir}/liblalframe.la
113
114install -d $RPM_BUILD_ROOT/etc/shrc.d
115%{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/*sh $RPM_BUILD_ROOT/etc/shrc.d
116
46059d55
JB
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(644,root,root,755)
17549f3e 125%doc AUTHORS README.md
46059d55
JB
126%attr(755,root,root) %{_bindir}/lalfr-*
127%attr(755,root,root) %{_bindir}/lalframe_version
128%attr(755,root,root) %{_libdir}/liblalframe.so.*.*.*
6872b688 129%attr(755,root,root) %ghost %{_libdir}/liblalframe.so.11
46059d55
JB
130/etc/shrc.d/lalframe-user-env.csh
131/etc/shrc.d/lalframe-user-env.fish
132/etc/shrc.d/lalframe-user-env.sh
133%{_mandir}/man1/lalfr-*.1*
134
135%files devel
136%defattr(644,root,root,755)
137%attr(755,root,root) %{_libdir}/liblalframe.so
46059d55
JB
138%{_includedir}/lal/FrameCalibration.h
139%{_includedir}/lal/LALFrStream.h
140%{_includedir}/lal/LALFrame*.h
141%{_includedir}/lal/SWIGLALFrame*.h
142%{_includedir}/lal/SWIGLALFrame*.i
143%{_includedir}/lal/swiglalframe.i
144%{_pkgconfigdir}/lalframe.pc
145
146%files static
147%defattr(644,root,root,755)
148%{_libdir}/liblalframe.a
149
150%files -n octave-lalframe
151%defattr(644,root,root,755)
152%attr(755,root,root) %{_libdir}/octave/*/site/oct/*/lalframe.oct
153
6872b688 154%files -n python3-lalframe
46059d55 155%defattr(644,root,root,755)
6872b688
JR
156%dir %{py3_sitedir}/lalframe
157%attr(755,root,root) %{py3_sitedir}/lalframe/_lalframe.so
158%{py3_sitedir}/lalframe/*.py
159%{py3_sitedir}/lalframe/__pycache__
160%dir %{py3_sitedir}/lalframe/utils
161%{py3_sitedir}/lalframe/utils/*.py
162%{py3_sitedir}/lalframe/utils/__pycache__
This page took 0.097333 seconds and 4 git commands to generate.